Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem bei lokaler IP- bzw. Namensauflösung - immer IPv6 anstatt IPv4

Mitglied: menace

menace (Level 1) - Jetzt verbinden

06.09.2013 um 16:08 Uhr, 21211 Aufrufe, 5 Kommentare, 1 Danke

Hallo,

ich habe hier ein Netzwerk mit knapp 70 WIN 7 Clients.
Zudem gibt es einen standalone MS 2012 Server, welcher als Hyper-V Virtualisierungs-Host fungiert. Auf diesem laufen verschiedene VMs, unter anderem auch ein weiterer virtueller 2012 Server, auf dem DNS, DHCP und WINS aktiviert ist. Es handelt sich um lauter standalone Geräte, es gibt keine Domäne.
Im DHCP und DNS ist ausschlielich IPv4 konfiguriert bzw. eingerichtet. Auf allen PCs und VM Servern ist in den Netzwerkkarten Optionen aber das IPv6 Protokoll angehakt, es wurde dort aber nichts konfiguriert. Die Server haben alle statische IPv4 Adressen, die Clients nutzen DHCP.

Das Problem ist nun, dass sowohl bei den Clients als auch bei den Server bei Ping localhost immer ::1 zurückgegeben wird und nicht die IPv4 Adresse.
Pinge ich von einem der Clients z.B. den hostname Server1 an, bekomme ich dessen IPv4 192.168.1.1 zurück. Pinge ich aber auf Server1 den eigenen Hostname Server1 bekomme ich die dort aktuell hierlegte IPv6 Adresse zurück fe80::35e3:f0b2:4d87:9824%10:
Das selbe bekomme ich auch wenn ich von dort server1.domain.local pinge, was auf den DNS eigentlich mit der zugehörigen IPv4 Adresse eingetragen ist.

Was kann ich nun tun, dass die PCs / Server immer die jeweilige IPv4 Adresse zurückgeben bzw. nutzen und nicht die IPv6?
Das IPv6 Protokoll möchte ich nicht deaktivieren, da ich hier schon gelesen hae, dass es dann zu anderen Problemen kommt und dies von MS außerdem nicht erwünscht ist.
Mitglied: Th0mKa
06.09.2013 um 19:19 Uhr
Moin,

Und inwieweit ist das jetzt ein Problem? Funktioniert irgendetwas nicht? Versuche es mal mit "ping -4 localhost".

VG,

Thomas
Bitte warten ..
Mitglied: menace
09.09.2013 um 09:42 Uhr
das Problem ist, dass ich das Gefühl habe, dass die Namensauflösung zum Teil nicht ordentlich funktioniert.
Auf den Clients läuft eine Software, welche über Port 45540 mit einem Server funktioniert.
Wenn ich auf den Clients einstelle, dass der Server per UDP Broadcast auf 45540 gefunden werden soll, funktioniert alles.
Wenn ich auf den Clients einstelle, dass der Server per fest eingetragener IP gefunden werden soll, funktioniert auch alles.
Wenn ich aber auf den Clients einstelle, dass der Server per Hostname gefunden werden soll, funktioniert nichts. Am Server kommt dann nichts an.

Ich habe hier dann den Verdacht, das irgendetwas auf IPv6 Ebene abläuft, was nicht passt...
Bitte warten ..
Mitglied: Th0mKa
09.09.2013 um 11:04 Uhr
Und was passiert wenn du wie vorgeschlagen "ping -4 server1" in der Kommandozeile eingibst?
Bitte warten ..
Mitglied: aqui
09.09.2013, aktualisiert um 11:11 Uhr
.local in der DNS Rootdomain zu verwenden ist auch nicht wirklich gut, denn das ist ein fest reservierter Domain Name für mDNS.
http://en.wikipedia.org/wiki/Multicast_DNS
("...exclusively resolves host names ending with the .local top level domain (TLD). This can cause problems if that domain includes hosts that do not implement mDNS but can be found via a conventional unicast DNS server !" )
Das es da früher oder später zu DNS Konflikten kommen muss ist dann vorprogrammiert wenn man die TLDs so fehlerhaft setzt !
Sinnvoller ist immer sowas wie .intern usw. zu verwenden was damit nicht kollidiert !
Bitte warten ..
Mitglied: menace
09.09.2013 um 11:22 Uhr
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. Alle Rechte vorbehalten.

ping server1

Ping wird ausgeführt für server1 [fe80::9575:c2ab:3a4d:fdb0%10] mit 32 Bytes Daten:
Zeitüberschreitung der Anforderung.
Zeitüberschreitung der Anforderung.

Ping-Statistik für fe80::9575:c2ab:3a4d:fdb0%10:
Pakete: Gesendet = 2, Empfangen = 0, Verloren = 2
(100% Verlust),
STRG-C
^C

ping -4 server1

Ping wird ausgeführt für server1 [192.168.1.7] mit 32 Bytes Daten:
Antwort von 192.168.1.7: Bytes=32 Zeit<1ms TTL=128
Antwort von 192.168.1.7: Bytes=32 Zeit<1ms TTL=128
Antwort von 192.168.1.7: Bytes=32 Zeit<1ms TTL=128
Antwort von 192.168.1.7: Bytes=32 Zeit<1ms TTL=128

Ping-Statistik für 192.168.1.7:
Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
(0% Verlust),
Ca. Zeitangaben in Millisek.:
Minimum = 0ms, Maximum = 0ms, Mittelwert = 0ms
ping server1.domain.local

Ping wird ausgeführt für server1.domain.local [192.168.1.7] mit 32 Bytes Daten:
Antwort von 192.168.1.7: Bytes=32 Zeit<1ms TTL=128
Antwort von 192.168.1.7: Bytes=32 Zeit<1ms TTL=128
Antwort von 192.168.1.7: Bytes=32 Zeit<1ms TTL=128
Antwort von 192.168.1.7: Bytes=32 Zeit<1ms TTL=128

Ping-Statistik für 192.168.1.7:
Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
(0% Verlust),
Ca. Zeitangaben in Millisek.:
Minimum = 0ms, Maximum = 0ms, Mittelwert = 0ms

also, ping hostname gibt IPv6 zurück.
Ping -4 hostname gibt IPv4 IP zurück.
Ping hostname.domain.local gibt IPv4 IP zurück.

komisch, oder?!


Bzgl. der *.local Domain muss ich mir dann nochmals Gedanken machen, ob und wie ich das dann auf *.intern umstelle...
Bitte warten ..
Ähnliche Inhalte
Router & Routing
IPV6 und IPV4 im Heimnetz
Frage von OsiMacRouter & Routing5 Kommentare

Hallo ich habe mal eine Frage, ich bin bei KabelDeutschland als Internet Provider. Ich bekomme eine ipv6 und ipv4 ...

Netzwerke
Routing-Frage IPv6 und IPv4
gelöst Frage von 135624Netzwerke7 Kommentare

Hallo, ich habe eine Frage zum Thema IPv6. Ich habe das mit dem Subnetting ungefähr begriffen nur eines ist ...

Router & Routing
Eine externe IPv4, mehrere externe IPv6
gelöst Frage von KamoranesiRouter & Routing4 Kommentare

Hallo, ich habe festgestellt, dass ich eine externe IPv4 für meine unterschiedlichen Geräte im Netzwerk habe, aber jedes meiner ...

Utilities

Suche Tool für Netzwerkprotokollierung ipv4 und ipv6

gelöst Frage von Ingo2001Utilities11 Kommentare

Hallo zusammen, ich habe zuhause aktuell das Problem, dass sporadisch keine Verbindung zu ipv4 oder ipv6 Adressen aufgebaut werden ...

Neue Wissensbeiträge
Humor (lol)
Preisvertipper
Information von Dilbert-MD vor 2 TagenHumor (lol)7 Kommentare

Moin! weil heute Freitag ist, zeige ich Euch den Preisvertipper der Woche: vergesst den Acer Predator 21x, der ist ...

Windows Update
Sicherheitsupdate für SQL Server 2014 SP3
Information von sabines vor 3 TagenWindows Update2 Kommentare

Für den SQL Server 2014 existiert ein Sicherheitsupdate. Laut KB Artikel wird es als CU3 angezeigt: Server 2014 SP3 ...

Backup

Veeam Agent für MS Windows - neue Version verfügbar (bedingt jedoch offenbar .NET Framework 4.6)

Information von VGem-e vor 4 TagenBackup1 Kommentar

Moin Kollegen, einer unserer Server zeigte grad an, dass für o.g. Software ein Update verfügbar ist. Ob ein evtl. ...

Python

Sie meinen es ja nur gut - Microsoft hilft python-Entwicklern auf unnachahmliche Weise

Information von DerWoWusste vor 6 TagenPython2 Kommentare

Stellt Euch vor, Ihr nutzt python unter Windows 10 und skriptet damit regelmäßig Dinge. Nach dem Update auf Windows ...

Heiß diskutierte Inhalte
Cloud-Dienste
MS Sharepoint generelle Frage zur Einrichtung
Frage von ralf86Cloud-Dienste15 Kommentare

Hallo, ich will den Sharepoint als FileServer nutzen. Hier sollen mehrere Freigabeordner mit unterschiedlichen Berechtigungen erstellt werden z.B. Geschäftsführung ...

Router & Routing
FritzBox und SynologyNAS VPN
Frage von ndeedyRouter & Routing10 Kommentare

Moin moin. Irgendwie habe ich entweder ein bescheuertes Setup, oder mir bereits komplett die Birne mit Versuchen durchgebraten. Bin ...

Vmware
VMware Update 5.1 zu 6.7U4
gelöst Frage von patrickebertVmware8 Kommentare

Hallo alle zusammen, ich den nächsten Monaten steht für mich die Umstellung zwei neuer physikalischer Server an und ich ...

Outlook & Mail
Outlook 2016: Schrift der Ordnerspalte verkleinern
Frage von usercrashOutlook & Mail7 Kommentare

Hallo, wie/wo kann man in MS Outlook 2016 im Ordnerbereich am linken Bildrand die Schriften, die Überschriften und den ...