Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Probleme mit Domäne

Mitglied: ManuelF

Folgendes Szenario:
3 Filialen verbunden mit VPN

1. Filiale hat den Windows 2000 Domänencontroller mit Active-Directory und IP-Segemtierung: 192.168.1.X Subnetz-Maske: 255.255.255.0 Domäne=XXXXX2000


2. Filiale hat einen PDC Windows NT4 Server und IP-Segmentierung: 192.168.2.X Subnetz-Maske: 255.255.255.0 Domäne=XXXXX

3. Filiale hat einen unkonfigurierten Windows 2000 Server mit IP-Segemtierung: 192.168.3.X Subnetz-Maske: 255.255.255.0 Domäne=XXXXX

Vom alten PDC Windows NT4 Server wurden die Benutzer auf den unkonfigurierten Windows 2000 Server übernommen (Nur die Konten der Benutzer, Systemrichtlinien usw. werden neu definiert!)

Die alte Domäne heisst: XXXXX
Die neue Domäne heisst: XXXXX2000

Nun möchte ich den unkonfigurierten Server als zusätzlichen Domänencontroller zur Domäne XXXXX2000 hinzufügen...

Nun wird man nach dem Admin-Konto gefragt: Gebe alle nötigen Daten sowie die Domäne XXXXX2000 ein... bekomme aber folgende Fehlermeldung: Die Domäne "XXXXX2000" ist keine Active Directory-Domäne, oder es konnte keine Verbindung zu einem Active Directory Domänencontroller hergestellt werden.

Die 1. Filiale hat einen Windows 2000 Server mit Active-Directory! Die Verbindung über VPN besteht auch...

weiss jemand Rat? danke im Voraus

Content-Key: 1744

Url: https://administrator.de/contentid/1744

Ausgedruckt am: 20.06.2021 um 02:06 Uhr

11 Kommentare
Mitglied: linkit
Könnte vielleicht daran liegen, daß wenn du dich per VPN irgendwo einwählst, daß du aus dem Client-Adresssatz eine IP zugwiesen bekommst.

Du wählst dich beispielsweise im Net 192.168.1 ein und bekommst dann auch daraus per VPN eine IP zugewiesen (zumindest, wenn du das über Routing von Serverbetriebsystem aus konfiguriert hast). Tatsächlich befindest du dich aber im Netz 192.168.3. .... könnte vielleicht der Grund sein....
Mitglied: Atti58
Vielleicht versuchst Du mal, auf Domäne XXXXX2000 eine Route auf den unkonfigurierten Server und gleichzeitig eine Route vom unkonfigurierten Server zu Domäne XXXXX2000 zu setzen ...
Mitglied: Atti58
Ich gehe davon aus, dass die verwendeten Netzwerkmasken für Klasse C Netze (255.255.255.0) sind - und da liegt meiner Meinung nach Dein Problem. Nach meinem Verständnis müssen PDC und BDC im gleichen Netz liegen und das ist bei Dir nicht der Fall. Wenn Du daran nichts ändern kannst, wirst Du wohl nur mit "vertrauten Domänen" arbeiten können ...
Mitglied: das-omen
Hi!


@ manuel F

Versuche mal mit ns Lookup den Domänencontroller aufzulösen. Dieses muss zwingend funktionieren

@ ATI58

Windows 2000 Server sind PDC und BDC schon mal abgeschafft. *klugscheiss*
Gut der erste in der Domäne ist erstmal etwas gleicger weil er die Betriebsmasterfunktionen hält. Dieses kann man aber auch ändern. Die Subnetze spielen meiens Wissens auch keine Rolle.

Tschau

Das Omen
Mitglied: Atti58
... schön wär's, wenn alles, was in der Theorie so ist, auch praktisch funktionieren würde ... Wir haben jedenfalls die größten Probleme, wenn wir Usereinstellungen über die Management Konsole vornehmen und die Konsole hat sich mal wieder von selbst einen "Backupdomaincontroller" zum aktiven Verwalter der "User and Computer" gemacht. Die Einstellungen werden oft selbst nach einem Reboot des Clients nicht durchgestellt. Ändert man aber den aktiven DC auf den nicht existierenden Primary, geht's sofort ... ;-) face-wink ... Theorie und Praxis ...
... ändern? Und dann ist der vemeintlich ehemalige BDC der PDC ... ;-) face-wink

Welche "Subnetze"? Das Netz 192.168.1.0 Mask 255.255.255.0 ist kein Subnetz von 192.168.2.0 Mask 255.255.255.0 ...

Gruß

Atti
Mitglied: das-omen
Hi!

@ atti58

hmm sorry das mit den Subnetzen stimmt. Class C 192 und folgende. Das passiert wenn man auf Arbeit mit nen 10 ner Netz subnetting betreibt und die selbe Maske hat. Asche auf mein Haupt.
Dein Problem umgehst du wenn du die Replizierung per Hand anschiebst. Wenn ich jetzt noch wüsste ob du 2000 Server benutzt (automatische Replizierung 15 min) oder 2003 Server automatische Replizierung 5 Sekunden) könnte ich das Problem besser nachvollziehen.

Tschau

das Omen
Mitglied: Atti58
Im Moment setzen wir noch Win2k Server ein, wollen aber in absehbarer Zeit auf Win2k3 migrieren. Inzwischen haben wir uns aber darauf eingestellt, dass die Replizierung von Userrechten nicht, wie von MS versprochen "sofort" passiert und achten darauf, ob wir mit dem Betriebsmaster ;-) face-wink verbunden sind ...

Deine "Subnet" - Nachlässigkeit sei Dir verziehen ;-) face-wink ...

Gruß

Atti.
Mitglied: ManuelF
1. Danke für eure Hilfe!

2. das Problem besteht leider immernoch...

meine dass es auch etwas mit den DNS-Lookups auf sich hat!

würde es etwas bringen, wenn ich sämtliche Subnetz-Masken auf 255.255.0.0 einstellen würde?

Wie genau funktioniert ns lookup?

danke für Eure Hilfe
Mitglied: Patric
Welchen DNS-Server verwendet der unkonfigurierte? Würde mal den W2000 DC dort eintragen.

Was auch geht: in der %systemroot%\system32\drivers\etc\lmhosts die Zeile
<IP AD-DC (192.168.1.???)> <Netbiosname des AD-DC> #DOM:<XXXXX2000>
anhängen (Achtung: Notepad will daraus eine .txt machen, aber nicht mit uns!)

Wenn der unkonfigurierte W2000 Server kein DC ist, werden die dort schon hinmigrierten user accounts beimDC-Promo aber nicht in der Domäne landen, sondern lokale Konten auf dem (dann nicht mehr) Unkonfigurierten sein.
Mitglied: Patric
Ooops. Korrektur:

Was auch geht: in der %systemroot%\system32\drivers\etc\lmhosts die Zeile
[IP AD-DC (192.168.1.???)] [Netbiosname des AD-DC] #DOM:XXXXX2000
(ohne eckige Klammern)
anhängen (Achtung: Notepad will daraus eine .txt machen, aber nicht mit uns!)

Mitglied: Danzig
Hallo,

habe mal alles nur Überflogen doch eins ist klar ohne zuwiesen was nun wirklich nicht kann dir wahrscheinlich nur die Glaskugel doch die ist im Urlaub.

Kannst du den Laufen server (Fiale1) von Server (Fiale3)
Ping IP Ja/Nein
Ping Name Ja/Nein

Sind den Server evetuelle Route bekannt besteht verbindung zum Router?

wenn alles Ja

NSLOOKup

augabe mal Posten

und dir wird sicher geholfen

MFG Danzig
Heiß diskutierte Beiträge
Windows 10
Austritt Mitarbeiter - Windows- u. M365 Konto
gelöst NixVerstehenVor 1 TagFrageWindows 1011 Kommentare

Moin zusammen, ich habe hier im Kleinunternehmen tatsächlich zum ersten Mal die Situation, das eine Mitarbeiterin aus dem kaufmännischen Bereich ausscheiden wird. Die Kollegin ist ...

Netzwerke
Kassen freezen ohne ersichtlichen Grund
Ronic1Vor 17 StundenFrageNetzwerke12 Kommentare

Hallo Zusammen, ich schreibe heute zum ersten Mal in diesem Forum. Also weißt mich bitte auf etwaige Fehler meinerseits hin. Wie ich in anderen Beiträgen ...

Windows Server
Always-on-VPN mit einer Netzwerkkarte
bluelightVor 1 TagFrageWindows Server11 Kommentare

Hallo zusammen, ich bin tatsächlich einmal auf eure Hilfe angewiesen! Ich habe für unser Unternehmen ein Domänennetzwerk auf einem Rootserver von Netcup erstellt und weitestgehend ...

Microsoft
Wird die durch den DHCP zugewiesene IP-Adresse in der Ereignisanzeige gespeichert?
stephan.csVor 1 TagFrageMicrosoft6 Kommentare

Guten Morgen zusammen, leider bin ich mit meiner Recherche bis jetzt nicht weiter gekommen. Darum die Frage Wir haben folgende Situation: - Windows 10 Clients ...

Installation
Setup mit automatischen Klicks
akadawaVor 1 TagFrageInstallation9 Kommentare

Moin, ich habe eine Installation welche ich gerne über das Softwarecenter vom SCCM installieren lassen möchte. Leider lassen die Parameter der Setup.exe es nicht zu, ...

Windows Netzwerk
PRTG Probe erkennt Lancom Router nicht mehr
gelöst blackarchVor 1 TagFrageWindows Netzwerk6 Kommentare

Hallo zusammen, die o.g. Probe ist auf dem Server eines Standortes installiert und lief bis dato problemlos. Gestern fiel nun der Ping für den Router ...

Windows 10
PDF Datei wird falsch angezeigt
ben1300Vor 1 TagFrageWindows 107 Kommentare

Hallo zusammen, habe hier eine PDF Datei, welche auf einem Macbook (Big Sur) und einem Windows 10 Prof. x64 Client problemlos dargestellt wird. Nun kommt ...

TK-Netze & Geräte
Starface mit NGN verliert Gateway
FabezzVor 17 StundenFrageTK-Netze & Geräte9 Kommentare

Guten Morgen zusammen, ich hoffe dass ich das richtige Thema getroffen habe. In unserer Firma wurde beschlossen dass die in die Tage gekommene Openscape ausgetauscht ...