Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Programm-Verknüpfung als Root und als User differiert

Mitglied: major

major (Level 1) - Jetzt verbinden

04.03.2005, aktualisiert 30.11.2005, 13623 Aufrufe, 3 Kommentare

Hallo,

habe folgendes Problem:
Habe unter XP einen User, der Administrator-Rechte besitzt (=Root) und einen ohne (=User).
Um bei einer bestimmten Dateinamen-Erweiterung (z.B. ".txt") nicht immer ein "großes" Programm (z.B. Word) zu laden, habe ich das unter Root geändert, weil ich als User nicht das Recht dazu hatte. Jetzt funktioniert es zwar für Root, aber unter User wird immer noch das alte Programm (=Word) geöffnet.

Hab mir zwar das Topic <link="https://www.administrator.de/Userrechte_unter_XP_Home.html;>User ..." unter XP Home</link> durchgelesen, bin aber nicht ganz schlau daraus geworden (bin nicht DER Computer-Freak, wie ihr sicherlich schon gemerkt habt).
Vielleicht habt ihr noch nen speziellen Tip für mich, wie ich das geregelt kriegen könnte?

Grüße,
Major
Mitglied: 2P
04.03.2005 um 19:18 Uhr
Hi!

Also ich wäre ja jetzt spontan davon ausgegangen, dass diese Änderung dann auch bei dem User greifen - aber naja ...
Vielleicht gibst du dem User einfach mal kurzfristig Adminrechte, änderst deine Einstellungen und entziehst ihm die Adminrechte wieder.
Von der Ct´ gibt es da eine kleine Batchdatei mit der du diesen "Gruppenwechsel" leicht per Mausklick erledigen kannst.

Link: ftp://ftp.heise.de/pub/ct/listings/0418-176.zip

bis dann ...
Bitte warten ..
Mitglied: Atti58
04.03.2005 um 19:20 Uhr
Du hast zwei Möglichkeiten, dieses Problem zu beheben, entweder machst Du den User temporär zum lokalen Admin, stellst die Sachen um, die Du einstellen willst und nimmst ihm die Rechte des Admins wieder.

Die zweite Möglichkeit ist folgende:

1. Du stellst als Administrator alles ein, was Du möchtest und öffnest auch gleich noch alle Office-Programme ein Mal (so vermeidest Du, dass die Programme "nachinstallieren" wollen) und loggst Dich als ein anderer User mit Adminrechten wieder ein.

2. Du löscht den kompletten Inhalt des (versteckten!!) Ordners "Default User" unter "Dokumente und Einstellungen" und kopierst das Administratorprofil über "Eigenschaften von Arbeitsplatz" -> "Erweitert" -> "Benutzerprofile" -> "Einstellungen" mit Änderung der Berechtigungen auf "Jeder" zum Ordner "C:\Dokumente und Einstellungen\Default User"

3. um sicher zu gehen, dass Deine Benutzer keine Berechtigungsprobleme beommen, musst Du jetzt noch "regedit" starten, "HKEY_LOCAL_MACHINE" markieren und über "Datei" -> "Struktur laden" die "NTUSER.DAT" im Verzeichnis "C:\Dokumente und Einstellungen\Default User" als z.B. "Test" öffnen. Jetzt suchst Du nur im Abschnitt "Test" nach "Administrator" und ersetzt alle Vorkommen durch "%USERNAME%" - aber mit Vorsicht bitte (mache Dir vielleicht vorher eine Sicherungskopie). ... Bevor Du den Registry-Editor schließt, musst Du unbedingt die "NTUSER.DAT" freigeben der Struktur durch Markieren von "Test" und "Datei" -> "Struktur entfernen", sonst geht alles daneben!!!!

Gruß

Atti
Bitte warten ..
Mitglied: major
30.11.2005 um 13:09 Uhr
Hallo,
hab das gleiche Problem wie "major", hab den Beitrag gelesen und mir diese Batch-Datei von der Ct runtergeladen:


Aber leider klappt das bei mir nicht Es wird immer gemeckert: "Passwort falsch!" Aber normalerweise kann ich mich sehr wohl mit diesem PAsswort einloggen.
Allerdings muss ich gestehen, dass ich das Administrator-Konto mal in "Andreas" umbenannt habe, weshalb ich in der Batch-Datei das (nach dem ersten Versuch) auch die Vorkommen von "admin" in "Andreas" geändert habe, aber es klappt trotzdem nicht.

Kann mir da jemand weiterhelfen?
Das weiter unten beschriebene Verfahren von Atti erscheint mir auf den ersten Blick ein bißchen gefährlich, das würde ich gerne umgehen, wenn es irgendwie leichter geht (so per Mausklick )

Grüße,
Gogs
Bitte warten ..
Ähnliche Inhalte
Linux Tools

Bash-Skript von User www-data als root laufen lassen

gelöst Frage von Jens4everLinux Tools6 Kommentare

Hallo zusammen, kann mir jemand dabei helfen, den User www-data zu berechtigen ein Bashskript auszuführen, das im /var/www/ liegt? ...

Exchange Server

Exchange 2016 Powershell Öffentlicher Ordner Root Verzeichnis Berichtigung für User entfernen

gelöst Frage von Tibii73Exchange Server2 Kommentare

Hallo, habe ein Problem. Und zwar: Ich soll auf einem Exhange Server die Berechtigungen für die User auf die ...

Windows Server

ROOT CA Umbenennen

gelöst Frage von agowa338Windows Server2 Kommentare

Hallo, kann mir jemand sagen, ob es einen einfacheren Weg zur Umbenennung einer ROOT CA gibt, als eine neue ...

Ubuntu

Zugriffsrechte für non-Root-User für CIFS-Laufwerk festlegen unter Ubuntu

gelöst Frage von StefanKittelUbuntu4 Kommentare

Hallo, ich habe hier eine Konzeptumgebung um was auszuprobieren. Server mit Ubuntu 16.04. Server LTS (Hetzner CX) CIFS-Laufwerk (Hetzner ...

Neue Wissensbeiträge
Off Topic
Avengers 4: Endgame - Erster Trailer
Information von Frank vor 2 TagenOff Topic

Ich weiß es ist Off Topic, aber ich freue mich auf diesen Film und vielleicht geht es anderen hier ...

Webbrowser
Microsoft bestätigt Edge mit Chromium-Kern
Information von Frank vor 2 TagenWebbrowser5 Kommentare

Microsoft hat nun in seinem Blog bestätigt, dass die nächste Edge Version kein EdgeHTML mehr für die Darstellung benutzen ...

Sicherheit

MikroTik: Sicherheitslücke wird ausgenutzt obwohl ein Update seit langem verfügbar ist

Information von sabines vor 2 TagenSicherheit

Obwohl ein Update, dass die nun massenhaft ausgenutzte Lücke schließt, seit langem (März 2018) verfügbar ist, wird es offensichtlich ...

Informationsdienste
Gut getarnter Trojaner unterwegs (Emotet)
Information von nepixl vor 4 TagenInformationsdienste3 Kommentare

Hallo, quick & dirty: ein neuer Cryptotrojaner sorgt wieder für Millionenschäden. BSI Artikel Heise Artikel Der Trojaner kommt in ...

Heiß diskutierte Inhalte
Rechtliche Fragen
Systemhaus auf Abwegen
Frage von rocco61Rechtliche Fragen12 Kommentare

Hallo zusammen, bin derzeit ratlos bei dem folgenden Scenario: In einen Seniorenheim wurde beschlossen, die IT an eine andere ...

Router & Routing
MikroTik - Routing, Bridging, Switching
gelöst Frage von Alex29Router & Routing9 Kommentare

Hallo in die Runde, als Hobby-Admin würde ich bitte mal wieder Eure Hilfe benötigen. Seit der Umstellung auf RouterOS ...

Windows Server
HP Proliant DL 380G7 ILO2 Problem und DL 580G6 OS Prolem
gelöst Frage von Home-NeulingWindows Server6 Kommentare

Hallo, ich bin neu hier, und hoffe das ich hier jetzt auch richtig Poste. Ich habe mir zuhause ein ...

Exchange Server
Exchange Server 2010: Keine Eingehenden E-MAils
Frage von gabeBUExchange Server6 Kommentare

Hallo Zusammen Ich habe das kurzen auf dem Exchange 2010 Server das Problem, dass ich keine externen E-Mails mehr ...