Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Nach "PXE basierte Netzwerkinstallation"

Mitglied: eKwie

eKwie (Level 1) - Jetzt verbinden

16.01.2006, aktualisiert 17.01.2006, 6526 Aufrufe, 2 Kommentare

Ausprobiert, nicht funktioniert

Ich möchte Suse Linux 10 über PXE von einem Server auf einen Clienten Installieren!
Ich hab als Server einen Suse Linux 10 Rechner
Als Client ein Rechner ohne CD/Floppy, only Netzwerkanschluss!

Also ich hab alles nochmals neu eingestellt!
Unwichtige dinge in den Configs habe ich rausgelassen,
wenn ich zuviel rausgelassen habe (was ich nicht glaube/hoffe)
sagt mir bescheid!

Hier meine Konfiguration:

Ordnerstruktur:
/srv/ --> /srv/SuseBoot/ --> Da ist komplette Suse 10 DVD drin
--> /srv/tftpboot/ --> ( initrd, linux, memtest, message, pxelinux.0 )
--> /srv/tftpboot/pxelinux.cfg/ --> default


default (in /srv/tftboot/pxelinux.cfg/ )

CODE
default linux
label linux #linux installation
append initrd=initrd vga=normal textmode=1 insmod=e1000 install=nfs://192.168.0.2/srv/SuseBoot/

implicit 1
display message
prompt 1
timeout 200
CODE

message (in /srv/tftboot/ )

TEXT

linux - Installation

TEXT

/etc/dhcpd.conf

IP des Servers ist 192.168.0.2, die range geht von 101-121

CODE
  1. Standardeinstellungen
option domain-name "PXEServer";
option domain-name-servers 192.168.0.2;
allow bootp;
allow booting;
allow unknown-clients;
ddns-update-style none;
default-lease-time 14400;
#Gruppe der PXE Clients
subnet 192.168.0.0 netmask 255.255.255.0 {
filename "/pxelinux.0";
range 192.168.0.101 192.168.0.121
default-lease-time 14400
use-host-decl-names on;
}
CODE


/etc/exports

CODE==
/srv/SuseBoot/ *(rw,no_root_squash,sync)
CODE==

/etc/xinitd.d/tftp

CODE==
default: off
  1. description: tftp service is provided primarily for booting or when a \
  2. router need an upgrade. Most sites run this only on machines acting as
  3. "boot servers".
service tftp
{
socket_type = dgram
protocol = udp
wait = yes
user = root
server = /usr/sbin/in.tftpd
server_args = -s /srv/tftpboot/
disable = no
}
CODE==


Was passiert?!

Ich starte den Client, er bootet, wow sogar über Netzwerk.. kommt dann zu der Message wo man "auswählen" kann.
Ich geb dann linux ein, er läd "linux" und "Initrd" .. dann das übliche
"Uncompressing the Kernel, booting Linux"
Und Stop, er hängt.

Normal ist auf dem Rechner schon Linux 10 installiert, da läd er den Kernel auch richtig, also kann es kein Hardwareproblem sein ?!

Fällt euch irgendwas auf? Also springt euch der Fehler der mich seit Wochen auf trab hält ins Auge?

MfG und danke für eure Hilfe =)
Mitglied: xypseudo
17.01.2006 um 11:59 Uhr
deine kiste hängt ja an dem punkt, an dem das image in den ram
entpackt wird - wenn ich dich richtig verstanden habe...
bei den kisten, die ich betreue, ist das inner regel ein ram-defekt.
wenn du die möglichkeit hast, tausche den ram mal zum testen aus.


gruss, pseudo
Bitte warten ..
Mitglied: eKwie
17.01.2006 um 13:11 Uhr
Habe die Riegel mal ausgetauscht (2x128 MB).. hängt sich an der selben stelle wieder auf.
Habe es nun zwischendurch auch mal mit SuseLinux 9.3 probiert.

Das komische ist, ich habe die Einstellungen von Azubis im 2 Lehrjahr mal übernommen, bei denen funktionierts (sogar mit Win2k), bei mir (mit den selben einstellungen) nicht.

Rechner haben wir die selben, den speicher hab ich eben auch augetauscht.. geht auch nicht.

wusa -.-
Bitte warten ..
Neue Wissensbeiträge
Internet

Schwarzer Tag für die Netzfreiheit: Die umstrittene Urheberrechtsreform wurde beschlossen

Information von Frank vor 1 StundeInternet7 Kommentare

Ich zitiere einfach mal Julia Reda von den Piraten, da mir selbst einfach die Worte dazu fehlen: Schwarzer Tag ...

Internet
Ist zwar keien Anleitung, aber
Anleitung von SachsenHessi vor 2 StundenInternet1 Kommentar

oder doch eine Anleitung ? Für die nächste EU-Wahl ? SH

PHP
Pfsense - Vouchergenerator 1.6.1
Anleitung von cafepost vor 3 StundenPHP

Hallo Zusammen , aus Sicherheitsgründen wurde mein Server auf den neuesten Stand gebracht, jetzt wollte ich den Vouchergenerator 1.6.1 ...

Internet

Verlag protestiert gegen Artikel 13 (jetzt Artikel 17) der geplanten EU-Verordnung

Information von Dilbert-MD vor 6 StundenInternet

Leider etwas spät, aber immerhin hat auch der heise-Verlag eingesehen, dass die Umsetzung der Urheberrechtsreform - so wie sie ...

Heiß diskutierte Inhalte
Voice over IP
Mikrotik: Voip mit SIP Phones in verschiedenen Subnetzen mit FritzBox
Frage von SpartacusVoice over IP16 Kommentare

Hallo, ich habe das Problem, dass ich verschiedene SIP-Clients in unterschiedlichen Subnetzen habe, die mit meinem Server FritzBox7412 keine ...

Exchange Server
Exchange Empfangsconnector nimmt keine SMTP Verbindung von extern an
gelöst Frage von lasterExchange Server12 Kommentare

Hallo, ich kann keine E-Mails aus einem anderen/fremden LAN an Exchange zustellen. Aus dem LAN, in dem auch der ...

Grafik
Viele Fotos organisieren - Windows Dateisystem zu lahm bzw. überfordert
Frage von augustaparkGrafik12 Kommentare

Hallo und Guten Morgen, hat einer eine Idee, wie man viele Fotos sinnvoll und effizient organisieren kann? Wir haben ...

Windows 10
22 Notebooks automatisch konfigurieren und Software installieren - womit?
gelöst Frage von ipzipzapWindows 1012 Kommentare

Hallo, ich habe für ein Projekt 22 nagelneue Notebooks mit Windows 10 bekommen, die ich alle im Großen und ...