Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Rückgabewert 1 nach start von BATCH-Datei aus Aufgabenplanung heraus (Win2008)

Mitglied: Saggi

Saggi (Level 1) - Jetzt verbinden

30.01.2010 um 12:12 Uhr, 27849 Aufrufe, 12 Kommentare

Hallo,

ich habe das Problem, dass ich eine Protokolldatei habe, welche immer größer (logischerwiese ;) ) und nach einigen Tagen bereits ca 100MB groß ist. der Hersteller der 3rd Party Software (will) ändert auch daran nichts also haben wir eine Batch geschrieben, welche die Datei mit einem Timestamp versieht und danach in den Ordner "Archiv" verschiebt.

Das Script funktioniert wunderbar wenn ich es manuell ausführe, aber sobald ich es in der Aufgabenplanung habe und es automatisch gestartet wird, so passiert nichts. Der Prozessablauf sagt zwar, dass das Programm korrekt durchgelaufen wurde, aber ich erhalte auch den Rückgabewert 1.

Alle anderen Batches, welche dort ausgeführt werden, laufen auch wunderbar - sogar mit Rückgabewert 0.

Hat vielleicht jemand ne Idee, woran das liegen kann???

MfG und schönes Wochenende

Saggi
Mitglied: AndreasBrecht
03.02.2010 um 15:32 Uhr
Hat der Benutzer, der die Taskausführt, denn di nötigen berechtigungen?
Bitte warten ..
Mitglied: Saggi
03.02.2010 um 23:12 Uhr
Hallo,

es ist der Administrator. Domänen-Admin als Useraccount und sogar der Administrator Account in der Domäne.


MfG
Bitte warten ..
Mitglied: AndreasBrecht
03.02.2010 um 23:34 Uhr
Anscheinend habe ich Deine Frage nicht gründlich genug gelesen. Mach die bat, das was siesoll, und stört dich nur der Rückgabewert. oder bleibt sie hängen, oder läuft sie durch und macht aber nichts?
Bitte warten ..
Mitglied: Saggi
04.02.2010 um 13:40 Uhr
Hallo,

sie läuft angeblich durch - gibt aber als Rückgabewert die 1. Es passiert also nichts.

Ein zweiter Unterschied ist, das als "Ergebnis der letzten Ausführung" steht (0x1)

Bei durchgelaufenen Aufgaben steht "DerVorgang wurde erfolgreich beendet (0x0)


MfG
Bitte warten ..
Mitglied: AndreasBrecht
04.02.2010 um 17:55 Uhr
Grumpf das macht es nicht einfach. Evtl. wäre es ein gangbare Weg, die batch in Teilschritte zu zerlegen, um herauszufinden, ws genau nicht funktioniert??
Bitte warten ..
Mitglied: Wolff
04.03.2010 um 08:15 Uhr
Ich möchte mich hier mal anschließen - auch ich habe dieses Problem mit einer Batchdatei.

Es scheint also nicht nur an dem Aufbau der Datei von Saggi zu liegen.

Hat vielleicht noch jemand eine Idee?
Bitte warten ..
Mitglied: FishermanXL
19.08.2010 um 11:54 Uhr
Hier die Lösung - hatte genau das gleiche Problem

Die Eigenschaften des Tasks aufrufen, dort auf die Registerkarte Aktionen, dort dann Bearbeiten. In der letzten Zeile bei Starten in (optional) einfach den Pfad angeben, wo sich die Batchdatei befindet.

z.B. wenn der Pfad zum Batchfile c:\programme\batchfiles\backup.bat ist,
dann einfach c:\programme\batchfiles angeben.
Bitte warten ..
Mitglied: SchubOZ
24.09.2010 um 13:45 Uhr
Hallo Fisherman,

habe auch das Problem.
Was muss ich bei Programm/Script angeben, die cmd.exe oder die Batch-Datei?
Bei "Argumente hinzufügen (optional)" muss der Pfad der batch-Datei rein, richtig?

Habe alles probiert, die batch-Datei wird in der Aufgabenplanung nicht ausgeführt.
batch läuft aber sauber wenn man diese manuell startet.

Hat irgendwer noch eine Idee?

Grüße Schub
Bitte warten ..
Mitglied: milestone
18.11.2010 um 21:17 Uhr
@Schub

Es steht zwar schon an anderer Stelle, aber hier nochmal im Detail wie das genau funktioniert:

Aktion: Programm Starten
Programm/Skript: C:WindowsSystem32cmd.exe
Argumente hinzufügen (optional): /C C:BackupBackup.bat
Starten in (optional): C:Backup

Hoffe das dir das weiterhilft.
Bitte warten ..
Mitglied: SchubOZ
19.11.2010 um 15:47 Uhr
Ja, danke.
Problem war aber die Batch-Datei selber.
Bitte warten ..
Mitglied: heyko
13.08.2012 um 12:23 Uhr
Hallo zusammen,

vielen Dank für den Hinweis mit dem "Starten in" damit konnte ich das Problem bei mir lösen.

Sofern Ihr den Task nicht als Administrator (oder wie oben sogar als Domänen-Administrator) starten wollt, reicht es wenn der Nutzer in der lokalen Sicherheitsrichtlinie zu "Anmelden als Stapelverarbeitungsauftrag" zugewiesen wird.

Gruß,

Heyko
Bitte warten ..
Mitglied: Denniz
10.12.2013 um 09:39 Uhr
Hallo zusammen,

wir haben seit ca. 3 Wochen das gleiche Problem mit dem Rückgabewert 0x1. Die Aufgabe lief seit ca. 1 Jahr ohne Probleme.
Es wird nach einem bestimmten Ereignis eine CMD Datei gestartet die eine E-Mail verschickt. "Starten in" ist und war gesetzt.
Interessant bei uns ist, wenn ich die Aufgabe manuell starte, funktioniert alles, nur wenn die Aufgabe durch das Ereignis gestartet wird funktioniert es nicht.
Nach einem Serverneustart kann es sein, dass es mal einen Tag funktioniert und dann wieder nicht geht.

Ich danke für eure Hilfe.

Gruß
Dennis
Bitte warten ..
Ähnliche Inhalte
Batch & Shell

Batch Datei wird per Aufgabenplanung nicht ausgeführt

Frage von CorraggiounoBatch & Shell7 Kommentare

Hi, ich hoffe ihr könnt mir weiterhelfen. Folgende Konfiguration habe ich vorgenommen um ein batch-script auszuführen: Unter Programm/Skript habe ...

Windows Server

Batch-Datei startet in der Aufgabenplanung nicht

gelöst Frage von koehloWindows Server12 Kommentare

Hallo zusammen, ich bekomme das einfach nicht hin und hoffe jetzt auf Hilfe von den Profis. Ich arbeite mit ...

Server-Hardware

HP iLO 1 - Start Server per Batch

gelöst Frage von caspi-pirnaServer-Hardware13 Kommentare

Hallo, ich habe einen betagten Server (HP ProLiant DL385 G1) mit iLo-Schnittstelle (iLo 1.9x) und möchte diesen von einem ...

Windows 7

Windows Netzlaufwerk per Batch-Datei und Aufgabenplanung trennen

Frage von dr.kelsoWindows 710 Kommentare

Hallo zusammen, ich versuche gerade über die Aufgabenplanung zu realisieren, dass ein Netzlaufwerk täglich zu einer bestimmten Zeit getrennt ...

Neue Wissensbeiträge
Humor (lol)
Preisvertipper
Information von Dilbert-MD vor 11 StundenHumor (lol)6 Kommentare

Moin! weil heute Freitag ist, zeige ich Euch den Preisvertipper der Woche: vergesst den Acer Predator 21x, der ist ...

Windows Update
Sicherheitsupdate für SQL Server 2014 SP3
Information von sabines vor 1 TagWindows Update2 Kommentare

Für den SQL Server 2014 existiert ein Sicherheitsupdate. Laut KB Artikel wird es als CU3 angezeigt: Server 2014 SP3 ...

Backup

Veeam Agent für MS Windows - neue Version verfügbar (bedingt jedoch offenbar .NET Framework 4.6)

Information von VGem-e vor 2 TagenBackup1 Kommentar

Moin Kollegen, einer unserer Server zeigte grad an, dass für o.g. Software ein Update verfügbar ist. Ob ein evtl. ...

Python

Sie meinen es ja nur gut - Microsoft hilft python-Entwicklern auf unnachahmliche Weise

Information von DerWoWusste vor 4 TagenPython2 Kommentare

Stellt Euch vor, Ihr nutzt python unter Windows 10 und skriptet damit regelmäßig Dinge. Nach dem Update auf Windows ...

Heiß diskutierte Inhalte
Windows Update
WSUS - erforderlich Updates
Frage von emeriksWindows Update24 Kommentare

Hi, ein gängiges Verfahren, welche Updates man am WSUS-Server genehmigen soll und welche nicht, beruft sich darauf, dass man ...

Netzwerkgrundlagen
Neue Serverumgebung von 0 aufbauen
Frage von JacareNetzwerkgrundlagen20 Kommentare

Hallo zusammen, ich bin noch nicht lange hier und weiß nicht, ob meine Frage daher etwas ungewöhnlich ist. Ich ...

Off Topic
Installationskosten Verkabelung
Frage von Xaero1982Off Topic14 Kommentare

Moin Zusammen, ich bräuchte mal ein paar Meinungen, weil ich mir da gerade echt nicht ganz sicher bin. Ich ...

LAN, WAN, Wireless
Ich möchte mein Heimnetz umbauen. Welches ist die beste Variante?
Frage von s.burgerLAN, WAN, Wireless13 Kommentare

Schönen guten Tag liebe Admin-Community, ich wollte schon seit geraumer Zeit mein Heimnetzwerk etwas aufräumen und wollte euch um ...