Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Routing von 2 internen Netzen bei SBS2003

Mitglied: syncmaster

Ich habe einen SBS203 mit 2 Netzwerkkarten. Jede dieser Karten hat ein eigenes Netz (192.168.40.x und 192.168.41.x).

Was muß ich tun, damit alle Clients aus dem 40-er Netz auch die Clients des 41-er Netzes sehen und umgekehrt?

Leider habe ich das IP-Forwarding von früher bei SBS2003 nicht mehr gefunden.

Wäre toll, wenn mir jemand helfen könnte, da ich das Problem noch diese Woche lösen muß.

Gruß

Thomas

Content-Key: 3331

Url: https://administrator.de/contentid/3331

Ausgedruckt am: 24.07.2021 um 15:07 Uhr

Mitglied: LarsJakubowski
LarsJakubowski 20.10.2004 um 10:24:41 Uhr
Goto Top
Versuch mal den Befel "add route" um die Route hinzuzufügen.
Würde die Route aber auf "ständig" setzen.

Der Befhel würde dann so aussehen: add route -p 192.168.41.0 255.255.255.0 IP gateway 192.168.40.0

Das sollte so gehen.
Für Beispiele der Route Befehle ruf an der Eingabeaufforderung route auf.

Lars
Mitglied: syncmaster
syncmaster 21.10.2004 um 20:12:31 Uhr
Goto Top
Das habe ich auch schon probiert (nur nicht permanent), aber das klappt auch nicht. Nun hat jemand gemeint, daß sich die beiden Netze vielleicht vertrauen müssen. Ich habe aber keine Ahnung wo man dies einstellen kann. Bei den Netzwerkeigenschaften geht es nicht.

Hast du noch eine Idee?
Mitglied: LarsJakubowski
LarsJakubowski 21.10.2004 um 20:22:47 Uhr
Goto Top
Bei einem Ping ist die Vertrauenseinstellung uninteressant. Das wird bei Active Directory vielleicht interessant. Aber auch nur wenn es zwei unterschiedliche Domains in den Netzen gibt.

Normalerweise ist das Routing so korrekt. Wie lautet denn dieFehlermeldung, wenn Du versuchst die Route hinzuzufügen?

Trägst Du den richtigen Gateway ein?
Denk dran, Du musst die Route auf beiden Seiten des Netzwerkes hinzufügen.

Wie sind die beiden Netze miteinander verbunden. Gib mir doch mal alle Konfig Einstellungen die Du hast.
Ich überlege mir dann was.

Lars
Mitglied: syncmaster
syncmaster 21.10.2004 um 21:17:42 Uhr
Goto Top
Das Hauptnetz hat den Adressbereich 192.168.40.0
Server-IP Hauptnetz 192.168.40.1

Das andere Netz hat den Adressbereich 192.168.41.0
Server-IP anderes Netz 192.168.41.254

Ich lege nur eine Route auf:
route add -p 192.168.81.0 mask 255.255.255.0 192.168.80.1

und eine auf:
route add -p 192.168.80.0 mask 255.255.255.0 192.168.81.254

Eigentlich sollte das klappen! Oder nicht?
Mitglied: syncmaster
syncmaster 21.10.2004 um 21:28:04 Uhr
Goto Top
Hab aus Versehen die falschen Routing--Adressen reingeschrieben. Mache aus 80 einfach die 40 und aus 81 die 41. Dann stimmt alles.
Mitglied: LarsJakubowski
LarsJakubowski 21.10.2004 um 21:43:55 Uhr
Goto Top
Das Problem ist, dass Du keinen Gateway hast, um die Netze zu verbinden.
ALs Gateway brauchst Du z.B. einen Router.

Ohne gateway kannst Du zwei unterschiedliche Netze nicht miteinander verbinden.

Weist Du was ich meine?

Lars
Mitglied: LarsJakubowski
LarsJakubowski 21.10.2004 um 21:49:57 Uhr
Goto Top
Du kannst auch einen Windows Server als Router nutzen, in dem Du dort einen DHCP Router aktivierst. Das geht sogar mit Windows Boardmitteln ziemlich einfach.

Lars
Mitglied: syncmaster
syncmaster 21.10.2004 um 21:57:51 Uhr
Goto Top
OK, dann fehlt dir noch eine Info. Als Gateway im 40-er Netz habe ich eine Workstation, die als Internet-Gateway, Firewall und VPN-Server fungiert. Da dieser Rechner nur im 40-er Netz ist, kann ich diesen natürlich nicht als Gateway für das 41-er Netz verwenden. Oder doch?

Könnte es funktionieren, wenn ich diesem Rechner einfach eine 2. IP-Adresse verpasse, die im 41-er Netz liegt?
Mitglied: LarsJakubowski
LarsJakubowski 21.10.2004 um 22:16:21 Uhr
Goto Top
Ne, so einfach ist es nicht.
Aber ich habe gerade was bei Dir überlesen. Du hast einen Server, der 2 Netzwerkkarten hate.
Der muss als Router zwischen den Netzen fungieren.
Dazu musst Du den DHCP Dienst installieren und den Softwarerouter des DHCP aktvieren?
Schon mal gemacht?
Wenn nicht, dann kann ich Dir das morgen auch erklären. Ist keine große Sache.

Lars
Mitglied: syncmaster
syncmaster 21.10.2004 um 22:40:26 Uhr
Goto Top
Nein, habe ich noch nicht gemacht. Wäre echt nett, wenn du mir zur Einrichtung des Softwarerouters einige Takte sagen könntest.
Ich werde versuchen morgen nachmittag mal hereinzuschauen. Wenn das nicht klappt, dann mache ich es am Samstag.

Bis dann.
Mitglied: LarsJakubowski
LarsJakubowski 22.10.2004 um 08:13:51 Uhr
Goto Top
Sorry, habe mich gestern Abend vertan.
Du musst lediglich Routing und RAS auf dem Server aktivieren und konfigurieren.

Am besten meldest DU dich kurz, wenn Du davor sitzt. Ist dann einfacher das mit Dir einzurichten.

Lars
Mitglied: syncmaster
syncmaster 22.10.2004 um 08:48:20 Uhr
Goto Top
Ich bin gegen 10.00 Uhr vor dem Server.
Mitglied: LarsJakubowski
LarsJakubowski 22.10.2004 um 08:55:30 Uhr
Goto Top
Gut. Melde Dich dann.
Versuche das dann mit Dir einzurichten. Schwer ist es nicht. Keine Sorge

Lars
Mitglied: syncmaster
syncmaster 22.10.2004 um 10:32:25 Uhr
Goto Top
Hallo,

ich sitze jetzt vor dem Gerät. Sollen wir das Ganze lieber telefonisch machen? Natürlich auf meine Kosten!
Mitglied: LarsJakubowski
LarsJakubowski 22.10.2004 um 10:45:29 Uhr
Goto Top
Sorry, aber gehts auch so in einer Stunde?
Verkaufe gerade mein altes Auto :-) face-smile

Lars
Mitglied: syncmaster
syncmaster 22.10.2004 um 10:56:14 Uhr
Goto Top
Alles klar. Wenn du willst, dann kannst du mir auch kurz unter 0172/7128076 Bescheid geben.
Mitglied: LarsJakubowski
LarsJakubowski 22.10.2004 um 12:06:45 Uhr
Goto Top
Sorry, aber ich komme gerade an keinen Server drauf, wo ich die Routing und RAS Einstellungen mit Dir vornehmen kann.
Ich versuche es aber gerade noch.
Wollte nur das Du eben bescheid weist.

P.S. mein Auto ist erfolgreich verkauft :-) face-smile

Lars
Mitglied: syncmaster
syncmaster 23.10.2004 um 00:45:27 Uhr
Goto Top
Hallo Lars,

leider hat es bei mir gestern auch nicht mehr geklappt. Aber vielleicht haben wir in den nächsten Tagen ja die Gelegenheit, die Sache anzugehen. Im übrigen habe ich eigentlich immer Zugriff auf den Server, so daß es bei mir höchstens an der Zeit mangelt.

Bis dann
Mitglied: LarsJakubowski
LarsJakubowski 23.10.2004 um 12:11:34 Uhr
Goto Top
Ich bin Monatg wieder ganz da.
Dann können wir uns mal zusammen mit dem Problem auseinander setzen.

Hier ist meine Nummer: 0175 148 4921.
Wir können Montag ja telefonieren.

Lars
Mitglied: syncmaster
syncmaster 23.10.2004 um 14:14:23 Uhr
Goto Top
Alles klar. Ich hab am Montag noch einen Kunden am Telefon, was aber bis etwa 11.00 Uhr erledigt sein dürfte. Ich melde mich telefonisch.
Bis dann
Mitglied: LarsJakubowski
LarsJakubowski 23.10.2004 um 15:02:16 Uhr
Goto Top
11 Uhr hört sich gut an.

Dann bis Montag.

Lars
Mitglied: syncmaster
syncmaster 26.10.2004 um 00:48:10 Uhr
Goto Top
Hallo Lars,

meinst du daß es heute noch klappen könnte die Sache anzugehen?
Mitglied: LarsJakubowski
LarsJakubowski 26.10.2004 um 09:34:24 Uhr
Goto Top
Hi,

denke schon. Bin ab 17 Uhr heute im Büro.
Da können wir telefonieren wenne s da geht.

lars
Mitglied: syncmaster
syncmaster 26.10.2004 um 09:45:49 Uhr
Goto Top
Okay, ich rufe dich dann an. Gestern hat es leider erst um 18.00 Uhr geklappt. Bei uns ist ein Rechner ausgefallen und wollte repariert werden.
Mitglied: JaMeS
JaMeS 27.10.2004 um 08:51:43 Uhr
Goto Top
Ihr sucht wahrscheinlich in die falsche Richtung -
das Problem liegt nach meiner Erfahrung bei der Browserliste (war in Coax-Zeiten durch erforderlichen Teil-Netze häufiges Problem). Symtome: mal in einem, mal im anderen Teilnetz fehlen (oft nur einige, auch mal alle) Clients. Anpingbar sind sie, shares sind problemlos möglich. Auch wenn mit WINS (auf den betroffenen Server) gearbeitet wird, wird u.U. keine einwandfreie Browserlist publiziert (das macht es so spannend: mal gehts, mal nicht)!
Wenn im Server zwei (oder mehr) NIC's vorhanden sind, muß ihm untersagt werden, als Masterbrowser in diesen (Teil-) Netze zu fungieren - er 'weisst' sonst nicht um welches er sich zuerst (zuletzt) kümmern muß ...
Alles schön beschrieben in MS Knowledge: Artikel-ID D191611; da steht auch wie abzuschalten!
Heiß diskutierte Beiträge
question
RAM-Zugriff auf einem neuen High-Performance Server, teilweise um Welten langsamer als auf einer WorkstationMysticFoxDEVor 1 TagFrageBenchmarks45 Kommentare

Moin Zusammen, mir ist gestern beim Optimieren eines neuen Servers eine Sonderheit aufgefallen, die ich mir so beim besten Willen, momentan absolut nicht erklären kann. ...

general
Kosten nicht gerechtfertigt? Dienstleister stellt Kosten für "Troubleshooting" bei Neuanschaffung von HCI + CoreSwitchDirty2186Vor 1 TagAllgemeinZusammenarbeit17 Kommentare

Hallo Zusammen, ich interessiere mich für Eure Meinung zu dem Thema Leistungsnachweise von Systemhäusern und Dienstleistern und deren Berechnung von Leistungen. Da sich hier ja ...

question
Listet Microsoft Default ACLs von Windows?DerWoWussteVor 1 TagFrageSicherheit18 Kommentare

Moin Kollegen. Nach dem Sicherheits-GAU "Hivenightmare" stellt sich mir die Frage, wie ich in Zukunft sicherstellen kann, dass die ACLs der Systemdateien in Windows korrekt ...

question
Erfahrungen mit CodeTwo Exchange Migration von 2016-2019dlohnierVor 1 TagFrageExchange Server18 Kommentare

Hallo, ich möchte unseren Exchange Server 2016 der noch auf WIndows 2016 läuft auf einen Server 2019 mit Exchange 2019 migrieren. Habe das Tool "CodeTwo ...

question
Doppelte A-Records in DNSBPeterVor 1 TagFrageWindows Server10 Kommentare

Hallo, unsere Windows Notebooks registrieren sich im DNS mit ihrer Lan- und Wlan Adresse. D.h. es gibt 2 gleiche Namen mit 2 unterschiedlichen IP-Adressen. Wie ...

question
2U Home-Server Frage zur HardwaremossoxVor 21 StundenFrageServer-Hardware10 Kommentare

Hallo zusammen, ich habe in den letzten Jahren auf die Systeme von Synology gesetzt. Im Wesentlichen ging es immer nur um simple CIFS Dienste, nichts ...

question
Powershell Ordner löschen die älter als x Tage sindsascha46Vor 19 StundenFrageEntwicklung6 Kommentare

Hallo Ich würde gerne in einem Verzeichnis alle Ordner die älter als X Tage sind löschen. Aber irgendwie bekomme ich das nicht hin. Bisher habe ...

question
Antivirus auf Synology sinnvoll?CoreknabeVor 1 TagFrageSAN, NAS, DAS3 Kommentare

Moin, nachdem Antivirus Essentials auf unserem Synology-NAS wieder einmal lustige Kapriolen fabriziert (Installationsdatei für MS Office ist hochgefährlich), stelle ich mir die Frage, ob es ...