Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Routing unter Debian

Mitglied: samsx87

samsx87 (Level 1) - Jetzt verbinden

28.08.2007, aktualisiert 02.09.2007, 5305 Aufrufe, 5 Kommentare

Hallo zusammen

Ich habe ein Problem mit dem routing unter debian.
Mein Netzwerk sieht wie folgt aus:

WAN
|
|
Router 192.168.1.1
(Routet das 10.0.0.0 Netz nach 192.168.1.5) ------------------ Windows XP PC (192.168.1.2)
|
|
Netz 1:
Netmask: 192.168.1.0
Subnetzmask: 255.255.255.0
Standartgateway 192.168.1.1
|
|
eth0 (192.168.1.5)
Debian (welcher als Router fungieren soll)
eth1 (10.0.0.1)
|
|
Netz 2:
Netmask: 10.0.0.0
Subnetmask: 255.0.0.0
Stabdartgateway: 10.0.0.1
|
|
Windows 2003 Server (10.0.0.2)

Wie kann ich nun den Debian Rechner als Router (inkl. NAT) konfigurieren?

Das pingen von 192.168.1.2 nach 10.0.0.1 sowie umgekehrt funktioniert
Das pingen von 10.0.0.2 nach 10.0.0.1 funktioniert, jedoch NICHT umgekehrt
Das pingen von 10.0.0.2 nach 192.168.1.2 funktioniert in beide Richtungen NICHT

Die routing Tabelle auf dem Debian Rechner sieht wie folgt aus:

192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
10.0.0.0 * 255.0.0.0 U 0 0 0 eth1
default 192.168.1.1.loc 0.0.0.0 UG 0 0 0 eth0
Mitglied: Dani
28.08.2007 um 19:02 Uhr
Hallo samsx87,
also hier gibts n prima Tutorial von aqui dazu. Funktioniert sowohl unter Linux als auch unter Windows.


Grüße
Dani
Nächstes mal bitte die Suche benutzen!!
Bitte warten ..
Mitglied: samsx87
28.08.2007 um 20:47 Uhr
Vielen Dank für die Antwort!
Habe das Tutorial durchgelesen, jedoch bin ich immer noch gleich weit wie am Anfang

Kann mir jemand helfen?
Bitte warten ..
Mitglied: aqui
02.09.2007 um 16:25 Uhr
...Das pingen von 10.0.0.2 nach 10.0.0.1 funktioniert, jedoch NICHT umgekehr t

Das hat natürlich mit deinem Debian Router rein gar nichts zu tun, denn das ist mit Sicherheit eine Firewall Einstellung a.) unter Windows und/oder b.) unter Linux.
Lokale Firewalls musst du für ICMP Echo Packete (Ping) öffnen. Wie man das unter Windows macht ist einfach:
Eigenschaften LAN Verbindung -> Erweitert -> Windows Firewall Einstellungen -> Erweitert -> ICMP Einstellungen -> Hier den Haken setzen bei Eingehende Echoanforderungen zulassen !!!

Bei Linux dürfte es analog sein obwohl Ping dort in der Regel per Default geht.

Ggf. ist das das Problem aller deiner Ping Tests, deshalb macht es am meisten Sinn erstmal das funktionierende Routing des Routers zu verifizieren indem man die Interface des Routers pingt (Debian) aus dem jeweiligen anderen Netz und nicht gleich 2 Endgeräte mit unkalren Firewall Settings .
Also folgendes solltest du zuerst machen:
  • Ein Ping auf eth0 (192.168.1.5) aus dem 10er Netz
  • Ein Ping auf eth1 (10.0.0.1) aus dem 192.168.1er Netz
  • Ein Ping aus dem 10er Netz auf den DSL Router 192.168.1.1

Das muss auf alle Fälle beidseitig funktionieren und damit hätte man dann grundsätzlich das funktionierende Routen der Debian Maschine geprüft !!!

Wenn du dir das Tutorial durchgelesen hast wird dir nicht entgangen sein das du zwingend eine statische Route auf dem DSL Router benötigst die da lautet:
Zielnetz: 10.0.0.0, Maske: 255.0.0.0, Gateway: 192.168.1.5

Das ist zwingend erforderlich sonst kann der DSL Router keine Packete ins 10er Netz routen.

Das du natürlich den Debian Rechner in der sysconfig auf IP Forwarding gesetzt hast bzw. diesen Parameter aktiviert hast mit einem anschliessenden Reboot sei hier mal vorausgesetzt, denn sonst routet der Debian Rechner nicht !!!
Bitte warten ..
Mitglied: samsx87
02.09.2007 um 16:37 Uhr
Vielen Dank für deine Antwort!
Das Problem wart tatsächlich die Windows Firewall
Bitte warten ..
Mitglied: aqui
02.09.2007 um 16:39 Uhr
Ist es hier im Forum in 98% aller Fälle bei Verbindungsproblemen....du bist also in guter Gesellschaft
Bitte warten ..
Ähnliche Inhalte
Debian
Debian 8.6 Absichern?
Frage von Motte990Debian14 Kommentare

Hallo Leute zurzeit befasse ich mit Debian 8.6 in einer Vmware Umgebung. Zum Einsatz kommen Debian 8.6 mit apache2 ...

Debian
Debian SCP Probleme
Frage von ProtectedDebian11 Kommentare

Hallo, ich habe mir eine Storagebox bei Hetzner zugelegt, welche auch SCP als Übertragung erlaubt. Ich habe bereits den ...

Debian
Debian Postfix Einrichtung
Frage von Diamond72Debian4 Kommentare

Hallo Zusammen, ich möchte gerne auf meinem Webserver (Debian Jessie) postfix konfigurieren. Ziel ist es den Server so zu ...

Router & Routing
Standortübergreifendes Routing
Frage von flabsRouter & Routing2 Kommentare

Hallo zusammen, ich habe Frage zum Thema Standort übergreifendes Routing. An Standort A habe ich eine Pool an externen ...

Neue Wissensbeiträge
Humor (lol)
Administrator.de Perlen
Tipp von DerWindowsFreak2 vor 4 TagenHumor (lol)6 Kommentare

Hallo, Heute beim stöbern auf dieser Seite bin auf folgenden Thread aus dem Jahre 2006 gestossen: Was meint ihr? ...

Erkennung und -Abwehr
OpenSSH-Backdoor Malware erkennen
Tipp von Frank vor 5 TagenErkennung und -Abwehr

Sicherheitsforscher von Eset haben 21 Malware-Familien untersucht. Die Malware soll Hintertüren via OpenSSH bereitstellen, so dass Angreifer Fernzugriff auf ...

iOS
WatchChat für Whatsapp
Tipp von Criemo vor 8 TageniOS5 Kommentare

Ziemlich coole App für WhatsApp User in Verbindung mit der Apple Watch. Gibts für iOS sowohl als auch für ...

iOS
IOS hat nen Cursor!
Tipp von Criemo vor 9 TageniOS5 Kommentare

Nette Funktion im iOS. iPhone-Mauszeiger aktivieren „Nichts ist nerviger, als bei einem Tippfehler zu versuchen, den iOS-Cursor an die ...

Heiß diskutierte Inhalte
Samba
Windows 10 Client in Samba-Domäne hinzufügen scheitert
Frage von diwaffmSamba31 Kommentare

Hi Leute, ich habe einen Samba Server in der Version 4.9.3 auf einer OpenSuse Maschine laufen. Damit sind momentan ...

Windows Systemdateien
Verknüpfungen nach Pfadwechsel
Frage von Hendrik2586Windows Systemdateien17 Kommentare

Guten Morgen meine lieben Kollegen und Kolleginnen, ich hab da mal eine Frage die Ihr sicher schon kennt. Es ...

Batch & Shell
CMD-Fenster nach Task schließen
gelöst Frage von Hyperlink.93Batch & Shell16 Kommentare

Hallo, ich habe ein Skript was über einen Task bei jeder User Anmeldung läuft. Der Task startet eine CMD ...

Netzwerkmanagement
Sehr langsame Netzverbindung in einem bestimmten Subnet
gelöst Frage von gabeBUNetzwerkmanagement15 Kommentare

Hallo Zusammen Ich habe das folgende Problem: Unser Netzwerk, dass aus verschiedenen Subnetzwerken aufgebaut ist, ist nicht in jedem ...