Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Sehr, sehr langsamer http-Transfer bei einem gleichzeitigem Download

Mitglied: Dj4ngo

Dj4ngo (Level 1) - Jetzt verbinden

09.12.2013 um 16:11 Uhr, 3847 Aufrufe, 7 Kommentare

Hallo Zusammen,

zu meinem Problem:

Wir haben eine 4Mbit Internetanbindung, die über ein IPFire-gateway (IPFire 2.13 (i586) - core73) ans LAN angebunden ist.
Als Switch benutzen wir einen LevelOne - GEL 2870.

Wenn die Clients normal surfen ist eigentlich auch alles wunderbar und verhält sich der Leistung entsprechend normal.
Startet jetzt aber ein Client einen Download per http oder ftp passiert folgendes:

- Der downloadene Client kriegt die volle Bandbreite (Startet ein weiterer Client einen Download, teilen sich die Downloader die zu verfügungstehende Bandbreite so wie es sein soll.)

- Alle anderen Clients die ab jetzt versuchen http-Seiten aufzurufen haben teilweise response-Zeiten von 20-30 Sekunden und mehr. Also wirklich super langsam und nicht mehr wirklich zu gebrauchen.

Der Support-Mitarbeiter von unserem Provider meinte dazu, es wäre ein völlig normales Verhalten der Leitung, wenn sie ausgelastet ist. Irgendwie will das hier im Haus niemand so richtig hinnehmen, weil man es z.B. von zu Hause anders kennt. Http-Response-Zeiten von 30 Sekunden und länger können doch nicht normal sein, oder?

Jetzt meine Frage: Woran könnte das liegen und wie komme ich dem Problem auf die Spur? Es laufen keine Qos-Dienste oder sonst ein shaping.


Danke für eure Mühe und Anworten.

LG
Andreas
Mitglied: sqanto
09.12.2013 um 16:18 Uhr
Hi


Das Zauberwort heißt bei euch vielleicht priorisierung

Du kannst z.b am Switch bestimmten Traffic limitieren(ftp)

und anderen bevorzugen (http,https)

Ich bin eher der Cisco typ und kenne die befehle bei LevelOne nicht
Bitte warten ..
Mitglied: MrNetman
09.12.2013 um 16:39 Uhr
Normal heißt ja nicht aktzeptabel.

Die technsiche Erklärung für die Einschränkungn ist ok.
Dass die Mitarbeiter so etwas nicht aktzeptieren wollen ist auch logisch.

So wirst du also für solche Zwecke in deiner IPFire etwas regeln müssen um die Bandbreite für den Rest der Mitarbeiter nicht zu zerstören. Das ist Layer7 Priorisierung in Kombination mit den Clients. So etwas wie es muss immer etwa 1/3 der Bandbreite oder mindestens 1Mbit/s für neue Request offen bleiben. Ein Proxy kann möglicherweise auch so etwas leisten.

Du nennst es ja selbst shaping. So sieht eine Lösung aus.
Ansonsten ist Ehternet und IP: Was so eben geht. "best effort"

Gruß
Netman
Bitte warten ..
Mitglied: aqui
09.12.2013, aktualisiert um 18:28 Uhr
Na ja der Level One Switch im lokalen LAN ist ja auch die komplett falsche Baustelle ! Der hat mit der o.a. Problematik nämlich rein gar nix zu tun.
Relevant ist die IPFire bzw. was VOR der IPFire ist. Die IPFire hat ja einen Breitbandanschluss als WAN Port, sprich einen nackten Ethernet Port. Folglich kann sie also die 4 Mbit Leitung NICHT direkt bedienen ohne Modem.
Die Kardinalsfrage ist nun also WAS steckt zwischen IPFire und der 4 Mbit Wanddose ?? Ein Modem, ein Router…??
Das teilt der TO uns ja intelligenterweise nicht mit so das uns da nur die berühmte Kristallkugel bleibt.
Sinnvollerweise wäre es ein reines Modem. Wenn es aber ein Router ist, der wohlmöglich auch noch NAT macht, hast du 2 kaskadierte NAT Prozesse, 2 unterschiedliche Router HW zum Troubleshooten usw. usw.
Bevor wir also jetzt hier weiterraten sollte der TO da mal etwas detailierter werden.
Sinnvoll wäre auch mal eine andere Router HW oder eine andere FW zu testen https://www.administrator.de/contentid/149915 um mal grob durch ein Ausschlussverfahren den Verursacher rauszubekommen. 20-30 Sekunden, wenn das nicht gelogen oder übertrieben ist, ist wirklich nicht normal.
Obwohl der Provider nicht ganz Unrecht hat, denn bei FTP kommt meist ein kontinuierlicher Datenstrom wo sich die TCP Windows anpassen können was hie und da mal ein HTTP Request nicht hat. So lange Wartezeiten sind aber nicht normal, wenn alle User teilen sich diese Bandbreite….

Sehr sinnvoll beim Einsatz von IPFire in Verbindung mit langsamen Leitungen ist diese auf CoDel Betrieb zu stellen:
https://www.heise.de/artikel-archiv/ct/2013/20/188_Paketbeschleuniger
Auch das wird vermutlich dein Problem schon lösen.
Bitte warten ..
Mitglied: Dj4ngo
09.12.2013, aktualisiert um 17:22 Uhr
Danke erstmal fuer die wirklich schnellen Antworten...

- Zwischen Dose und IPFire befindet sich ein Router des Providers - auf den wir allerdings keinen Zugriff haben.

Ich arbeite mal die Vorschläge ab und melde mich danach nochmal....


Vielen Dank erstmal...

LG
Andreas
Bitte warten ..
Mitglied: aqui
09.12.2013, aktualisiert um 18:27 Uhr
.. ."befindet sich ein Router des Providers"
Das war zu befürchten…. Habt ihr da ein öffentliches Subnetz vom Provider bekommen oder nutzt der Router zur Schnittstelle zu euch ein privates RFC 1918 Subnetz ? Auf was für einer HW rennt die IPFire speziell welche NIC Karten ? Kontraproduktiv ist hier alles was Treiber bzw. Chipsets hat die Paket Forwarding der CPU aufbürden wie Chipsets von Realtek z.B. Das solltest du klären und ggf. tauschen.
Wenn möglich auch CoDel aktivieren in der IPFire.

Ein weiteres Problem ist der Geschwindigkeitsunterschied zwischen den Routern dieser Kaskade. Die IPFire geht davon aus das sie 100 Mbit/s Wirespeed hat am WAN Port. Kannst du an der IPFire irgendwie die Bandbreite in der Konfig vorgeben und sagen das dort nur 4 Mbit sind.
Dann würde sie den Traffic besser steuern können. Bei der pfSense ist sowas möglich.
Ansonsten testweise mal andere Routing HW checken nur mal um zu sehen ob es grob einen Unterschied macht.
Bitte warten ..
Mitglied: Keke84
10.12.2013, aktualisiert um 02:20 Uhr
Also das darf so nicht sein. Die Kommentare weiter oben mit QOS haben damit ja nichts zu tun, denn es geht um den Download. Da kannst du nichts sinnvoll shapen. Meiner Ansicht nach ist es Aufgabe des Providers, dass man auch bei Vollspeed-Download noch mit einer zweiten Verbindung surfen kann. Und soweit ich weiss gibts da auch keine Probleme. Als nächsten - und einfachen Schritt - ohne jetzt hier sehr viel rumzuraten was es alles sein kann, würde ich mal dein IPFire GW austauschen. Wenn du die Gelegenheit dazu hast, teste mal eine Watchguard - oder auch eine Fritzbox oder was auch immer - aber einfach mal den Router tauschen.
Viel Erfolg.
Bitte warten ..
Mitglied: aqui
10.12.2013 um 10:49 Uhr
.. ."ist es Aufgabe des Providers, dass man auch bei Vollspeed-Download noch mit einer zweiten Verbindung surfen kann." Nein, nicht wirklich. Es ist die Aufgabe des TCP/IP Protokolls, des Stomversorgers und der Leitung.
Das wäre so als wenn du sagst: "Eigentlich ist es Aufgabe des Staates das mein Auto auf der Strasse rollt…".
Außer Watchguard und Fritzbox kannst du auch noch Cisco, Lancom, D-Link, Edimax, TP-Link, Monowall, pfSense, Astaro, Sophos usw. usw. testen.
Auf die Ergebnisse sind wird dann mal gespannt….
Bitte warten ..
Ähnliche Inhalte
Samba
Up- und Download zu NAS langsam
Frage von strohanSamba7 Kommentare

Hallo liebe Leute, habe hier in meinem Heimnetz eine Eigenbau-NAS, angeschlossen an eine FritzBox 5790. Ich verwende (gezwungenermaßen) 2,4 ...

Server

Download aus einer VM langsam (Virtualbox)

gelöst Frage von thepandapiServer3 Kommentare

Guten Morgen alle Zusammen! ich hätte da mal eine Frage. Ich habe auf meinem Server via Virtualbox eine VM ...

iTunes

Windows 10 iTunes 12.3.2.35 download iOS sehr langsam

gelöst Frage von tefloniTunes7 Kommentare

Hallo, ich habe seit kurzem ein Breitbandanschluss mit 100Mbit. Der funktioniert wunderbar. Überrascht bin ich, dass via ITunes gerade ...

Viren und Trojaner

Ransomware download?

gelöst Frage von runasserviceViren und Trojaner7 Kommentare

Hallo, ich möchte gerne mein Testsystem mit einen Verschlüsselungstrojaner infizieren. Ich habe bereits einige Tage lang, alle möglichen Spam-Mails ...

Neue Wissensbeiträge
Viren und Trojaner

Staatstrojaner soll auch per Einbruch installiert werden können

Information von transocean vor 1 TagViren und Trojaner2 Kommentare

Moin, Bundesinnenminister Horst Seehofer will dem Verfassungsschutz Wohnungseinbrüche erlauben, um den geplanten Staatstrojaner zu installieren. Gruß Uwe

Windows 7
Win7 Update scheitert KB4512506
Information von infowars vor 1 TagWindows 7

Falls jemand auch das Problem hat mit dem: Monatliches Sicherheitsqualitätsrollup für Windows 7 für x64-basierte-Systeme (KB4512506) Das scheint mit ...

Humor (lol)
Wenn hacken nach hinten los geht
Information von em-pie vor 2 TagenHumor (lol)5 Kommentare

Moin, weil heute Freitag ist, nachfolgender kurzer Artikel zum schmunzeln:) l+f: NULL ist ein notorischer Falschparker

Windows Update
Windows: August 2019 Patchday-Probleme
Information von kgborn vor 3 TagenWindows Update3 Kommentare

Ich kippe mal einige kurze Informationen hier rein - vielleicht hilft es Betroffenen. Die August 2019-Updates für Windows haben ...

Heiß diskutierte Inhalte
Switche und Hubs
Glasfaser-Anschluss Telekom muss verteilt werden
Frage von cansoniSwitche und Hubs29 Kommentare

Vorweg: Bin nur Anwender und kein Experte Die Situation: Der Vermieter stellt einen Glasfaseranschluss in der Wohnung bereit. Wir ...

Ubuntu
Download manchmal langsam oder komplette Abbrüche bzw. Videos spielen nicht bis zum Schluss
Frage von stefanstpUbuntu18 Kommentare

Immer wieder berichten unsere Kunden, dass Downloads abbrechen oder super langsam sind oder Videos nicht abgespielt werden können bzw. ...

Hyper-V
VMs von Hyper-V auf externer Festplatte
Frage von SnowbirdHyper-V18 Kommentare

Hallo, ich möchte gerne von VirtualBox auf Hyper-V umsteigen und würde auch gerne weiterhin meine VMs auf der externen ...

Festplatten, SSD, Raid
SSDs durch Lagerung ohne Strom nach 6 Monaten defekt?!?
gelöst Frage von GlobetrotterFestplatten, SSD, Raid16 Kommentare

Moin Gemeinde Ich hatte gerade nen Trauerspiel Habe hier etliche NAS-Geräte herumfahren welche ich mal auf die Seite gelegt ...