Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

server mit 2 netzwerkkarten ,1.karte hängt öfter. routingproblem ?

Mitglied: le-stebon

le-stebon (Level 1) - Jetzt verbinden

22.07.2006, aktualisiert 24.07.2006, 3781 Aufrufe, 6 Kommentare

Hallo Mitstreiter ... ich habe folgendes Problem:

Auf unserem Server befinden sich 2 Netzwerkkarten:

Die erste ist mit den LAN-Einstellungen fürs Intranet konfiguriert: 192.168.250.xxx

Die Zweite hat eine feste öffentliche IP-Adresse und ist mit dem Router verbunden.

Ich habe ein statisches Routing für beide Karten eingerichtet, damit Pakete von außen nach innen und umgekehrt geroutet werden.

Das funktioniert soweit auch recht gut. Die Rechner aus dem Lan können so ohne Probleme ins Netz.

Nun habe ich allerdings das Problem, das die Karte mit der öffentlichen IP nach ca. 1-2 Tagen "aussteigt". Ich muss diese
dann deaktivieren und wieder aktivieren.

Das Routing scheint zu funktionieren, jedoch habe ich bei der Einrichtung den Hinweis bekommen das es nicht sinnvoll ist unterschiedliche Gateways für beide Karten zu verwenden, da diese Redundanz bieten.

Vielleicht hatte jemand ein ähnliches Problem und kann mir weiter helfen.

Ich danke euch und wünsche allen ein schönes sonniges Wochenende.

le-stebon
Mitglied: brammer
22.07.2006 um 14:59 Uhr
Hallo,

der erste Eindruck: die Netzwerkkarte ist defekt.
Was für eine Karte ist es denn ?
Was für ein Betriebssystem und was für sonstige Hardware (soweit relevant)?
Bitte warten ..
Mitglied: Guenni
22.07.2006 um 15:46 Uhr
@le-stebon

Hi,

ist diese öffentliche IP für dich reserviert?

Wenn nicht, würde ich sagen, liegt es daran (Adressenkonflikt).

Eine öffentliche Adresse bekommt der Router bei einer
Verbindung zum Internet vom Provider.

Das Routing scheint zu funktionieren, jedoch habe ich bei der Einrichtung den Hinweis
bekommen das es nicht sinnvoll ist unterschiedliche Gateways für beide Karten zu
verwenden, da diese Redundanz bieten.

Nur die Karte, die zum Router führt, bekommt ein Gateway, nämlich die
IP des Routers, die auch im privaten Netz ist. Die andere Karte braucht
kein Gateway.

Der Router und die Karte1 bekommen eine IP im gleichen Netz, Karte2
eine IP in einem anderen Netz:

Router: 192.168.250.1

Karte1: 192.168.250.2
GW: 192.168.250.1

Karte2: 192.168.251.1
GW: keins

Wenn du dir mit route print die Routingtabelle ausgeben läßt,
müsste etwas ähnliches bei dir rauskommen:

Kernel IP Routentabelle
Ziel Router Genmask Flags Metric Ref Use Iface
192.168.178.0 * 255.255.255.0 U 0 0 0 eth0
192.168.179.0 * 255.255.255.0 U 0 0 0 eth1
default 192.168.178.1 0.0.0.0 UG 0 0 0 eth0

Ist von meinem Linux-Server, ohne dass statische Routen eingerichtet
wurden, welche auch überflüssig sind, weil das System beide Schnittstellen "kennt".

Gruß
Günni
Bitte warten ..
Mitglied: le-stebon
22.07.2006 um 19:09 Uhr
von der hardware her sind Broadcom Gigabit onBoard Karten drin.
Das Board bzw. der ganze Server ist neu.
Bei dem Board handelt es sich um ein TYAN TomCat.
Bei dem Preis was die kosten würde ich k* wenn das billige Hardware ist ;o)

Das System ist ein Windows 2003 Server Standard.

Ich habe eher die Befürchtung, das wenn es ein Hardwareproblem ist vielleicht die Broadcom Karte nicht mit dem Router (Cisco 2600er) will.

Die IP Adresse ist nur für uns reserviert. Wir haben ne Standleitung und der Router wurde uns vom Provider gestellt.
Bitte warten ..
Mitglied: le-stebon
22.07.2006 um 19:15 Uhr
also die IP ist ausschließlich für uns , dank Standleitung.
Am Router kann ich nich viel machen. Der wurde vom Provider gestellt.

Ich werde es mal mit deiner Lösung versuchen.

Die Karte1 habe ich so wie du in deinem Bespiel konfiguriert.
Bei der 2ten werde ich mal den Gateway weglassen und auch die statischen Routen entfernen.
Ich hoffe Windows ist so schlau und weiß das Pakete für ein anderes Netz dann auch über die andere Karte geroutet werden sollen.

Ich werde euch berichten ;o)

Vielen Dank schonmal

le-stebon
Bitte warten ..
Mitglied: aqui
23.07.2006 um 13:32 Uhr
Statische Routen auf dem Server einzurichten ist vollkommen überflüssig ! Warum auch, denn der Server "kennt" ja beide Netze, da sie an ihm ja direkt angeschlossen sind !!! Wahrscheinlich stellst du dir dadurch mit diesen wahrscheinlich falschen Routen ein Bein und das bewirkt die Probleme.
Die Problematik ist das das IP Forwarding bei MS per se abgeschaltet ist d.h. der Server routet erstmal gar nicht sondern betrachtet seine beiden NICs erstmal nur als einsame Zugangsnetze die er komplett separat bedient.

Wenn du XP/2000 hast musst du einen Eingriff in die Registry machen um das IP Forwarding (Routing) einzuschalten zwischen den NICs:
www.microsoft.com/windows2000/de/server/help/default.asp?url=/windows2000/de/server/help/sag_TCPIP_pro_EnableForwarding.htm

Bei 2003 ist das lediglich ein Häkchen in den Netzwerk Setups.

Da du ja mit beiden Segmenten ins Internet willst trägst du nun unter beiden Netzwerkkarten die IP Adresse deines Routers als default Gateway Eintrag ein. Deine Clients im Routersegement sofern du dort welche hast nutzen direkt die Router IP als Gateway. Die Clients im anderen Segment bekommen die Server Adresse als default Gateway. Das sollte dann deine Probleme dauerhaft lösen.
Alle evtl. eingetragenen statischen Routen solltest du komplett löschen !
Mit Redundanz hat das übrigens nichts zu tun. Die bekommt man wenn man die Adapter in den sog. Teaming Mode versetzt. Das geht aber nur auf einem Segment und ist eine komplett andere Baustelle....

Generell sein noch angemerkt das es durchaus mutig oder leichtsinnig ist.. je nachdem.. einen Windows Server an eine öffentliche IP Adresse zu hängen ! Bei den Sicherheitsproblemen die MS da hat kann man nur dringend davon abraten oder wenn es denn sein muss wenigstens eine kleine separate Firewall dazwischenzuschalten. Snifferst du dies Segment mit wirst du sehen das es max. 10 Sek. dauert bis der Server Attacken ausgeliefert ist.
Bitte warten ..
Mitglied: le-stebon
24.07.2006 um 12:47 Uhr
@ aqui

hab jetzt die statischen routen rausgenommen und den gateway so geändert wie dein vorschlag war.

bisher scheint es stabil zu laufen ... thx für den tip.

zwischen router und server läuft ne firewall , ich weiß der server sollte besser davor auch noch eine haben ... sozusagen DMZ.

Dank nochmals an alle die sich für meinen tread interessiert haben.

viele grüße in die welt

le-stebon
Bitte warten ..
Ähnliche Inhalte
Netzwerkgrundlagen
2 Router 1 Switch 2 Netzwerke
gelöst Frage von axel123321Netzwerkgrundlagen12 Kommentare

Hallo zusammen, ich muss folgendes Netzwerk aufbauen: Also Router 01 ist an das Internet angeschlossen. Zugleich soll er das ...

Windows Server
1 DHCP 2 Subnetze
Frage von technikdealerWindows Server5 Kommentare

Hay Ihr. Ich habe ein Server 2008 R2 mit konfigurierter Bereichsgruppierung. Ein Bereich der Gruppe hat 192.168.100.0 und der ...

LAN, WAN, Wireless

2 Internetanbieter, 2 Häuser, 1 Richtfunkverbindung

Frage von h3rbiroLAN, WAN, Wireless5 Kommentare

Hallo erstmal. Ich glaub dass ich aufgrund der vielen Experten hier an der richtigen Adresse bin. Ich habe folgende ...

Router & Routing

1 Adressbereich - 2 Gateways

gelöst Frage von Alexander90Router & Routing10 Kommentare

Hallo zusammen, ich Suche nach einer einfachen Möglichkeit den Internet-Traffic einzelner Geräte über einen VPN-Server zu schicken (z.B. ein ...

Neue Wissensbeiträge
Internet

CDU Propaganda: Urheberschutz im Internet - Ende des digitalen Wild-West

Information von Frank vor 13 StundenInternet3 Kommentare

Hallo Administratoren, aus einem Kommentar heraus habe ich folgenden Beiträge von Herr Sven Schulze und Axel Voss (beide CDU ...

Router & Routing

Zyxel VMG 1312 B30A - Firmwareupdate nur im "privaten" Firefox Modus möglich

Tipp von the-buccaneer vor 1 TagRouter & Routing2 Kommentare

Hatte hier ein Zyxel 1312 das ums verrecken kein Firmwareupdate durchführen wollte. Datei ist auswählbar, dann kommt der Fortschrittskreisel ...

Windows 7

Windows 7 u. Server 2008 (R2) SHA-2-Update kommt am 12. März 2019

Information von kgborn vor 2 TagenWindows 75 Kommentare

Kleine Info für die Admins der oben genannten Maschinen. Ab Juli 2019 werden Updates von Microsoft nur noch mit ...

Firewall
PfSense 2.5.0 benötigt doch kein AES-NI
Information von ChriBo vor 4 TagenFirewall2 Kommentare

Hallo, Wie sich einige hier erinnern werden hat Jim Thompson in diesem Aritkel beschrieben, daß ab Version 2.5.0 ein ...

Heiß diskutierte Inhalte
Hardware
IT-Werkzeugkoffer bis 50,- EUR
gelöst Frage von departure69Hardware53 Kommentare

Hallo. Ich bin als IT-Systembetreuer einer Gemeinde zusätzlich auch der IT-Systembetreuer einer Grund- und Hauptschule. Dort muß ich jedoch ...

Netzwerke
Verteilung von Programmdaten außerhalb des internen Netzwerkes
Frage von mertaufmbergNetzwerke27 Kommentare

Guten Morgen liebe Administratoren, ich versuche zurzeit eine möglichst sichere und einfache Lösung zu suchen, um ein Programmverzeichnis über ...

Datenbanken
PHP Fatal error: Uncaught Error: Call to undefined function oci connect
Frage von PlanitecXDatenbanken19 Kommentare

Hallo Zusammen, ich sitze seit Tagen am Problem das ich keine PHP Anwendung mit Anbindung zu Oracle zum laufen ...

Hardware
PC im Selbstbau, Workstation, mittelklasse Gaming
gelöst Frage von MrRobot1997Hardware19 Kommentare

Hallöchen Leute, ich bin seit einigen Jahren leider nicht mehr wirklich im Bild, wenn es um die Hardware und ...