Server2016 erlaubt keine Änderung der Einstellungen für User

gechger
Goto Top
Guten Tag,

im Einsatz ist ein Server 2016, installiert in einer Hyper-V Umgebung und er dient als Terminalserver. Updates sind alle drauf. Geschützt wird das System durch G-Data EndpointProtection
und der Server 2016 Firewall-
Der Administrator ist in der Lage, die Einstellungen zu öffnen und seinen Desktop anzupassen. Die normalen User können das aber nicht. Bei Klick auf den Button Einstellungen passiert nichts.

Über Systemsteuerung / Anpassung erscheint eine Meldung:
ms-settings:display, Fehler bei der Installation. Wenden Sie sich an den Softwarehersteller.

Der Aufruf SystemSettings.exe in C:\Windows\ImmersiveControlPanel ist erfolglos (außer beim Administrator).
Wir haben sämtliche Einstellungen der GPO und der lokalen Sicherheitsrichtlinie überprüft und nichts gefunden, was dieses Verhalten erklären könnte.
Berechtigungen ändern ist gesperrt, selbst der Admin darf da nichts machen.

2 Tage googeln hat auch keine brauchbare Lösung gebracht. Deshalb nun meine Frage im Forum, ob jemand von Euch schon mal mit diesem Problem zu tun hatte.

Ich danke wie immer für Eure Ideen
Chris
ms-settings

Content-Key: 390351

Url: https://administrator.de/contentid/390351

Ausgedruckt am: 18.08.2022 um 21:08 Uhr

Mitglied: falscher-sperrstatus
Lösung falscher-sperrstatus 23.10.2018 um 11:42:31 Uhr
Goto Top
Tippe auf GPOs oder sonstige Software, die genau das verbietet.

Viele Grüße,

certifiedit.net
Mitglied: gechger
gechger 23.10.2018 um 12:07:22 Uhr
Goto Top
GPO war auch unser erster Verdacht. Wir haben aber nichts gefunden, was dieses Verhalten erklären könnte.
Mitglied: gechger
gechger 23.10.2018 um 12:19:29 Uhr
Goto Top
Es gibt dazu einen Eintrag in der Ereignisanzeige:

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event;>"
- <System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2018-10-23T09:26:44.859269700Z" />
<EventRecordID>22750</EventRecordID>
<Channel>Application</Channel>
<Computer>MZ-SV16-WTS01.mobilzeit.local</Computer>
<Security />
</System>
- <EventData>
<Data>SystemSettings.exe</Data>
<Data>10.0.14393.82</Data>
<Data>57a55dc6</Data>
<Data>Windows.UI.Xaml.dll</Data>
<Data>10.0.14393.2457</Data>
<Data>5b7e2ddf</Data>
<Data>c0000409</Data>
<Data>00000000000528e0</Data>
<Data>446c</Data>
<Data>01d46ab283be5f8c</Data>
<Data>C:\Windows\ImmersiveControlPanel\SystemSettings.exe</Data>
<Data>C:\Windows\System32\Windows.UI.Xaml.dll</Data>
<Data>9413e0b7-cba3-4836-a3e5-42134dfaaddb</Data>
<Data />
<Data />
</EventData>
</Event>
Mitglied: bloodstix
bloodstix 23.10.2018 um 12:49:42 Uhr
Goto Top
Hi,
mal mitm ProcMon von Sysinternals geschaut, wo es da hackt?
Ich tippe auf G-Data, habe mit der Software leider sehr schlechte Erfahrungen gemacht.

Gruß
bloody
Mitglied: gechger
gechger 24.10.2018 um 08:06:17 Uhr
Goto Top
Hallo bloody,

das G-Data verantwortlich ist glaube ich weniger. Dann dürfte es überhaupt nicht gehen. Der Administrator himself darf aber alles machen. ALle anderen User nicht, selbst als Mitglied der Admin-Gruppe geht es nicht. Ich vermute ein fehlgeleitetes Berechtigungsflag. Da ich aber an der Berechtigung in betroffenen VErzeichnis nichts ändern kann, kann ich das auch nicht testen. Oder ich müßte die Besitzrechte vom TrustedInstaller übernehmen. Ob das nachteilige Folgen hat kann ich nicht abschätzen.

LG Chris
Mitglied: gechger
gechger 26.10.2018 um 12:51:16 Uhr
Goto Top
Problem ist gelöst, es war eine Berechtigungseinstellung in den GPOs.
im Pfad Computerkonfiguration --> Richtlinien --> Windows Einstellungen --> Sicherheitseinstellungen --> Dateisystem
gab es eine Regel zur Einschränkung der Administrative Tools. Die Domänenbenutzer waren da nicht drin, nur der Administrator.

gpo

Ergänzend habe ich in den
Sicherheitseinstellungen --> Anwendungssteuerungsrichtlinien --> AppLocker
die Sperre von der Nutzung windows.immersivecontrolpanel entfernt.

Jetzt können alle User wieder Ihre Einstellungen checken.