Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst SMTP-Relay bei Hetzner

Mitglied: beowulf1980

beowulf1980 (Level 1) - Jetzt verbinden

06.02.2011 um 17:58 Uhr, 20529 Aufrufe, 7 Kommentare

Hallo zusammen,

ich habe ein dringendes Problem und hoffe von euch kann mir jemand dabei helfen.
EIn Kunde von mir hat seine Domain und seine Email-Accounts bei Hetzner Online AG.
Bis jetzt hatten alle User ihre Mails direkt per POP beim Hoster abgeholt.

Ich sollte bei dem jetzt einen SBS mit Exchange einrichten.
Hat auch super geklappt. Ich hatte vorher auch mit dem Support von Hetzner mehrfach Email-Verkehr um schon mal die Sachen für den SMTP-Relay zu besprechen.

Laut Hetzner sollte man dafür eine eigene Mai-Box einrichten und diese Mail-Box dann auf Catchall umsetzen sobald man den MX-Eintrag bei Ihnen ändert.

Ich hatte vorher auch schon mal ausprobiert ob das dann funktioniert. War alles super.

Da die Verbreitung des MX-Eintrages ja dann logischerweise dauert wollte ich die Umstellung dieses Wochenende machen.
Also hab ich gestern alle EInstellungen vorgenommen und den MX-Eintrag geändert. Die Mails kommen jetzt auch passend an aber versenden geht nicht.
Die Nachrichten stauen sich in der Warteschlange. Also mal Troubleshoot durchgeführt auf dem Exchange und siehe da er sagt beim Relay das ich falsche Zugangsdaten benutzen würde.

Nach der Umstellung finde ich jetzt aber in der konsoleH keine Möglichkeit mehr etwas an den Mail-Accounts umzustellen also kann ich auch nicht nochmal nach dem Catchall-Konto etwas machen.

Hat jemand von euch vielleicht schonmal einen Exchange für den Versand über Hetzner konfiguriert ? Vielleicht habe ich ja nur was übersehen.
Mein Kunde findet das bestimmt nicht lustig das er am Montag keine Mails senden kann aber leider kann man am Wochenende den Support von Hetzner nicht erreichen.

Gruß
Beowulf
Mitglied: Pjordorf
06.02.2011 um 18:32 Uhr
Hallo,

Zitat von beowulf1980:
ich habe ein dringendes Problem
dringendes?

aber versenden geht nicht.
Exchange und siehe da er sagt beim Relay das ich falsche Zugangsdaten benutzen würde.
Dein Exchange verwendet falsche Zugangsdaten um sich bei deinem von dir gewählten Smarthost anzumelden. Daher können keine Mails versendet werden.

Mein Kunde findet das bestimmt nicht lustig das er am Montag keine Mails senden kann
Dein Exchange hat das Problem, nicht hetzner.

Da du aber absolutes nichts zu deiner geheimnisvollen Exchange Version gesagt hast, mache ich mir nicht die Mühe dir die Schritte aufzuzeigen wie do wo das Passwort und benutzer ändern kannst.

Und ich gehe recht in der Annahme das du mit SMTP-Relay einen Smarthost meinst? http://de.wikipedia.org/wiki/SMTP-Relay-Server

Gruß,
Peter

[Nachtrag]
Dein SMTP Protokoll hast du dir aber schon angeschaut, oder?
[Nachtrag]
Bitte warten ..
Mitglied: beowulf1980
06.02.2011 um 18:54 Uhr
Hallo Peter,

entschuldige das ich die Version vergessen habe. Ist 2007er.
Ja es geht um den Smarthost. Ich weiß schon wo man den im Exchange editiert. Aber mir geht es darum das ich doch bei Hetzner die Möglichkeit haben muss den Account zu editieren den ich für die Authentifizierung benutze.

Ich hatte es vor der Umstellung ja schonmal getestet. Da ging es auch so. Und ich hatte seitdem da nichts mehr umgestellt.

Wenn ich im Exchange den Troubleshoot ausführe bekomme ich die Meldung

Die Warteschlange für 'Remoteübermittlung' (Kunde-SERVER\21) auf Server 'Kunde-SERVER' befindet sich im Wiederholungsstatus. Anzahl von Nachrichten in der Warteschlange: 1. Letzte Fehlerinformationen: 451 4.4.0 Primary target IP address responded with: "535 Incorrect authentication data." Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts..

Gruß
Beowulf
Bitte warten ..
Mitglied: laster
06.02.2011 um 19:48 Uhr
Hallo,

warum wurde denn der MX-Record umgestellt, wenn die Mails weiterhin über den Provider gehen?
Wenn der MX-Record auf die IP von Deiner Firewall verweist, musst Du direkt versenden.
Wenn Du weiterhin über den Provider empfängst und versendest, brauchst Du doch den MX-Record nicht zu verändern?

vG
LS
Bitte warten ..
Mitglied: beowulf1980
06.02.2011 um 20:02 Uhr
Hi,

der MX-Eintrag wurde geändert weil ab jetzt die Mails über den Exchange laufen sollen. Der Versand soll dann aber über den Smarthost gemacht werden.

Ich hatte mal überlegt das der Exchange selbstständig Mails versenden soll aber als ich da mal nach gegooglet habe, habe ich gesehen das man da extrem viel beachten muss und es bei vielen zu Fehlern kommt.

Gruß
Beowulf
Bitte warten ..
Mitglied: Pjordorf
06.02.2011 um 20:15 Uhr
Hallo,

Zitat von beowulf1980:
der MX-Eintrag wurde geändert weil ab jetzt die Mails über den Exchange laufen sollen.
Der MX betrifft aber nur Mails die an deinen Exchange direkt zugestellt werden.

Der Versand soll dann aber über den Smarthost gemacht werden.
OK. Nicht direkt über DNS.

Dazu muss das Konto bei deinem Provider welches als Smarthost her halten soll natürlich bekannt sein (Name und Passwort). Meistens ist dies ein x-beliebiges Postfach bei deinem Hoster welches du selbst einrichten kannst. Es kann auch bei einem anderen Provider sein. Dann auf deinem Exchange genau dieses Konto und Passwort sowie den richtigen Port (SMTP Versand üblicherweise = 25) verwenden und gut ist.

Ich hatte mal überlegt das der Exchange selbstständig Mails versenden soll aber als ich da mal nach gegooglet habe, habe
ich gesehen das man da extrem viel beachten muss und es bei vielen zu Fehlern kommt.
Versand per DNS, also direkt an die anderen Mailserver. SPAM Problem , Feste IP, Reverse MX usw...

Ich hatte es vor der Umstellung ja schonmal getestet. Da ging es auch so. Und ich hatte seitdem da nichts mehr umgestellt.
Solltest du die Asisstenten deines SBS (2003 oder SBS 2008?) danach nochmals laufen lassen, so wird das Passwort entfernt!

Gruß,
Peter
Bitte warten ..
Mitglied: laster
06.02.2011 um 21:05 Uhr
Hallo,

@Pjordorf
Der MX betrifft aber nur Mails die an deinen Exchange direkt zugestellt werden.

Wenn Mails beim Empfänger ankommen, prüft dieser eventuell den DNS zur IP. Wenn das dann nicht stimmt, werden die Mails nicht angenommen - bleiben in der arteschlange...

vG
LS
Bitte warten ..
Mitglied: beowulf1980
07.02.2011 um 09:31 Uhr
So hallo zusammen,

Problem wurde gelöst. Falls nochmal jemand das Problem hat.

Beim umstellen des MX-Records wird für die Domain das Mailing komplett deaktivert. Man muss eine Subdomain registrieren und da kann man dann wieder Accounts anlegen. Und mit dem Catchall-Account kann man dann auch den Smarthost vom Exchange füttern.

Danke für die Hilfeversuche.

Gruß
Beowulf
Bitte warten ..
Ähnliche Inhalte
E-Mail
Mailserver - SMTP Relay
Frage von WaishonE-Mail8 Kommentare

Hallo, ich bin aktuell ein bisschen am herumexperimentieren mit einem Mailserver auf Debian 8 mit Postfix und Dovecot. Dieser ...

Exchange Server

Exchange 2010 SMTP-Connector - zusätzliches Relay

Frage von FA-jkaExchange Server6 Kommentare

Hallo, in meinem Testnetz (basierend auf einem SBS2011) möchte ich von diversen Geräten (IMM-Konsole, RAID-Controller, NAS, Backup-Software, USV-Software, VPN-Gateways ...

Windows Server

SMTP Relay über Gmail funktioniert nicht

gelöst Frage von JohnWorksWindows Server10 Kommentare

Hallo Zusammen, ich habe Anleitung ( ) den SMTP-Server hinzugefügt und soweit konfiguriert. Nach der Installation und Konfiguration werden ...

Ubuntu

Postfix als SMTP Relay für Exchange 2016

gelöst Frage von m.reegerUbuntu11 Kommentare

Hallo miteinander, ich habe hier eine Anleitung von wiesi200 gefunden. ) Diese war auch sehr hilfreich, doch ich bekomme ...

Neue Wissensbeiträge
Microsoft
PowerShell script für LAPS
Information von kgborn vor 18 StundenMicrosoft2 Kommentare

Kurzer Hinweis für Admins im AD-Umfeld. Ich bin die Tage auf das PowerShell Script der Woche “Local Administrator Password ...

Windows 10
Windows 10 bis Version 1803 und das Zwangs-Upgrade
Information von kgborn vor 18 StundenWindows 10

Ich denke, die meisten Admins hier werden Systeme mit Windows 10 Enterprise einsetzen und Updates per WSUS/SCCM oder ähnlichem ...

Microsoft Office
BSI-Empfehlungen für die Office-Konfiguration
Information von kgborn vor 18 StundenMicrosoft Office

Kurze Information für Admins, die Office verwalten. Das BSI hat einige Regeln für die Absicherung von Office-Konfigurationen veröffentlicht. Ich ...

Windows 10

Sandy-Bridge plus Nvidia plus Win10 1903 braucht Hotfix

Information von DerWoWusste vor 5 TagenWindows 101 Kommentar

Es gibt ein Problem in der seltenen Konstellation Nvidia-Grafikkarte/Sandy-Bridge-CPU/Win10v1903: die von Nvidia vorgeschlagenen Treiber lassen sich nicht installieren. verlinkt ...

Heiß diskutierte Inhalte
Batch & Shell
Powershell Skript für Reg Datei ändern
gelöst Frage von SoccerdeluxBatch & Shell16 Kommentare

Hallo zusammen, ich muss auf einem Windows 10 Pc ein Skript ausführen lassen was sich alle 5 Minuten wiederholt. ...

LAN, WAN, Wireless
WLAN in Veranstaltungshalle
Frage von coltseaversLAN, WAN, Wireless14 Kommentare

Hallo zusammen, für eine Halle mit 1300 m² suche ich derzeit nach einer WLAN-Hotspot-Lösung für bis zu 500 User ...

Windows 10
Windows 10 Logonskript greift nicht
Frage von xbast1xWindows 1013 Kommentare

Hallo zusammen, da sich die per GPO gemappten Laufwerke bei allen Usern schließen und das Problem sich nicht lösen ...

LAN, WAN, Wireless
Eigenes LAN mit WLAN (Internet) vom Nachbarn verbinden
Frage von kaniggelLAN, WAN, Wireless12 Kommentare

Hallo, mein Provider hat mir den DSL-Anschluss gekappt. Wie kann ich bis das wieder funktioniert mein LAN mit dem ...