Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

SSH Tunnel XP zu Vista - Netzlaufwerk nicht verfügbar

Mitglied: flschmid

flschmid (Level 1) - Jetzt verbinden

11.04.2008, aktualisiert 12.04.2008, 7982 Aufrufe, 3 Kommentare

Hallo zusammen,

ich möchte einen SSH Tunnel von einem Windows XP SP2 Client zu einem Windows Vista Server aufbauen, um auf ein Netzlaufwerk zugreifen zu können.

Auf dem XP Client habe ich zunächst das benötigte Update KB884020 installiert, dann ein Loopback Adapter installiert und ihn mit der IP Adresse 192.168.50.1 versehen. "Client für Windows Netzwerke" und "Dateifreigabe" habe ich für den Loopback Adapter deaktiviert.

Ein Ping auf die Adresse 192.168.50.1 ist möglich.

Auf den Vista Server stelle ich eine SSH Verbindung mit dem Putty Client und dem freeSSHd her. Problemlos.

Im Putty Client erstelle ich einen Tunnel von Lokal: 192.168.50.1:139 auf 127.0.0.1:139 und von 192.168.50.1:445 auf 127.0.0.1:445


Stelle ich nun eine SSH Verbindung her und versuche über Start -> Ausführen: \\192.168.50.1 auf die Freigaben des Servers zuzugreifen erhalte ich die Fehlermeldung "Netzlaufwerk konnte nicht gefunden werden".

Anschließend habe ich versucht eine Verbindung ohne das Loopback Interface aufzubauen, indem ich die Dateifreigabe meiner "normalen" Netzwerkkarte mit der Ip 192.168.0.4 deaktiviert habe und die Daten für den Tunnel im Putty client entsprechend geändert habe.

Nun erhalte ich hier die Meldung "Netzlaufwerk konnte nicht gefunden werden".

Ich benutze die neueste Version von Putty 0.60 und Firewalls sind abgeschalten.

Leider kann ich das Problem nicht weiter eingrenzen.

Ist es möglich, dass es an der Einstellung der Netzwerkfreigabe auf dem Vista System liegt und der Tunnel korrekt funktioniert, aber keine Freigabe findet?

Vielen Dank im Voraus.
Grüße,
Florian
Mitglied: n.o.b.o.d.y
12.04.2008 um 09:05 Uhr
Hallo,

was ich auf jeden Fall checken würde ist, ob im freesshd das Portforwarding aktiviert ist. Dann würde ich nicht die 127.0.0.1 nehmen, sondern die echte lokale IP des Vista-Rechners.
Funktionier denn überhaupt ein Zugriff durch den Tunnel? Z.B. RDP oder HTTP oder so was?

Ralf
Bitte warten ..
Mitglied: flschmid
12.04.2008 um 15:51 Uhr
Hallo,

ich denke das Problem ist spezifischer.
Ich kann z.B. über den Tunnel eine VNC Verbindung oder Remote Desktop zum Server aufbauen.
Nur eben die Dateifreigabe will nicht funktionieren.

Ich habe die Daten für den Tunnel im Putty Client nun auf die echte lokale IP des Vista Rechners geändert und die Ports 139 und 445 umgeleitet, aber ich bekomme immer noch die Meldung, dass das Netzlaufwerk nicht gefunden werden kann.

Ich komme leider nicht mehr weiter.

Wäre wirklich super, wenn mir noch jemand helfen könnte.

Vielen Dank.
Grüße,
Florian
Bitte warten ..
Ähnliche Inhalte
Microsoft
SSH RDP Tunnel Problem
Frage von Philbo69Microsoft15 Kommentare

Hey Leute ich habe ein Problem mit dem Aufbau einer RDP Session per SSH Tunnel. Host: IP-COP Port 222 ...

Ubuntu
SSH Tunnel einrichten : Basics
Frage von DestinationPortUbuntu6 Kommentare

Hallo, habe eine Übungsangabe bekommen, die ich selbst ohne Vorkenntnisse noch nicht ganz lösen kann. 1) Zwischen zwei Linux ...

Linux Netzwerk

HTTPS über SSH Tunnel endlos langsam

gelöst Frage von QQR700Linux Netzwerk8 Kommentare

Hallo, ich hab hier einen SSH-Tunnel, den ich etwa so aufbaue: die erste IP ist die lokale IP und ...

Netzwerke

SSH - Programm über SSH Client starten

Frage von VernoxVernaxNetzwerke9 Kommentare

Hallo. Ich habe eben es irgendwie geschafft mein Handy und meinen Pc über SSH zu verbinden. Mit der tollen ...

Neue Wissensbeiträge
Humor (lol)
Und wie seid Ihr gegen Cyberattacken gewappnet?
Information von DerWoWusste vor 1 TagHumor (lol)5 Kommentare

aber wo ist der Hammer? :-)

Sicherheit
Ein weiterer Microsoft-Stirnklatscher
Information von DerWoWusste vor 2 TagenSicherheit7 Kommentare

Habe gerade einen Artikel zu einem Sicherheitsproblem gefunden, welches mir zu seiner Zeit (gepatcht 2015) wohl durchgerutscht ist. Es ...

Windows 10
Upgradepfade Windows 10 LTSC
Erfahrungsbericht von Datenreise vor 2 TagenWindows 10

Nur eine kurze Info, für diejenigen, die es interessiert, da es hierzu im Netz aus nachvollziehbaren Gründen nicht allzu ...

Administrator.de Feedback
Wartungsarbeiten heute Nacht (Update)
Information von Frank vor 2 TagenAdministrator.de Feedback10 Kommentare

Hallo User, durch Umbauarbeiten in unserem Rechenzentrum (am Backbone) kann es heute Nacht (14-15.01.2019) zu kurzen Ausfällen unserer Seite ...

Heiß diskutierte Inhalte
Windows 10
Windows 10 - kein Boot mehr nach Domänenaustritt
gelöst Frage von Ghost108Windows 1025 Kommentare

Hallo zusammen, habe hier eine Windows 10 Maschine, die ich gerne aus der Domäne austreten lassen möchte. Nach Austritt ...

Microsoft
SFirm 4.0 auf Terminalserver startet für jeden angemeldeten Benutzer diverse Dienste
Frage von Frank84Microsoft24 Kommentare

Hallo zusammen, wir verwenden Sfirm 4.0 auf einem Terminalserver (der SQL Server ist auf einem separaten Server), das Problem ...

Windows 10
VM wächst schnell von 14 auf 35 GB an - warum?
Frage von degudejungWindows 1017 Kommentare

Hallo, ich bin ein Freund schlanker VMs und setze daher gerne mit dem Erscheinen einer neuen Win10 Version - ...

Internet
Google-Suchergebnisse, Schnelleinblendung, woher kommt der Inhalt?
gelöst Frage von departure69Internet17 Kommentare

Hallo. Ich bin der Systembetreuer einer kleinen Gemeinde in Süddeutschland. Wir betreiben auch eine Leihbücherei. Eine Kundin hat letzten ...