Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Statisches Routingproblem mit WLAN Router

Mitglied: mannix-de

mannix-de (Level 1) - Jetzt verbinden

10.08.2005, aktualisiert 08:34 Uhr, 3306 Aufrufe, 1 Kommentar

Hallo zusammen, ich versuche das komplexe Problem mal zu erklären.

1. SuSe Linux 9.3 Router mit 2 Netzwerkkarten eth0 und eth1
An der eth0 (ip 10.20.30.200) hängt das interne Netz 10.20.0.0/16. Das Netzkabel
geht zu einem Switch nennen wir ihn SW1.
Die eth1 ist mit dem Netz 192.168.10.0/24 konfiguriert. Von dieser Netzwerkkarte geht ein Kabel
direkt an das DSL Modem.

Ip Forwarding, Masquerading etc. alles eingeschaltet -> alle Rechner die an dem Switch hängen können auch problemlos ins internet und untereinander und mit dem Router kommunizieren (haben als Standard Gateway 10.20.30.200).

2. WLAN Router
Der WAN Port hängt an dem Switch SW1 und hat die Adresse 10.20.30.0
Die wireless-schnittstelle (ip 192.168.0.1) ist mit dem Netz 192.168.0.0/24 konfiguriert.
Das Standard gateway des WLAN Routers ist ebenfalls 10.20.30.200

Auch die notebooks können über den WLAN-Router auf das Internet zugreifen und auch den Router pingen etc.

Was nicht funtioniert ist das pingen des WLAN Routers (192.168.0.1) vom Linux Router aus. Okay dachte ich mir kann ja auch nicht, mußt Du ne statische route eintragen. Hmmm, aber wie mache ich das.
route add -net 192.168.0.0 netmask 255.255.255.0 dev eth0 <--- funktioniert nicht, okay dann
route add -net 192.168.0.0 netmask 255.255.255.0 gw 10.20.30.0 dev eth0 <--- funktioniert auch nicht.

Wo bitte ist mein Denkfehler, ich bin mir sicher das da ein Denkfehler vorliegt. Das sieht doch eigentlich so aus

Linux Router eth0(10.20.30.200) ------- Switch -------- WLAN Router(10.20.30.0) ------- WLAN-Netz 192.168.0.0
| |
PC1 PC2


Der Router ist doch über die eth0 und das gateway 10.20.30.0 zu erreichen.

Wenn also jemand weiß wo ich quer gedacht habe bitte ich um Aufklärung

Danke im voraus

Manfred
Mitglied: 10545
10.08.2005 um 08:34 Uhr
Hallo Manred,

nimm mal bei dem WLAN-Router die WAN-IP von der '0' weg. Setze die Schnittstelle (z.B.) auf 5, aber nicht 0 und nicht 255 ? die sind reserviert.

Welcher WLan-Router ist es (Hersteller/Typ)?

Im Linux-Router sollte das Standard-Gateway auf die DSL-Nic zeigen (192.168.10.?)
Ansonsten gibt es nur noch den Rückweg zum WLan-Router im LX-Rtr zu setzen ? also etwa:

Route add -net 192.168.0.0 netmask 255.255.255.0 10.20.30.5 <==(Beispiel nach der Neuzuteilung der WAN-IP, siehe weiter oben!)

Gruß, Rene
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Routing Frage, statisch?
gelöst Frage von DerInteressierteRouter & Routing12 Kommentare

Ich bin was dieses Problem angeht blutiger Laie und bitte alle Profis um Antwort und Lösung. Ich verwende 2 ...

Router & Routing
Routing statisch gegen RIP
gelöst Frage von OsiMacRouter & Routing5 Kommentare

Hallo ich bin grad dabei Routing zu lernen / Verstehen. Habe mir mal zur veranschaulichung mit Cisco Packet Tracer ...

LAN, WAN, Wireless
WLAN-AP - WLAN-Bridge
Frage von MiStLAN, WAN, Wireless8 Kommentare

Guten Morgen, ich brauche WLAN-Bridge, die mir 1-3 PCs (ohne WLAN) ins LAN einbindet. So ungefähr stelle ich mir ...

Windows Netzwerk

Was muss ich als Parameter eingeben, das nslookup zeigt, das der gesuchte Name statisch oder dynamisch ist!

gelöst Frage von holli.zimmiWindows Netzwerk12 Kommentare

Hi, wie schon in der Überschrift geschrieben, würde ich gerne wissen, was ich da eingeben muss! Hintergrund: Wir muessen ...

Neue Wissensbeiträge
iOS
WatchChat für Whatsapp
Tipp von Criemo vor 14 StundeniOS

Ziemlich coole App für WhatsApp User in Verbindung mit der Apple Watch. Gibts für iOS sowohl als auch für ...

iOS
IOS hat nen Cursor !!!
Tipp von Criemo vor 1 TagiOS5 Kommentare

Nette Funktion im iOS. iPhone-Mauszeiger aktivieren „Nichts ist nerviger, als bei einem Tippfehler zu versuchen, den iOS-Cursor an die ...

Off Topic
Avengers 4: Endgame - Erster Trailer
Information von Frank vor 3 TagenOff Topic2 Kommentare

Ich weiß es ist Off Topic, aber ich freue mich auf diesen Film und vielleicht geht es anderen hier ...

Webbrowser
Microsoft bestätigt Edge mit Chromium-Kern
Information von Frank vor 3 TagenWebbrowser5 Kommentare

Microsoft hat nun in seinem Blog bestätigt, dass die nächste Edge Version kein EdgeHTML mehr für die Darstellung benutzen ...

Heiß diskutierte Inhalte
Exchange Server
Exchange Server 2010: Keine Eingehenden E-MAils
gelöst Frage von gabeBUExchange Server17 Kommentare

Hallo Zusammen Ich habe das kurzen auf dem Exchange 2010 Server das Problem, dass ich keine externen E-Mails mehr ...

Server
Server in zwei verschiedene Netzwerke einbinden
gelöst Frage von BennyFServer13 Kommentare

Hallo zusammen, bei uns im Haus sind im Erdgeschoss die Geschäftsräume und ab dem 1. Stock sind unsere privaten ...

Windows Netzwerk
Kerio. Kann keine Mails empfangen aber senden. Wer ist schuld. Kerio oder Windows domäne?
Frage von frosch2Windows Netzwerk13 Kommentare

Hallo, es existiert ein Problem bei uns mit dem mailen. Alle bestehenden Nutzer können mailen. Raus wie rein. Neuen ...

Netzwerkmanagement
Ticketsystem für eine Kommune gesucht
gelöst Frage von akovisNetzwerkmanagement11 Kommentare

Ich suche aktuell ein Ticketsystem für eine Kleinstadt von 13000 Einwaohnern. Das System soll alle Anfragen aus verschiedenen Kanälen ...