Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Subdomain von extern nicht verfügbar

Mitglied: MisterSaint

MisterSaint (Level 1) - Jetzt verbinden

01.10.2006, aktualisiert 04.10.2006, 4526 Aufrufe, 10 Kommentare

Hallo,

ich habe einen Sharepoint Server laufen (IP Endung 110), auf diesen werden alle Port 80 Anfragen geschickt.
Jetzt habe ich auf diesem Server eine neue Webseite mit eigener interner IP (Endung 111) erstellt. Diese Webseite möchte ich mit einer Subdomain erreichen, also zb test.domain.com.
Im internen DNS habe ich den Eintrag für test.domain.com auf die IP Adresse 111 gelegt, der Webseite habe ich den Headerwert test.domain.com hinzugefügt und die fixe interne IP gegeben.
Wenn ich jetzt von einem Rechner im Netzwerk auf die Subdomain zugreife habe ich kein Problem und kann die Subdomain normal aufrufen.
Rufe ich die Subdomain aber von extern auf dann leitet mich der Router immer auf die Hauptseite 110 weiter. Ich komm also auch mit dem Link test.domain.com auf die Hauptseite.
Ich kann bei meinem Router leider nur einmal den Port 80 auf eine IP leiten (gibt es eigentlich andere Router bei denen man einen IP Bereich für Port 80 angeben kann?).

Kann mir vielleicht wer einen Tipp geben an was es liegen könnte, dass ich meine Subdomain von extern nicht erreiche? Pingen kann ich sie nämlich, also der Host-A Eintrag für die Subdomain ist beim Domainprovider eingetragen.
Ich habe leider nur eine externe IP, somit ist es auch nicht möglich, dass ich die Subdomain auf eine IP leite.

Im Forum habe ich leider keinen Hinweis gefunden der mir weiterhelfen könnte.
Wäre euch sehr dankbar, da mich dieses Problem nun schon einige Zeit beschäftigt.

Danke Mister
Mitglied: filippg
01.10.2006 um 01:57 Uhr
Hallo,

du must vom Router einen anderen Port auf den Server umleiten (z.B. 8080), evtl auch den Port auf dem Server der Subdomain entsprechend einrichten. Und dann musst du die Website immer entsprechend mit der Portangabe aufrufen, also im Browser z.B. test.domain.com:8080.
Dabei gehe ich mal davon aus, dass mit dem DNS wirklich alles stimmt.

Filipp
Bitte warten ..
Mitglied: MisterSaint
01.10.2006 um 08:56 Uhr
Hi,

das mit dem Port will ich eigentlich vermeiden.
Der Benutzer sollte keinen Port angeben müssen um auf die Subdomain zu gelangen.

Lg Mister
Bitte warten ..
Mitglied: DaSam
01.10.2006 um 10:18 Uhr
Hi,

im IIS kann manv mehrere Webserver auf die gleiche IP definieren - ausschalggebend ist dann für das korrekte Erkennen des Webservers der Host.

Ich weis nicht, wie es mit dem Sharepoint-Dingens geht, aber im normalen IIS ist das kein Problem. Schau Dir einfach mal den Einstellungsdialog für die virtuellen Server an (falls vorhanden) - wie gesagt, im reinen IIS gehts, von ISA und Sharepoint habe ich keinen Plan.

Dann den test.domain.xyz auch auf die .110 legen

cu,
Alex
Bitte warten ..
Mitglied: MisterSaint
01.10.2006 um 11:32 Uhr
Hi Alex,

danke für den Tipp. Ich habe es jetzt mal so umgestellt und derzeit funktioniert es. Ich hab zwar meinen internen DNS von den LAN Einstellung eines User PC weggenommen, somit sollte die Anfrage eigentlich über den externen DNS laufen. Jetzt muss ich es dann nur noch von extern versuchen. Bin schon mal gespannt ob es wirklich funktioniert.
Ich dachte es kommt dann zu einem Portkonflikt, wenn zweimal die gleiche IP mit dem gleichen Port verwendet werden? Habe ich früher nämlich schon mal probiert und dann hat es mir eine Webseite wegen dem Konflikt beendet. Aber dort hatte ich glaub keinen Headerwert eingetragen, das könnte natürlich der Grund gewesen sein.

Lg Mister
Bitte warten ..
Mitglied: filippg
01.10.2006 um 11:49 Uhr
im IIS kann manv mehrere Webserver auf die
gleiche IP definieren - ausschalggebend ist
dann für das korrekte Erkennen des
Webservers der Host.
Das geht aber nur, wenn beide Domains auch auf dem gleichen (physikalischen) Server liegen, dann kann dieser anhand des Host-Header-Feldes erkennen welcher gemeint ist, auch wenn beide mal die gleiche IP angesprochen wird. Hier laufen die beiden Sites aber wohl auf unterschiedlichen Rechnern.

Danke für die Bewertung, wer auch immer das war.

Filipp
Bitte warten ..
Mitglied: DaSam
01.10.2006 um 14:20 Uhr
Hi,

aber er schreibt ja, dass sich der Webserver auf DIESEM Server befindet - also anstelle eine zweite IP-Adresse auf der NIC zu konfigurieren sollte er das mit dem Hostheader schon mal probieren - kalr natürlich nur, wenn es tatsächlich der selbe Server ist.

(Ich war's nicht mit der BEwertung - aber jetzt schaut's besser aus, oder? ).

cu,
Alex
Bitte warten ..
Mitglied: MisterSaint
01.10.2006 um 20:40 Uhr
Hallo,

sorry für die verspätete Antwort, aber ich kann es eben erst morgen extern probieren.

Wegen den Servern. Ja, es sind 2 Webseiten auf einem Server. Nach meiner Überlegung dürfte es mit 2 Servern doch auch kein Problem sein, wenn diese in der gleichen Domäne sind bzw. den gleichen internen DNS verwenden, oder? Seh ich das falsch?

Lg Mister
Bitte warten ..
Mitglied: MisterSaint
03.10.2006 um 07:54 Uhr
Hi,

also ich hab es nun ausprobiert und funktioniert super.
Danke für die Hilfe!

lg Mister
Bitte warten ..
Mitglied: DaSam
03.10.2006 um 09:24 Uhr
Hi,

wenn die beiden Webserver auf dem gleichen physikalischen Server sind, mach das doch so, wie ich es beschrieben habe:

Beide Webserver haben die gleiche IP Adresse und unterscheiden sich nur dadurch, dass sie unterschiedliche Hostheader auswerten - d.h. je nach Anforderung wird entweder der eine oder der andere antworten.

Den "Hauptserver" könnt ihr ja ohne Hostheader-Auswertung konfigurieren, der antwortet dann auf jeden Fall. Den zweiten halt dann mit Hostheader (geht ja eh' nicht anders, der IIS sperrt sich sowieso, wenn zwei virtuelle Server die gleichen IP:Port Einstellungen haben).

cu,
Alex
Bitte warten ..
Mitglied: MisterSaint
04.10.2006 um 13:56 Uhr
Hi,

ich habe es nun eh so eingestellt.
Die zweite Frage war eigentlich nur generell, weil ich brauch es bestimmt einmal. Wenn es 2 Hardwareserver gibt die in der gleichen Domäne + DNS Server sind dann sollte es doch auch kein Problem sein, oder? Verwaltet der DNS auch die von extern ankommenden Anfragen oder nur die internen?

lg Mister
Bitte warten ..
Ähnliche Inhalte
Windows Server
MSDCS-Subdomain
Frage von CufusedByteWindows Server3 Kommentare

Hallo Community, ich habe hier ein kleines Problem, ich habe in einem Netzwerk zwei Server die als "DNS" deklariert ...

Exchange Server
Transport Regeln - Subdomain
Frage von teslajrExchange Server1 Kommentar

Hallo Leute, für eine fliessende Migration soll eine temporäre Lösung her. in der neuen Exchange 2016 Umgebung existieren alle ...

Server
SUBDOMAIN 1und1 auf SBS
gelöst Frage von poonerServer7 Kommentare

Hallo Leute, ich brauch mal kurz Unterstützung. Ich habe einen SBS hier welcher mit einer Internetadresse eingerichtet ist, sprich ...

Internet Domänen

Subdomain von all-inkl auf Subdomain 1blu vServer

gelöst Frage von 137354Internet Domänen24 Kommentare

Hallo zusammen, ich habe eine Subdomain bei all-inkl.com: dudle.123-ab.de Auf dem vServer von 1blu habe ich eine Subdomain dudle.123-cd.de ...

Neue Wissensbeiträge
Internet

Kommentar: Bundesregierung erwägt Ausschluss von Huawei im 5G-Netz - Unsere Presse wird immer sensationsgieriger

Information von Frank vor 4 MinutenInternet

Hier mal wieder ein schönes Beispiel für fehlgeleiteten Journalismus und Politik zu gleich. Da werden aus Gerüchten plötzlich Fakten, ...

Windows 10

Netzwerk-Bug in allen Windows 10-Versionen durch Januar 2019-Updates

Information von kgborn vor 4 StundenWindows 101 Kommentar

Nur ein kurzer Hinweis für Admins, die Windows 10-Clients im Portfolio haben. Mit den Updates vom 8. Januar 2019 ...

Windows 10

Windows 10 V1809: Rollout ist gestartet - kommt per Windows Update

Information von kgborn vor 22 StundenWindows 101 Kommentar

Eine kurze Information für die Admins, die Windows 10 im Programm haben. Microsoft hat die letzte Baustelle (die Inkompatibilität ...

Sicherheit

Heise Beitrag Passwort-Sammlung mit 773 Millionen Online-Konten im Netz aufgetaucht

Information von Penny.Cilin vor 1 TagSicherheit5 Kommentare

Auf Heise Online ist folgender Beitrag veröffentlicht worden: Heise Beitrag passwörter geleakt Ich bin mir jetzt nicht ganz sicher, ...

Heiß diskutierte Inhalte
Switche und Hubs
Medienkonverter mit 12 oder 24 Ports gesucht
Frage von wmuellerSwitche und Hubs23 Kommentare

Guten Morgen, ich bin auf der Suche nach einem größeren Medienkonverter, der "stumpf" 1:1 die Ports auf über ein ...

Windows Server
Uhren gehen immer wieder falsch
Frage von killtecWindows Server23 Kommentare

Hallo, ich habe folgende Konstellation: 1. Physischer DC Div. Virtuelle DC's auf Hyper-V Servern Die Hyper-V-Server, der Physische DC ...

Debian
OpenSSH Login mit Public Key schlägt fehl, mit Passwort funktioniert
gelöst Frage von DKowalkeDebian19 Kommentare

Hallo zusammen, ich hatte hier schon nach einer Anleitung für einen SFTP Server mit Linux gefragt, habe dort auch ...

Windows Server
Client in die Domäne einbinden - Allgemeine Frage dazu
gelöst Frage von RalphTWindows Server19 Kommentare

Moin, ich habe 2 DCs in einer Hauptstelle und 2 DCs in einer Nebenstelle. Ich bringe in der Hauptstelle ...