Suchen und Ersetzen eines Zeichensatzes in einem Dateipfad

Mitglied: 3xplor3r

3xplor3r (Level 1) - Jetzt verbinden

13.11.2011, aktualisiert 14.11.2011, 3217 Aufrufe, 8 Kommentare

Hallo Gemeinde,

ich habe gerade nochmal einen anderen Gedanken gehabt und schon probiert, bin aber noch nicht zum Erfolg gekommen.

Die Umgebungsvariable %download% repräsentiert den folgenden Pfad.

Jetzt könnten weitere Unterverzeichnisse existieren. Nehmen wir an es würde ein Unterverzeichnis existieren.

In der Variable %%i steht dieser Pfad. Jetzt suche ich schon den ganzen Nachmittag nach einer Möglichkeit das Wort "Download" durch "Upload" zu ersetzen. Ein einfaches Suchen und Ersetzen würde dazu führen, dass auch andere Ordner bspw. Download\Test\Download auch ersetzt werden. Das soll jedoch nicht geschehen. Jetzt gibt es für mich zwei Möglichkeiten.

1) Entweder man sucht jetzt den Teil zwischen dem 7 und 8 "\" und plaziert dort den Zeichensatz "Upload".
2) Man sucht von links den ersten Zeichensatz "Download" und ersetzt diesen mit "Upload"

LG
3x
Mitglied: bastla
13.11.2011 um 20:22 Uhr
Hallo 3xplor3r und willkommen im Forum!
Ein einfaches Suchen und Ersetzen würde dazu führen, dass auch andere Ordner bspw. Download\Test\Download auch ersetzt werden
Nicht, wenn Du
durch
ersetzt.

Ansonsten könntest Du vielleicht etwas genauer erklären, was Du eigentlich erreichen willst ...

Trotzdem noch zu Idee 1): Ungetestet etwa so:
Es sollte dann aber schon für alle Dateien mindestens 8 Ordnerebenen geben ...

Grüße
bastla

P.S.: Darf ich Dich einladen, für Batchzeilen (oder etwa auch Textbeispiele, die unverändert dargestellt werden sollen) "Code"-Formatierung zu benutzen?
Bitte warten ..
Mitglied: 3xplor3r
14.11.2011 um 11:37 Uhr
Hallo Bastla,

natürlich nehme ich Deine Einladung. Ich habe während der Thread-Erstellung schon danach gesucht. Dann hatte ich wiederum einen anderen Thread gesehen, in dem ein User [code] Code [/code] verwendet hatte, was jedoch nicht funktionierte. Aber ich probiere es gleich nochmal selbst aus.

Du hast eigentlich in meinem Gefasel alles richtig interpretiert. Jetzt wollte ich statt dem ersten ECHO-Befehl

schreiben, was auch ohne Syntaxfehler läuft. Allerdings wird die Variable nicht ersetz, was durch ein erneutes

zu der Ausgabe
führt. Nebenbei hätte ich auf Deine Syntax auch kommen müssen. Den Ansatz hatte ich eigentlich schon, habe es dann aber wieder verworfen. Hier nochmal der Code in Gänze.

LG
3x
Bitte warten ..
Mitglied: Skyemugen
14.11.2011 um 14:41 Uhr
[OT]Aloha 3x ...

du hättest mal auf bastlas link klicken sollen, dann wäre dir aufgefallen, dass es bei uns nicht [code][/code] sondern <code></code> aktiv ist bitte für unsere Augen nachträglich ändern, danke =)

greetz André[/OT]
Bitte warten ..
Mitglied: bastla
14.11.2011 um 14:42 Uhr
Hallo 3xplor3r!

Einer Laufvariablen wie %%q kannst Du mit set keinen Wert zuweisen - da Du aber ohnehin den gewünschten Wert kennst (bzw dafür kennen musst), spricht ja eigentlich nix dagegen, diesen gleich direkt einzufügen:
Alternativ kannst Du den Wert auch vorweg einer Variablen zuweisen und dann diese verwenden, also:
Grüße
bastla
Bitte warten ..
Mitglied: 3xplor3r
14.11.2011 um 14:52 Uhr
Hallo bastla,

ich habe den Wert jetzt einer Umgebungsvariable zugewiesen. Wollte das Anfängercoding nur so variabel wie möglich halten. Aber so gehts auch. Die Verzeichnisstruktur sollte sich nicht ändern. Vielen Dank.
Bitte warten ..
Mitglied: bastla
14.11.2011 um 15:02 Uhr
Hallo 3xplor3r!
Wollte das Anfängercoding nur so variabel wie möglich halten.
Das ginge aber, je nachdem, wozu die ganze Aktion dienen soll, auch noch variabler ...

Grüße
bastla
Bitte warten ..
Mitglied: 3xplor3r
14.11.2011 um 15:12 Uhr
Ist es jetzt möglich die Laufvariablen einer normalen Variablen zuzuweisen?

LG
3x
Bitte warten ..
Mitglied: bastla
14.11.2011 um 15:46 Uhr
Hallo 3xplor3r!
Ist es jetzt möglich die Laufvariablen einer normalen Variablen zuzuweisen?
Ja.

Falls es Dir nicht aufgefallen sein sollte: Ich habe Dich jetzt schon zweimal nach dem Verwendungszweck gefragt - magst Du den vielleicht doch noch beschreiben?

Grüße
bastla
Bitte warten ..
Heiß diskutierte Inhalte
Zusammenarbeit
Klimaschutz
NebellichtVor 21 StundenTippZusammenarbeit48 Kommentare

Hallo friends, (friends in Anlehnung an die vielen Fs in dem englischen von FFF: fridays for future. Übrigens am 19.03.2021 gibts wieder einen globalen ...

Notebook & Zubehör
Tipp für festgefressene Scharniere bei Lenovo V120 Notebook?
gelöst LochkartenstanzerVor 1 TagFrageNotebook & Zubehör20 Kommentare

Moin Kollegen, Ich habe hier ein Lenovo V120 mit einem laut Internet üblichen Problem von "festgefressenen" Scharnieren. Ich könnte jetzt aufwendig das Notebook zerlegen ...

Microsoft Office
Microsoft365 und Outlook verbinden
ratzekahl1Vor 1 TagFrageMicrosoft Office30 Kommentare

Guten Morgen zusammen, ich habe einige Probleme / Fragen. Ich habe Office 365 auf den ersten Rechnern installiert. Admin angelegt, Benutzer usw. Da ich ...

Microsoft Office
Wechsel von Office - Exchange on premise zu Office 365 - Exchange Online
jann0rVor 1 TagAllgemeinMicrosoft Office14 Kommentare

Moin, ich weiß nicht so richtig, unter welche Überschrift man dieses Thema hier am besten packen kann, daher mal als allg. Beitrag / Erfahrungsbericht. ...

Viren und Trojaner
Ryuk Ransomware Warnzeichen
SchlemihlVor 1 TagFrageViren und Trojaner8 Kommentare

Guten Abend, nachdem ich hier und hier erfahren habe, wie sich die Ransomware Ryuk verhält, musste ich feststellen, dass unser kleines Netzwerk für eine ...

Internet
Sichere Verbindung von zu Hause zu einem Firmenpc
haiflosseVor 1 TagFrageInternet6 Kommentare

Hallo! Ich suche eine Lösung mit der ich eine sichere Verbindung (ohne das ein Virus, Trojaner oder Ransom Virus den Computer bzw. Netzwerk zerstört) ...

Windows 10
Leeres Desktop bei neuen Usern - möglich?
gelöst istike2Vor 1 TagFrageWindows 104 Kommentare

Hallo, in dem aktuellen Windows 10 Image haben wir leider vergessen das Desktop zu bereinigen. Wir haben also bei jedem neuen User einen vollen ...

TK-Netze & Geräte
2 x VPN site-to-site möglich?!
RicoPausBVor 1 TagFrageTK-Netze & Geräte6 Kommentare

Moin aktuell haben wir hier ein site-to-site vpn via IPsec. Das ganze läuft stabil aber langsam mit 2 x AVM6490 an Vodafone-Anschlüssen. Nun gibt ...