Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Aus Systeminfo die Domäne anzeigen

Mitglied: haufeft

haufeft (Level 1) - Jetzt verbinden

29.11.2007, aktualisiert 20:02 Uhr, 16926 Aufrufe, 8 Kommentare

Hallo @All

es geht um folgendes problem, ich versuche aus der systeminfo die domäne in einen echo auszugeben.

01.
for /f "tokens=1*" %%i in ('systeminfo^|findstr /i "Domäne" ') do set "dm=%%j"
02.
echo %dm%
aber leider ist keine ausgabe da

gibt es eine andere möglichket die domäne auszulesen?? der befehl systeminfo dauert immer ein wenig bis er was ausspuckt.

könnte es auch ein problem wegen dem umlaut geben??

@Biber
hoffe es ist so richtig :D


mfg
haufe
Mitglied: Dani
29.11.2007 um 16:49 Uhr
Hi haufe,
ich heiße zwar nicht Biber (auch nicht als 2. Namen oder Spitzname) aber es sollte die Lösung für dein Problem Sein.
Die Domäne wird schon in einer Umgebungsvariable (Systemweit) gespeichert. Mit einem
01.
echo %userdomain% 
solltest du den Namen erhalten.


Grüße
Dani
Bitte warten ..
Mitglied: bastla
29.11.2007 um 16:59 Uhr
... bzw, damit's der Ausgabe in "systeminfo" entspricht, mit %USERDNSDOMAIN%.

Grüße
bastla
Bitte warten ..
Mitglied: Dynadrate
29.11.2007 um 17:03 Uhr
...alle verfügbaren Umgebunsvariablen erfährt man übrigens auch mit dem Befehl "set"
Bitte warten ..
Mitglied: haufeft
29.11.2007 um 17:40 Uhr
Vielen Dank @ ALL

Leider geht das nicht (Liegt wohl an Vista).

Wenn ich echo %userdomain% eingebe bekomme ich den Pc Namen.

In der Systeminfo steht unter Domäne die Arbeitsgruppe und das ist was ich möchte.
Die Systeminfo:
01.
Hostname:                             HAUFE-PC
02.
Betriebssystemname:                   Microsoft® Windows VistaT Ultimate
03.
Betriebssystemversion:                6.0.6001 Service Pack 1, v.658 Build 6001
04.
Betriebssystemhersteller:             Microsoft Corporation
05.
Betriebssystemkonfiguration:          Eigenständige Arbeitsstation
06.
Betriebssystem-Buildtyp:              Multiprocessor Free
07.
Registrierter Benutzer:               haufe
08.
Registrierte Organisation:
09.
Product ID:                           xxxxxxxxxxxxxx
10.
Ursprüngliches Installationsdatum:    23.11.2007, 12:01:53
11.
Systemstartzeit:                      27.11.2007, 13:55:41
12.
Systemhersteller:                     Haufe
13.
Systemmodell:                         System Product Name
14.
Systemtyp:                            x64-based PC
15.
Prozessor(en):                        1 Prozessor(en) installiert.
16.
                                      [01]: Intel64 Family 6 Model 15 Stepping 7
17.
 GenuineIntel ~2394 MHz
18.
BIOS-Version:                         American Megatrends Inc. 0401   , 02.03.20
19.
07
20.
Windows-Verzeichnis:                  C:\Windows
21.
System-Verzeichnis:                   C:\Windows\system32
22.
Startgerät:                           \Device\HarddiskVolume2
23.
Systemgebietsschema:                  de;Deutsch (Deutschland)
24.
Eingabegebietsschema:                 de;Deutsch (Deutschland)
25.
Zeitzone:                             (GMT+01:00) Amsterdam, Berlin, Bern, Rom,
26.
Stockholm, Wien
27.
Gesamter physikalischer Speicher:     6.142 MB
28.
Verfügbarer physikalischer Speicher:  4.443 MB
29.
Auslagerungsdatei: Maximale Größe:    12.495 MB
30.
Auslagerungsdatei: Verfügbar:         10.656 MB
31.
Auslagerungsdatei: Zurzeit verwendet: 1.839 MB
32.
Auslagerungsdateipfad(e):             C:\pagefile.sys
33.
Domäne:                               ARBEITSGRUPPE
34.
Anmeldeserver:                        \\HAUFE-PC
35.
Hotfix(es):                           47 Hotfix(e) installiert.
Der Set Befehl liefert mir leider auch keine Infos:
01.
ALLUSERSPROFILE=C:\ProgramData
02.
APPDATA=C:\Users\haufe\AppData\Roaming
03.
CommonProgramFiles=C:\Program Files\Common Files
04.
CommonProgramFiles(x86)=C:\Program Files (x86)\Common Files
05.
COMPUTERNAME=HAUFE-PC
06.
ComSpec=C:\Windows\system32\cmd.exe
07.
FP_NO_HOST_CHECK=NO
08.
HOMEDRIVE=C:
09.
HOMEPATH=\Users\haufe
10.
LOCALAPPDATA=C:\Users\haufe\AppData\Local
11.
LOGONSERVER=\\HAUFE-PC
12.
NUMBER_OF_PROCESSORS=4
13.
OS=Windows_NT
14.
Path=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\log
15.
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
16.
PROCESSOR_ARCHITECTURE=AMD64
17.
PROCESSOR_IDENTIFIER=Intel64 Family 6 Model 15 Stepping 7, GenuineIntel
18.
PROCESSOR_LEVEL=6
19.
PROCESSOR_REVISION=0f07
20.
ProgramData=C:\ProgramData
21.
ProgramFiles=C:\Program Files
22.
ProgramFiles(x86)=C:\Program Files (x86)
23.
PROMPT=$P$G
24.
PUBLIC=C:\Users\Public
25.
SESSIONNAME=Console
26.
SystemDrive=C:
27.
SystemRoot=C:\Windows
28.
TEMP=C:\Users\haufe\AppData\Local\Temp
29.
TMP=C:\Users\haufe\AppData\Local\Temp
30.
USERDOMAIN=haufe-PC
31.
USERNAME=haufe
32.
USERPROFILE=C:\Users\haufe
33.
windir=C:\Windows
34.
Wise_QuickFacts=C:\Program Files (x86)\Altiris\Wise Installation Express\Tutoria
35.
l\QuickFacts\
und %USERDNSDOMAIN% geht auch nicht

mfg

haufe
Bitte warten ..
Mitglied: bastla
29.11.2007 um 18:03 Uhr
Hallo haufeft!

Dann ist es dieses Mal wohl soweit - ein wenig VBS, allerdings in Batch verpackt:
01.
@echo off & setlocal
02.
set "GD=%temp%\GetDomain.vbs"
03.
echo Set objWMIService=GetObject("winmgmts:{impersonationLevel=impersonate}!\\.\root\cimv2")>%GD%
04.
echo Set colSettings=objWMIService.ExecQuery ("Select * from Win32_ComputerSystem")>>%GD%
05.
echo For Each objComputer in colSettings:WScript.Echo objComputer.Domain:Next>>%GD%
06.
for /f "delims=" %%i in ('cscript //nologo %GD%') do set "dm=%%i"
07.
del %GD%
08.
echo %dm%
Grüße
bastla

[Edit] Abfrage von "Workgroup" auf "Domain" geändert. [/Edit]
Bitte warten ..
Mitglied: haufeft
29.11.2007 um 19:11 Uhr
DANNKEEE

Geht


MFG

Haufe
Bitte warten ..
Mitglied: Biber
29.11.2007 um 19:45 Uhr
Moin haufeft,

@biber
hoffe es ist so richtig :D
Jepp, Deine Frage ist vorbildlich formatiert.

könnte es auch ein problem wegen dem umlaut geben??
Das nicht, aber eventuell wegen des Umlauts.

Bei mir am CMD-Prompt und auch im Batch liefert Deine FOR/F-Anweisung Ergebnisse,
01.
>for /f "tokens=1,*" %i in ('systeminfo^|findstr "Domäne"') do @echo %i %j
02.
Betriebssystemkonfiguration: Mitglied der Domäne/Arbeitsgruppe
03.
Domäne: xx.yyy
Deshalb vermute ich, wenn
  • es bei Dir am CMD-Prompt klappt
  • aber nicht im Batch, dass Du den Batch mit Notepad o.ä. geschrieben/gespeichert hast.

Da wird der Umlaut in einem anderen Zeichensatz/neudeutsch Codepage codiert gespeichert.

Abhilfe (bei Umlaut-Problemen):
  • Schreiben und Speichern der Batche im DOS-Zeichensatz (alle guten Editoren können das)
-ODER-
  • mit Notepad arbeiten, aber im Batch mit "CHCP 1252" den Batch anweisen, den Windowszeichensatz zu verwenden. Denselben wie im Notepad.
-oder- (Hartz4-Variante)
  • den immer noch mitgelieferten Praktikanten-Editor "edit" zum Bätcheschreiben zu verwenden.
Wie geschrieben, diese Abhilfemöglichkeiten gäbe es bei Umlautproblemen.

Im konkreten Fall würde dann zwar die "systeminfo"-Auswertung laufen, aber es ist in der Tat ein SEHR kleiner Spatz, den Du mit dieser Kanone erschrecken willst.

Da aber M$ den Arbeitsgruppennamen (also Standalone/wenn keine Domäne vorhanden) nirgends bereitstellt... hmmm...

Da wäre mein erster Tipp: bastlas Variante

Danach eventuell mal gucken, was *"net config workstation" ausgibt.
Kann ich für Arbeitsgruppen nicht testen, bin in einer Domäne.

Dritte Variante wäre eine schnelle Abfrage der Registry mit "Reg query".
Welcher Schlüssel, das müssten ein paar Suchmaschinen wissen.

Grüße
Biber
P.S. /Off Topic
Wieso ist denn die Büchse am 23.11.2007 installiert und hat bereits 47 Hotfixe drauf?
Ist Vi$ta denn noch nicht stabil? *lach
Bitte warten ..
Mitglied: haufeft
29.11.2007 um 20:02 Uhr
LASS MEIN VISTA IN RUHE!!!! :D:D:D:D:D

das ist doch so schön (un)stabil :D

ich nehme deine harz4 variante obwohl ich frührentner bin mit 28 jahren

nene wie du sagtest wird das wohl bei mir liegen das ich wordpad benutze.

not more :D:D

Quick Batch File Compiler ist da wohl besser :D:D


mfg
haufe
Bitte warten ..
Neue Wissensbeiträge
iOS
WatchChat für Whatsapp
Tipp von Criemo vor 2 TageniOS3 Kommentare

Ziemlich coole App für WhatsApp User in Verbindung mit der Apple Watch. Gibts für iOS sowohl als auch für ...

iOS
IOS hat nen Cursor !!!
Tipp von Criemo vor 3 TageniOS5 Kommentare

Nette Funktion im iOS. iPhone-Mauszeiger aktivieren „Nichts ist nerviger, als bei einem Tippfehler zu versuchen, den iOS-Cursor an die ...

Off Topic
Avengers 4: Endgame - Erster Trailer
Information von Frank vor 5 TagenOff Topic2 Kommentare

Ich weiß es ist Off Topic, aber ich freue mich auf diesen Film und vielleicht geht es anderen hier ...

Webbrowser
Microsoft bestätigt Edge mit Chromium-Kern
Information von Frank vor 5 TagenWebbrowser5 Kommentare

Microsoft hat nun in seinem Blog bestätigt, dass die nächste Edge Version kein EdgeHTML mehr für die Darstellung benutzen ...

Heiß diskutierte Inhalte
Hosting & Housing
VMware VM mit über 1TB RAM für S4HANA
gelöst Frage von Leo-leHosting & Housing24 Kommentare

Hallo zusammen, wer hat Erfahrng und kann mir einen Tipp zum sizing von S4HANA Systemen geben? Wir möchten, zunächst ...

LAN, WAN, Wireless
WLAN und Ausmessung - Eine Glaubensfrage?
Frage von ptr2brainLAN, WAN, Wireless23 Kommentare

Liebe Experten, als Sys-Admin habe ich mir schon öfter die Frage gestellt, ob es sich beim Thema WLAN und ...

Drucker und Scanner
SW-Laserdrucker mit sechs Papierfächern gesucht
Frage von MOS6581Drucker und Scanner19 Kommentare

Moin, zur Abwechslung mal eine sonderbare Anforderung :) Ich suche einen S/W Laserdrucker (kein MFP), der sechs Papierfächer bzw. ...

Virtualisierung
Gebrauchte Server Hardware als Virtualisierungs-"Spielwiese"?
Frage von NixVerstehenVirtualisierung19 Kommentare

Einen wunderschönen guten Morgen zusammen, ich möchte mich gerne etwas tiefer mit dem Thema Virtualisierung beschäftigen und dazu ein ...