Teilweise sehr langsames Firmennetzwerk. Analyse,aber wie?

Mitglied: c.t

c.t (Level 1) - Jetzt verbinden

10.09.2007, aktualisiert 16.11.2007, 9873 Aufrufe, 9 Kommentare

Hallo,

folgendes ereignet sich in der letzten Zeit bei meinem Kunden:

1 DC (Betriebsmaster) Windows 2000: ADS, DNS, DHCP, RAS, Exchange
1 DC Windows 2003: ADS, DNS

Ca. 30 Clients Windows XP und 1 Vista (leider)
Auf dem Betriebsmaster läuft auch Backup Exec.
Jeden Tag werden Daten auf´s Band gespeichert. Bis vor 2 Monaten schnurrte das Netzwerk wie ein Kätzchen.
Seit 2 Monaten bricht fast jeder Sicherungsjob wegen Überschreitung der maximalen Ausführungszeit ab.

Lange Rede kurzer Sinn. Manche Jobs benötigen "mittlerweile" für 1GB über 4 Stunden. Eine Woche davor ca. 14 Minuten. So pflanzt sich das weiter fort.
Habe mal Wireshark laufen lassen und bekam immer TCP_CHECKSUM_ERROR. Diese Meldung erzeugte 90% des Netzwerkverkehrs zu einer bestimmten Station. Leider konnte ich bisher nicht weiter suchen, da keine Zeit.
Jetzt muß aber eine Lösung her. Kann es sein, das es mit einem neu installierten Intel Dual Port-Treiber für die Netzwerkkarte zu tun hat?

Da ich nur recht selten was an dem System machen kann (dauerhaft in Betrieb) möchte ich die mir zu Verfügung stehende Zeit dann effektiv nutzen.

Meine Frage: Wie analysiert man ein Netzwerk am sinnvollsten. Welche Vorgehensweise sollte man einhalten?

Für jeden Denkanstoß bin ich dankbar!

Gruß

Ethernet
Mitglied: gnarff
10.09.2007 um 20:27 Uhr
Hallo c.t.!
Habe mal Wireshark laufen lassen und bekam
immer TCP_CHECKSUM_ERROR. Diese Meldung
erzeugte 90% des Netzwerkverkehrs zu einer
bestimmten Station. Leider konnte ich bisher
nicht weiter suchen, da keine Zeit.
Jetzt muß aber eine Lösung her.
Die Loesung ist ganz einfach, Du hast sie schon selber ausgesprochen, nimm Dir die Zeit!
Untersuche die betreffende "Station", die physischen Uebertragungswege zu und von derselben und den Datenverkehr.
Es ist nicht die Frage, wie man das Netzwerk analysiert, sondern wie man den Fehler untersucht...

Ein TCP Checksum Error koennte auf ein Routingproblem hinweisen...

saludos
gnarff
Bitte warten ..
Mitglied: c.t
13.09.2007 um 18:43 Uhr
Hi,

heute konnte ich nochmal ins Netz schnuppern. Es liegt niciht ma Netzwerk. Habe mal die Leistungsindikatoren gestartet. Der DC schreibt wie ein Weltmeister auf die Platte. Jetzt stehe ich echt am Schlauch. Wie soll ich denn herausbekommen, welches Tool ständig auf die Platte schreibt.
Die Checksum_Errors sind übrigens weg

Ich hoffe, mir kann jemand helfen.

Gruss

c.t
Bitte warten ..
Mitglied: gnarff
13.09.2007 um 21:30 Uhr
Der
DC schreibt wie ein Weltmeister auf die
Platte. Jetzt stehe ich echt am Schlauch. Wie
soll ich denn herausbekommen, welches Tool
ständig auf die Platte schreibt.
WAS schreibt der DC auf die Festplatte?
Die Dokumente Post Deployment Monitoring of Domain Controllers bzw. How do I monitor performance in Active Directory? könnten sich für Dich als Hilfreich erweisen.

saludos
gnarff
Bitte warten ..
Mitglied: c.t
14.09.2007 um 18:48 Uhr
Hi Gnarff,

also was da schreibt habe ich nicht rausbekommen. Alle Tasks sind im normalen Level. Fakt ist, dass das System für die Schreibvorgänge 100% Schreibzeit in Anspruch nimmt.
Zur Erklärung:
Habe im Systemmonitor den Physikalischen Datenträger mit den Indikatoren (Schreibzeit% und Schreibvorgänge/s) ausgewählt. Doe schreibvorgänge liegen in der Skala (100) im mittleren Bereich. Die Schreibzeit in % liegt bei 99% bis 100%.
Liege ich da richtig, das meine Platten (Raid 5) der Grund sein können?

Was anderes kann ich mir nicht erklären.

Gruss

c.t
Bitte warten ..
Mitglied: gnarff
14.09.2007 um 20:36 Uhr
Hallo c.t!

Wir können uns natürlich nun in wilden Vermutungen ergehen und dem RAID die Schuld geben, aber welcher Fehler könnte diese Symptome zeitigen?
Bei einem beschädigten Treiber oder Speichermedium, z.B. , würde es doch sofort zu einer Fehlermeldung kommen, bzw. gar nichts funktionieren.
Überpruefe den RAID, es kann ja nicht schaden...

Ich hatte dich ja auch nicht gefragt WER da auf die Festplatte schreibt -das wollen wir ja herausfinden; sondern WAS da auf die Festplatte geschrieben wird.
Es muss ja zwangsläufig mindestens eine Datei existieren, in die geschrieben wird -welche ist das und was steht da drin?

Vorher hattest Du einen TCP Checksum Error beobachtet, diese geschieht wenn Datenpakete als malformiert [sagt man das so auch auf Deutsch?] festgestellt werden.
Auch wenn Du diese Fehlermeldung nun nicht mehr hast, so musste doch irgendwo in Deinem Netzwerk eine Anwendung sein, die nicht richtig funktioniert hatte, auch ein schadhaftes Netzwerkkabel kann dazu fuehren...
Die Frage ist: Reparieren sich solche Dinge von selbst?

Mit QA_Check.cmd, aus dem ersten Link meines vorhergehenden Kommentares, kannst Du eine Fülle von Informationen erhalten und auswerten, z.B. die NTDS Object Counters, aber auch im zweiten Link findest Du Hilfreiches, z. B. in Table 8.2 Additional Active Directory System Monitor Counters Under the Database Object

Du musst das Problem schon ordentlich untersuchen...

saludos
gnarff
Bitte warten ..
Mitglied: c.t
15.10.2007 um 15:30 Uhr
Hi,

dachte ich hätte den Fehler gefunden. Netzwerkkartentreiber neu installiert. Danach schnurrte das System wie ein Kätzchen. Alle Sicherungen wurden abgeschlossen und die Festplattenwerte waren auch wieder normal.

Jetzt fängt der ganze Mist wieder an. Naja, nach der Neuinstallation des Kartentreibers ist das Netzwerk nicht mehr ganz so langsam.

Der Grund, warum die Werte Top in Ordnung waren, war der Neustart nach der Treiberinstallation. Jetzt ist es so, das nach einem halben Tag Betrieb alle Werte wieder im Keller sind.
Irgendetwas schaukelt sich da also hoch.

Leider konnte ich mit Deinen Hilfestellungen nicht allzuviel anfangen, da mein Englisch nicht so der Renner ist und es bei den Texten doch sehr ins eingemachte geht.

dcdiag und nslookup brachte keine Fehler. Auch im eventlog finde ich nichts, was auffällig wäre.
Hast Du trozdem noch nen Tipp für mich, wie man an sowas herangehen muß?

Gruss

c.t
Bitte warten ..
Mitglied: gnarff
15.10.2007 um 20:13 Uhr
Grundsätzlich gilt, ein DC, der nicht anständig funktioniert muss aus dem Netzwerk entfernt werden.

Worüber ich in deiner Schilderung laufend stolpere ist, dass der "DC wie ein Weltmeister schreibt"; nur - ein DC schreibt aber nichts außer Logfiles, es sei denn jemand ist auf die fatale Idee gekommen seinen DC gleichzeitig als Filesharing-Server o.ä zu benutzen.

Dass Dein Englisch nicht so gut ist, kann ich leider nicht ändern ich denke da musst Du durch. Ich habe Dir mit den o.a. Links alle Mittel in die Hand gegeben, detailliertere Logfiles zu generieren und auszuwerten. Da muss man sich halt mal mit einem Wörterbuch behelfen, das tue ich auch.
Ich habe auch bei allergrößter Sympathie für dich und Interesse für Dein Problem, nicht die Zeit das für Dich zu übersetzen.

Interessant finde ich, dass nach Neuinstallation des Treibers die Netzwerkleistung, wenn auch nur für kurze Zeit, normal war.
Hattest Du den alten Treiber auch wirklich restlos, d.h. von Hand entfernt?

Wenn Du magst und es eure Firmenpolitik zulässt, bin ich bereit Deine Logfiles auszuwerten, die Du mir dann mittels E-Mail in komprimierter Form zuschicken kannst.
Ich bräuchte dann die alten und die neuen Logfiles...

Nachbemerkung: Das Exchange auf DC1 läuft ist mehr als unpassend, dafür nimmt man einen eigenen Server...
saludos
gnarff
Bitte warten ..
Mitglied: c.t
16.11.2007 um 10:53 Uhr
Problem gelöst. Leider viel zu spät ist mir aufgefallen, das am Switch die Duplex-LED nicht leuchtete. Habe die Netzwerkkarteneinstellung von 100MBit auf "Auto" gesetzt. Jetzt rennt er wieder.
Warum er mit der Einstellung 100Mbit Probleme hat weiß ich nicht. Aber das Problem habe ich bei anderen System jetzt öfters feststellen können.

Der Beitrag kann also als gelösr deklariert werden.

Gnarff, ich danke Dir für Deine Geduld und Hilfe!

Gruss

C.T
Bitte warten ..
Mitglied: gnarff
16.11.2007 um 15:04 Uhr
Problem gelöst. Leider viel zu spät
ist mir aufgefallen, das am Switch die
Duplex-LED nicht leuchtete. Habe die
Netzwerkkarteneinstellung von 100MBit auf
"Auto" gesetzt. Jetzt rennt er
wieder.
Hatte ich ja in meiner ersten Antwort Dir geraten; alle physischen Übertragungswege zu ueberpruefen.

Gnarff, ich danke Dir für Deine Geduld
und Hilfe!

Sehr gerne und immer wieder...

saludos
gnarff
Bitte warten ..
Heiß diskutierte Inhalte
LAN, WAN, Wireless
Allgemeiner Fehler
gelöst jensgebkenFrageLAN, WAN, Wireless16 Kommentare

Hallo Gemeinschaft, habe bei einem PC folgendes Ping Problem über ipconfig erhalte ich die IP 192.168.178.37 will ich diesen ...

Microsoft
Die letzte Phase des Desktop Kriegs?
FrankInformationMicrosoft16 Kommentare

In seinem Blog vertritt Eric S. Raymond, bekannt auch unter seinem Hacker-Namen ESR, eine interessante Theorie um das Ende ...

Windows Userverwaltung
Powershell nach Gruppe und deren Mitglieder suchen
gelöst 145963FrageWindows Userverwaltung12 Kommentare

Hallo Admin' s, hier mein Object in der Active Directory. Wie kann ich jetzt gezielt nach der Gruppe "OU=Verwaltung" ...

Ubuntu
Server Bash Input Output error
gelöst DerEchteBoenFrageUbuntu12 Kommentare

Guten Tag Leute! Ich hab letztens einen älteren Hp Server mit 2x Intel Xeon mit jeweils 6 kernen und ...

Microsoft
Gespeichertes Eventlog per Powershell durchsuchen
gelöst DerWoWussteFrageMicrosoft12 Kommentare

Werte Kollegen! Ich archiviere die Securitylogs des Domänencontrollers jeden Tag. Wenn ich nun etwas im Log von z.B. vorgestern ...

Windows Userverwaltung
Active Directory Gruppen auslesen
gelöst MMaiwaldFrageWindows Userverwaltung12 Kommentare

Guten Abend, ich habe mir das Codeschnipsel geschnappt und möchte dieses noch erweitern. Dazu möchte ich noch die Beschreibung ...

Ähnliche Inhalte
Batch & Shell
Firmennetzwerk Dropbox deinstallieren
gelöst xbast1xFrageBatch & Shell17 Kommentare

Hallo zusammen, Dropbox soll von allen Firmenrechnern fliegen. Bisher habe ich das mittels batch üer GPO realisiert. Ich scheitere ...

Netzwerkmanagement
Absicherung internes Firmennetzwerk
banane31FrageNetzwerkmanagement7 Kommentare

Guten Abend zusammen, ich habe mir hier sämtliche Netzwerk Tutorials schon durch geschaut, komme aber Ad Hoc nicht weiter. ...

Windows Server
Kleines Firmennetzwerk einrichten
gelöst meex87FrageWindows Server10 Kommentare

Hallo Administratoren :) , ich hätte einige Fragen zum Thema "Firmennetzwerk". Ich möchte gerne für ein befreundetes Unternehmen ein ...

Server-Hardware
Firmennetzwerk - Aufbau (Windows Server)
Numo00FrageServer-Hardware6 Kommentare

Hallo Leute, ich bräuchte eine kleine Beratung bzw. Tipps von euch. Für eine kleine Firma (5-6 Mitarbeiter) soll ein ...

Verschlüsselung & Zertifikate

Onedrive.live.com - Zertifikatsfehler aus Firmennetzwerk

gelöst couchadm1nFrageVerschlüsselung & Zertifikate7 Kommentare

Hi, meine erste Frage hier (habe mich extra angemeldet). Ich hoffe jemand kann mir weiterhelfen Einige Mitarbeiter nutzen bei ...

Datenschutz

Sicherheitslösung für unser Firmennetzwerk

mossoxFrageDatenschutz7 Kommentare

Ich hatte gestern ein Gespräch mit einem Vertriebsmitarbeiter der Fa. We Syb Es ging um das Thema Datensicherheit und ...

Berechtigungs- und IdentitätsmanagementBerechtigungs- und IdentitätsmanagementWebdienste und -serverWebdienste und -serverDatenbankenDatenbankenMonitoring & SupportMonitoring & SupportHybrid CloudHybrid CloudSmall Business ITSmall Business IT