Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Ubuntu Updates in VirtualBox nicht möglich

Mitglied: AndyAh

AndyAh (Level 2) - Jetzt verbinden

07.10.2013, aktualisiert 12:01 Uhr, 2875 Aufrufe, 14 Kommentare

Hi NG,

ich habe ein Problem mit Ubuntu in der VirtualBox. Die Netzwerkeinstellung der virtuellen Maschine ist auf Netzwerkbrücke gestellt. Trotzdem kann ich aus dem Internet keine Updates und Software installieren, wenn in der /etc/network/interfaces die ETH0 Schnittstelle auf static mit den entsprechenden (korrekren) IP-Einstellungen eingestellt ist. Über die DHCP Einstellung funktioniert es.

Woran liegt das?

Gruß
Andy
Mitglied: ticuta1
07.10.2013 um 12:01 Uhr
An (interne )IP Konfiguration der Virtualbox
LG,
ticuta1
Bitte warten ..
Mitglied: AndyAh
07.10.2013 um 12:10 Uhr
Hi ticuta1,

könntest du das Ganze evtl. präzisieren? Wo soll welche Einstellung hin?

Gruß
Andy
Bitte warten ..
Mitglied: holyone
07.10.2013 um 12:19 Uhr
Hallo,
du musst bei VirtualBox im Netzwerkbereich "NAT" auswählen.
Und in der VM selber den DNS-Server eintragen. Dann sollten die Updates eigentlich fluppen.
Bitte warten ..
Mitglied: Chonta
07.10.2013, aktualisiert um 14:24 Uhr
Hallo,

das muss auch mit Netzwerkbrücke gehen.
Hat die VM mit festen IP überhaupt Netzwerk?
Ist eth0 oben oder unten?
Konfigurationsfehler in der Datei?
Netzwerk neu gestartet?
Fehlt für den Neustart ein auto eth0 in der /etc/network/interfaces ?
Sind DNS Server und Gateway auch gesetzt?

Gruß

Chonta
Bitte warten ..
Mitglied: Lochkartenstanzer
07.10.2013, aktualisiert um 15:00 Uhr
ifconfig -a?
netstat -r?
cat /etc/resolv.conf?

lks
Bitte warten ..
Mitglied: Lochkartenstanzer
07.10.2013, aktualisiert um 16:59 Uhr
Zitat von holyone:
du musst bei VirtualBox im Netzwerkbereich "NAT" auswählen.

Warum? es funktioniert ja in seinem bridged-Nertzwerk wenn er DHCP auswählt. Das ist eher ein Hinweis, daß die statischen Einträge nicht stimmen. Deswegen meine Nachfrage nach den verschiedenen Einstellungen. Wenn man die bei DHCP und bei statischer Konfiguration vergleicht, sollte es eigentlich direkt ins Auge springen.

lks

PS: Eine genauere fehlermeldung als "geht nicht" wäre hilfreich.
Bitte warten ..
Mitglied: Lochkartenstanzer
07.10.2013, aktualisiert um 17:01 Uhr
Zitat von AndyAh:
Woran liegt das?

Noch ein wenig Kristalllkugel:

  • IP-Adresse/Maske falsch?
  • Default route falsch?
  • Nameserver falsch?

lks
Bitte warten ..
Mitglied: AndyAh
08.10.2013 um 08:13 Uhr
Zitat von Lochkartenstanzer:
> Zitat von AndyAh:
> ----
> Woran liegt das?

Noch ein wenig Kristalllkugel:

  • IP-Adresse/Maske falsch?
Nein
* Default route falsch?
Nein
* Nameserver falsch?
In den Beispielen im Internet habe ich keine Nameserver-Einträge gefunden. Wie wüden diese dann lauten?



lks

Gruß
Andy
Bitte warten ..
Mitglied: Chonta
08.10.2013 um 08:23 Uhr
Hallo,

z.B. so

auto eth0
iface eth0 inet static
address 192.168.1.58
gateway 192.168.1.1
network 192.168.1.0
broadcast 192.168.1.255
dns-nameservers 66.212.63.228 66.212.48.10

http://askubuntu.com/questions/143819/how-do-i-configure-my-static-dns- ...

Natürlich ans eigene netz anzupassen.
Du sagst zwar zu IP falsch, Nein, aber hast die Fragen nach ifconfig all nicht beantwortet und auch nicht ob der Server mit seiner Statischen IP überhaupt in deinem eigenen Netz erreichbar ist oder nicht.
Kann der mit der statischen IP einen ping auf 8.8.8.8 absetzen? Wenn ja DNS Problem. Wenn nein ist überhaupt eth0 gestartet?

Gruß

Chonta
Bitte warten ..
Mitglied: AndyAh
08.10.2013 um 08:28 Uhr
Hi Chonta,

danke für den Tipp. Werde es mal ausprobieren. Die Frage nach der ifconfig kann ich dir zzt. leider nicht beantworten, da ich an einem anderen Rechner sitze. Ich kann mich leider mit meinem Win 8 Hostsystem nicht bei Administrator.de anmelden.

Gruß
Andy
Bitte warten ..
Mitglied: Chonta
08.10.2013 um 08:37 Uhr
Hallo,

kommt der Host auch nicht ins Netzwerk?
Du versuchst bei der IPconfiguration aber nicht der VM dieselbe IP wie dem HOST zu geben oder?

Gruß

Chonta
Bitte warten ..
Mitglied: AndyAh
08.10.2013 um 08:44 Uhr
Hi,

der Host kommt ansonsten ins Internet. Ob VM und HOST dieselbe IP haben, muß ich überprüfen, da der Host über DHCP läuft.

Gruß
Andy
Bitte warten ..
Mitglied: Lochkartenstanzer
08.10.2013 um 08:45 Uhr
Zitat von AndyAh:
Hi Chonta,

danke für den Tipp. Werde es mal ausprobieren. Die Frage nach der ifconfig kann ich dir zzt. leider nicht beantworten, da ich
an einem anderen Rechner sitze. Ich kann mich leider mit meinem Win 8 Hostsystem nicht bei Administrator.de anmelden.

putty funktioniert auch unter Win8.

Wenn Du einacfh die drei Fragen beantworten würdest, jeweils für DHCP udn für statische Adressvergabe, würde man recht schnell sehen, wo das Problem liegt.

lks
Bitte warten ..
Mitglied: AndyAh
17.10.2013 um 08:19 Uhr
Hi,

hab's jetzt hinbekommen! Ich habe eine 2. Netzwerkkarte für den DHCP konfiguriert.

Gruß
Andy
Bitte warten ..
Ähnliche Inhalte
Virtualisierung

Virtualbox startet nicht auf Ubuntu 18.04 - Deinstallation

gelöst Frage von wusa88Virtualisierung7 Kommentare

Hallo Zusammen, ich wollte auf einem Ubuntu 18.04, Virtualbox installieren. Habe mich vorerst an diese Anleitung gehalten.: Allerdings war ...

Netzwerkmanagement

Virtualbox NAT

Frage von TechTobiNetzwerkmanagement8 Kommentare

Hallo Leute, ich habe mal eine Netzwerkfrage mit der Verbindung im Bereich virtualbox. Laut diesem Blog wird der Host ...

Virtualisierung

VirtualBox 5.2.4 Netzwerkbug

Erfahrungsbericht von windowsboyVirtualisierung1 Kommentar

Hallo, ich habe heute Morgen bemerkt, das VirtualBox 5.2.4 scheinbar unter Linux bei der Netzwerkbrücke keine Internetverbindung bekommt. Er ...

Vmware

Virtualbox anfrage xD

Frage von 132954Vmware6 Kommentare

Hi Ich möchte gerne ein windows XP das ich mit dem VMware Converter zu einem Virtualbox kompatiblen Container gemacht ...

Neue Wissensbeiträge
Humor (lol)
Preisvertipper
Information von Dilbert-MD vor 4 TagenHumor (lol)8 Kommentare

Moin! weil heute Freitag ist, zeige ich Euch den Preisvertipper der Woche: vergesst den Acer Predator 21x, der ist ...

Windows Update
Sicherheitsupdate für SQL Server 2014 SP3
Information von sabines vor 6 TagenWindows Update2 Kommentare

Für den SQL Server 2014 existiert ein Sicherheitsupdate. Laut KB Artikel wird es als CU3 angezeigt: Server 2014 SP3 ...

Backup

Veeam Agent für MS Windows - neue Version verfügbar (bedingt jedoch offenbar .NET Framework 4.6)

Information von VGem-e vor 7 TagenBackup1 Kommentar

Moin Kollegen, einer unserer Server zeigte grad an, dass für o.g. Software ein Update verfügbar ist. Ob ein evtl. ...

Python

Sie meinen es ja nur gut - Microsoft hilft python-Entwicklern auf unnachahmliche Weise

Information von DerWoWusste vor 8 TagenPython2 Kommentare

Stellt Euch vor, Ihr nutzt python unter Windows 10 und skriptet damit regelmäßig Dinge. Nach dem Update auf Windows ...

Heiß diskutierte Inhalte
Windows Server
Lange Wartezeiten beim speichern und öffnen auf Win Server 2019
Frage von installerWindows Server49 Kommentare

Hallo, habe ein Problem mit langen Wartezeiten beim öffnen / speichern von Office Dokumenten etc. auf Netzlaufwerken auf einem ...

Utilities
TeamViewer - Software installieren mit Admin Account
Frage von gwitzigUtilities28 Kommentare

Hallo, ich bin bei einem Großkunden und muss einen Hotfix (Windows 7 Notebook) installieren. Habe es mit TeamViewer Version ...

LAN, WAN, Wireless
Durchblick im Ubiquiti Dschungel
Frage von installerLAN, WAN, Wireless26 Kommentare

Hallo, ich möchte gerne ein Wohnhaus mit Ubiquiti WLAn Access Points (inkl. Mesh Funktion) austatten und auch eine grafische ...

Monitoring
Monitoring Tool für 200 virtuelle Server
Frage von FortimiMonitoring22 Kommentare

Hallo zusammen Ich bin auf der Suche nach einem Monitoring Tool für unsere Informatik mit ca. 200 virtuellen Servern. ...