Nach Update von Office 2013 auf 2016 funktioniert das Autodiscover nicht mehr

Mitglied: StefanKittel

StefanKittel (Level 5) - Jetzt verbinden

30.11.2020, aktualisiert 01:04 Uhr, 982 Aufrufe, 14 Kommentare

Hallo,

ich habe hier einen PC mit Win10 Prof (20H2).
Darauf installiert war Office 2013 Home and Business.

Dieses habe ich regulrär deinstalliert, neu gestartet und Office 2016 Standard installiert.
Funktioniert alles soweit normal.

Nun erstelle ich in Outlook über die Systemsteuerung ein neues Profil und gebe in den Assistenten die Email-Adresse und das Kennwort ein.
Nun steht hier schon seit 2 Stunden "Nach xxx@firma.de-Einstellungen suchen".

Autodiscover selber funktioniert an einem beliebigen anderen PC.

Ich habe Office dann über "SetupProd_OffScrub" deinstaliert und neu installiert.
Funktioniert nicht.

Das gleiche nochmal aber zusätzlich in der Registry den Office-Baum vor der Neuinstallation gelöscht.
Funktioniert nicht.

Ein andere Benutzer funktioniert auch nicht.

Im Eventlog steht nichts dazu.

Jemand noch eine Idee bevor ich die Kiste neu installiere?

Stefan
Mitglied: Pjordorf
LÖSUNG 30.11.2020 um 01:16 Uhr
Hallo,

Zitat von StefanKittel:
Jemand noch eine Idee bevor ich die Kiste neu installiere?
Welchen Autodiscover von welchem DNS löst er denn auf? Falsche DNS Einstellungen? Wireshark sagt es dir.

Gruß,
Peter
Bitte warten ..
Mitglied: StefanKittel
30.11.2020 um 02:00 Uhr
Zitat von Pjordorf:
Welchen Autodiscover von welchem DNS löst er denn auf? Falsche DNS Einstellungen? Wireshark sagt es dir.
Es sind externe Exchange-Postfächer von Busymouse.
Die DNS-Einstellungen sind korrekt. Ein 2. PC mit gleichen DNS-Einstellungen hat das Problem nicht.

Wireshark sagt mir, dass Outlook den DNS-Server gar nicht fragt.
Bitte warten ..
Mitglied: Pjordorf
LÖSUNG 30.11.2020 um 04:15 Uhr
Hallo,

Zitat von StefanKittel:
Wireshark sagt mir, dass Outlook den DNS-Server gar nicht fragt.
Wohin geht das Outlokk denn dann hin?

Gruß,
Peter
Bitte warten ..
Mitglied: altmetaller
LÖSUNG 30.11.2020 um 08:23 Uhr
Hallo,

was sagt der Microsoft Remote Connection Analyzer denn, wenn Du ihn auf das Testpostfach loslässt?

Gruß,
Jörg
Bitte warten ..
Mitglied: StefanKittel
30.11.2020 um 08:50 Uhr
Zitat von Pjordorf:
Zitat von StefanKittel:
Wireshark sagt mir, dass Outlook den DNS-Server gar nicht fragt.
Wohin geht das Outlokk denn dann hin?
Nirgendwo. Er macht einfach gar nichts im Netzwerk.

Ich bin aber einen Schritt weiter.
Ich habe mit DISM Windows repariert.
Jetzt funktioniert es wieder, aber jeder Autodiscover dauert 20 Minuten.
Ich habe aus zeitlichen Gründen aber noch nicht geschaut ob ich rausfinden kann warum.

Stefan
Bitte warten ..
Mitglied: StefanKittel
30.11.2020 um 08:51 Uhr
Zitat von altmetaller:
was sagt der Microsoft Remote Connection Analyzer denn, wenn Du ihn auf das Testpostfach loslässt?
Der sagt es wäre alles OK. Genau wie der Punkte "Email-Autokonfiguration testen" von Outlook.

Stefan
Bitte warten ..
Mitglied: canlot
LÖSUNG 30.11.2020 um 09:53 Uhr
Bei irgendeiner Version wird doch die Microsoft Cloud zuerst abgefragt, meine ich. Das kann man mit einem Registry Eintrag abstellen.
Bitte warten ..
Mitglied: altmetaller
LÖSUNG 30.11.2020 um 10:14 Uhr
Hallo,

bist Du wirklich sicher, dass es nicht am Client liegt?

Vielleicht wird irgendwo etwas gecacht? Ich setze z.B. grundsätzlich Proxyserver vor einen Exchange.

Schon mal einen Blick auf die AutoDiscover.xml geworfen? Die müsste man eigentlich auch via Browser abrufen können.

Gruß,
Jörg
Bitte warten ..
Mitglied: StefanKittel
30.11.2020 um 10:31 Uhr
Moin,
ich habe den PC nun neu installiert.
Danach sind alle Probleme weg.

Danke für die Ideen.

Stefan
Bitte warten ..
Mitglied: altmetaller
30.11.2020 um 11:30 Uhr
Hallo,

Zitat von StefanKittel:

ich habe den PC nun neu installiert.

Ich weiß ja nicht, wer den aufgesetzt hat. Aber ich habe "seinerzeit" tatsächlich Szenarien gesehen, bei denen z.B. eine AutoDiscover.xml lokal hinterlegt und via Registry im Outlook verlinkt war.

Will meinen: Gerade an der Stelle gibt es unglaublich viele Stellen, an denen man herumfrickeln kann. Im Zweifelsfall steht das dann aber alles in der Doku bzw. im Betriebsführungshandbuch :-) face-smile

Gruß,
Jörg
Bitte warten ..
Mitglied: StefanKittel
30.11.2020 um 11:45 Uhr
Zitat von altmetaller:
Ich weiß ja nicht, wer den aufgesetzt hat. Aber ich habe "seinerzeit" tatsächlich Szenarien gesehen, bei denen z.B. eine AutoDiscover.xml lokal hinterlegt und via Registry im Outlook verlinkt war.
Ich, das kann ich ausschliessen.
Aber ich habe auch das probiert um das dynamische Autodiscover zu übergehen.
Keinen Effekt.

Will meinen: Gerade an der Stelle gibt es unglaublich viele Stellen, an denen man herumfrickeln kann. Im Zweifelsfall steht das dann aber alles in der Doku bzw. im Betriebsführungshandbuch :-) face-smile
Hilfreicher wäre es wenn MS besser programmieren würde und z.B. für das Autodiscover ein Protkoll erstellt.

Siehe z.B. auch
https://www.skittel.de/autodiscover-bei-hosted-exchange-beschleunigen/

Stefan
Bitte warten ..
Mitglied: altmetaller
30.11.2020 um 13:27 Uhr
Hallo,

Zitat von StefanKittel:

Hilfreicher wäre es wenn MS besser programmieren würde und z.B. für das Autodiscover ein Protkoll erstellt.

Ich finde das mit der XML-Datei "ausgesprochen transparent und flexibel". Im Grunde genommen kannst Du z.B. auch einen reinen SMTP- und IMAP-Server aufsetzen und die passende Autodiscover-Datei beim Webhoster auf den Webspace legen.

Das Einzige, was das etwas erschwert ist, dass letztendlich der Client entscheidet, wo und wie er nach dem File sucht. Vergleiche: Exchange Autodiscover Whitepaper – Aktualisierte Version (Frankys Web)

Aber auch bei einem entsprechenden Protokoll wäre es letztendlich Sache des Clients, wie er die Angaben auswertet.

Gruß,
Jörg
Bitte warten ..
Mitglied: StefanKittel
30.11.2020, aktualisiert um 13:36 Uhr
Zitat von altmetaller:
Ich finde das mit der XML-Datei "ausgesprochen transparent und flexibel".
Hat hier aber auch nicht funktioniert.

Das Einzige, was das etwas erschwert ist, dass letztendlich der Client entscheidet, wo und wie er nach dem File sucht.
Sollte mit der XML-Datei ja eigentlich egal sein.

Aber auch bei einem entsprechenden Protokoll wäre es letztendlich Sache des Clients, wie er die Angaben auswertet.
Ein Protokoll würde aber zumindest zeige dass er etwas und was. Dann hätte man der Fehlerdiagnose zumindest eine Chance.

<offtopic>Siehe auch sMIME bei Outlook: "Es ist ein Fehler aufgetreten".</offtopic>

<offtopic>Exchange ist gar nicht mal das Problem. Outlook ist ein Problem.</offtopic>

Stefan
Bitte warten ..
Mitglied: altmetaller
30.11.2020, aktualisiert um 14:02 Uhr
Hallo,

Zitat von StefanKittel:

Hat hier aber auch nicht funktioniert.

Wenn der Client nicht mal so banale Dinge wie den Download einer Autodiscover-Datei gebacken bekommt, hätte er bei der Bedienung eines Protokolls sicher noch tiefer ins Klo gefasst.

Sollte mit der XML-Datei ja eigentlich egal sein.

Ist es aber nicht. Auch beim Remote Connection Analyzer kannst Du sehen, in welcher Reihenfolge der sucht. Bei iPhones usw. sieht das schon wieder ganz anders aus...

Dann hätte man der Fehlerdiagnose zumindest eine Chance.

Die hast Du so auch. Alleine aufgrund deiner Schilderung wusste ich nach 10 Sekunden, dass es ein Defekt in der Clientinstallation ist. Ich hätte nicht einmal in die LOG-Dateien schauen müssen. Und wenn, hätte ich mein Augenmerk auf TCP/443 gelegt :-) face-smile

Outlook ist ein Problem.

Japp.

Gruß,
Jörg
Bitte warten ..
Heiß diskutierte Inhalte
Internet
Kein Internet nach Windows 2019 Server Installation
gelöst ZygmundVor 1 TagFrageInternet25 Kommentare

Computer : HP ProLiant DL580 Gen7 , 4x CPU , 16 GB ECC Ram, 1 TB SAS Installation von - Windows 8 Server - ...

Windows Server
GPO verschieben von Benutzern
gelöst AnGi1964Vor 1 TagFrageWindows Server10 Kommentare

Hallo in die Runde! Ich habe als Neuling hier gleich 2 Fragen und hoffe, das mir geholfen werden kann. 1. Ich habe bei einem ...

Firewall
Kennt jemand Forcepoint Firewalls oder setzt diese sogar ein?
ZeroTrustVor 1 TagFrageFirewall2 Kommentare

Ich wäre interessiert an User Meinungen über diese Firewall Lösungen. Kenne ich absolut nicht und habe auch noch nie davon gehört, geschweige jemals damit ...

Outlook & Mail
Outlook 2019 stürzt bei Erhalt von Besprechungsanfrage ab
gelöst PhiltaerVor 1 TagFrageOutlook & Mail17 Kommentare

Hallo, ich habe ein ganz merkwürdiges Problem. Outlook 2019 stürzt beim Erhalt von Emails die Besprechungsanfragen enthält ab. Das Programm friert ein mit "Reagiert ...

Netzwerke
Windows 10 - Netzwerk Speedlimit?
alwayshungryVor 14 StundenFrageNetzwerke11 Kommentare

Hallo, ich bin noch neu hier und hoffe, dass ihr mir helfen könnt. Gibt es eine Limitierung für Windows 10 bei der Netzwerkgeschwindigkeit? Leider ...

Router & Routing
Router Firewall gesucht
HamBamVor 1 TagFrageRouter & Routing9 Kommentare

Hallo zusammen, ich schaue mich für die Firma aktuell nach neuen Routern für unsere Außenstellen um. Aktuell haben wir da diese silbernen, bei Administratoren ...

Windows Server
Server 2019 - VM (DC) hängt sporadisch
zer0g2224Vor 1 TagFrageWindows Server13 Kommentare

Hallo liebe Kolleginnen und Kollegen, ich habe mal wieder eine Frage zu einem Problem: Eine VM (DC) bleibt im Betrieb sporadisch "hängen". Das äußert ...

Windows 10
Inaccessible boot device bei Windows 10
jensgebkenVor 21 StundenFrageWindows 1013 Kommentare

Hallo Gemeinschaft, habe Probleme bei einem Windows 10 Pro PC beim Start - blue screen mit inaccessible boot device habe folgendes probiert - automatische ...