Update von PHP 7.2.16 auf 7.4 (CentOS 7)

Mitglied: CharlyXL

CharlyXL (Level 1) - Jetzt verbinden

25.09.2020 um 21:53 Uhr, 460 Aufrufe, 6 Kommentare

Hallo zusammen,

ich habe auf meinem Server versucht PHP zu aktualisieren nach der folgenden Anleitung.
https://www.linuxtechi.com/install-php-7-centos-7-rhel-7-server/
Alles läuft problemlos durch aber bei der Versionsprüfung bleibt es bei der 7.2.16. Auch wenn ich phpinfo() starte bekomme ich immer wieder die alte Version.
Hat jemand eine Idee was ich noch machen kann?
Danke für eure Hilfe.

VG Charly
Mitglied: certifiedit.net
25.09.2020, aktualisiert um 23:28 Uhr
Hallo Charly,

du musst auch deine entsprechenden Sites aktualisieren, aber wenn man dir das sagen muss solltest du nochmals zwei Schritte zurückgehen, da das Thema "Sicherheit" wohl dann ebenfalls sehr oberflächlich behandelt wurde.

Grüße,

Christian
Bitte warten ..
Mitglied: ChriBo
26.09.2020 um 14:16 Uhr
Hi,
die Anleitung beschreibt nicht das Upgrade, sondern die Installation von PHP.
Du hast wahrscheinlich sowohl 7.2.16 ud 7.4 installiert.
Mach mal z.B. folgende Schritte:
yum list php; zeigt dir die installierten Versionen an
yum search php; zeigt dir ua. die verfügbaren Versionen an; ggf. übersichtlicher: yum search php-common.
yum remove php; damit deinstallierst du alles an php
yum-config-manager --enable remi-php74; nimm Version 7.4 zur Installation
yum install php php-common php-opcache php-mcrypt php-cli php-gd php-curl php-mysql -y ; aus der Anleitung
php -v : zeige installierte Version.

CH
Bitte warten ..
Mitglied: CharlyXL
26.09.2020 um 22:19 Uhr
Hallo Christian,
das ist eine vorkonfiguierte Maschine von Ionos.
Kannst Du mir bitte noch ein paar Schlagworte geben die mir zur Lösung helfen?
Danke.
VG Charly
Bitte warten ..
Mitglied: CharlyXL
26.09.2020 um 22:23 Uhr
Hallo CH

Du hast wahrscheinlich sowohl 7.2.16 ud 7.4 installiert.
Das kann gut sein.
Mach mal z.B. folgende Schritte:
yum list php; zeigt dir die installierten Versionen an
yum list php
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
    • base: mirror.eu.oneandone.net
    • centos-sclo-rh: mirror.eu.oneandone.net
    • centos-sclo-sclo: mirror2.hs-esslingen.de
    • epel: ftp.uni-stuttgart.de
    • extras: mirror2.hs-esslingen.de
    • remi-php74: mirror.23media.com
    • remi-safe: mirror.23media.com
    • updates: ftp.rz.uni-frankfurt.de
    • webtatic: uk.repo.webtatic.com
Installed Packages
php.x86_64 7.4.10-1.el7.remi @remi-php74

yum search php; zeigt dir ua. die verfügbaren Versionen an; ggf. übersichtlicher: yum search php-common.
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
    • base: mirror.eu.oneandone.net
    • centos-sclo-rh: mirror.eu.oneandone.net
    • centos-sclo-sclo: mirror2.hs-esslingen.de
    • epel: ftp.uni-stuttgart.de
    • extras: mirror2.hs-esslingen.de
    • remi-php74: mirror.23media.com
    • remi-safe: mirror.23media.com
    • updates: ftp.rz.uni-frankfurt.de
    • webtatic: uk.repo.webtatic.com
N/S matched: php-common
php-common.x86_64 : Common files for PHP
php54-php-common.x86_64 : Common files for PHP
php55-php-common.x86_64 : Common files for PHP
php56-php-common.x86_64 : Common files for PHP
php70-php-common.x86_64 : Common files for PHP
php71-php-common.x86_64 : Common files for PHP
php72-php-common.x86_64 : Common files for PHP
php73-php-common.x86_64 : Common files for PHP
php74-php-common.x86_64 : Common files for PHP
php80-php-common.x86_64 : Common files for PHP
rh-php70-php-common.x86_64 : Common files for PHP
rh-php71-php-common.x86_64 : Common files for PHP
rh-php72-php-common.x86_64 : Common files for PHP
rh-php73-php-common.x86_64 : Common files for PHP

Name and summary matches only, use "search all" for everything.
yum remove php; damit deinstallierst du alles an php
Kannst Du bitte noch vorher die obrigen Ausgaben kommentieren ehe ich was weglösche?!
yum-config-manager --enable remi-php74; nimm Version 7.4 zur Installation
Den Befehl habe ich auch schon versucht. Leider ohne Erfolg

Danke für Deine Hilfe.

VG Charly
Bitte warten ..
Mitglied: certifiedit.net
26.09.2020 um 23:36 Uhr
Wie gesagt die sie config. Aber wenn die vorkonfiguriert ist solltest du über die config GUI auch die PHP Version setzen können.
Bitte warten ..
Mitglied: ChriBo
27.09.2020 um 10:06 Uhr
Hallo,
du hast php in Version 7.4 installiert, alles OK.
Aber: diese php Installation hat nichts mit der Apache integration zu tun.
sie z.B. hier.
ggf. mußt du och Pfade und/oder Symlinks anpassen.
Was ist/war auf dem Server von Ionos schon vorkonfiguriert ?
Was läßt sich über die Ionos GUI einstellen ?
-
BTW: Zu deine Antworten und Fragen von dir wiill ich jetzt nicht konkret antworten, außer: setz dich mit CentOS und yum auseinander.

CH
Bitte warten ..
Heiß diskutierte Inhalte
TK-Netze & Geräte
Störung Fax2Mail bei NFON am 24.10.20? Kein Mailversand von NFON möglich?
gelöst StefanKittelFrageTK-Netze & Geräte26 Kommentare

Hallo, scheinbar gibt es eine Störung bei NFONs Fax2Mail am heutigen Tag 24.10.20. Man kann Faxe an schicken und ...

Windows Server
Veeam - DCs restore - 0xc00002e2
gelöst Freak-On-SiliconFrageWindows Server22 Kommentare

Servus; Ich hab hier zwei Server 2012R2 DCs auf jeweils einem Hyper-V sitzen. Gesichert wird mit Veeam B&R. JA, ...

Voice over IP
Brother-Fax an Speedport Hybrid funktioniert nicht
kman123FrageVoice over IP14 Kommentare

Hallo liebes Forum, ich bin neu hier und hätte eine kleine Frage, da ich einfach nicht weiter komme. Sorry ...

Router & Routing
VPN Performance durch Mikrotik erhöhen
JseidiFrageRouter & Routing12 Kommentare

Hallo zusammen, ich habe Stand heute zwei Standort die ich per Site-to-Site VPN über zwei Fritzboxen verbinde. Da hier ...

Datenbanken
MSsql Express - Daten befüllen
istbananeFrageDatenbanken8 Kommentare

Hallo zusammen, ich habe bisher nicht viel mit Datenbanken zu tun gehabt. Nun gibt es ein paar Access Datenbanken ...

Microsoft
Sharepoint Website für externe User
RoadmaxFrageMicrosoft8 Kommentare

Hallo Zusammen, ich möchte eine komplette Website für externe User (Gäste) freigeben, in der sie nur "lesen" können. Dabei ...

Ähnliche Inhalte
RedHat, CentOS, Fedora
CentOS 7 Festplattenaufteilung
gelöst DanielG1974FrageRedHat, CentOS, Fedora2 Kommentare

Hallo. Mal kein Problem, sondern eher eine Meinungsumfrage an die Linux-Profis. Ich möchte unsere Linux-Installationen (CentOS) standardisieren. Dazu hatte ...

RedHat, CentOS, Fedora
Aktualisierung von CentOS 7
gelöst honeybeeFrageRedHat, CentOS, Fedora2 Kommentare

Hallo, wie kann ich bei CentOS 7 die Sicherheitsupdates installieren? Habe mit diesem Command versucht: aber das wurde mit ...

RedHat, CentOS, Fedora
XRDP unter CentOS 7
gelöst honeybeeFrageRedHat, CentOS, Fedora2 Kommentare

Hallo, habe zwei Fragen: Wenn ich mich remote via xrdp anmelde, ist die Systemsprache auf Englisch eingestellt, nicht auf ...

RedHat, CentOS, Fedora

CentOS 7: Legitimierung ausschalten - wie?

gelöst honeybeeFrageRedHat, CentOS, Fedora2 Kommentare

Hallo, bei einem normalen Benutzer ohne Adminrechte kommt immer diese Meldung. Kann man das irgendwie ausschalten, ohne was an ...

RedHat, CentOS, Fedora

CentOS 7: Fehlende Pakete nachinstallieren

gelöst honeybeeFrageRedHat, CentOS, Fedora6 Kommentare

Hallo, habe folgende Meldung erhalten: OpenSSL ist bereits installiert. Wie kann ich die fehlenden Pakete nachinstallieren?

Virtualisierung

Docker: php:7.4-apache lässt sich mit Dockerfile nicht modifizieren

gelöst peterlaFrageVirtualisierung6 Kommentare

Hallo zusammen! Ich experimentiere gerade ein bisschen mit Docker herum. Folgendes Setup: Es läuft das php:7.4-apache-Image. Dieses möchte ich ...

Berechtigungs- und IdentitätsmanagementBerechtigungs- und IdentitätsmanagementWebdienste und -serverWebdienste und -serverDatenbankenDatenbankenMonitoring & SupportMonitoring & SupportHybrid CloudHybrid CloudSmall Business ITSmall Business IT