Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

utf-8 und backup-probleme

Mitglied: francesco

francesco (Level 1) - Jetzt verbinden

11.03.2006, aktualisiert 19:58 Uhr, 3566 Aufrufe, 1 Kommentar

utf-8 konvertierung klappt nicht so ganz und backup mit mysqladmin wird nicht ausgeführt

Hallo @ all,

ich habe gleich 2 Probleme.

1tes:

in meinem Umfragesystem (geschrieben in HTML/PHP und läuft auf einem WIN2k3 Server mit apache 2 Mysql als Datenbank und PHP) sind momentan nur 2 Sprachen DE und RU verfügbar, weitere Sprachen sollen hinzugefügt werden. Dafür gibts eine Language Datei,die geladen wird, wo alle Texte vorhanden sind (übliche Vorgehensweise).

So mit der Deutschen Sprachdatei gibts keine Probleme.
Mit der Russischen da haperts etwas. Bearbeite die Sprachdateien mit SCITE und notepad ++. Bei beiden kann ich UTF-8 einstellen (IST AUCH EINGESTELLT). Die Datei die nun online ist geht 1a. Nun habe ich 2 neue Seiten hinzugefügt und die Sprachdatei erweitertert um 10 Zeilen und diese als UTF-8 gespeichert.
Nun kriege ich eine Warnung und kriege die nicht weg:

Warning: Cannot modify header information - headers already sent by (output started at C:\Programme\Apache\Apache2\htdocs\poll\languages\ru\main.inc.php:1) in C:\Programme\Apache\Apache2\htdocs\poll\poll\0.php on line 15

Lasse ich die 10 Zeilen raus funktioniert alles bis auf die Fehlenden Variablen.

Kann mir da jemand weiterhelfen.

2tes

auf dem Server kann ich in MysqlAdmin einstellen, dass die Datenbank täglich gesichert wird. Es wird auch richtig eingetragen und im Schedule steht auch der JOP drinne, aber der wird nicht ausgefürt. Im Anwendungsfehlerprotokoll kriege ich diese Meldung

Cannot connect to MySQL Server. Access denied for user 'root'@'localhost' (using password: NO) (Error Number 1045)

Aber Username und password in mysqladmin wurden vergeben. Oder hab ich da was Falsch verstanden und es falsch konfiguriert??

Kann mir da jemand helfen??

Danke

Gruß Francesco
Mitglied: stpe
11.03.2006 um 19:58 Uhr
Zu Deiner ersten Frage kann ich nicht wirklich etwas sagen. Durchsuche die 10 Zeilen noch einmal genau nach Unterschieden zu den anderen. Füge der Datei einmal eine nach der anderen Zeile hinzu und teste jeweils Dein Script. So kannst Du die Zeile ermitteln, die die Schwierigkeiten verursacht.

Zur Sicherung: Um das Passwort des Users an mysqladmin zu übergeben, musst Du den Befehl in folgender Form aufrufen:

mysqladmin -u [benutzer] -p[passwort] [auszufuehrender befehl]

Wichtig dabei ist, dass das Passwort ohne Leerzeichen direkt an "-p" angehängt wird.

Gruss
Stefan
Bitte warten ..
Ähnliche Inhalte
Ubuntu

Dateiinhalt in UTF-8 ist nicht gleich UTF-8?

gelöst Frage von lexa-lexaUbuntu6 Kommentare

Hi Linux und PHP Gurus, ich habe ein Problem mit dem Zeichensatz *in* einer Datei und komme nicht weiter: ...

Internet

FTP Umwandlung UTF-8 in ANSI

gelöst Frage von Xaero1982Internet12 Kommentare

Moin Zusammen, gibt es eine Möglichkeit das CSV Dateien direkt vom FTP Server oder beim Upload vom UTF-8 Format ...

Python

Python mal utf-8 mal nicht

gelöst Frage von peterpaPython1 Kommentar

Hallo, ich versuche gerade ein Programm zu schreiben, in Python, welches eine große HTML Datei in mehrere kleine aufspaltet. ...

Blogs

Immer wiederkehrende PHP Fehlermeldung bei Wordpress UTF-8 - ASCII

gelöst Frage von vcdweltBlogs11 Kommentare

Hi, seit einiger Zeit wird mein error_log meines Wordpress Blogs mit immer der gleichen Fehlermeldung überschwemmt. 14-Dec-2017 08:18:05 UTC ...

Neue Wissensbeiträge
iOS
WatchChat für Whatsapp
Tipp von Criemo vor 19 StundeniOS

Ziemlich coole App für WhatsApp User in Verbindung mit der Apple Watch. Gibts für iOS sowohl als auch für ...

iOS
IOS hat nen Cursor !!!
Tipp von Criemo vor 1 TagiOS5 Kommentare

Nette Funktion im iOS. iPhone-Mauszeiger aktivieren „Nichts ist nerviger, als bei einem Tippfehler zu versuchen, den iOS-Cursor an die ...

Off Topic
Avengers 4: Endgame - Erster Trailer
Information von Frank vor 3 TagenOff Topic2 Kommentare

Ich weiß es ist Off Topic, aber ich freue mich auf diesen Film und vielleicht geht es anderen hier ...

Webbrowser
Microsoft bestätigt Edge mit Chromium-Kern
Information von Frank vor 3 TagenWebbrowser5 Kommentare

Microsoft hat nun in seinem Blog bestätigt, dass die nächste Edge Version kein EdgeHTML mehr für die Darstellung benutzen ...

Heiß diskutierte Inhalte
Exchange Server
Exchange Server 2010: Keine Eingehenden E-MAils
gelöst Frage von gabeBUExchange Server17 Kommentare

Hallo Zusammen Ich habe das kurzen auf dem Exchange 2010 Server das Problem, dass ich keine externen E-Mails mehr ...

Server
Server in zwei verschiedene Netzwerke einbinden
gelöst Frage von BennyFServer13 Kommentare

Hallo zusammen, bei uns im Haus sind im Erdgeschoss die Geschäftsräume und ab dem 1. Stock sind unsere privaten ...

Windows Netzwerk
Kerio. Kann keine Mails empfangen aber senden. Wer ist schuld. Kerio oder Windows domäne?
Frage von frosch2Windows Netzwerk13 Kommentare

Hallo, es existiert ein Problem bei uns mit dem mailen. Alle bestehenden Nutzer können mailen. Raus wie rein. Neuen ...

Netzwerkmanagement
Ticketsystem für eine Kommune gesucht
gelöst Frage von akovisNetzwerkmanagement11 Kommentare

Ich suche aktuell ein Ticketsystem für eine Kleinstadt von 13000 Einwaohnern. Das System soll alle Anfragen aus verschiedenen Kanälen ...