Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst VBScript Fehler mit If OK dann beenden Else Installation starten

Mitglied: MajceMihajlovic

MajceMihajlovic (Level 1) - Jetzt verbinden

15.08.2011, aktualisiert 13:44 Uhr, 5085 Aufrufe, 15 Kommentare

Probleme mit der Abfrage für eine Installation.

Hallo Liebes Forum

Ich habe folgendes Script:
01.
Dim oFSO, oApp, oFolderCopy, oShell
02.
Dim strFontsPath, strScriptPath
03.
 
04.
Set oFSO = CreateObject("Scripting.FileSystemObject")
05.
Set oShell = CreateObject("WScript.Shell")
06.
Set oApp = CreateObject("Shell.Application")
07.
 
08.
strScriptPath = WScript.ScriptFullName
09.
strScriptPath = left(strScriptPath,instrrev(strScriptPath,"\"))
10.

11.
strFontsPath = oShell.ExpandEnvironmentStrings("%WINDIR%") & "\Fonts"
12.
 
13.
Set oFolderCopy = oApp.Namespace(strScriptPath & "FontsToInstall")
14.
 
15.
For Each oFont In oFolderCopy.Items
16.

17.
IF oFSO.FileExists(strFontsPath & "\" & oFont.Name) Then End If
18.
Else
19.
  oApp.Namespace(strFontsPath).CopyHere oFont
20.
End If
21.

22.
Next
23.
 
24.
' Cleanup Objects
25.
Set oFolderCopy = Nothing
26.
Set oApp = Nothing
27.
Set oShell = Nothing
28.

29.
Mein Problem liegt beim Punkt: 
30.

31.
IF oFSO.FileExists(strFontsPath & "\" & oFont.Name) Then End If
32.
Else
33.
  oApp.Namespace(strFontsPath).CopyHere oFont
34.
End If
35.

36.
Egal was ich mache, es kommt immer eine Fehlermeldung. 
37.

38.
Und wenn ich es nicht beende, dann wird der User 500x gefragt, ob er die Schriftart ersetzen will, weil es diese schon hat. 
39.

40.
Ich bitte um Hilfe, da ich mich mit VB überhaupt nicht auskenne. 
41.

42.
Es sollte so aussehen:
43.

44.
IF Schriftart vorhanden THEN beende die Abfrage
45.
ELSE
46.
installiere die Schriftart. 
47.
END If
Danke danke danke allen.

Gruss Majce
Mitglied: robob
15.08.2011 um 12:34 Uhr
Hallo Majce,

versuche doch bitte mal folgende Stelle abzuändern:

01.
IF oFSO.FileExists(strFontsPath & "\" & oFont.Name) Then End If
02.
 Else
03.
 oApp.Namespace(strFontsPath).CopyHere oFont
04.
End If
in:
01.
IF NOT oFSO.FileExists(strFontsPath & "\" & oFont.Name) Then
02.
 oApp.Namespace(strFontsPath).CopyHere oFont
03.
End If
Gruss,
Robob.
Bitte warten ..
Mitglied: MajceMihajlovic
15.08.2011 um 12:38 Uhr
Hallo Robob

Dann bekomme ich für jede Schriftart (und es sind über 500x) die Meldung:

Die Schriftart "BLABLABLA" ist bereits installiert.
Möchten Sie sie ersetzen?

Deshalb wollte ich auch ein If YES vor dran haben, damit diese Meldung nicht kommt.

Gruss Majce
Bitte warten ..
Mitglied: robob
15.08.2011 um 12:46 Uhr
Das verstehe ich jetzt nicht, denn die Zeile würde ja durch das "NOT" eigentlich bedeuten, wenn die Datei NICHT vorhanden ist, dann kopiere die Schriftart ansonsten tue nichts innerhalb der IF-Schleife...
Ich teste das jetzt kurz mal an meinem Notebook und melde mich dann wieder, wenn hoffentlich nichts dazwischen kommt...

Gruss,
Robob.
Bitte warten ..
Mitglied: robob
15.08.2011 um 13:14 Uhr
Hallo Majic,

also bei mir funktioniert der geänderte Code ohne Probleme, das mit dem Kopierern wird nur ausgeführt, wenn die Datei wirklich nicht existiert und ich erhalte keine Fehlermeldungen, dass entprechende Dateien schon existieren würden.
Ich habe das VBScript in ein Unterverzeichnis kopiert, dort ein Unterverzeichnis namens "FontsToInstall" erstellt und ein paar Fonts reinkopiert, sowohl welche die auf dem System existierten und welche die nicht vorhanden sind.
Das Skript hat wirklich nur die nicht existierenden Schriftartendateien kopiert und für den Rest keine Fehlermeldungen angezeigt, also so wie es eigentlich sein sollte...

Gruss,
Robob.
01.
Dim oFSO, oApp, oFolderCopy, oShell
02.
Dim strFontsPath, strScriptPath
03.

04.
Set oFSO = CreateObject("Scripting.FileSystemObject")
05.
Set oShell = CreateObject("WScript.Shell")
06.
Set oApp = CreateObject("Shell.Application")
07.

08.
strScriptPath = WScript.ScriptFullName
09.
strScriptPath = left(strScriptPath,instrrev(strScriptPath,"\"))
10.
 
11.
strFontsPath = oShell.ExpandEnvironmentStrings("%WINDIR%") & "\Fonts"
12.

13.
Set oFolderCopy = oApp.Namespace(strScriptPath & "FontsToInstall")
14.

15.
For Each oFont In oFolderCopy.Items
16.
 
17.
IF NOT oFSO.FileExists(strFontsPath & "\" & oFont.Name) Then
18.
	oApp.Namespace(strFontsPath).CopyHere oFont
19.
End If
20.
 
21.
Next
22.

23.
 ' Cleanup Objects
24.
 Set oFolderCopy = Nothing
25.
 Set oApp = Nothing
26.
 Set oShell = Nothing
Bitte warten ..
Mitglied: MajceMihajlovic
15.08.2011 um 13:17 Uhr
Hallo Robob

Und wenn du es jetzt wieder ausführst, kommt keine Meldung?

Danke für die Informationen.

Ich habe es eben auf 3 verschiedenen Clients probiert, und trotzdem kommt bei jedem die gleiche Meldung.

Aber ich probiere es gerne noch einmal.

Danke dir viel viel mal für deine Hilfe.
Bitte warten ..
Mitglied: robob
15.08.2011 um 13:24 Uhr
Hallo Majce,

nein, ich habe das Skript 3x hintereinander gestartet, beim ersten Mal wurden die nicht vorhandenen Schriftarten in den Windows-Font-Ordner kopiert und es wurden, wie gesagt für die restlichen Schriftarten keine Fehlermeldungen angezeigt und beim 2. und 3. Durchlauf hat das Skript quasi nichts gemacht, es erschienen ebenso keine Fehlermeldungen.
Ich habe das Ganze auf meinem Windows 7 x64 Ultimate-System getestet.

Gruss,
Robert.
Bitte warten ..
Mitglied: MajceMihajlovic
15.08.2011 um 13:31 Uhr
Hallo Robob

Ja, da ist mir doch noch was eingefallen.

Die Fonts, eben so wie das Script, befinden sich auf einen Netzlaufwerk.

Bei mir lokal funktioniert es auch ohne Probleme.

Habe es jetzt eben auch getestet.

Eventuell liegt es an dem. Doch wieso, keine Ahnung.

Vielleicht bekomme ich es noch ohne Ahnung zustande

Danke dir für deine Bemühungen.

Gruss Majce
Bitte warten ..
Mitglied: robob
15.08.2011 um 13:45 Uhr
Jetzt habe ich ein bisschen weiter experimentiert und bin auch auf eine Schriftart gestossen, bei der das Problem bei mir auch aufgetreten ist, dass auch bei den weiteren Skriptaufrufen ohne neu hinzugekommene Schriftarten immer wieder nach dem Überschreiben der Datei gefragt wurde: Die Schriftart hieß "Victor", bei der der urpsüngliche Dateiname im FontsToInstall-Ordner "victor__.ttf" war und die kopierte Version im Windows-Fonts-Ordner hatte komischerweise plötzlich nur einen Unterstrich, also "victor_.ttf".

Somit handelt es sich im Skript-Aufruf nicht um den gleichen Name und die IF-Anweisung veranlasst eine Kopie der Datei.
Während der Kopie wird aber wohl durch den Windows-Fonts-Ordner der Name der Schriftart ausgelesen, die vom Dateinamen unterschiedlich sein kann, wie man sieht und somit bemängelt, dass es diese Schriftart wohl schon geben würde.

Aber warum die Kopie plötzlich einen Unterstrich beim Dateinamen weglässt ist schon komisch, ich hätte es noch eingesehen, wenn alle Unterstriche entfernt worden wären und der kopierte Dateinamen genau dem in Windows angezeigten Schriftartnamen (ohne Unterstrich) entsprechen würde...

So ist das Ganze jetzt natürlich schwierig...

Gruss,
Robert.
Bitte warten ..
Mitglied: robob
15.08.2011 um 14:07 Uhr
Hallo Majce,

also auf Netzwerklaufwerken habe ich mit dem Skript keine anderen Probleme als bei lokaler Ausführung (egal ob über gemappten Laufwerksbuchstaben oder UNC-Pfad oder ob Schreib- oder nur Leserechte auf der Freigabe).
Mit den Unterstrichen am Ende von Dateinamen wird bei diesem Kopiervorgang in den Font-Ordner komischerweise immer einer entfernt:

victor__.ttf wird zu victor_.ttf
victor_.ttf wird zu victor.ttf
und bei victor.ttf passt dann auch das Skript wieder, da beide Dateinamen gleich sind...

Dann hoffe ich doch mal, dass Du es noch hinbekommst oder sonst noch jemand eine Idee haben wird.

Gruss,
Robob.
Bitte warten ..
Mitglied: MajceMihajlovic
15.08.2011 um 14:49 Uhr
Hallo Robob

Und ich habe gerade gemerkt, dass er zwar nachschauen geht, aber die Schriftart nicht finden kann, da diese in einen Unterordner gesetzt worden ist, was das ganze noch schwieriger macht.

Jä nu, dann müssen es halt alle User einmal Manuel machen und gut ist

Ich wollte es eben als Startscript machen, und einfach in den Ordner neue Schriftarten einfügen und bei jedem Anmelden schnell eine Prüfung und fertig, doch Windows lässt dies mal wieder nicht zu

Also noch einen schönen Restmontag

Gruss Majce
Bitte warten ..
Mitglied: robob
15.08.2011 um 16:42 Uhr
Hallo Majce,

habe ich das richtig verstanden, dass die Schriftarten, die in den Windows-Fonts-Ordner kopiert wurden, sich dann im Windows-Fonts-Ordner nochmals in einem zusätzlichen Unterordner befinden?
Oder wie ist das gemeint mit dem zusätzlichen Unterordner?

Gruss,
Robobo.
Bitte warten ..
Mitglied: MajceMihajlovic
15.08.2011 um 16:49 Uhr
Hallo Robobo

Genau, Richtig Verstanden

Ich habe folgende Datei im FontstoInstall:
Helvetica Neue LT Com 77 Bold Condensed
Helvetica Neue LT Com 77 Bold Condensed Oblique

Im C:\Windows\Font wird dann ein "Ordner" daraus gemacht mit den beiden Schriften drinnen, also so:

Helvetica Neue LT Com 77

Alles auser die Grösse wird dann weggelöscht und im Ordner angezeigt.

Ist leider neu bei Windows 7.

Und abstellen kann man es auch nicht, habe es gesucht.

Ebenso wenig kann ich die ganzen Ordner exportieren um sie danach irgendwo anders wieder zu importieren, die Schriften kommen nur getrennt zum Vorschein, so wie wieder im FontsToInstall Ordner.

Also schon fast unmöglich.

Gruss Majce
Bitte warten ..
Mitglied: bastla
15.08.2011 um 20:29 Uhr
Hallo MajceMihajlovic und robob!

Vielleicht geht es mit dem hier vorgestellten Script besser ...
BTW:
01.
strScriptPath = WScript.ScriptFullName 
02.
strScriptPath = left(strScriptPath,instrrev(strScriptPath,"\")) 
ließe sich etwas eleganter so lösen:
strScriptPath = Replace(WScript.ScriptFullName, WScript.ScriptName, "")
Noch eine Anmerkung: In VBS sind Variablendeklarationen ohne
Option Explicit
ziemlich witzlos ...

Grüße
bastla
Bitte warten ..
Mitglied: MajceMihajlovic
16.08.2011 um 11:12 Uhr
Hallo Bastla

Danke für den Link, jedoch für 500 Schriften jede einzeln einzutragen ist nicht wirklich sinn und zweck der Automatisierung, oder?

Gruss Majce
Bitte warten ..
Mitglied: bastla
16.08.2011 um 11:34 Uhr
Hallo MajceMihajlovic!
jedoch für 500 Schriften jede einzeln einzutragen
... wäre mir nie eingefallen - da nähme ich dann schon eher eine Schleife ...

Eigentlich ging es darum, eine mit W7-kompatible Methode für die Installation zu finden - mit der beschriebenen Vorgangsweise wird der Kontextmenü-Eintrag "Installieren" (BTW: wäre natürlich an die verwendete Sprache anzupassen) verwendet.

Die Prüfung auf Vorhandensein der Schritart (und dann das Unterlassen eines Installationsversuches) müsste natürlich weiterhin vorweg erfolgen ...

Grüße
bastla
Bitte warten ..
Ähnliche Inhalte
Windows Tools
DotNet Installation schlägt fehl
gelöst Frage von emeriksWindows Tools1 Kommentar

Hi, Windows Server 2008 R2 SP1 Ich will/muss .Net auf min. 4.5 aktualisieren, weil eine Anwendung das erfordert. Egal, ...

Windows Server
RDS Installation schlägt fehl
gelöst Frage von mhard666Windows Server10 Kommentare

Hallo allerseits, ich schlage mich seit geraumer Zeit mit folgendem Problem herum: Ich versuche unter Server 2012R2 eine RDS-Umgebung ...

Windows Server

TeamViewer 11 MSI Installation schlägt fehl

Frage von Ghost108Windows Server13 Kommentare

Hallo zusammen, versuche gerade krampfhaft den Teamviewer 11 zu deinstallieren. Erhalte daraufhin folgende Fehlermeldung: Auch die Neuinstallation von Teamviewer ...

Windows 10

Installation - CreateProcess schlug Fehl: Code 2

gelöst Frage von KLeinstein.tmWindows 103 Kommentare

Hallo alle Zusammen, ich habe momentan ein Problem beim Installieren eines Setups. Mein System ist Windows 10. (Notebook) Wenn ...

Neue Wissensbeiträge
Humor (lol)
Und wie seid Ihr gegen Cyberattacken gewappnet?
Information von DerWoWusste vor 19 StundenHumor (lol)4 Kommentare

aber wo ist der Hammer? :-)

Sicherheit
Ein weiterer Microsoft-Stirnklatscher
Information von DerWoWusste vor 1 TagSicherheit7 Kommentare

Habe gerade einen Artikel zu einem Sicherheitsproblem gefunden, welches mir zu seiner Zeit (gepatcht 2015) wohl durchgerutscht ist. Es ...

Windows 10
Upgradepfade Windows 10 LTSC
Erfahrungsbericht von Datenreise vor 1 TagWindows 10

Nur eine kurze Info, für diejenigen, die es interessiert, da es hierzu im Netz aus nachvollziehbaren Gründen nicht allzu ...

Administrator.de Feedback
Wartungsarbeiten heute Nacht (Update)
Information von Frank vor 1 TagAdministrator.de Feedback10 Kommentare

Hallo User, durch Umbauarbeiten in unserem Rechenzentrum (am Backbone) kann es heute Nacht (14-15.01.2019) zu kurzen Ausfällen unserer Seite ...

Heiß diskutierte Inhalte
Windows 10
Windows 10 - kein Boot mehr nach Domänenaustritt
gelöst Frage von Ghost108Windows 1025 Kommentare

Hallo zusammen, habe hier eine Windows 10 Maschine, die ich gerne aus der Domäne austreten lassen möchte. Nach Austritt ...

Windows 10
Windows 10 1803 - nicht identifiziertes Netzwerk - kein Login an Domäne möglich
Frage von Tomy389Windows 1021 Kommentare

Hallo Zusammen, ich hoffe zu dem Thema gibt es nicht schon einen Thread aber ich sollte eigentlich schon alles ...

Exchange Server
Microsoft Exchange Ser ver 2016 CU 8 auf den neuesten Stand bringen
gelöst Frage von Hendrik2586Exchange Server20 Kommentare

Hallo an euch alle. :) Kurze Frage. Ich habe hier einen Exchange Server wie o.g. Problem ist das wir ...

Microsoft
SFirm 4.0 auf Terminalserver startet für jeden angemeldeten Benutzer diverse Dienste
Frage von Frank84Microsoft18 Kommentare

Hallo zusammen, wir verwenden Sfirm 4.0 auf einem Terminalserver (der SQL Server ist auf einem separaten Server), das Problem ...