Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

VLAN über Switche bis zur pfSense im Hyper-V 2012 R2

Mitglied: unqiue24

unqiue24 (Level 1) - Jetzt verbinden

12.03.2019 um 11:17 Uhr, 235 Aufrufe, 9 Kommentare

Hallo,

ich bekomme leider eine VLAn Konfiguration in meine pfSense nicht rein.

Mein Aufbau:

2 Accesspoints am:
SWITCH 1: Port 3,4

Switch 1 hängt an einem Switch 2:
SWITCH 1, Port 8 auf SWITCH 2, Port 10

Switch 2 hängt an Switch 3:
SWITCH 2, Port 8 auf SWITCH 3, Port 2

Am Switch 3 hängt dann der Hyper V mit einer LAN Netzwerkkarte:
SWITCH 3, Port 18 auf Hyper-V LAN 1

Auf der pfSense habe ich auf der LAN1 ein VLAN eingerichtet: 200

Die Strecke ist also:

AP1 => SW1:3 / SW1:8 => SW2:10 / SW2:8 => SW3:2 / SW3:18 => LAN1

Switch 1: VLAN 200: untagged 1-7, tagged 8
Switch 2: VLAN 200: exclude 1-7,9,11-26, tagged 8,10
Switch 3: VLAN 200: exclude 1,3-7,9-17,19-26, tagged 2,8,18

Nun bekomme ich aber von der pfSense keine IP Adresse zugewiesen. DHCP Server auf der pfSense natürlich aktiviert.

  • Nun könnte ich beim VLAN etwas falsch gemacht haben
  • Ich könnte beim Hyper-V etwas falsch gemacht haben
  • Ich könnte bei der pfSense etwas falsch gemacht haben

Eine statische IP im WLAN gesetzt, aber die IP der VLAN Schnittstelle ist nicht erreichbar.

Denk es liegt an der VLAN Konfiguration. Wie sucht man da am besten? Oder blockt der Hyper-V 2012 R2
Mitglied: ashnod
12.03.2019, aktualisiert um 12:01 Uhr
Moin ...


Zitat von unqiue24:
Am Switch 3 hängt dann der Hyper V mit einer LAN Netzwerkkarte:
SWITCH 3, Port 18 auf Hyper-V LAN 1

Auf der pfSense habe ich auf der LAN1 ein VLAN eingerichtet: 200

Beschreibe doch den Teil mal genauer .....
du hast also LAN1 und VLAN200 an einem virtuellen Port der pfSense, kennt der auf dem HyperV konfigurierte Anschluss dieses VLAN?

VG
Bitte warten ..
Mitglied: unqiue24
12.03.2019, aktualisiert um 12:11 Uhr
Ich habe am Hyper-V nichts konfiguriert. Ich habe nur gesehen das ich bei einer Schnittstelle ein VLAN zuweisen kann ... aber auf der LAN Schnittstelle kommen ja dann mehrere VLAN´s an.

Die pfSense soll 4 unterschiedliche IP Bereich mit je einem eigenen VLAN abdecken. Zum testen halt nur mal VLAN 200.

Kann sein das ich pro VLAN im Hyper-V eine Netzwerkschnittstelle erstellen muss und in pfSense dann nimmer mit VLAN´s sondern mit den virtuellen Schnittstellen vom Hyper-V arbeiten muss?
Bitte warten ..
Mitglied: ashnod
12.03.2019 um 12:25 Uhr
Zitat von unqiue24:
Kann sein das ich pro VLAN im Hyper-V eine Netzwerkschnittstelle erstellen muss und in pfSense dann nimmer mit VLAN´s sondern mit den virtuellen Schnittstellen vom Hyper-V arbeiten muss?

Na zumindest hast du deine Fehlerquelle dann gefunden ....

Du musst in der VM für die pfSense an den Netzschnittstellen die Informationen mitgeben und zusehen das diese auch an der realen Hardware-Netzkarte und der Verbindung zum Switch anliegen.

Aus Sicht der pfSense ist es ohnehin wurscht ob du die 4 Netze via VLAN auf einen Anschluss LAN1 legst oder dafür 4 Netzwerkkarten (LAN2, LAN3, LAN4) anlegst.

Letzteres sehe ich eher als Vorteil ...

VG
Bitte warten ..
Mitglied: aqui
12.03.2019 um 12:35 Uhr
ich bekomme leider eine VLAn Konfiguration in meine pfSense nicht rein.
Das hiesige Tutorial zu dem Thema auf der pfSense hast du genau gelesen und verstanden ??:
https://administrator.de/wissen/vlan-installation-routing-pfsense-mikrot ...
Bitte warten ..
Mitglied: unqiue24
12.03.2019 um 13:18 Uhr
Danke, das kannte ich noch nicht!
Bitte warten ..
Mitglied: unqiue24
12.03.2019 um 14:29 Uhr
Hallo,

ok, ich kann wohl eine physikalische Schnittstelle nur einmal zuweisen per Gui.

Habs nun doch mit Trunk verucht.

Die Schnittstelle der VM auf Trunk gestellt:
Set-VMNetworkAdaptervlan -VMName pfSense-VMNetworkAdapterName "pfSenseVLAN" -Trunk -AllowedVlanIdList "100,200" -NativeVlanId 100

Das wurde übernommen. Aber ich bekomme nach wie vor keine IP zugewiesen.

Hab ich es richtig verstanden:
Den Port, wo der AP angesteckt ist, steht auf Untagged, alle Verbindungen bis zum Hyper-V sind tagged. Auch dort wo der Hyper-V angesteckt ist.

Kann ich irgendwie einfach prüfen, ob das VLAN bis zum Hyper-V korrekt ist?
Bitte warten ..
Mitglied: aqui
12.03.2019, aktualisiert um 19:53 Uhr
Das wurde übernommen. Aber ich bekomme nach wie vor keine IP zugewiesen.
Bedeutet dann das dein Native VLAN 100 ist und das VLAN 200 getaggt auf dem Link übertragen wird.
Soweit so gut.
Bei der pfSense landet das native VLAN (Default VLAN) einen Tagged Uplinks immer auf dem physischen Interface und dessen IP und das Tagged dann auf dem zur ID korrespondierenden Subinterface.
Bei dir terminiert also das VLAN 100 da untagged auf dem Trunk auf dem physischen Interface der pfSense und das VLAN 200 auf dem Subinterface.
Prüfe also das dein VLAN 100 DHCP Server einmal auf dem physischen Interface gebunden ist und der vom VLAN 200 auf dem Subinterface zum physischen Interface !
Hier hast du vermutlich einen Fehler gemacht ?!
Da es nachweislich fehlerfrei funktioniert muss es also ein PEBKAC Problem sein.
Kann ich irgendwie einfach prüfen, ob das VLAN bis zum Hyper-V korrekt ist?
Ja mit einem Wireshark Sniffer.
Der zeigt dir an ob die Pakete richtig getagged werden oder nicht !
Bitte warten ..
Mitglied: unqiue24
14.03.2019 um 14:54 Uhr
Hallo,

danke .. ich habe wohl das Problem gefunden. Der erste Switch ist ein TP-Link 8-fach mit 4x PoE.

Bei dem scheint das Tagging nicht richtig zu klappen. An dem Port wo ich den AP angesteckt hatte, habe ich untagged eingestellt (Später soll ein SSID to VLAN Mapping erfolgen) und dann muss ich wohl auch diesen Port taggen, da ja die Pakete getaggt ankommen, richtig?

Jedenfalls stecke ich den AP an den 2. Switch an einem untagged Port an, klappt alles.

Ich kann leider beim 1. Switch das VLAN 1 nicht abwählen. Vielleicht ist das das Problem.

An sich habe ich das Problem so nun gelöst.

Danke an alle!
Bitte warten ..
Mitglied: aqui
14.03.2019, aktualisiert um 16:09 Uhr
habe ich untagged eingestellt (Später soll ein SSID to VLAN Mapping erfolgen)
Das ist dann auch FALSCH !!
Dieser Port muss in jedem Falle Tagged sein wenn du mit MSSID und VLANs arbeitest.
Siehe auch hier:
https://administrator.de/wissen/vlan-installation-routing-pfsense-mikrot ...
insbesondere hier:
https://administrator.de/wissen/vlan-installation-routing-pfsense-mikrot ...
Dort wird es explizit erklärt und insbesondere darauf hingewiesen das die AP Ports tagged sein müssen.

Ist ja auch logisch, denn wie soll sonst der Switch die VLAN Zuordnung machen bei untagged Paketen ??
Ohne Tag keine VLAN Information...! Kommt man auch selber mit nur etwas Nachdenken drauf
Ich kann leider beim 1. Switch das VLAN 1 nicht abwählen. Vielleicht ist das das Problem.
Nein !! Das ist Unsinn !
Bitte die VLAN "Schnellschulung" mal in Ruhel lesen und verstehen !:

Nur so viel:
An einem Tagged Uplink ist das Default- bzw. Native VLAN immer untagged anliegend.
Das besagt das der Switch ALLE ungetaggten Pakete die ohne eine VLAN ID dort ankommen ins VLAN forwardet.
Das ist die sog. "PVID". Die PVID bestimmt in welches VLAN ungetaggte Pakete an diesem Port gehen.
In der regel ist das das VLAN 1. Siehe auch hier:
https://www.administrator.de/forum/gibt-pvid-vlans-325880.html
Lesen !
Das Management, sprich die Managemen IP aller MSSID fähigen APs ist immer im VLAN 1 wird also untagged vom AP gesendet. Kommt also auch am Switch untagged an und wenn die PVID an diesem Tagged Port dann auf 1 steht wird der AP Management Traffic in VLAN 1 gesendet...logisch !
Folglicherweise sollte also dein management PC an deinem TP Link in VLAN 1 sein um den AP zu erreichen. Auch logisch !
Hast du z.B. fälschlicherweise die PVID auf 10 gesetzt forwardet der Switch den AP management Traffic dann ins VLAN10. Dort erreicht es dann natürlich den Management Rechner der ja in VLAN 1 warten niemals.
Folge: Keine Management Konnectivität auf den AP.
Fazit:
Mit (sehr) großer Wahrscheinlichkeit hast du den TP Link Switch falsch konfiguriert !
Das ein so fundamentales Feature wie das VLAN Tagging da nicht funktioniert ist unmöglich.
Das wäre so als wenn du glaubst die Räder an einem nagelneuen PKW würden sich nicht drehen....

Hoffentlich hast du jetzt etwas "Durchblick" beim Thema VLAN. Sonst nochmal ganz in Ruhe das Tutorial lesen !!
An sich habe ich das Problem so nun gelöst.
Indem du einen neuen Switch gekauft hast... Das wäre gelinde gesagt wenig intelligent ! Aber nundenn...

Wenns das denn war, bitte dann auch
https://administrator.de/faq/32
nicht vergessen !
Bitte warten ..
Ähnliche Inhalte
Windows Server
Hyper-V Server 2012 R2 Lizensierung
gelöst Frage von lcer00Windows Server6 Kommentare

Hallo, Google ist gerade kaputt und ich finde nicht vernünftiges :) (nee, die Suche findet nur relevante Artikel zur ...

Windows Server

Von Server 2012 R2 Core zu Hyper-V Server 2012 R2

gelöst Frage von WeeWeeWeeWindows Server4 Kommentare

Hallo zusammen, leider habe ich bei der Installation von 3 Servern (dienen als Virtualisierungsserver) die falsche DVD verwendet. Jetzt ...

Switche und Hubs

Switch VLAN einrichten

gelöst Frage von TastuserSwitche und Hubs8 Kommentare

Hallo, ich habe einen Switch mit VLAn-Funktion, verstehe jedoch nicht ganz wie das funktioniert. Folgende Punkte sind vorhanden: - ...

Hyper-V

Hyper-V 2008 R2 auf 2012 R2 Failovercluster - Migrationstipp

Frage von derLenhartHyper-V3 Kommentare

Hallo, ich habe eine Testumgebung mit einem Singelhost Hyper-V 2008 R2 und einem iSCSI Target. Nur habe ich ein ...

Neue Wissensbeiträge
Datenschutz

SiSyPHuS Win10: Analyse der Telemetriekomponenten in Windows 10

Tipp von freesolo vor 3 TagenDatenschutz1 Kommentar

Alle die sich detailliert für die Datensammlung interessieren die unter Windows 10 stattfindet, sollten sich folgende Analyse des BSI ...

Sicherheit
Adminrechte dank Intel-Grafikkarte
Information von DerWoWusste vor 3 TagenSicherheit2 Kommentare

ist das Advisory, welches beschreibt, welche Intel HD Graphics Modelle Sicherheitslücken haben, mit denen sich schwache Nutzer zu Admins ...

Internet

EU Urheberrechtsreform: Eingriff in die Internetkultur

Information von Frank vor 4 TagenInternet1 Kommentar

Liebe Besucherin, lieber Besucher, warum erscheint das obere Banner in allen Beiträgen? Aus Protest gegen Teile der geplanten EU-Urheberrechtsreform ...

Windows Server
Windows Backup - FilterManager Event 3
Tipp von NixVerstehen vor 5 TagenWindows Server

Hallo zusammen, ich bin kein gelernter ITler und auch beruflich nicht in dem Feld tätig. Wir setzen in unserem ...

Heiß diskutierte Inhalte
DNS
50 EUR für Telekom-, Unitymedia- und Vodafone-Kunden
Frage von Zorro1199DNS14 Kommentare

Hallo zusammen, wie evaluieren gerade das korrekte Einhalten von DNS-TTLs durch verschiedene Provider. Aktuell suchen wir noch Kunden der ...

Windows Server
Sonntagsfrage: Welchen Sinn seht Ihr noch im Server 2019 Essentials
Frage von ashnodWindows Server13 Kommentare

Guten Morgen, ich habe gestern den Windows Server 2019 Essentials als Trial in einer VM installiert um mir das ...

Windows Server
Windows 2012 R2 - Skript um Druckerkonfiguration auszulesen und zu setzen
gelöst Frage von Der-PhilWindows Server11 Kommentare

Hallo! Kennt ihr eine Möglichkeit, per Skript die Konfiguration eines Druckers auszulesen und auf einen anderen anzuwenden? Hintergrund: Ich ...

Grafik
Viele Fotos organisieren - Windows Dateisystem zu lahm bzw. überfordert
Frage von augustaparkGrafik11 Kommentare

Hallo und Guten Morgen, hat einer eine Idee, wie man viele Fotos sinnvoll und effizient organisieren kann? Wir haben ...