Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Vollaufender Systemcache bei Netzwerkzugriff

Mitglied: UHAG

UHAG (Level 1) - Jetzt verbinden

07.04.2010, aktualisiert 21:44 Uhr, 6672 Aufrufe, 7 Kommentare

Hallo,

habe seit einiger Zeit das Problem, das bei einem unserer Server bei Netzzugriff über eine Windowsfreigabe der Systemcache vergrößert, damit der frei verfügbare RAM sinkt, bis auf 0. Alle anderen Prozesse werden dadurch natürlich "weggedrückt". Vor allem die VMs die auf der Maschine mitlaufen müssen nach dem Kopieren sehr viel von der Platte nachladen, weil aller RAM in den Systemcache fließt. Das Problem tritt sowohl vom RAID als auch von HDDS auf die direkt auf dem Board angeschlossen sind.
Da wir oft sehr große Bilddateien vom Server kopieren wird dieser oft beansprucht und ist beim Kopieren nicht mehr bedient bar. Ich würde nun gerne wissen wie das ganz technisch funktioniert um den Fehler einkreisen zu können. Anbei eine Abbildung der Speicherhistorie vom ProcessMonitor. Wäre für jeden Hinweis dankbar weil ich wie gesagt nicht mehr so richtig weiß wie ich diesem Problem begegnen soll. Anbei noch meine Systemdaten. Falls ihr noch mehr Infos braucht, reagiere ich zeitnah.

HW:
RAM: 4GB
RAID: Adaptec RAID SAS/SATA mit RAID 5
NIC: Intel 1000PT

SW:
MS Windows 2003 x64 Ent.
VMWare Server 1.0.9
Updates aktuell

Vielen Dank für eure Bemühungen
Viele Grüße

Speicherhistorie beim Kopiervorgang (ca. 10GB pro Datei)
27ef0be0b25a8947a2e72b9d64a5b394 - Klicke auf das Bild, um es zu vergrößern
Mitglied: MausBanderS
07.04.2010 um 22:15 Uhr
Heho...

AFAIR ist die Einstellung unter Systemsteuerung->System->Erweitert->Einstellungen von Systemleistung->Erweitert->Speichernutzung Programme/Systemcache dafür verantwortlich. Die Einstellung Systemcahce sorgt für die Verwendung des gesamten Arbeitsspeichers als
Cache, was Deine Probleme verursacht.

Allerdings schlage ich vor, Du beäugst Cacheset.exe aus der SysinternalsSuite einmal näher.

HTH,

Gruß Martin
Bitte warten ..
Mitglied: maretz
07.04.2010 um 22:25 Uhr
Moin,

lagert der Server denn definitiv nur noch aus?

a) Bei VMs passiert es auch häufig das er auf die Festplatte zugreifft da er den RAM der VM ja auch als Datei auf der Festplatte hat (z.B. Suspend-To-Ram-Funktion) .

b) Sollte er nur den freien RAM bis auf 0 runterfahren und die Swap-File nur wenig nutzen dann ist das auch kein Problem sondern etwas vorteilhaftes. Ich vergleiche das mal mit dem Motorrad von mir: Ich habe 4 Zylinder a 250ccm. Ich möchte auch bitte das alle 4 genutzt werden - und nicht das ich mit 3 Zylindern fahre damit ich den 4ten in Reserve habe! Beim PC möchte ich auch das mein RAM genutzt wird - sonst hätte ich den nicht gebraucht und es wäre Geldverschwendung! Und jedes bisschen nicht-genutzter RAM darf gern als File-Cache verwendet werden... (Das ist übrigens bei Linux schon lange üblich - unser Webserver in der Firma hat 8 GB RAM und davon sind ca. 7 GB als Filecache genutzt... - aber der Hoster hat die dinger halt alle mit 8 GB ausgestattet....). Wenn ich ehrlich bin: Von mir aus darf der sogar noch den Grafik-RAM als Filecache mitnutzen - mir doch egal, Bunte Bilder will ich nicht aber wenn ne Datei aus dem RAM kommt ist das locker um eine größenordnung (ns statt ms bzw. GB/s statt MB/s) schneller als die Festplatte...
Bitte warten ..
Mitglied: UHAG
07.04.2010 um 22:46 Uhr
lagert der Server denn definitiv nur noch aus?

Definitiv ja!
Habe jetzt nochmal alles was Prozesse sind aus gemacht. VMWare ... usw.
Auch mal die Option Systemsteuerung->System->Erweitert->Einstellungen von Systemleistung->Erweitert->Speichernutzung auf Programme gesetzt.
Keine Verbesserung. Magerer Speed von den Platten die direkt am Board sind ca. 20MB/s. Vom RAID nur 50MB/s.
Bitte warten ..
Mitglied: filippg
08.04.2010 um 04:16 Uhr
Hallo,

wir hatten schon gelegentlich Ärger mit RAM durch das Scalable Networking Pack (TCP Offloading/TCP Chimney). Würde dir raten, das mal (testweise) zu deaktivieren.

Gruß

Filipp
Bitte warten ..
Mitglied: UHAG
15.04.2010 um 20:55 Uhr
Problem gelöst.

http://www.ghisler.ch/board/viewtopic.php?p=171529

Lag an unserem Dateimanager. Wenn mit Windows Explorer kopiert wird gibt es keine Problem.

Danke für eure Hilfe
Bitte warten ..
Mitglied: filippg
15.04.2010 um 21:21 Uhr
Hallo,

von wo nach wo wird kopiert? Du führst auf dem Client TC aus, und auf dem Server steigt der Speicherverbrauch?

Gruß

Filipp
Bitte warten ..
Mitglied: UHAG
13.05.2010 um 11:12 Uhr
Jupp, genau so war es. Auf den Windows 7 Clienten läuft der Total Commander als FileManager.
Bitte warten ..
Ähnliche Inhalte
Netzwerke
Netzwerkzugriff langsam
gelöst Frage von slanskyNetzwerke5 Kommentare

Hallo Leute, ich habe folgendes Problem: Wir haben mehrere Rechner innerhalb der Firma umgezogen. Das bedeutet die Rechner sind ...

Windows 7
Absturz bei Netzwerkzugriff
gelöst Frage von hotrockinWindows 71 Kommentar

Hallo, ich habe mit einem neu installiertem Windows7-64 PC folgendes Phänomen (erstmals, ich habe davor schon viele Systeme eingerichtet, ...

Windows 10
Netzwerkzugriff bedingt langsam
Frage von ForgottenRealmWindows 106 Kommentare

Moinmoin, bei einem Kunden habe ich ein merkwürdiges Problem beim Zugriff auf ein NAS. Ca. 25 PCs mit Windows ...

Windows Update
Win 7 Netzwerkzugriff Problem
Frage von rocco61Windows Update2 Kommentare

Hallo zusammen, heute kam ein Update Microsoft 30 Updates in Folge. Brav wie man ist Installiert man die, nun ...

Neue Wissensbeiträge
Viren und Trojaner

Staatstrojaner soll auch per Einbruch installiert werden können

Information von transocean vor 21 StundenViren und Trojaner2 Kommentare

Moin, Bundesinnenminister Horst Seehofer will dem Verfassungsschutz Wohnungseinbrüche erlauben, um den geplanten Staatstrojaner zu installieren. Gruß Uwe

Windows 7
Win7 Update scheitert KB4512506
Information von infowars vor 1 TagWindows 7

Falls jemand auch das Problem hat mit dem: Monatliches Sicherheitsqualitätsrollup für Windows 7 für x64-basierte-Systeme (KB4512506) Das scheint mit ...

Humor (lol)
Wenn hacken nach hinten los geht
Information von em-pie vor 2 TagenHumor (lol)5 Kommentare

Moin, weil heute Freitag ist, nachfolgender kurzer Artikel zum schmunzeln:) l+f: NULL ist ein notorischer Falschparker

Windows Update
Windows: August 2019 Patchday-Probleme
Information von kgborn vor 3 TagenWindows Update3 Kommentare

Ich kippe mal einige kurze Informationen hier rein - vielleicht hilft es Betroffenen. Die August 2019-Updates für Windows haben ...

Heiß diskutierte Inhalte
Switche und Hubs
Glasfaser-Anschluss Telekom muss verteilt werden
Frage von cansoniSwitche und Hubs24 Kommentare

Vorweg: Bin nur Anwender und kein Experte Die Situation: Der Vermieter stellt einen Glasfaseranschluss in der Wohnung bereit. Wir ...

Hyper-V
VMs von Hyper-V auf externer Festplatte
Frage von SnowbirdHyper-V15 Kommentare

Hallo, ich möchte gerne von VirtualBox auf Hyper-V umsteigen und würde auch gerne weiterhin meine VMs auf der externen ...

Festplatten, SSD, Raid
SSDs durch Lagerung ohne Strom nach 6 Monaten defekt?!?
gelöst Frage von GlobetrotterFestplatten, SSD, Raid12 Kommentare

Moin Gemeinde Ich hatte gerade nen Trauerspiel Habe hier etliche NAS-Geräte herumfahren welche ich mal auf die Seite gelegt ...

Ubuntu
Download manchmal langsam oder komplette Abbrüche bzw. Videos spielen nicht bis zum Schluss
Frage von stefanstpUbuntu12 Kommentare

Immer wieder berichten unsere Kunden, dass Downloads abbrechen oder super langsam sind oder Videos nicht abgespielt werden können bzw. ...