Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

VPN Server routet anfragen von 192.x.x.x nicht an 10.x.x.x weiter

Mitglied: jakdo31

jakdo31 (Level 1) - Jetzt verbinden

23.01.2008, aktualisiert 25.01.2008, 19527 Aufrufe, 6 Kommentare

W2k3 sbs -

Hallo,
Ich versuche jetzt schon elends lange eine statische vpn route über server A zu Netzwerk B einzurichten aber es klappt irgenwie nicht

zuerst einmal:

e4a8ae5eeef3fd2297558a3e420cd3a0-vpn-shema - Klicke auf das Bild, um es zu vergrößern

Es gibt da 2 Netzwerke:

Stadt1: 10.0.0.0 - Subnetmask: 255.255.0.0 (Netzwerk B)

stadt2: 192.168.5.0 - Subnetz 255.255.255.0 (Netzwerk A)

jetzt soll von Stadt2 eine statische vpn verbindung hergestellt werden damit ich von einer workstation auf einen server von stadt1 zugreifen kann ohne jeweils eine eigene vpn verbindung aufbauen zu müssen ....

hier noch ein paar infos:

Stadt1:

Vpn-Gateway: 10.0.0.10 (watchguard firebox)
Domaincontroller: 10.0.6.1 (W2k3-SBS)
Workstations: 10.0.3.x (WinXP)

Stadt2:
Router: 192.168.5.254
Domaincontroller: 192.168.5.20 (W2k3-SBS)
VPN-Server: 192.168.5.24 (LAN) (Windows 2003 server)
192.168.5.25 (zweite lan - eigentlich kein anschluss)
bzw: per vpn: 10.0.254.1 (VPN-tunnel)

workstations: 192.168.5.x


Was ich schon habe:
es besteht eine statische vpn verbindung zwischen dem vpn server und stadt1
er kann sowohl auf netzwerk von stadt1 als auch von stadt2 zugreifen
auch die dns-auflösung klappt hier reibungslos und wenn ich auf einen server zugreifen will weiß er auch in welcher domain er liegt!

auf dem Router von stadt2 ist eingestellt als statische route dass alle anfragen an
10.0.0.0 mit subnetz 255.255.0.0 weitergeroutet werden an 192.168.37.24

wenn ich von einer workstation einen trace an eine 10er ip adresse mache dann versucht er auch über den vpn server zu gehen - aber endet bei diesem und wird nicht über den vpn tunnel weitergeleitet!

WO STELLE ICH JETZT EIN, DASS ER DIESE ANFRAGEN WEITERROUTEN SOLL


Eine kleine frage hat sich mir nur aufgedrängt:
Der Router leitet die Anfragen an 10.0.x.x an 192.168.5.24 weiter ich weiß aber nicht ob der Router diese Pakete schon so verändert dass er sagt dort ist schluss und nicht weiter -
Wie kann ich herausfinden welches Ziel solche Pakete haben bzw ob diese verändert wurden??

gibt es da vielleicht irgendein Trace Programm welches ihr empfehlen würdet?
Mitglied: Arch-Stanton
23.01.2008 um 18:18 Uhr
Hallo,

warum baust Du denn kein VPN zwischen den beiden Routern? Das würde doch vieles erleichtern. Außerdem solltest du das 10.0-Netz zugunsten eines privaten Netzwerkes ändern.

Gruß,
Arch Stanton
Bitte warten ..
Mitglied: jakdo31
23.01.2008 um 19:50 Uhr
Hallo, danke für deinen Rat, leider unterstützt der Router kein aktives VPN und Ziel ist es vielleicht später einmal ein VPN zwischen beiden sbs servern aufzubauen - aber bis es jamals soweit ist, ist es erforderlich zu wissen wie man auf einer win2k3 server maschine eine anfrage weiterroutet /tunnelt ...
Bitte warten ..
Mitglied: aqui
25.01.2008 um 11:36 Uhr
Da wurde wieder am falschen Ende gespart scheinbar.... Ok, mit einem Kniff bekommst du es aber hin:
Für das VPN ist ja nun der Server das Gateway/Router, denn er baut ja den Tunnel auf. Vermutlich haben aber alle Geräte in den netzen A und B den Router als Default Gateway eingetragen ?!

Du machst nun ganz banal einen zusätzlichen statischen Routing Eintrag auf dem Router:

Netzwerk A:

Zielnetz: 10.0.0.0, Maske: 255.255.0.0, Gateway: 192.168.5.24

Analog dazu bei Netzwerk B:

Zielnetz: 192.168.5.0, Maske: 255.255.255.0, Gateway: 10.0.6.1

Ob Packete auch wirklich den Weg nehmen kannst du mit dem traceroute (tracert bei Windows) oder pathping Kommando sofort verifizieren !
Das sollte dein Problem sofort lösen !
Ganz problematisch wird es allerdings solltest du wirklich am falschen Ende gespart haben und einen Billigrouter einsetzen, der nicht einmal statische Routen kann im Setup, dann wirds richtig arbeitsintensiv:
Entweder stellst du das default Gateway auf den Server um (einfache Variante) oder du musst auf jedem deiner Clients in beiden Netzen eine permanete statische Route eintragen oder über eine Batch Datei beim Booten im Autostart Ordner starten mit
route add 10.0.0.0 mask 255.255.0.0 192.168.5.24 (-p)
jetzt mal am Beispiel Netzwerk A.

Wie gesagt technisch wäre eine Lösung mit aktiven VPN Routern wie z.B. [ http://www.draytek.de Draytek] sie hat die weitaus bessere, weil performantere und sicherere und einfacher zu konfigurierende Alternative !
Bitte warten ..
Mitglied: jakdo31
25.01.2008 um 18:00 Uhr
Hallo, ja das habe ich schon gemacht - wenn ich eine 10. 0. x.x ip von einer workstation trace dann wird diese anfrage auch an den vpn server geleitet - nur der weiß nciht dass er das über den vpn weitertunneln soll!!
das was du mir mit der statischen route geschrieben hast habe ich schon im router drinnen gehabt - das problem muss irgendwo beim vpn server liegen!

bei dem muss doch irgendwo einstell bar sein dass er diese anfragen weitertunnelt / weiterroutet ..

einen anderen vorschlag??
Bitte warten ..
Mitglied: aqui
25.01.2008 um 18:05 Uhr
Hast du auf dem Server das Routing aktiviert ??? Normal macht Windows kein Forwarding ?
Bitte warten ..
Mitglied: jakdo31
25.01.2008 um 20:34 Uhr
ja - ich habe das routing and ras aktiviert aber es hatte bis jetzt noch nichts gebracht
Bitte warten ..
Ähnliche Inhalte
Windows Server

Windowsfreigabe aus 10.X.X.X Subnetz nicht erreichbar

Frage von WebkamerWindows Server8 Kommentare

Liebe Admin Gemeinde, ich hab hier ein komisches Problem: Es gibt 2 Netzwerk: 192.168.X.X und 10.X.X.X (Also quasi lt. ...

Linux Netzwerk

OpenVPN verbindet, routet aber normal weiter

gelöst Frage von Herr-NLinux Netzwerk28 Kommentare

Ich habe auf meinem debian Server OpenVPN eingerichtet. Als Client kommt die OpenVPN Connect APP für Android zum Einsatz. ...

Windows 10

Win 10 - FritzBox - VPN

gelöst Frage von chris84Windows 1013 Kommentare

Hallo Zusammen, in der Vergangenheit hatte ich eine VPN Verbindung über FritzFernzugang zu meiner FB im Büro aufgebaut. Lief ...

Netzwerke

VPN mit Windows 10

Frage von MiStNetzwerke17 Kommentare

Hallo, ich habe hier eine CISCO-ASA 5505. Diese stellt mir eine VPN-Verbindung von meinem Laptop (Win7) auf das Firmennetz ...

Neue Wissensbeiträge
iOS
IOS hat nen Cursor !!!
Tipp von Criemo vor 11 StundeniOS2 Kommentare

Nette Funktion im iOS. iPhone-Mauszeiger aktivieren „Nichts ist nerviger, als bei einem Tippfehler zu versuchen, den iOS-Cursor an die ...

Off Topic
Avengers 4: Endgame - Erster Trailer
Information von Frank vor 2 TagenOff Topic2 Kommentare

Ich weiß es ist Off Topic, aber ich freue mich auf diesen Film und vielleicht geht es anderen hier ...

Webbrowser
Microsoft bestätigt Edge mit Chromium-Kern
Information von Frank vor 2 TagenWebbrowser5 Kommentare

Microsoft hat nun in seinem Blog bestätigt, dass die nächste Edge Version kein EdgeHTML mehr für die Darstellung benutzen ...

Sicherheit

MikroTik: Sicherheitslücke wird ausgenutzt obwohl ein Update seit langem verfügbar ist

Information von sabines vor 3 TagenSicherheit

Obwohl ein Update, dass die nun massenhaft ausgenutzte Lücke schließt, seit langem (März 2018) verfügbar ist, wird es offensichtlich ...

Heiß diskutierte Inhalte
Exchange Server
Exchange Server 2010: Keine Eingehenden E-MAils
Frage von gabeBUExchange Server16 Kommentare

Hallo Zusammen Ich habe das kurzen auf dem Exchange 2010 Server das Problem, dass ich keine externen E-Mails mehr ...

Rechtliche Fragen
Systemhaus auf Abwegen
Frage von rocco61Rechtliche Fragen15 Kommentare

Hallo zusammen, bin derzeit ratlos bei dem folgenden Scenario: In einen Seniorenheim wurde beschlossen, die IT an eine andere ...

Server
Server in zwei verschiedene Netzwerke einbinden
Frage von BennyFServer10 Kommentare

Hallo zusammen, bei uns im Haus sind im Erdgeschoss die Geschäftsräume und ab dem 1. Stock sind unsere privaten ...

Outlook & Mail
Kalendersync mit Android und Outlook
Frage von Stefan007Outlook & Mail9 Kommentare

Hi Leute, kennt jemand eine Möglichkeit um Termine zwischen installiertem Outlook auf dem PC und dem Kalender auf einem ...