Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Wie W2012R2 von NVMe booten?

Mitglied: sysad

sysad (Level 3) - Jetzt verbinden

17.04.2019 um 23:17 Uhr, 623 Aufrufe, 16 Kommentare

Hallo,

mein Testserver ist ein W2012R2 mit SATA-SSD (Samsung 850 pro). Jetzt möchte ich auf eine neue HW mit einem M.2 Slot umziehen und habe das ganze mit Acronis Universal Restore auf eine Samsung 970 pro mit NVMe geklont. Leider weigert sich der Server, von dieser zu booten. BIOS ist m.E. richtig eingestellt.

Da gibt es doch bestimmt einen Trick, bin für Tipps dankbar.

Danke!
Mitglied: Raboom
LÖSUNG 17.04.2019 um 23:23 Uhr
Hi,

erscheint zumindest der Bootloader und er findet die Partition nicht?
War das Original eine EFI oder MBR Installation?

Ggf mal mit einem grub-Stick probieren, ob das Klonen funktioniert hat? So kannst du eingrenzen, ob es ein Klone-Problem öder BIOS-Problem ist.

Grüße Raboom
Bitte warten ..
Mitglied: DerWoWusste
LÖSUNG 17.04.2019 um 23:29 Uhr
2012 neu installieren, danach c: mit dem Backup überschreiben. Dieser einfache Weg klappt in der Regel.
Bitte warten ..
Mitglied: StefanKittel
LÖSUNG 17.04.2019 um 23:44 Uhr
Moin,

sicher das die Kiste auch von M2 booten kann?
Hat das Board einen M2-Slot oder verwendest Du einen PCIe-Adapter?

Stefan
Bitte warten ..
Mitglied: anteNope
LÖSUNG 18.04.2019, aktualisiert um 00:43 Uhr
Hier gibt es mehrere Hürden.

  • Ist das Partitionsschema GPT? (wenn vorher MBR, zunächst in GPT konvertieren und entsprechende EFI-Partitionen anlegen lassen)
  • Kann Win 2012 von Haus aus NVMe? Mal zum Test das Setup gestartet und geschaut ob die NVMe erkannt wird? Falls nicht, vor dem Clonen die Treiber installieren und dann weiter mit folgendem Punkt
  • Hast du nachgesehen ob die Start-Parameter in der Registry stimmen? Bin mir gerade nicht sicher ob die bei 2012 schon alle auf "0" stehen (wie bei Win 10 & Co) ...

Der DWORD "Start" sollte den Wert "0" haben. In alten Systemen (Window 7 & Co) standen die auf "3" wenn nicht verwendet:

  • Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\stornvme
  • Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\intelide
  • Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\storahci
  • Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\intelrst
  • ... usw.

Wenn die Start-Parameter nicht stimmen, bekommt man üblicher Weise den Fehler STOP: 0x0000007b oder ähnliches.

2012 neu installieren, danach c: mit dem Backup überschreiben. Dieser einfache Weg klappt in der Regel.
Oder du machst ein Bare-Metal-Recovery. Das dürfte prinzipiell auch zum Erfolg führen?
Bitte warten ..
Mitglied: sysad
18.04.2019 um 10:59 Uhr
Danke, das klingt interessant. Habs mittlerweile vorübergehend über HyperV gelöst, also direkt auf der M2 den W2012 neu installiert und den alten W2012 drauf virtualisiert.
Bitte warten ..
Mitglied: sysad
18.04.2019 um 11:00 Uhr
Jou, W2012R2 frisch installiert, läuft. Ich täte nur gern die alten Konfigurationen mit umziehen.
Bitte warten ..
Mitglied: sysad
18.04.2019 um 11:01 Uhr
Klon scheint gut und BIOS auch. Evtl liegt es am MBR.
Bitte warten ..
Mitglied: anteNope
LÖSUNG 18.04.2019 um 21:21 Uhr
Klon scheint gut und BIOS auch. Evtl liegt es am MBR.

Klar liegt das am MBR. Wenn du eine NVMe mit PCIe Anbindung hast, kannst du die nur über EFI starten, sprich GPT und EFI-Partition sind notwendig.
Bitte warten ..
Mitglied: sysad
21.04.2019 um 20:25 Uhr
Hab versucht die Originale SSD in GPT umzuwandeln. Mir wird aber nur die Umwandlung in Dyn. Datenträger angeboten. Das hab ich gemacht. Der Menüpunkt 'zu GPT Datenträger konvertieren' bleibt ausgegraut.

Was soll ich machen?
Bitte warten ..
Mitglied: Raboom
LÖSUNG 21.04.2019 um 20:28 Uhr
M.W. geht das nicht, nur neuaufsetzen
Bitte warten ..
Mitglied: sysad
21.04.2019 um 20:50 Uhr
Anscheinend kann man mit Windows Bordmitteln das nur machen, wenn man alle Partitionen löscht. Es soll aber Tools geben die das können, ohne das alles gelöscht werden muss. Was für eines soll ich nehmen?

Danke!
Bitte warten ..
Mitglied: Raboom
LÖSUNG 21.04.2019 um 21:07 Uhr
Gegenfrage: was sind MBR und GPT und was machen diese mit der HDD?
Wenn es Tools geben soll, wie heißen die, mir ist bisher noch keines untergekommen?
Bitte warten ..
Mitglied: StefanKittel
LÖSUNG 21.04.2019 um 21:15 Uhr
Moin,

das einzige Tool was ich kenne ist VMware Converter.
Aber der ist natürlich sehr zweckgebunden (V2V und P2V).

Stefan
Bitte warten ..
Mitglied: anteNope
LÖSUNG 21.04.2019 um 21:18 Uhr
Was bin ich lesend! Uff!!!
  • Option 1: Bare-Metal-Recovery und den Datenträger mit UEFI-Startoption starten
  • Option 2: Nimm dir eine Acroins CD in die Hand und sichere oder klone den Datenträger. Dort gibt es eine GTP-MBR-Konvertierungs-Option
  • Option 3: Installiere neu und dann über WindowsServerSicherung die Konfiguration wiederholen ...

Und wenn das alles immer noch nicht funktioniert. Stopf die SATA SSD da rein und gut ist.
Bitte warten ..
Mitglied: sysad
22.04.2019 um 21:29 Uhr
Danke für den letzten Tipp, so ist bis jetzt auch die Lage gewesen, mit SATA SSD drin.

Jetzt bin auch schon soweit, dass die NVMe (W21012 neu installiert und altes C: rüberkopiert) bootet.

Was bis jetzt noch nicht richtig geht sind die ebenfalls kopierten HyperV VMs (W10pro). HyperV bootet die VMs, aber nur die Standardprogramme starten (Explorer, Mail, Edge). Die von mir auf der VM installierten Programme starten nicht, und das ohne Fehlermeldung.
Bitte warten ..
Mitglied: sysad
22.04.2019 um 21:33 Uhr
mbr2gpt.exe soll das können und ein altes 'Partition Wizard' auch, ich hab damit aber keine Erfahrung.
Bitte warten ..
Ähnliche Inhalte
Windows Server

W2012R2 Druckereinstellungen werden nicht verteilt

Frage von MartinLWindows Server9 Kommentare

Hallo liebe Gemeinde, nach einigem rumprobieren muss ich mal wieder nach einem Lösungsvorschlag fragen :) Ich habe bei uns ...

Windows Server

W2012R2 im Explorer nicht sichtbar

Frage von WSaul1Windows Server1 Kommentar

Hallo, ich habe einen W2012R2 Rechner eingerichtet. Funktioniert soweit. Weiter sind im Netzwerk 1 W7, 1 W10 und ein ...

Windows Server

NET aus W2012R2 entfernen möglich?

gelöst Frage von sysadWindows Server4 Kommentare

Hallo, wie kann man .NET 4 aus einem W2012R2 deinstallieren und wieder neu installieren? Ich bekomme trotz installiertem .NET ...

Windows Server

RDS-Host - W2012R2 - Winlogon Fehler 4005

Frage von c0d3.r3dWindows Server2 Kommentare

Hallo, seit kurzem tritt bei uns ein bekanntes Phänomen vom 2012er (R2) Server ein - Winlogon verabschiedet sich mit ...

Neue Wissensbeiträge
LAN, WAN, Wireless
OPNsense Captive Portal mit vordefnierten Voucher
Tipp von Crusher79 vor 4 StundenLAN, WAN, Wireless

Hallo, Ziel war es vorhandene Klienten-Daten (Nummer im System) und Kennwörter anzulegen. Voucher werden durch externes Programm in Papierform ...

Administrator.de Feedback
Entwicklertagebuch: Die nächste Version
Information von admtech vor 1 TagAdministrator.de Feedback6 Kommentare

Hallo Administrator User, vielleicht haben es einige User schon mitbekommen: Wir arbeiten aktuell an einer komplett neuen Version von ...

Windows Server

Active Directory ESE Version Store Changes in Server 2019

Information von Dani vor 4 TagenWindows Server

Moin, Last month at Microsoft Ignite, many exciting new features rolling out in Server 2019 were talked about. But ...

Exchange Server

Microsoft Extending End of Support for Exchange Server 2010

Information von Dani vor 4 TagenExchange Server5 Kommentare

Moin, After investigating and analyzing the deployment state of an extensive number of Exchange customers we have decided to ...

Heiß diskutierte Inhalte
Netzwerkgrundlagen
Zukunftsicheres Heimnetzwerk aufbauen
Frage von CRO-WarriorNetzwerkgrundlagen16 Kommentare

Hallo Leute. Ich bin dabei das Haus in Kroatien zu renovieren. Da hab ich jetzt die Möglichkeit alles so ...

Windows Server
Windows Domäne, SBS 2011, Anmeldung als Admin nicht mehr möglich
Frage von big-dummyWindows Server14 Kommentare

Hallo, vorab: ich habe nun leider keine Grundruhe mehr - die Folgen wären katastrophal. Was ist das Problem: Ich ...

Router & Routing
Anmeldung am Router von einer ext. IP?
Frage von BigSnakeyeRouter & Routing13 Kommentare

Hallo, ich habe gerade seltsames in meiner Fritzbox entdeckt. Plötzlich war die Verbindung unterbrochen - kein Internet. Also habe ...

Batch & Shell
Powershell: dir ausgabe an copy Befehl weiterleiten
gelöst Frage von sugramBatch & Shell10 Kommentare

Hallo Nachdem hier ja immer wieder geschrieben wird, Batch ist tot, habe ich mich auch mal an Powershell gewagt. ...