Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Win XP: DNS-Namensauflösung über nicht mehr vorhandenen Nameserver

Mitglied: olliko

Xp versucht immer noch, Internetnamen über einen abgeschallteten Nameserver aufzulösen....

Hallo,

ich habe meinen internen DNS-Server abgeschaltet und lasse die Namensauflösung jetzt über meinen Router erledigen. Die neue Konfiguration habe ich bei XP eingetragen und IPconfig /all gibt auch die Werte richtig wieder.

Windows-IP-Konfiguration

Hostname. . . . . . . . . . . . . : dewin
Primäres DNS-Suffix . . . . . . . :
Knotentyp . . . . . . . . . . . . : Hybrid
IP-Routing aktiviert. . . . . . . : Nein
WINS-Proxy aktiviert. . . . . . . : Nein
DNS-Suffixsuchliste . . . . . . . : nic.loc

Ethernetadapter LAN-Verbindung 2:

Verbindungsspezifisches DNS-Suffix: nic.loc
Beschreibung. . . . . . . . . . . : VMware Accelerated AMD PCNet Adap

Physikalische Adresse . . . . . . : 00-0C-29-E1-54-94
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja
IP-Adresse. . . . . . . . . . . . : 192.168.123.42
Subnetzmaske. . . . . . . . . . . : 255.255.255.0
Standardgateway . . . . . . . . . : 192.168.123.254
DHCP-Server . . . . . . . . . . . : 192.168.123.254
DNS-Server. . . . . . . . . . . . : 192.168.123.254
Lease erhalten. . . . . . . . . . : Mittwoch, 21. Juni 2006 08:32:13
Lease läuft ab. . . . . . . . . . : Samstag, 1. Juli 2006 08:32:13


nslookup liefert aber folgendes:

D:>nslookup www.hp.com
DNS request timed out.
timeout was 2 seconds.
* Der Servername für die Adresse 192.168.123.1 konnte nicht gefunden werden:
Timed out
* Die Standardserver sind nicht verfügbar.
Server: UnKnown
Address: 192.168.123.1

DNS request timed out.
timeout was 2 seconds.
DNS request timed out.
timeout was 2 seconds.
*** Zeitüberschreitung bei Anforderung an UnKnown


Es macht übrigens keinen Unterschied, ob XP die Nameserver-IP per DHCP verpasst bekommt oder ob ich diese manuell eintrage.


VIELLEICHT WICHTIG: Die Installation wurde schon zweimal per Linux-DiskDump "umgezogen" - von einer HP-Workstation auf einen neuen PC mit VIA-Mainboard und von dort in eine virtuelle Maschine unter VMWARE 5.5-Linux. Als ich mich vor ein paar wochen schon mal mit dem Problem beschäftigt habe, tauchte im Gerätemanager die Onboard-Netzwerkkarte der HP-Workstation auf. Der Eintrag war zwar ausgegraut, aber ich konnte sie nicht löschen. Leider wird die HP-WS-Netzwerkkarte jetzt nicht mehr im GM angezeigt.


Kennt jemand das Rädchen, an dem ich drehen muss, damit endlich der richtige Nameserver benutzt wird ?


Danke für eure Mühe !

olliko

Content-Key: 34569

Url: https://administrator.de/contentid/34569

Ausgedruckt am: 02.08.2021 um 12:08 Uhr

Mitglied: Kosh
Kosh 21.06.2006 um 12:48:40 Uhr
Goto Top
Guck mal mit:
"netsh interface show interface"
was dir da alles angezeigt wird.

Ausserdem wirf mal einen Blick in den Gerätemanager, und wähle unter "Ansicht"->"ausgeblendete Geräte anzeigen"

Wenn da die HP-Karte noch auftaucht, dann weg damit ; )
Mitglied: Kosh
Kosh 21.06.2006 um 12:53:00 Uhr
Goto Top
achja das könnte vielleicht auch helfen: (wenn alle stricke reissen)
"netsh winsock reset"


es gibt auch noch nen befehlt der den kompletten stack wieder neu aufbaut, aber ich kann mich leider nicht mehr an ihn erinnern.
(irgendwas mit "netsh rebuild catalog" oder so)
Mitglied: olliko
olliko 21.06.2006 um 15:24:52 Uhr
Goto Top
Hallo,

also zuerst mal habe ich folgendes gemacht :

C:\>netsh interface show interface

Verw.-status Status Typ Schnittstellenname
Aktiviert Dediziert LAN-Verbindung 2
Aktiviert Dediziert LAN-Verbindung
Aktiviert Dediziert 1394-Verbindung
Aktiviert Dediziert LAN-Verbindung 3
Aktiviert Dediziert LAN-Verbindung 4
Aktiviert Intern Intern
Aktiviert Loopback Loopback

Die auch unter Netzwerkverbindungen angezeigte ist "LAN-Verbindung 2", also die, die ich immer konfiguriere, was aber keinen Effekt hat.

Habe mich dann nach einer Befehlsreferenz für netsh umgeschaut und folgendes gefunden :

http://www.microsoft.com/technet/prodtechnol/windowsserver2003/de/libra ...

Gut, wollte ich die überflüssigen LAN-Verbindungen Löschen, gab aber immer nur Fehler-Meldungen :

C:\>netsh interface delete interface name="LAN-Verbindung 3"
Falscher Parameter.


Ein letztes verzweifeltes "netsh winsock reset" hat leider auch nix gebracht.


Weiss jeman weiter ?

Gruss, Olliko
Mitglied: olliko
olliko 21.06.2006 um 19:38:10 Uhr
Goto Top
Ich habe mit regedt32 die Registry nach der IP-Adresse des alten DNS-Servers durchsucht und überall durch die IP des neuen ersetzt.

Manchmal kann's so einfach sein !

Gruss
Mitglied: Kosh
Kosh 22.06.2006 um 07:15:15 Uhr
Goto Top
Freut mich wenns wieder geht ; )

Wäre vielleicht noch interessant WO in der reg die alten Einträge drin waren.
Mitglied: olliko
olliko 22.06.2006 um 08:59:16 Uhr
Goto Top
Das waren eine ganze Menge. Und es waren tatsächlich auch noch die eintrage der alten HP-Intel-Karte drin. Wo ich sie gefunden habe, habe ich sie gelöscht.

Ich hoffe ich kriege alle zusammen :

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\DNSClient
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Tcpip\Parameters
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Tcpip\Parameters\Interfaces\{01E5AC7D-F42E-4366-9B92-5E3396763749}
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\Tcpip\Parameters
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\Tcpip\Parameters\Interfaces\{01E5AC7D-F42E-4366-9B92-5E3396763749}
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet004\Services\Tcpip\Parameters
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet004\Services\Tcpip\Parameters\Interfaces\{01E5AC7D-F42E-4366-9B92-5E3396763749}
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{01E5AC7D-F42E-4366-9B92-5E3396763749}


Gruss, olliko
Mitglied: Kosh
Kosh 22.06.2006 um 09:22:07 Uhr
Goto Top
Danke für die Info.
Heiß diskutierte Beiträge
question
Hyper-V - verwaiste Snapshots löschen gelöst basdschoVor 1 TagFrageHyper-V28 Kommentare

Hallo, mein Veeam machte bei einer installation Probleme und konnte plötzlich die Snapshots nicht mehr löschen. Kein Problem, Disks konsolidiert, alte Snapshot Dateien gelöscht. Nun ...

question
USB 3 beißt sich mit 2,4Ghz Funkperipherie gelöst O-Two06Vor 1 TagFragePeripheriegeräte3 Kommentare

Hiho, ich habe nun schon einige Artikel über das leidige Thema gelesen, komme aber zu keiner Lösung. Ich habe Mini-PCs, bei denen nun leider mal ...

question
Fritzbox 7590 ersetzten gegen Modem + Router oder Router mit Modemindignus-estVor 1 TagFrageNetzwerke10 Kommentare

Hallo zusammen, nach langer Krankheit und Genesungszeit fasse ich jetzt mal wieder den Mut eine frage zustellen die mir schon seit längeren im Kopf herum ...

question
Ipv6 RouterliodiceVor 23 StundenFrageDSL, VDSL10 Kommentare

Hallo zusammen, ich hoffe ihr könnt mir weiterhelfen, ich benötigen einen ADSL Router (Kabelgebundenen) der IPv4 und IPv6 kann, also Dual Stack (DHCP Extern und ...

question
Günstiges Open-Source NAS für HeimgebrauchpanguuVor 16 StundenFrageSAN, NAS, DAS9 Kommentare

Hallo, mit NAS-Systemen hatte ich bisher gearbeitet: Synology, QNAP, Buffalo, etc. Dabei kommen proprietäre Betriebssysteme zum Einsatz, die sich natürlich von Hersteller zu Hersteller unterscheiden ...

question
SSH Login nur möglich bei eingelogtem USERhell.wienVor 1 TagFrageLinux Netzwerk18 Kommentare

habe einen Server (Debian) mit SSH (nur mit Public Key und auf einem Custom Port) und ufw aktiv. Ich kann mich nicht einlogen. Wenn ich ...

question
ProLiant DL380p G8 findet HP SAS-Festplatten MB3000FBUCN nicht ?IT-DAUVor 1 TagFrageServer-Hardware5 Kommentare

Hallo liebe Community! Kurz vorweg: ich bin Quereinsteiger in der IT-Branche und möchte nun als Vorbereitung zu meinem Ausbildungskurs bzw. für zu Hause ein bisschen ...

question
Umstellung Pfsense VM auf HW IP WLAN Clientsraxxis990Vor 1 TagFrageFirewall5 Kommentare

Hallo , Ich habe begonnen meine Pfsense von VM auf Richtige HW umzurüsten. Soweit hat das auch geklappt. Fritte in LAN 1 und LAN 2 ...