Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Windows 7 Home Premium löst keine langen subdomains auf

Mitglied: DerHammer

DerHammer (Level 1) - Jetzt verbinden

04.03.2010 um 12:04 Uhr, 5378 Aufrufe, 9 Kommentare

Hallo,

wir haben einen kleinen Atom Nettop mit Windows 7 Home Premium hier stehen. Nachdem alles wichtige installiert ist, ist uns aufgefallen das unsere internen Projekt Seiten nicht funktionieren. Windows 7 scheint Subdomains ab einer bestimmten länge abzuschneiden oder einfach nicht auf zu lösen.

Unsere Interne Domain Syntax sieht wie folgt aus : projekt_name.server.firmenname.intern

Ich habe das nun mit mehreren Projekten ausprobiert und es scheint so als taucht der Fehler nur auf wenn der Projektname länger als 7 Zeichen ist. (Ist leider bei 90% der fall)

Insgesammt komme ich dann auf (8+8+10+6) = 32 Zeichen.

Ein nslookup liefert übrigens das korrekte Ergebnis.

Kann mir da jemand weiterhelfen? Habe sonst nichts passendes dazu gefunden.

- DerHammer
Mitglied: Snowman25
04.03.2010 um 12:43 Uhr
vllt. mal mit einem anderen Browser versuchen?
Bitte warten ..
Mitglied: DerHammer
04.03.2010 um 13:07 Uhr
Das Problem tritt sowohl mit IE8 als auch mit Firefox 3.5 auf.
Bitte warten ..
Mitglied: Snowman25
04.03.2010 um 13:11 Uhr
Eigenartig...
Geht nslookup auch über den gleichen DNS?
Könntest du mal eine Beispiel-URL posten?
Gruß
Snow
Bitte warten ..
Mitglied: DerHammer
04.03.2010 um 15:29 Uhr
Rechner läuft mit DHCP und bekommt unseren internen DNS Server (bind9) mitgeteilt. Der wird auch von nslookup benutzt.

Hier ein Beispielt welches ich zum testen des Fehlers eingerichtet habe:

Funktioniert: abcdef.arbeit01.xxxxxxxxxx.intern
Funktioniert nicht: abcdefg.arbeit01.xxxxxxxxxx.intern

Beide zeigen auf den gleichen Server.
Bitte warten ..
Mitglied: Snowman25
04.03.2010 um 15:34 Uhr
Zitat von DerHammer:
Funktioniert nicht: abcdefg.arbeit01.xxxxxxxxxx.intern
nslookup kann richtig auflösen aber über einen Browser wird es nicht mehr richtig aufgelöst?
Sind hosts, networks, etc. alle richtig? (also die Dateien)
Bitte warten ..
Mitglied: DerHammer
05.03.2010 um 09:48 Uhr
Dort stehen nur die Standardeinträge. Nichts außergewöhnliches.

Edit.: Erste Frage übersehen. nslookup löst richtig auf nur die Browser verweigern Ihren Dienst. Hat bestimmt wieder etwas mit der beschnittenen Windows Version zu tun.
Bitte warten ..
Mitglied: DerHammer
05.03.2010 um 13:38 Uhr
Habe nun zumindest herausgefunden warum die Auflösung von kurzen Namen funktioniert. Laut Wireshark erfolgt die Auflösung per netbios. Er ignoriert die suffixe unseres internen LANs komplett und fragt nur abcdef.arbeit01 ab. Da netbios ja nur recht kurze namen zulässt funktioniert es nicht mehr bei längeren Domains.
Also ignoriert die Home version die DNS-Suffixe die ich sogar extra eingetragen habe. Wirklich Top.

Gibts dafür einen Registry Trick oder etwas in der Richtung?
Bitte warten ..
Mitglied: Snowman25
05.03.2010 um 13:53 Uhr
Sendet dein DHCP auch NetBIOS-Einstellungen an die Clients?
Vllt. sind die ja falsch.
Bitte warten ..
Mitglied: DerHammer
05.03.2010 um 14:16 Uhr
So ich habe die Lösung.

Das super Windows 7 ignoriert die DNS-Suffixe die man in den Netzwerkeinstellungen unter TCPIP v4 / erweitert / dns eintragen kann. Um das zu fixen einfach in der Registry "HKLM\SOFTWARE\Policies\Microsoft\Windows NT\DNSClient" öffnen (oder anlegen wenn nicht vorhanden) und deinen dword eintrag mit dem Namen "AppendToMultiLabelName" hinzufügen. Diesen auf 1 setzen, neu starten und alles funktioniert wie es soll.

Premium.
Bitte warten ..
Ähnliche Inhalte
Windows 7
Startproblem mit Windows 7 Home Premium
Frage von Dad2802Windows 73 Kommentare

Beim Kaltstart des PC zeigt sich in den letzten Tagen immer wieder ein Blue Screen, mit den unterschiedlichsten Fehlermeldungen, ...

Windows 10

Inplaceupgrade Windows 7 Home Premium auf Windows 10

Frage von Penny.CilinWindows 1010 Kommentare

Hallo, ich nehme Bezug auf diese Frage Windows 10 Upgrade noch möglich Ich habe ein Notebook eines Anwenders hier ...

Windows 7

Windows 7 Home Premium ISO - wo downloaden?

Frage von deckard2019Windows 79 Kommentare

Hallo. Ich habe eine Frage zu den Windows 7 ISOs, die ich auf der Microsoft Website downloaden kann. Ich ...

Voice over IP

Analyse RTP - Rx-Pkts-Lost vs. Remote-Rx-Pkts-Lost

Frage von istike2Voice over IP

Hallo, ich habe hier einen Anrufe wo unser PBX vom Angerufenen durchgehend sehr schlechte RTP Streamqualität bekommt. (Ich wundere ...

Neue Wissensbeiträge
Internet
EU-Urheberrechtsreform: Zusammenfassung
Information von Frank vor 2 TagenInternet1 Kommentar

Auf golem.de gibt es eine Analyse von Friedhelm Greis, der das Thema EU-Urheberrechtsreform gut und strukturiert zusammenfasst. Zwar haben ...

Microsoft Office

Office365 Schwachstellen bei Sicherheit und Datenschutz

Information von Penny.Cilin vor 3 TagenMicrosoft Office7 Kommentare

Auf Heise+ gibt es einen Artikel bzgl. Office365 Schwachstellen. Das ist noch ein Grund mehr seine Daten nicht in ...

Sicherheit
Schwachstellen in VPN Clients
Tipp von transocean vor 5 TagenSicherheit2 Kommentare

Moin, es gibt Sicherheitslücken bei VPN Clients namhafter Hersteller, wie man hier lesen kann. Gruß Uwe

Sicherheit

Wikileaks-Gründer Julian Assange wurde festgenommen

Information von Frank vor 7 TagenSicherheit3 Kommentare

Wikileaks-Gründer Julian Assange wurde heute in London festgenommen. Die Botschaft Ecuadors, in der er seit sieben Jahren lebte, hat ...

Heiß diskutierte Inhalte
Tipps & Tricks
Verdammt voll erwischt
Frage von AlchimedesTipps & Tricks23 Kommentare

Folgende Mail habe ich auf meinem Freenet Account erhalten: Nun folgendes Problem: 1) Ich besuche Porno Seiten yep hat ...

Windows 10
Laufwerks-Mapping über Batch - Laufwerke werden zu spät im Explorer angezeigt
Frage von PhilzipWindows 1015 Kommentare

Hallo zusammen, ich habe beim Thema Laufwerksmapping via Batch ein Phänomen, welches ich so noch nicht kannte. Per Batch ...

Vmware
Richtige Einstellungen beim ESXI 6.5 in Sachen CPU Zuweisung bei einer VM
gelöst Frage von zeroblue2005Vmware13 Kommentare

Hallo Zusammen, heute wollte ich mal fragen, wie ich eine VM die richtige Anzahl der von CPUs zuweise. Bin ...

Vmware
ESXI hebt Registrierung von Masschinen auf
Frage von SpitzbubeVmware12 Kommentare

Hallo, nutze seit einiger Zeit für meine IT Projekte einen alten HP G7 Server mit ESXi 6.5 und einem ...