Windows Explorer EXE verschieben kopiert offensichtlich und löscht nachher (verwendet unter W10, vermutlich aber auch darunter)

Mitglied: 1410640014

1410640014 (Level 1) - Jetzt verbinden

14.12.2015 um 11:11 Uhr, 858 Aufrufe, 6 Kommentare

Hallo,

mir ist aufgefallen, dass das "Verschieben" von EXE-Dateien im Windows-Explorer recht lange dauert. Ist mir bei recht große Setup-Dateien jenseits der 1GB aufgefallen.

Mit dem Move-Befehl auf der Kommandozeile dagegen geschieht dies im 0,nix.

Da mir der technische Hintergrund nicht einleuchtet, warum hier im Explorer offenbar zuerst an den Zielort kopiert und dann am Quellort gelöscht wird, beim Move-Befehl das dagegen ohne Kopieren geht bitte ich um Aufklärung.

LG
Mitglied: 122990
122990 (Level 2)
14.12.2015, aktualisiert um 11:21 Uhr
Moin.
Ge"moved" wird nur auf dem selben Laufwerk, weil dort ja nur die Einträge in der MFT angepasst werden müssen, hier also nichts kopiert werden muss.
Zwischen zwei physisch/logisch unterschiedlichen Laufwerken wird verständlicherweise kopiert und dann die Quelle gelöscht. War schon immer so.

Da Windows 10 unter Admins "inoffiziell noch Betastatus hat", weiß man aber nie ob MS da nicht doch wieder ein Ei hinterlegt hat ;-) face-wink

Gruß grexit
Bitte warten ..
Mitglied: emeriks
14.12.2015 um 11:42 Uhr
Da Windows 10 unter Admins "inoffiziell noch Betastatus hat"
Was, so weit schon?!
Bitte warten ..
Mitglied: AndreasHoster
14.12.2015 um 12:51 Uhr
Deaktiviere mal Deinen Virenscanner. Ich vermute der klinkt sich in den Explorer ein und scannt die EXE.
Habe jetzt nur gerade kein Win10 vor mir, um das zu Testen, aber bei großen Videodateien passiert das definitiv nicht (zumindestens mit dem Windows Defender nicht).
Bitte warten ..
Mitglied: Pjordorf
14.12.2015 um 13:50 Uhr
Hallo,

Zitat von @1410640014:
Da mir der technische Hintergrund nicht einleuchtet, warum hier im Explorer offenbar zuerst an den Zielort kopiert und dann am Quellort gelöscht wird, beim Move-Befehl das dagegen ohne Kopieren geht bitte ich um Aufklärung.
Das macht der Move Befehl genauso. Erst Kopieren, dann löschen (schon immer). da ist auch der Explorer nicht von ausgenommen. Und wie dir schon darauf hingewiesen wurde, ist es entscheidend von wo nach wo Kopiert / verschoben werden soll.
Gleiches Laufwerk = Anpassung in der FAT/MSFT bzw. Inhaltsverzeichnis.
Andere Laufwerke = echtes kopieren der tatsächlichen Daten.
Der Explorer braucht natürlich immer deutlich länger alleine um zu ermitteln welche Datenmenge und auch zeit benötigt werden. Würde er - wie mal in der Vergangenheit - nur Kopieren wäre der genauso schnell wie der "copy und anschließende move" oder gar nur auf DOS ebene. Anstatt nur das zu tun was er sollte braucht es deutlich länger dir anzuzeigen was er in welcher Zeit tun würde.... Selbst das ermitteln der Verzeichnisse von wo nach wo und das Darstellen sowie anpassen der Sortierungen, Gruppierungen usw. bei nur dem anpassen des Inhaltsverzeichnis dauert in der GUI insgesamt länger. Der eigentliche Vorgang ist aber stets gleich langsam / schnell, nur das Beiwerk ist hier das was es langsam macht.

Für den der es noch beherrscht ist ein copy oder move in ein MS-DOS Fenster (Kommandozeile) immer noch bevorzugt als die Bedienung per Maus (GUI) wenn es um große oder sehr viele Dateien geht.

Gruß,
Peter
Bitte warten ..
Mitglied: 1410640014
18.12.2015, aktualisiert um 09:35 Uhr
@AndreasHoster

Hmm, da kein AV-Programm noch aktiv war, kann es das nicht gewesen sein.

@Pjordorf

Move kann wohl nicht kopieren. In dem Moment, wo das Kommando eingetipp wurde, ist alles auch schon erledigt.

Dagegen vergehen beim Explorer mitunter Minuten.
Bitte warten ..
Mitglied: Pjordorf
18.12.2015 um 11:48 Uhr
Hallo,

Zitat von @1410640014:
Move kann wohl nicht kopieren
Ein Move von einer Platte zu einer anderen involviert immer ein Kopieren - erst kopieren dann löschen. Anders geht es nicht. Es sind zwei hintereinander ablaufende Prozesse (Kopieren dann Inhaltsverzeichnis löschen aktualisieren). Ein Move innerhalb einer Platte führt nur dazu das nur das Inhaltsverzeichnis angepasst wir.

In dem Moment, wo das Kommando eingetipp wurde, ist alles auch schon erledigt.
Scheint das du innerhalb der gleichen Platte es gemacht hast. (Wir können hier nur raten da du nichts dazu sagst....

Dagegen vergehen beim Explorer mitunter Minuten.
Das liegt an der GUI damit dein Mausschubser etwas bewirkt und dessen Aufbereitung der Daten damit du auch siehst was du schubst.

Gruß,
Peter
Bitte warten ..
Heiß diskutierte Inhalte
Netzwerke
Was passiert wenn ich zeitgleich PoE und Strom vom Netzteil an einen Access Point (Mikrotik) lege?
kartoffelesserVor 2 TagenFrageNetzwerke3 Kommentare

Hallo Experten und Admins Ich habe einen Mikrotik wAP ac (RB-WAPG-5HACD2HND) an einem Laptopwagen im Einsatz. Leider ist die vorhandene Stromversorgung für den AP ...

Windows Server
Infrastruktur für Firma
brainwashVor 19 StundenFrageWindows Server7 Kommentare

Hallo zusammen, kurze Erklärung zu meinem Problem Wir sind eine kleine Firma mit zwei Standorten im Bereich Brandschutz. Zur Zeit nutzen wir für unsere ...

Netzwerkprotokolle
Proxy Zugang von Extern
gelöst Jannik2018Vor 1 TagFrageNetzwerkprotokolle17 Kommentare

Hallo zusammen, ich habe mir einen Squid Proxy auf einer Linux VM aufgesetzt und möchte das man aus allen netzen drauf zugreifen kann allerdings ...

Windows Server
Windows 10 VM auf Server 2019 Essentials
jhuedderVor 1 TagFrageWindows Server10 Kommentare

Hallo, einer meiner Kunden möchte aus Kostengründen einen Windows Server 2019 (direkt auf einer physikalischen Maschine installiert) erwerben und dort für einen Außendienstler mit ...

Server-Hardware
Verkaufe RX300 S7 Server von Fuijutsu
HolzBrettVor 20 StundenAllgemeinServer-Hardware9 Kommentare

Hi, Ich wohne in Aachen und habe die Server von der Firma umsonst erhalten. Ich habe sie bereits überprüft (es geht alles). Ich möchte ...

Windows Server
Veeam Endpoint Backup FREE zur Sicherung eines DCs
gelöst takvorianVor 1 TagFrageWindows Server7 Kommentare

Hallo zusammen, ich habe hier bei mir 1 Hypervisor mit 4 VMs (darunter 1 DC) welche ich mittels backupAssist alle wegsichere. Klappt soweit auch ...

LAN, WAN, Wireless
WLan-unterstütztes Telefonieren iOS, Unifi
VisuciusVor 1 TagFrageLAN, WAN, Wireless8 Kommentare

Hallo. Ich bins (wieder) ;-) Guten Morgen, ich beobachte seit einer Umstellung ein "komisches Verhalten" und kann mir das gerade nicht erklären. Und vielleicht ...

LAN, WAN, Wireless
Heimnetzwerk mit VLAN - getrennter Internetzugang
gelöst anyibkVor 1 TagFrageLAN, WAN, Wireless5 Kommentare

Hallo liebe Community! Ich bastle seit einiger Zeit an einem recht besonderen Heimnetzwerkproblem. Wir haben einen neuen Glasfaseranschluss ins Haus (3 Parteien) bekommen und ...