Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Windows greift nach Systemwiederherstellung auf alte nicht mehr vorhandene Treiber zu und startet deshalb nicht mehr!

Mitglied: Kasten
Hallo,
ich habe folgendes problem:
gestern Nachmittag wollte ich mir meinen neuen grafikartentreiber installieren (meine karte: geforce 7800 gt). Hierzu löschte ich wie normal meinen alten treiber. Hierbei löschte ich aus versehen auch alle anderen nvidia treiber, also einen ethernet, einen smartbus und einen ide-treiber! Dies bemerkte ich anfangs nicht. Als ich dann den neuen grafiktreiber drauf hatte, bemerkte ich meinen löschfehler und wollte diesen durch eine systemwiederherstellung (die von windows, ich besitze leider kein anderes plattenbackup). Diese wurde auch ausgeführt. Als der rechner dann aber starten wollte, kam die fehlermeldung, dass die datei nvatabus.sys aus system32\drivers fehlerhaft oder nicht vorhanden sei.
Diese nvatabus.sys datei gehört zu dem von mir gelöschten ide-treiber, es ist der ide-sw treiber, welchen es zu meinen motherboard hinzugab (msi k8n neo4f), und welcher die perfomance steigern sollte, aber nicht zwingend notwendig ist. Nun habe ich diesen ja leider gelöscht, durch die systemwiederherstellung versucht windows diesen aber nun wie es aussieht beim starten zu laden und greift nicht auf die hauseigenen treiber zurück!

Nun meine frage: was kann ich tun? Kann ich die systemwiederherstellung rückgängig machen? Kann ich von "außen" einen treiber auf das nicht starten wollende windows aufspielen? Oder kann ich diese treibersuche von windows unterbinden?

Mein windows ist xp proffesional, ich habe xp home (hatte die prof. cd nicht gefunden) auf den rechner auf ne andere platte aufgespielt! damit ich noch zugriff auf meine datein habe, kann so also das andre windows etwas verändern. Ich weiß aber nicht wie und was.
Danke für hilfe!

Achso, ich möchte windows ungern ganz neu installieren!
Und nochwas, Windows verweist auf die Reparaturfunktion durch booten von der Windows-CD. Da ist bei mir nicht viel passiert, musste das Betriebssystem auswählen, Adminkennwort eingeben und dann kam nur ne MS-DOS Eingabe...

Content-Key: 34843

Url: https://administrator.de/contentid/34843

Ausgedruckt am: 04.12.2021 um 09:12 Uhr

Mitglied: leknilk0815
leknilk0815 26.06.2006 um 14:12:41 Uhr
Goto Top
Hi,

die Reparatur- Inst., die Du meinst, geht erst später los. An demm Punkt, an dem Du "reparieren" ausgewählt hast, mußt Du normal weiter machen (keine Reparatur), die Abfrage kommt erstt nach der Plattenerkennung, da wird nach bestehenden Installationen gesucht und dann gefragt, ob Du diese reparieren willst.

In dieser von Dir beschriebenen DOS- Box könnte man die Treiber wieder reinkopieren, das kannst Du aber auch über Deine Home - Installation. Problem wird sein, daß mit dem Treiber evt. dann Konflikte in der Registry durch das vorherige löschen etc. auftreten können.

Ich würde eine Rep laufen lassen...

Gruß - Toni
Mitglied: geTuemII
geTuemII 26.06.2006 um 14:17:16 Uhr
Goto Top
Hallo,

starte mal die Last Known Good Configuration (Letzte als funktionierend bekannte Konfiguration) aus dem Auswahlmenue, in dem du sinst auch den Abgesicherten Modus wählen kannst. Falls Windows dir das Menue nicht freiwillig zum Start anbietet, drücke während des Boots F8.

Die Option sollte eigentlich funktionieren, da in ihr der Stand gespeichert ist, mit dem das System das letzte Mal erfolgreich anmelden konnte. Im Erfolgsfall mußt du dann halt die benötigten nVidia-Treiber händisch nachinstallieren.

HTH geTuemII
Mitglied: geTuemII
geTuemII 26.06.2006 um 14:24:50 Uhr
Goto Top
Zweite Variante:

Falls du im Abgesicherten Modus starten kannst (das sollte gehen, da in diesem Fall der VGA-Treiber der Grafika geladen wird), kannst du im Gerätemanager --> Grafika --> Eigenschaften --> Erweitert --> Installierter Treiber den alten Grafiktreiber wieder laden. Ich persönlich finde Installierter Treiber eine ziemlich bescheuerte Übersetzung für Driverrollback.

Natürlich kannst du auch im Abgesicherten Modus einfach die Grafiktreiber nochmal installieren.

HTH geTuemII
Mitglied: leknilk0815
leknilk0815 26.06.2006 um 14:27:12 Uhr
Goto Top
@ HTH geTuemII:

er hat doch die IDE- Treiber gekillt, nicht die Grakas...
Mitglied: geTuemII
geTuemII 26.06.2006 um 15:23:41 Uhr
Goto Top
Du hast natürlich recht, ich hatte mich kurz an meinem eigenen Beitrag verknotet ;-) face-wink . In der Last Known Good hat er ja dann wieder die Konfiguration mit nVidia- aber ohne Graka-Treiber, daher die Verwechslung.

Danke für den Hinweis,
geTuemII
Mitglied: leknilk0815
leknilk0815 26.06.2006 um 15:24:33 Uhr
Goto Top
grins...
Mitglied: Kasten
Kasten 26.06.2006 um 18:41:58 Uhr
Goto Top
Hi,
also, der abgesicherte Modus geht logischerweise nicht...
Dann, Treiber reinkopieren hilft auch nicht, als ich die gesuchte nvatabus.sys reinschob startete der rechner immer wieder beim treiber in den speicher laden neu...

Desweiteren kann ich grade leider nichts weiter ausprobieren, da der Rechner grade weg ist (bei nem Freund), ich glaube aber auch unter der Letzten Bekannten Konfiguratuion startete Windows nicht, bin mir aber nicht sicher (ich muss fürs F8 drücken immer erst ne andre Tastatur ausleihen...)

erstmal Danke für die Hilfen, ich hoffe mal das Reparieren funktioniert, auch wenn der IDE-Treiber nicht auf der Windows-CD ist...

ich sag so schnell es geht wieder bescheid,
danke
Mitglied: Kasten
Kasten 30.06.2006 um 16:44:03 Uhr
Goto Top
so,
also, es ist dann doch auf ne festplatten formatierung mit neuem windows hinausgelaufen...

zuerrst hab ich die reparatur ausprobiert, als windows dann das setup startete hing das immer an einer stelle bei 34 min und der geräteinstallation fest... irgendwie durch das abknipsen meiner zweiten festplatte konnte ich windows dann doch wieder im abgesichterten modus starten... auch nach einer neuinstallation der treiber dort konnte ich windows aber nicht mehr richtig so starten, beim windows start lud windows ewig und hing dann plötzlich, hatte dabei einen permanenten festplattenzugriff, auch nach computer-reset (also kein kaltstart) hing die festplatte weiter im nirgendwo und der computer ging nicht mehr richtig an...


nun ist windows neu installiert, allerdings braucht er och ne ewigkeit zum starten, wenn ich aber die ide-sw treiber, welche für meinen nforce4 chipsatz die performance treiber sein sollen, hängt dann windows wieder beim starten fest (mit letzter bekannter konfig. konnte ich wieder neu starten), und beim installieren der motherboard treiber hatte ich arg merkwürdige sachen zu verzeichen (zugriff bei der treiberinstallation verweigert von der netzwerkkarte (aufm motherboard) oder bei anderen motherboard treibern)...


also merket: niemals von msi die ide treiber deinstallieren!

tschüss
Heiß diskutierte Beiträge
imho
Wir müssen über Corona und das Impfen redenFrankVor 1 TagIMHOOff Topic59 Kommentare

Ich denke, dass geht uns alle an und daher will ich meinen Beitrag dazu leisten, um über Corona und das Impfen aufzuklären. Ich habe bereits ...

general
Echt jetzt? Es werden kommentarfrei Beiträge gelöscht?VisuciusVor 1 TagAllgemeinOff Topic16 Kommentare

Frank: Das hätte ich so nicht erwartet! Erst eine politische Diskussion vom Zaun brechen und dann mit den Antworten überfordert sein?! Ich hatte lediglich darauf ...

question
Browser Zertifikatswarnung lösen?IT-heilt-NIEVor 1 TagFrageVerschlüsselung & Zertifikate13 Kommentare

Hallo an alle, ich benötige mal eure Hilfe, da ich mich mit dem Thema Zertifikate noch nicht gut auskenne. Ich komme gleich mal zum Punkt. ...

question
Ursache für Auslösung Storm-Control Cisco SG350Xlcer00Vor 2 TagenFrageNetzwerke17 Kommentare

Hallo zusammen, heute morgen gab es bei uns einen unplanmäßigen Stomausfall, der zum ungraceful-Shutdown der Server sowie der Switche (2 gestackte SG350) führte. Nach Wiederhochfahren ...

tip
Download AdventskalenderMrCountVor 1 TagTippUtilities2 Kommentare

Servus zusammen, auch dieses Jahr bieten wieder einige Webseiten einen Adventskalender mit kostenloser Software an. Hier eine kleine Liste: Vielleicht ist ja für den ein ...

question
Windows 2016 Laufwerk C erweitern D verkleinernr2d2r3poVor 1 TagFrageWindows Server17 Kommentare

Hallo, wir haben hier einen Windows 2016 Server bei den die C-Platte langsam voll wird, aber die D-Platte fast leer ist. Wir kann ich ohne ...

question
"Treesize" für Ordner in einem Outlook-Postfach gelöst StefanKittelVor 1 TagFrageOutlook & Mail2 Kommentare

Hallo, ich habe hier ein Hosted-Exchange-2016-Postfach welches in einem Outlook 2016 eingebunden ist. Dies enthält ca. 500 Ordner und ist fast 100 GB groß. Kennt ...

question
Hausüberwachung Kameraingo1988Vor 20 StundenFragePeripheriegeräte8 Kommentare

Hallo an alle, ich möchte ab sofort mein Haus mit Kameras überwachen lassen. Es sollen 4 Kameras außen am Haus angebracht werden. Ich möchte die ...