Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWünsch Dir wasWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows Server 2019, 1809 - Terminalserver Startmenü tot

Mitglied: tredl127

tredl127 (Level 1) - Jetzt verbinden

08.04.2020 um 15:47 Uhr, 620 Aufrufe, 15 Kommentare

Hallo Zusammen!

Ich habe 8 Stück Windows Server 1809 in einer Sammlung und die werden als Terminalserver benutzt.

Wir haben immer wieder das Problem, dass bei gewissen Usern und dann am ganzen Server das Startmenü nicht mehr funktioniert.

Das heisst ein Linksklick auf das Startmenü geht nicht mehr...

Habe schon sehr viele Postings und Einträge gelsen und immer wieder geht es um Cortana usw.

Wir verwenden Roaming Profile welche am TS auch jeden Tag in der nacht wieder gelöscht werden lokal von den Servern.

Hat von euch jemand eine Ahnung wie man diesen Fehler beheben kann, ohne den Server wieder neu clonen zu müssen.

Vielen Dank für eure Hilfe.

glg

Tredl
Mitglied: Username4812
08.04.2020 um 17:08 Uhr
Grüß dich tredl127,

ich hatte neulich das Problem, dass der Dienst "Windows Search" als Starttyp "deaktiviert" stand. Soweit ich weiß, sollte dieser aber auf "Automatisch - verzögerter Start" stehen und auch ausgeführt werden.
Ich nehme an, dass keine Windows Updates ausstehen?
Bitte warten ..
Mitglied: tredl127
08.04.2020 um 17:16 Uhr
Hy!

Dieser Dienst ist bei unseren Terminal Servern immer deaktiviert.
Bitte warten ..
Mitglied: GrueneSosseMitSpeck
08.04.2020 um 18:19 Uhr
mal im Ereignisprotokoll nachschauen, es gibt noch andere Gründe, warum das Startmenü nicht mehr geht.
Bei Windows 10 Arbeitsstationen ist das normalerweise der Suchdienst, der nach dem Domänenbeitritt nicht mehr startet...
Bitte warten ..
Mitglied: tredl127
08.04.2020 um 18:24 Uhr
Danke für die Info, aber wie gesagt!

Bei uns ist die Cortana Suche deaktiviert auf den Terminalserver, da es zu viel Performance wegnimmt,
wenn dort viele Schüler drauf arbeiten.

Wir haben 8 Terminals im Einsatz und diese sind zu einer Sammlung zusammengeschlossen.

Normalerweise funktioniert es immer ganz gut, aber jetzt habe ich wieder einen Ausreisser.

Das lokale Admin Profil funktioniert, und sobald man sich als User oder Domain Admin anmeldet,
geht es nicht mehr.

Ich hab schon so viele Foren und Seiten besucht und die Schreiben immer von einer Cortana Reparatur ....
Irgendwas muss das mit dem Domain Join oder mit einem Profil zu tun haben.

Wir haben auch extra ein Default.V6 Profil erzeugt und die Performance zu verbessern.
Bitte warten ..
Mitglied: AlbertMinrich
08.04.2020, aktualisiert um 21:22 Uhr
Willkommen im Club,

auch wir haben dieses Problem. Windows Server 2016 1607.
Ich hab mir schon einen Wolf gesucht, aber noch keine Lösung gefunden.
Bei uns stellt es sich so dar:
Bei irgendeiner Anmeldung (völlig willkürlich, immer andere User, immer andere Terminalserver) kommt es zu einem ziemlich genau 5 minütigen Black Screen. Danach ist die Session da, aber das Startmenü funktioniert nicht.
Alle User, die sich danach am gleichen Terminalserver anmelden, haben das gleiche Problem (5 Minuten Black Screen, nicht funktionierendes Startmenü). Beendet man die Sitzung des ersten, problemverursachenden Users, haben alle User an dem Terminalserver keine Probleme mehr. Sie müssen sich nicht mal neu anmelden, das Startmenü funktioniert dann sofort wieder.

Wir konnten feststellen, dass in der Problemsession der Prozess runtimebroker.exe 3x läuft, in allen anderen Sessions nur einmal.
Man muss die Session nicht mal beenden, es reicht, diese 3 runtimebroker Prozesse zu killen, auch dann funktioniert das Startmenü wieder bei allen. Diese Lösung ist aber nicht so zuverlässig. Das Problem kommt dann gerne mal wieder.

Wir haben ca. 350 Sessions pro Tag, verteilt auf 30 Terminalserver. Das Problem tritt pro Tag ca. 1-4 mal auf. Wir behelfen uns im Moment so, dass wir die Anmeldungen monitoren, dauert eine länger als 2 Minuten, wissen wir, aha, das Problem ist jetzt da am Terminalserver X. Diesen Terminalserver nehmen wir dann für den Rest des Tages aus der Farm.

Wenn jemand eine Lösung kennt, immer her damit.

Nachtrag:
Dieses BlackScreen Problem haben wir erst, seitdem wir unsere Terminalsever vor ein paar Monaten neu aufsetzen mussten.
Vor ca. 2 Jahren hatten wir auch schon das Startmenü Problem (aber ohne Black Screen und ohne dass dann der ganze Server betroffen war). Damals half es, das Startmenü vom servergespeicherten Profil auszuschließen.

Danke
Gruß
Martin
Bitte warten ..
Mitglied: UnlimitedRequests
08.04.2020 um 23:44 Uhr
Von diesem Backscreen Problem habe ich vor einigen Monaten von einem befreundeten Admin gehört. Die Symptome sind identisch gewesen. Bisher keine Lösung. Selbst MS ist mehrfach dran gewesen. Das mit dem Roaming Profil Ausschluss werde ich so weitergeben.
Bitte warten ..
Mitglied: tredl127
09.04.2020 um 07:11 Uhr
Hy!

Danke für die Info!

Zum BlackScreen Problem im Windows Server kann ich berichten, dass wir das auch hatten!

Die 2 Audio Dienst am TS deaktivieren dann hat man keinen BlackScreen mehr

glg

Tredl
Bitte warten ..
Mitglied: AlbertMinrich
09.04.2020 um 10:27 Uhr
Zitat von tredl127:
Zum BlackScreen Problem im Windows Server kann ich berichten, dass wir das auch hatten!
Die 2 Audio Dienst am TS deaktivieren dann hat man keinen BlackScreen mehr

Wir haben Citrix im Einsatz, somit gibt es 4 Windowsdienste mit Audio im Namen:
  • Windows-Audio
  • Windows-Audio-Endpunkterstellung
  • Citrix Audio Redirectionservice
  • Verbessertes Windows-Audio/Video-Streaming

Welche Dienste meinst du?
Wenn ich einen der ersten 3 beende, geht kein Audio mehr am ThinClient.
Das wäre also auch keine Lösung.

Gruß
Martin
Bitte warten ..
Mitglied: beidermachtvongreyscull
09.04.2020 um 10:38 Uhr
Moin,

ich kann folgendes dazu sagen:

Ich habe beim Bauen von customized Images eine Reihe von Diensten ausgemacht, die pro Nutzer einen Child-Service generieren.

Unter den folgenden Diensten

  • BluetoothUserService
  • CaptureService
  • DevicePickerUserSvc
  • DevicesFlowUserSvc
  • PimIndexMaintenanceSvc
  • MessagingService
  • PrintWorkflowUserSvc
  • OneSyncSvc
  • WpnUserService
  • BcastDVRUserService
  • CDPUserSvc
  • UnistoreSvc
  • UserDataSvc

ist mindestens einer dabei, der am Aufbau des Startmenüs beteiligt ist. Ich weiß es deshalb, denn wenn man die Dienste deaktiviert, spart man Ressourcen, aber das Startmenü (Linke Maustaste) geht nicht mehr auf. Das Kontextmenü mit rechter Maustaste aber immernoch.
Ich denke, dass die Dienste mit "User" im Namen und/oder UnistoreSvc darin involviert sind.

Du kannst es ja gerne mal live bei einem testen.

Gruß
bdmvg
Bitte warten ..
Mitglied: tredl127
09.04.2020 um 12:10 Uhr
Danke für deine Info!

Ich habe jetzt alle Dienste bei mir kontrolliert.

Die von dir genannten sind alle "stopped"

Komisch eben als lokaler Admin gehts, und sobald man was über die Domain macht gehts nicht mehr.

glg

Andi
Bitte warten ..
Mitglied: tredl127
10.04.2020 um 09:04 Uhr
Hallo Leute!

Ich habe nun eine Lösung für all eure Probleme mit BlackScreen / Lange Anmeldezeit / Startmenü.

Problem wird durch einen Registry-Bloat ausgelöst.

Ich habe vor dem Sysprep folgendes gemacht:

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\RestrictedServices\Configurable\System
- Alles bis auf Standard gelöscht

In diesem Schlüssel können teilweise 50000 Einträge sein:

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\FirewallRules
- Alles bis auf Standard gelöscht

Danach folgenden Key setzen:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy
DeleteUserAppContainersOnLogoff
REG_DWORD
1
Bitte warten ..
Mitglied: AlbertMinrich
12.04.2020 um 13:16 Uhr
Zitat von tredl127:

Hallo Leute!

Ich habe nun eine Lösung für all eure Probleme mit BlackScreen / Lange Anmeldezeit / Startmenü.

Leider nein. Wär ja auch zu schön gewesen.
Bitte warten ..
Mitglied: beidermachtvongreyscull
12.04.2020 um 13:20 Uhr
Die Sache mit dem Bloat hat aber tatsächlich Hand und Fuss.
Bitte warten ..
Mitglied: tredl127
12.04.2020, aktualisiert um 15:02 Uhr
Hy!

Wir hatten das Problem in vielen Schulen die auf Terminalserver arbeiten!

Leider war / bzw. ist das ein BUG vom 2016 Server!

https://social.microsoft.com/Forums/azure/en-US/f18fa9e9-2f5b-42ad-9248- ...


Nach Update auf 2019 war das Problem behoben.

Wir haben uns dann eine Batch Datei geschrieben, die den Audio Dienst neu startet.

Bei uns war der Audio Dienst Gott sei Dank nicht in Verwendung, deshalb haben wir ihn einfach deaktiviert,
dann war das Problem auch behoben.
Du kannst es zum Testen ja mal ausprobieren.

glg

Tredl
Bitte warten ..
Ähnliche Inhalte
Microsoft

Windows 10 1809 und Server 2019 Rückzug

Information von sabinesMicrosoft5 Kommentare

Hier mal ein interessanter Artikel zum Rückzug von Windows 10 1809 und Server 2019 und dem allgemeinen Durcheinander bei ...

Windows Update

Windows Server 2019 Datacenter 1809 auf 1903 updaten

gelöst Frage von CyberRinoWindows Update2 Kommentare

Hallo , ich habe mal eine Frage, ich soll einen Windows Server 2019 von 1809 auf 1903 upgraden. Geht ...

Windows Server

Windows Server 2019 (Standard) 1809 auf 1903 upgrade

Frage von macobi83Windows Server7 Kommentare

Hallo Zusamen, gerne würde ich im Betreff genanntes Upgrade durchführen. hat das von euch schonmal jemand gemacht? nirgendswo finde ...

Microsoft

Windows 10 1809 RemoteApp

gelöst Frage von Frank84Microsoft14 Kommentare

Hallo zusammen, Wir waren bis vor kurzem noch auf w10 1703, nachdem die pro Variante nun im November abgekündigt ...

Neue Wissensbeiträge
iOS
IOS iPadOS 13.5.1 erschienen
Information von sabines vor 5 StundeniOS

Recht kurz nach iOS 13.5.0 ist gestern iOS/iPadOS in der Version 13.5.1 für IPhone und IPad erschienen. Es schließt ...

Windows Update

Nach Windows 10 Update auf 2004 ist kein RDP-Zugriff mehr möglich - möglicher Fix

Anleitung von VincentGdG vor 5 StundenWindows Update2 Kommentare

Moin. Ich habe gestern unsere PC per RDP auf 2004 upgedatet. Danach hatte ich auf einige PC keinen Zugriff ...

Weiterbildung
2. IT Pro Night Thema Sicherheit
Information von 1Werner1 vor 21 StundenWeiterbildung

Moin, nach dem im letzten Jahr die IT ProNight ein voller Erfolg war, haben wir diese dies Jahr ins ...

Informationsdienste

Die Zerstörung der Presse - Youtuber Rezo möchte Missstände in unserer Mediengesellschaft aufzeigen, um sie zu lösen

Information von Frank vor 1 TagInformationsdienste35 Kommentare

Youtuber Rezo greift in seinem neuen Video den Boulevard an, warnt vor allem vor Verschwörungen und richtet einen Appell ...

Heiß diskutierte Inhalte
Microsoft
100 Prozent CPU Last gleich Volllast, Pustekuchen, nicht bei Microsoft!!! VOL 2
Frage von MysticFoxDEMicrosoft60 Kommentare

Liebe Freunde der Präzision und der Norm, ich möchte in diesem Beitrag konstruktiv an den folgenden Vorgängerbeitrag anschliessen, der ...

Microsoft
Zugriffsprobleme Festplatte
gelöst Frage von MiMa89Microsoft58 Kommentare

Hallo Zusammen, ich hoffe Ihr könnt mir bei folgendem Problem helfen. Ich habe eine externe Festplatte die nicht mehr ...

Informationsdienste
Die Zerstörung der Presse - Youtuber Rezo möchte Missstände in unserer Mediengesellschaft aufzeigen, um sie zu lösen
Information von FrankInformationsdienste35 Kommentare

Youtuber Rezo greift in seinem neuen Video den Boulevard an, warnt vor allem vor Verschwörungen und richtet einen Appell ...

SAN, NAS, DAS
Entscheidungshilfe Storage für Netzwerkupgrade
Frage von m-jelinskiSAN, NAS, DAS34 Kommentare

Hallo zusammen, unsere Server und Storage-Systeme sind nun 6 Jahre alt und überfällig ausgetauscht zu werden. Daher haben wir ...