Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows VPN - erste Verbindung schlägt immer fehl

Mitglied: ITgustel

ITgustel (Level 1) - Jetzt verbinden

25.03.2019 um 17:03 Uhr, 568 Aufrufe, 7 Kommentare

Hallo Kollegen,

folgendes, ich nutze ein SSTP-VPN um von zuhause (Win7) in die Firma zu kommen.
Dabei habe ich das Problem, dass immer der erste Ping fehlschlägt bzw. bei einer VNC-Verbindung diese immer erst nach dem zweiten Aufbau steht.

Ich konnte das Problem dahingehend eingrenzen, dass wir in der Firma 10.X.X.X-er Netze verwenden, ich zuhause ein 10.10.X.X-er Netz.
Wenn ich nun von zuhause (10.10.10.1/16) einen Server in der Firma anpingen will (z. B. 10.10.4.41/24), funktioniert das erst nach dem zweiten Ping...

Ich denke es hängt damit zusammen, dass es zwei 10er-Netze sind und Windows wohl erst versucht das im lokalen LAN aufzulösen. Ich habe testweise mal mit meinem Handy einen mobilen Hotspot aufgezogen und meinen Privat-Rechner darüber mit der Firma verbunden (hier bekam der Rechner vom Handy ein 192.168.er Netz). Damit hat es auch Windows auf den ersten Ping geschafft richtig zu routen.

Interessanterweise haben meine Android-Geräte (z. B. 10.10.10.11/16) damit gar kein Problem, hier klappt es immer sofort mit dem ersten Ping.

Nun gut, kennt jemand ein Mittelchen dagegen? Es ist nicht wirklich ein sooo großes Problem, nur störend, dass alles immer erst auf den zweiten Anlauf klappt. Die Firmennetze will ich deswegen keinsfalls umstellen. Mein Privtnetz eigentlich auch nicht, weil es eine Menge Arbeit an selbst erstellten Scripten nach sich ziehen würde... Wie gesagt, kann ich Windows dazu bringen sich hier wie Android zu verhalten (gibt es keinen genialen Registry-Hack oder sowas)? :D

Danke und Grüße
ITgustel
Mitglied: emeriks
25.03.2019, aktualisiert um 17:19 Uhr
Hi,
Zitat von ITgustel:
Wenn ich nun von zuhause (10.10.10.1/16) einen Server in der Firma anpingen will (z. B. 10.10.4.41/24), funktioniert das erst nach dem zweiten Ping...
Wobei da die Frage wäre, wer da antwortet.

zuhause (10.10.10.1/16)
Brauchst Du zuhause denn tatsächlich ein 65.000-Adressen-Netz? Wahrscheinlich reicht es schon, wenn Du eine 24'-Maske nimmst.

E.
Bitte warten ..
Mitglied: ITgustel
25.03.2019 um 17:34 Uhr
Der erste Ping geht vermutlicherweise in LAN, die weiteren Pings kommen vom angepingten Server korrekt über das VPN:

Ping wird ausgeführt für 10.10.4.41 mit 32 Bytes Daten:
Antwort von 10.10.10.3: Zielhost nicht erreichbar.
Antwort von 10.10.4.41: Bytes=32 Zeit=43ms TTL=127
Antwort von 10.10.4.41: Bytes=32 Zeit=43ms TTL=127
Antwort von 10.10.4.41: Bytes=32 Zeit=43ms TTL=127

Eigentlich nicht, habe es nur so aufgeteilt, 10.10.10.X = PCs / 10.10.20.X = Netztechnik / 10.10.30.X = Server usw...
Bitte warten ..
Mitglied: certifiedit.net
25.03.2019 um 17:47 Uhr
Wahrscheinlich reicht sogar ein /28 oder /29....
Bitte warten ..
Mitglied: aqui
25.03.2019, aktualisiert um 19:08 Uhr
Wenn ich nun von zuhause (10.10.10.1/16) einen Server in der Firma anpingen will (z. B. 10.10.4.41/24), funktioniert das erst nach dem zweiten Ping...
Überlappende Subnetzmasken ! Das kann so niemals gehen denn damit gibt es doppelte IP Netze auf beiden Seiten und die Wegefindung ist nicht mehr eindeutig.
Das ist ein gravierender IP Adress Design Fehler im VPN Umfeld. Siehe auch:
https://administrator.de/wissen/vpns-einrichten-pptp-117700.html#toc-7
Der Einwand "Wobei da die Frage wäre, wer da antwortet." ist richtig und beschreibt das Dilemma treffend.
Besser du änderst dein privates Netz in eine 172.16-32er Adresse um dem Problem komplett aus dem Wege zu gehen. Eine /16er Maske zu verwenden ist so oder so ziemlicher Unsinn in einem Heimnetz. (Und generell gesehen auch !)

Alternative du änderst dein 10er Netz zuhause in eins mit einem /26er oder /27er Prefix in ein Subnetz was es definitiv NICHT auf der anderen Seite (Firma) gibt !! Das würde mit einem Restrisiko auch klappen. Aber sobalt es irgendwo im Firmennetz einer Summary Route gibt die dein Subnetz inkludiert bist du wieder raus.
Es bleibt also dabei das wenn du ganz auf Nummer sicher gehen willst KEIN 10er Netz verwendest und lokale ein 172.16-32er verwendest. Dann bist du safe und es kann keinerlei Überlappungen mehr geben !
"IP Netze müssen eindeutig sein !" Das lernt der Netzwerker eigentlich in der ersten Klasse IP Grundkurs.
Bitte warten ..
Mitglied: emeriks
25.03.2019 um 19:45 Uhr
Zitat von ITgustel:
Antwort von 10.10.4.41: Bytes=32 Zeit=43ms TTL=127
Und danach schaust Du in den ARP-Cache und hast die MAC-Adresse des Antwortenden bzw. des Routers, wenn dazwischen.
Bitte warten ..
Mitglied: aqui
26.03.2019 um 10:24 Uhr
Fakt ist das das IP Adressdesign falsch ist und es deshalb so nie klappen kann ! Siehst du ja auch selber an den Subnetzen und muss man hier nicht noch weiter drehen und wenden, dann damit kann man es logischerweise nicht lösen !
Bitte warten ..
Mitglied: Deepsys
26.03.2019 um 15:31 Uhr
Hi,

ich weiß nicht was die anderen Kollegen hier alles so schreiben (und habe keine Lust das alles zu lesen), aber das ist doch kein ungewöhnliches Verhalten.
Der erste ping weckt doch erst den VPN-Tunnel, und wenn der sich nicht so schnelle verbindet, dann ist der erste verloren.
Eigentlich recht normal.
Hast du denn damit ein echtes Problem?

Normalerweise baut man den Tunnel auf und startet dann die Anwendung und pingt nicht rum

Da es ja dann funktioniert, wird das Routing wohl stimmen.

VG,
Deepsys
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless

RDP Verbindung schlägt fehl bei installierten VPN Client

Frage von Jan1986LAN, WAN, Wireless4 Kommentare

Hallo zusammen, ich habe den Lancom VPN Client 3.13 auf meinem neuen Notebook installiert. Seit der Installation funktionieren sämtliche ...

Router & Routing

VPN-Verbindung funktionert erst wieder nach Wechsel des Netzwerks

Frage von pejaRouter & Routing5 Kommentare

Hallo, wir haben hier eine Windows-Dömäne mit einem IP-Netz 192.168.20.0 An der Firewall existiert ein VPN zu einer zweiten ...

Hyper-V

Windows Fall Creators Update + Hyper-V + VPN (NCP) - Verbindung erst nach 10 Minuten

gelöst Frage von FraggDiebHyper-V9 Kommentare

Hi Leute, wir verwenden bei uns Windows 10 Notebooks auf denen NCP läuft. Die Firewall von NCP ist so ...

Vmware

VSphere Client Verbindung schlägt unter Windows 10 via site to site VPN fehl

gelöst Frage von TranministratorVmware6 Kommentare

Hallo liebe Admins, ich jage momentan einer Lösung für ein Phänomen nach welches bei weiten mein Horizont übersteigt. Wir ...

Neue Wissensbeiträge
Sicherheit

Chrome 79 übermittelt eingegebene Kennwörter nach Hause

Information von DerWoWusste vor 17 StundenSicherheit11 Kommentare

Ab sofort warnt Chrome standardmäßig Nutzer davor, wenn aus Leaks bekannte Passwörter zum Einsatz kommen. Beim Besuch einer Website, ...

Viren und Trojaner
Trend Micro WFBS 10 SP1 Patch 2185
Tipp von Abramelin vor 1 TagViren und Trojaner1 Kommentar

Hi, Hab gerade gesehen das Patch 2185 für TM WFBS 10 SP1 erschienen ist! Werde mal Morgen den Patch ...

Viren und Trojaner

Neuer Virus lässt Windows im abgesicherten Modus starten

Tipp von transocean vor 1 TagViren und Trojaner6 Kommentare

Moin, lest selbst. Grüße Uwe

Sicherheit
Böser Bug in Domänenkennwortrichtlinie!
Information von DerWoWusste vor 1 TagSicherheit2 Kommentare

Ich spiegele mal Borncity: In Kürze: Nutzt Ihr eine Domänen-Kennwortrichtlinie der herkömmlichen Art (keine PSO-Richtlinie)? Ja? Und plant Ihr, ...

Heiß diskutierte Inhalte
Windows 10
Windows 10 Herunterfahren - Funktioniert nach Upgrade von Windows 7 nicht mehr
Frage von krischeuWindows 1016 Kommentare

Hi, ich habe verschiedene PCs mit dem Upgrade Assistenten von Windows 7 Pro 64 Bit auf Windows 10 geupdatet. ...

Windows 10
Win10 Remote Desktop User anders
Frage von ludibubiWindows 1014 Kommentare

Folgende Situation: Auf meinem Rechner (Win10) in der Firma (Domänen-Netzwerk) starte ich abends bevor ich gehe einen Newsletterversand. Damit ...

Switche und Hubs
Kein DHCP hinter neuen Switch
Frage von mwormerSwitche und Hubs12 Kommentare

Hallo zusammen, bin gerade ein wenig ratlos. Wir haben vorgestern unseren alten Zyxel GS-1548 gegen einen TP-Link SG1024DE getauscht. ...

Entwicklung
Programmiersprache für Server
gelöst Frage von MondeosEntwicklung11 Kommentare

Ich bin relativ neu im Gebiet der Programmierung etc.(mache das auch nur als Hobby bin noch Schüler), und wollte ...