Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows XP Registry File -Security- Kein Zugriff mehr, hab ich mich ausgesperrt ?

Mitglied: Freec75

Freec75 (Level 1) - Jetzt verbinden

12.09.2007, aktualisiert 25.09.2007, 9571 Aufrufe, 7 Kommentare

EDIT: Ich habe weiter unten eine Korrektur angebracht, damit der Sinn der Folgethreads ersichtlich bleibt.

Vor allem dieser Absatz...
Hallo, ich habe eventuell einen bösen Fehler bei der Rechtevergabe für das Registry-File "Security" begangen.
ist Inhaltlich falsch, es war der Key...
Um einige Änderungen vorzunehmen, hatte ich kurzzeitig vom Admin-Account im abgesicherten Modus mit Regedit Vollzugriff für den Root-Schlüssel "Security" eingestellt.

Als ich diesen wieder zurücknehmen wollte, setzte ich zunächst Häckchen bei "Verweigern".
Dann fiel mir ein, das dort vorher gar keine waren, und entfernte sie wieder.
Daraufhin wurden automatisch wieder welche bei "Zulassen" gesetzt, die ich auch entfernte.

Es kam eine Warnung, dass durch diese Einstellung NIEMAND mehr Zugriffsrechte hätte, die ich mit "OK" quittierte. Daraufhin wurden alle Kästchen für die Rechtevergaben grau, und es liess sich gar nichts mehr einstellen.
Ich konnte mir irgendwie nicht vorstellen, dass man den Zugriff auf irgendwas wirklich für JEDEN (auch den Admin) sperren kann, oder liege ich damit falsch und hab nur was übersehen?

Beim nächsten Bootvorgang musste ich dann feststellen, dass auch das System nicht mehr auf "Security" zugreifen kann, es kommt eine Messagebox die meldet, dass lsass.exe keinen Zugriff bekommt (worauf genau steht dort zwar nicht, aber vorher lief alles...), und wenn ich auf "OK" klicke, wird einfach ein Reset ausgelöst.

Habe bisher versucht:

Alle Bootvarianten, die im Menü(F8) angeboten werden zu starten.
Es kommt immer diese Fehlermeldung.

"Security" in diesen -glaub ich- recht bekannten Linux-Offline-Registry&Password-Editor zu laden doch keine Funktionen zur Änderung der Rechte gefunden, ausserdem wird beim Versuch, untergeordnete Schlüssel zu laden, immer angezeigt, das diese nicht vorhanden wären, obgleich sie in der Liste auftauchen.

Ich komme in mein System einfach nicht mehr rein.

Deshalb wollte ich mal vorsichtig fragen, wie dass jetzt wieder rückgängig zu machen ist, bin wirklich aufgeschmissen...
Mitglied: 51705
12.09.2007 um 20:30 Uhr
schon versucht, unter Erweitert den Besitz zu übernehmen, und dann die Rechte setzen?

Achtung, nach Besitzübernahme Eigenschaften schliessen, neu öffnen und dann...
Bitte warten ..
Mitglied: Kosh
13.09.2007 um 07:52 Uhr
tjo da hast du dich sauber rausgeschmissen

boote mit der windows cd und gehe in die konsole.

gehe ins verzeichnis c:\windows\system32\config und benenne die datei security in security.old um.

dann kopierst du die datei "security" von c:\windows\repair nach c:\windows\system32\config


dann sollte der zugriff wieder klappen.
Bitte warten ..
Mitglied: Freec75
13.09.2007 um 16:40 Uhr
Hallo,
Danke euch für die schnellen Reaktionen!

Da ich im Moment von meinem Rechner aus nicht schreiben kann,
hat es bei mir dann etwas gedauert...

@smerlin
Im Moment fährt das System leider nicht hoch, und ich weiss nicht, wie oder ob ich so überhaupt MS Regedit starten kann.
In dem Linux-Tool scheint es keine Funktionen für Besitzübername oder Rechtevergaben zu geben.
Oder anders gesagt: Habe keine gefunden.

@Kosh
Ok, die Datei "Security" habe ich nun gesichert und mit der aus dem Repair-Verzeichnis ersetzt.
Leider fährt das System immer noch nicht hoch.
Die ursprüngliche Fehlermeldung ist zwar verschwunden, wurde jedoch von dieser abgelöst:

lsass.exe:
"Bei dem Versuch, ein Kennwort zu aktualisieren, zeigt dieser Rückgabestatus an,
dass der als Kennwort angegebene Wert ungültig ist".

Diesmal erfolgt der Reset von alleine, etwa 1 Sekunde, nachdem die Meldung erscheint.
Im Abgesicherten Modus das gleiche.

Was auch immer diese Meldung jetzt genau bedeutet, Kennwörter hatte ich definitiv für keine der aktiven Benutzerkonten (2 Stück, Admin [abgesichert] und Hauptbenutzer [normaler Start] ) gesetzt.
Bitte warten ..
Mitglied: Kosh
14.09.2007 um 07:23 Uhr
alles klar.

dann mache dasselbe noch mal mit der datei "SAM" (von repair -> config).
dann sollte es klappen.
es kann allerdings sein etwaige angelegte benutzer dann nicht mehr vorhanden sind.
wenns das auch noch nicht war, dann auch noch "SYSTEM" umkopieren.

vergiss nicht die aktuellen reg-hives in " .old" umzubenennen.

wenn du dich dann wieder anmelden kannst schauen wir weiter.
Bitte warten ..
Mitglied: Freec75
15.09.2007 um 10:24 Uhr
Habe ich gemacht, genauer gesagt dann mit beiden Dateien, so fährt er endlich wieder hoch!

Das Hauptbenutzerkonto ist noch intakt und ich konnte erstmal alle geschützten Dokumente sichern.
Danke! Damit war für mich schonmal einiges gerettet

Hatte gestern vorher noch was ausprobiert, und auch wenn ohne Erfolg,
stünde damit seit dem noch eine parallele XP-Installation mit Zugriffsmöglichkeit auf die Systemdateien der betroffenen Installation zur Verfügung.


Ok, kurz gesagt, ich kann mich Anmelden, das System läuft bis auf einige Treiber und Dienste, Backups der reg-hives sind vorhanden, wie soll ich jetzt weiter vorgehen?
Bitte warten ..
Mitglied: Kosh
17.09.2007 um 07:25 Uhr
soweit ich dich verstanden habe hast du die berechtigungen direkt auf dem file "security" gesetzt.

das machen wir nun rückgängig.
mach den explorer auf, und setze die berechtigungen von "security.old" genau gleich wie sie bei der datei "security" gesetzt sind.

dies musst du allerdings als administrator machen.
wenn er dich die rechte nicht setzen lässt, musst du noch unter "sicherheit"->"erweitert"->"Besitzer" den besitz der datei übernehmen.

wenn du alles wieder geradegebogen hast, dann starte xp wieder von der cd, und benenne die zuvor in ".old" umbenannten regfiles wieder zurück.

nach einem neustart sollte dein system wieder wie gewohnt laufen.
Bitte warten ..
Mitglied: Freec75
25.09.2007 um 02:15 Uhr
Ich möchte mich entschuldigen, und hier eine Korrektur anbringen, nach einer Reproduktion sollte der Sachverhalt jetzt etwas besser ersichtlich werden, ich hatte alles aus dem Gedächtnis geschrieben und sorgfältig durcheinandergebracht...


Ich hatte in Regedit die Rechte für HKLM/Security geändert und beim Versuch, sie später wieder zurückzusetzen durch unüberlegtes Herumklicken an den Haken für
die Rechtevergaben, ohne es zu bemerken, alle Benutzerobjekte entfernt.
Nachdem ich den Sicherheitsdialog mit Ok geschlossen und versucht hatte, den Browser zu starten, um eine Lösung dafür zu suchen, bekam ich keine Verbindung mehr und es liessen sich danach auch keine Sicherheitseinstellungen mehr aufrufen, weder in Regedit, noch in Dateieigenschaften.
Es kam statt der Dialogfenster nur die Fehlermeldung, dass der Computer keiner eindeutigen Domäne mehr zugeordnet werden könne.
Ich veranlasste dann einen Neustart...

Nun ist es eloganter beschrieben, wenn auch auch noch unangenehmer für mich zu lesen

Ab da sollte es hinkommen.

Ich hatte dann versucht, den letzten Tip einfach so umzusetzen:
Hab die Rechtevergaben am Root-Key in der security.old mit dem aktiven hive als Vorlage wieder gesetzt, was problemlos möglich war, sofern ich das File als Struktur lud und dabei umbenannte.
Trotzdem kam beim Booten dann dies:
lsass.exe
Die Sicherheitskontenverwaltung konnte nicht geladen werden, da Folgender Fehler aufgetreten ist: Zugriff verweigert. Fehlerstatus 0x00002222
Empfehlung in dieser Box dann: Abgesichert Starten, Protokoll lesen.

Kam auch beim abgesicherten, protokollierten Start, und die Bootlog.txt, sofern damit gemeint, war danach unlesbar, ASCII war das jedenfalls nicht...
Die zwei .old Files hatte ich über die "Repairs" kopiert und das von Regedit neu ins Config-Verzeichnis geschriebene File umbenannt.

Statt mich weiter zu wundern, wollte ich nochmal fragen, ob unter diesen Voraussetzungen noch etwas zu machen ist, wegen dem ursprünglichen Text nochmals sorry, der Tag war eben meiner nicht....
Bitte warten ..
Ähnliche Inhalte
Windows XP

XP Registry Zugriff verweigert unter SYSTEM

Frage von 122573Windows XP2 Kommentare

Hallo, ich versuche gerade auf nem JVC Netbook Updates für XP Embedded zu installieren. Mit ner .reg Datei, ist ...

Windows Server

Windows 2012 R2 ausgesperrt

gelöst Frage von momaiWindows Server2 Kommentare

Hallo, ich habe mich heute wohl von einem Windows Server ausgesperrt bzw. ich komme nicht mehr via RDP drauf. ...

Windows Server

Windows Server 2008 ausgesperrt, RDP gelöscht

Frage von RS1983Windows Server6 Kommentare

Hallo zusammen wie im Titel schon geschireben, wurde wohl durch einen meiner Mitarbeiter versehentlich der RDP Port 3389 gelöscht. ...

Windows Userverwaltung

Mit gpedit selber ausgesperrt

gelöst Frage von computerpapWindows Userverwaltung3 Kommentare

Hallo Ich habe mit gpedit herumgespielt und mich selber ausgesperrt. Ich habe Win10 welches ich von Win7 Ultimate hochgezogen ...

Neue Wissensbeiträge
Windows 10

Windows 10 - Programme laufen schneller, wenn Sie mit Administratorrechten ausgeführt werden !

Erfahrungsbericht von 1Werner1 vor 5 StundenWindows 106 Kommentare

Moin, das wollte ich erst nicht glauben, aber es ist so. Wenn Ihr ein Programm mit Administratorrechten unter Windows ...

Sicherheits-Tools
Putty hat heftige Bugs korrigiert!
Information von Lochkartenstanzer vor 1 TagSicherheits-Tools5 Kommentare

Moin, Wie man aus herauslesen kann, sind in den Versionen vor 0.71 gravierende Bugs, die es angeraten erscheinen lassen, ...

Off Topic
Sachen die die Welt nicht braucht - Platz 1
Tipp von brammer vor 4 TagenOff Topic21 Kommentare

Hallo, ich habs als Tipp angelegt als Erfahrungsbericht nein Danke brammer

Humor (lol)
Spirit of Health-Kongress in Berlin
Information von AnkhMorpork vor 4 TagenHumor (lol)6 Kommentare

tgif! Beim dritten Spirit of Health-Kongress trafen sich am Wochenende Alternativmediziner und Naturheilkundler im Maritim Hotel Berlin, um sich ...

Heiß diskutierte Inhalte
Windows Server
Eingeschränkte Gruppen - Spezielle Benutzergruppe hinzufügen
Frage von killtecWindows Server17 Kommentare

Hallo, ich möchte gerne folgendes Realisieren: Ich habe bei mir Eingeschränkte Gruppen via GPO aktiv und möchte nun der ...

Microsoft Office
Videodateien auf Windows Server 2008 R2 öffnen schlägt fehl
Frage von SchroediMicrosoft Office13 Kommentare

Hallo zusammen, wir haben das Problem das embedded Videos in PowerPoint (O365) auf unserer Citrix Farm (6.5) nicht abgespielt ...

DNS
Größere DNS Probleme nach zweitem DC. Eigentlich sollte es auch dadurch besser werden
Frage von TeWutzDNS13 Kommentare

Hallo zusammen, nachdem ich letzte Woche erfolgreich einen zweiten DC ) an den Start gebracht habe melden sich weiterhin ...

LAN, WAN, Wireless
Switch als Verbindung von 2 Netzwerken
gelöst Frage von Lutz-ReLAN, WAN, Wireless12 Kommentare

Guten Tag Ich hab folgendes Problem 2 Rechner und 2 IP Kameras sind ohne dhcp in einen IP4 Netzwerk ...