Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

WinXP-Client über Linux-VPN-Server ins andere Netz

Mitglied: 43092

43092 (Level 1)

07.02.2007, aktualisiert 18.10.2012, 4376 Aufrufe, 10 Kommentare

Routingprobleme im VPN

Hallo,

ich habe bei mir Zuhause einen SuSE-10.1-Rechner stehen. Dieser hängt über einen Router im Internet. Ich habe jetzt pptp auf dem Server konfiguriert, kann mich auch auf diesen Verbinden, bekomme ne IP und kann beide Interfaces des Servers (sowohl eth0 als auch mein gegenüber des ppp) pingen. Nur hinter dem Server (einen Netzwerkdrucker oder Win-PC) kann ich nicht pingen.
Beide (sowohl Drucker als auch Win-PC in meinem Heimnetz) haben per DHCP als Gateway den Router eingetragen. Kann also vom Routing her nicht funktionieren. Habe also den Server so konfiguriert das er Pakete routet (sollte er jedenfalls) und den Server auf dem Win-PC als Gateway eingetragen. Nun kann ich nichts mehr im Inet pingen. Der Name wird noch aufgelöst (Nameserver klappt also) aber es kommt kein Ping zurück. Masquerading ist auf dem Server auch aktiviert.....ich weiß nicht mehr weiter.

Ich will einfach nur von meinem Rechner aus eine RDP-Verbindung zu einem Rechner in meinem Heimnetzwerk aufbauen.


Jemand ne Idee wie ich das doch noc hinkriege?

Gruß

nullomat
Mitglied: Dani
07.02.2007 um 18:56 Uhr
Hi,
welche IP-Adresse bekommst du, wenn du dich per VPN einwählst und welche IP-Adressen verwendest du im LAN.
Der Server wird eine NIC haben und diese ist mit dem Router verbunden.
Ich nehme an, wenn du beim LAN-Client den Server als GW hinterlegst, kannst du dein VPN-Client erreichen?!
Ich würde vermuten, dass auf dem Server noch eine Route nötig ist. Könntest du mal die Routingtabelle posten??!!


Gruß
Dani
Bitte warten ..
Mitglied: 43092
07.02.2007 um 20:02 Uhr
Dann legen wir mal los.

Also, der Server hat die 192.168.2.11 auf der NIC, der Router die 192.168.2.1, der Lan-Client die 192.168.2.15.
Per VPN kriege ich am VPN-CLient die 192.168.2.100, der Server hat die 192.168.2.2 (dann spar ich mir das NAT auf dem Server).

Also, hier dir Routing-Tabelle vom Server.

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
localhost * 255.255.255.0 U 0 0 0 eth0
localhost * 255.255.255.0 U 0 0 0 tap0
link-local * 255.255.0.0 U 0 0 0 eth0
loopback * 255.0.0.0 U 0 0 0 lo
default router 0.0.0.0 UG 0 0 0 eth0



Hier die Routingtabelle von LAN-Client:
Aktive Routen:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Anzahl
0.0.0.0 0.0.0.0 192.168.2.11 192.168.2.15 20
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.2.0 255.255.255.0 192.168.2.15 192.168.2.15 20
192.168.2.15 255.255.255.255 127.0.0.1 127.0.0.1 20
192.168.2.255 255.255.255.255 192.168.2.15 192.168.2.15 20
224.0.0.0 240.0.0.0 192.168.2.15 192.168.2.15 20
255.255.255.255 255.255.255.255 192.168.2.15 192.168.2.15 1
Standardgateway: 192.168.2.11


Hier die Route des VPN-CLient:

Aktive Routen:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Anzahl
0.0.0.0 0.0.0.0 192.168.1.1 192.168.1.22 25
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.1.0 255.255.255.0 192.168.1.22 192.168.1.22 25
192.168.1.22 255.255.255.255 127.0.0.1 127.0.0.1 25
192.168.1.255 255.255.255.255 192.168.1.22 192.168.1.22 25
224.0.0.0 240.0.0.0 192.168.1.22 192.168.1.22 25
255.255.255.255 255.255.255.255 192.168.1.22 3 1
255.255.255.255 255.255.255.255 192.168.1.22 192.168.1.22 1
Standardgateway: 192.168.1.1
Ständige Routen:
Keine


Wie man sieht habe ich jetzt mal auf dem LAN-Client als Standard-Gateway den Server engegeben......ich komm jetzt mit dem LAN-Client nicht mehr ins I-Net was die Vermutung nahelegt das der SCHEISS-SERVER einfach nicht routet. Warum weiß der Geier.

Traceroute vom LAN-CLient ins Netz:

C:\Dokumente und Einstellungen\Computer>tracert www.web.de

Routenverfolgung zu www.web.de [217.72.195.42] 374ber maximal 30 Abschnitte:

1 * * * Zeit374berschreitung der Anforderung.


Sorry wenn die Umlaute nicht so richtig kommen aber ich komme nur über Umwege an den Lan-Client ran.

gruß

nullomat
Bitte warten ..
Mitglied: Dani
09.02.2007, aktualisiert 18.10.2012
Hi,
Wie man sieht habe ich jetzt mal auf dem LAN-Client als Standard-Gateway den Server
engegeben......ich komm jetzt mit dem LAN-Client nicht mehr ins I-Net was die Vermutung
nahelegt das der SCHEISS-SERVER einfach nicht routet. Warum weiß der Geier.

Also das Problem haben wie hier schon gelöst:
https://www.administrator.de/forum/keine-verbindung-%c3%bcber-modem-am-s ...


Gruß
Dani
Bitte warten ..
Mitglied: Kevin26
09.02.2007 um 21:32 Uhr
Naja, mein Problem wurde dadurch nicht gelöst.....aber ich hab mir das ganze auf ne andere Weise zu Herzen genommen.

Ich hab mir nochmal die ip_forward angekuckt. Wie bereits beschrieben war das Routing im SuSe aktiviert was ja nichts anderes mach als die ip_forward zu editieren und ne "1" reinzusetezne. War damals auch gesetzt, geroutet hat nichts. Nunja, heut war auf jedenfalls ne "0" drin obwohl im Yast immernoch das Routing aktiviert ist. Habe das ganze jetzt hart in die boot.local eingetragen. Das Routing funktioniert jetzt, der Lan-Client ist jetzt vom VPN-Client zumindest pingbar.

Jetzt will ich ne RDP-Vebrindung vom VPN-Client zum LAN-CLient aufmachen. Trotz Ping krieg ich keine Verbindung her. Das RDP auf dem Lan-Client funktioniert aber, vom Server aus kann ich auf den Client zugreifen.

Krieg ich über das pptp-Tunnel-gedöhns nicht alle Protokolle drüber? Normalerweise müsste es ja gehen.

Gurß

Kevin


BTW: Der postrouting-Eintrag ist für diese Situationegal da ich kein Masquerading brauche. Bin im selben IP-Bereich.
Bitte warten ..
Mitglied: Dani
09.02.2007 um 21:45 Uhr
G' Abend,
das ist schon mal was. Hast du auf dem Server die Firewall deaktiviert?! Ja - komisch...
Ansonsten die Ports aufmachen, die RDP braucht!


Gruß
Dani
Bitte warten ..
Mitglied: Kevin26
10.02.2007 um 10:02 Uhr
Firewall läuft nirgends. Halt von Firewalls nix da ich eh mit jedem Gerät hinter enm Router hänge.
Bitte warten ..
Mitglied: Dani
10.02.2007 um 14:30 Uhr
Hi,
Suse hat aber immer eine dabei?! rc tab tab => Suse2Firewall
Dann rc Suse2Firewall stop.


Gruß
Dani
Bitte warten ..
Mitglied: Kevin26
10.02.2007 um 15:08 Uhr
Wie gesagt....die läuft nicht. Hab die aus dem Runlevel rausgeschmissen.
Bitte warten ..
Mitglied: Kevin26
11.02.2007 um 14:04 Uhr
So, gestern habe ich das ganze mal von nem anderen Rechner aus probiert. Ich kriege eine Verbindung, bekomme die RDP-Session auf und kann mich anmelden. Nach kurzer Zeit scheint sich die Verbindung aber irgendwie zu verändern. Die Verbindung wird noch als aktiv vermerkt, es werden aber keine Pakete mehr an den Lan-CLient übertragen. Ein Ping der vorher noch ging ist dann auf einmal nicht mehr möglich.

Das ganze ist schon sehr merkwürdig.

Gruß

Kevin
Bitte warten ..
Mitglied: Dani
12.02.2007 um 00:29 Uhr
G' Abend,
in der Tat. Ich kann mir leider keinen Rheim drauf machen. Warum und wodurch das passiert?!


Gruß
Dani
Bitte warten ..
Ähnliche Inhalte
Linux Tools

ShrewSoft VPN-Client unter Linux keine Daten

Frage von EnzephaloNLinux Tools5 Kommentare

Hallo Ich habe erfolgreich unter Windows den ShrewSoft VPN-Client eingesetzt um mich mit einem VPN eines Kunden zu verbinden. ...

DSL, VDSL

Sprechen Fritzboxen mit jedem Linux VPN Client?

gelöst Frage von QQR700DSL, VDSL8 Kommentare

Hallo, ich hoffe, ich bin mit meiner Frage hier in der richtigen Gruppe?! Ich plane den Zugang zu einem ...

LAN, WAN, Wireless

Vom VPN Netz ins private Netz

gelöst Frage von DasBillLAN, WAN, Wireless15 Kommentare

Guten Abend, ich betreibe einen ESXi 6 Server auf dem insgesamt drei virtuelle Maschinen laufen eine Sophos UTM Home ...

Router & Routing

VPN über nachgelagerten DDWRT Router mit Client im selben Netz

gelöst Frage von kuckucksuhrRouter & Routing4 Kommentare

Hallo Zusammen, ich würde mich über eure Hilfe freuen, da in Sachen VPN leider noch nicht viel Erfahrung sammeln ...

Neue Wissensbeiträge
Internet

Schwarzer Tag für die Netzfreiheit: Die umstrittene Urheberrechtsreform wurde beschlossen

Information von Frank vor 1 StundeInternet6 Kommentare

Ich zitiere einfach mal Julia Reda von den Piraten, da mir selbst einfach die Worte dazu fehlen: Schwarzer Tag ...

Internet
Ist zwar keien Anleitung, aber
Anleitung von SachsenHessi vor 1 StundeInternet1 Kommentar

oder doch eine Anleitung ? Für die nächste EU-Wahl ? SH

PHP
Pfsense - Vouchergenerator 1.6.1
Anleitung von cafepost vor 3 StundenPHP

Hallo Zusammen , aus Sicherheitsgründen wurde mein Server auf den neuesten Stand gebracht, jetzt wollte ich den Vouchergenerator 1.6.1 ...

Internet

Verlag protestiert gegen Artikel 13 (jetzt Artikel 17) der geplanten EU-Verordnung

Information von Dilbert-MD vor 6 StundenInternet

Leider etwas spät, aber immerhin hat auch der heise-Verlag eingesehen, dass die Umsetzung der Urheberrechtsreform - so wie sie ...

Heiß diskutierte Inhalte
Voice over IP
Mikrotik: Voip mit SIP Phones in verschiedenen Subnetzen mit FritzBox
Frage von SpartacusVoice over IP16 Kommentare

Hallo, ich habe das Problem, dass ich verschiedene SIP-Clients in unterschiedlichen Subnetzen habe, die mit meinem Server FritzBox7412 keine ...

Exchange Server
Exchange Empfangsconnector nimmt keine SMTP Verbindung von extern an
gelöst Frage von lasterExchange Server12 Kommentare

Hallo, ich kann keine E-Mails aus einem anderen/fremden LAN an Exchange zustellen. Aus dem LAN, in dem auch der ...

Grafik
Viele Fotos organisieren - Windows Dateisystem zu lahm bzw. überfordert
Frage von augustaparkGrafik12 Kommentare

Hallo und Guten Morgen, hat einer eine Idee, wie man viele Fotos sinnvoll und effizient organisieren kann? Wir haben ...

Windows 10
22 Notebooks automatisch konfigurieren und Software installieren - womit?
gelöst Frage von ipzipzapWindows 1012 Kommentare

Hallo, ich habe für ein Projekt 22 nagelneue Notebooks mit Windows 10 bekommen, die ich alle im Großen und ...