Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

XP: Verzeichnis s, sy oder sys kann nicht angelegt werden

Mitglied: mk

mk (Level 1) - Jetzt verbinden

25.02.2006, aktualisiert 15.04.2006, 7718 Aufrufe, 25 Kommentare

Hallo!

Auf meiner XP-Prof.-Maschine kann ich keine Verzeichnisse mit Namen "s", "sy" oder "sys" anlegen (ich bin als Administrator angemeldet).

Fehlermeldungen:

- auf der Konsole: "md sys" -> "Das System kann die angegebene Datei nicht finden."
- im Explorer : ... -> "Neuer Ordner kann nicht umbenannt werden, das System kann die angegebene Datei nicht finden..."

Kennt jemand die Lösung dieses Problems?

Gruß
Michael
Mitglied: RobertTischler
25.02.2006 um 17:57 Uhr
Hallo

Was hast den gemacht? Habe eingeschränkte rechte und kann das alles machen. Hast du im system irgent wo rumgespielt? Was für ein OS hast du eigentlich.

MFG

PS: ja ich hab´s gesehen steht aber so am anfang etwas deplaziert, habe mich auf die Beschreibung konzentriert.
Bitte warten ..
Mitglied: 16568
25.02.2006 um 18:00 Uhr
@Robert Tischler:

Du scheinst es ja mächtig auf Punkte abgesehen zu haben, wa?

Ma kucken, was der Mod dazu so meint...

Die Gegenfrage welches OS ist ja hier wohl vollkommen deplaziert...


Lonesome Walker
Bitte warten ..
Mitglied: mk
25.02.2006 um 18:06 Uhr
Hallo!

Offensichtlich HABE ich am System 'rumgespielt, oder irgendwas installiert, ich wüsste nur gerne was das war (OS wie bereits angegeben: Win XP Professional)

Michael
Bitte warten ..
Mitglied: MagicM
25.02.2006 um 18:16 Uhr
... vielleicht irgendeine Security-Suite, die installiert wurde?
Bitte warten ..
Mitglied: mk
25.02.2006 um 18:34 Uhr
... da ist nur AntiVir Personal Edition

Interessanterweise kann ich aber alle (?) anderen Verzeichnisnamen anlegen!
Bitte warten ..
Mitglied: 16568
25.02.2006 um 18:56 Uhr
Hast Du ein packprogramm wie WinZip oder WinRAR installiert?

Dann schick ich Dir mal ein Archiv, das ein paar Ordner enthält:
s, sys, und sy ^^



Lonesome Walker
Bitte warten ..
Mitglied: mk
25.02.2006 um 18:58 Uhr
Ja: WinZip.

Meinst du, dass beim Entpacken das Verzeichnis angelegt werden kann?
Bitte warten ..
Mitglied: 16568
25.02.2006 um 19:01 Uhr
Ich hoffe es mal ^^

Hast Du eine Mail-Addy?

Wenn ja, dann bitte PN.


Gruß


Lonesome Walker
Bitte warten ..
Mitglied: mk
25.02.2006 um 19:11 Uhr
O.k., Zipfile kam an, danke!
WinZip meckert aber, dass nichts zu entpacken wäre. Waren die Ordner leer?
Bitte warten ..
Mitglied: 16568
25.02.2006 um 19:13 Uhr
Jupp, die Ordner waren leer, aber er hätte eigentlich die Ordner entpacken/erstellen sollen.

Mom, ich schicke neue...


Lonesome Walker
Bitte warten ..
Mitglied: mk
25.02.2006 um 19:20 Uhr
Same procedure...

Das "system"-Verzeichnis wurde angelegt, sonst nix ???
Bitte warten ..
Mitglied: 16568
25.02.2006 um 19:26 Uhr
Uargh, dann würde ich ma sagen, Du hast ein SEHR ungewöhnliches Problem.

Wie aufwendig wäre eine Neuinstallation

Ja, ich weiß, hat keiner Bock, aber hat auch keiner Bock auf Backup ^^


In der Tat, sowas ist mir noch nie untergekommen...



Lonesome Walker
Bitte warten ..
Mitglied: MagicM
25.02.2006 um 19:31 Uhr
Hast Du schon die standardvorgehensweise ausprobiert: Systemwiederherstellung abschalten, Antivir abschalten, alle nicht notwendigen Programme und Dienste beenden?
Bitte warten ..
Mitglied: RobertTischler
25.02.2006 um 19:53 Uhr
Hallo

Hab mal in der Technet Datenbank gesucht und leider auch nichts gefunden. Wird dir wohl nichts anderes übrig bleiben als neu zu Installieren und dann nach jeder Installation zu Testen ob der Fehler wieder auf tritt. Mal eine andere Frage was bezwegst zu mit dem Verzeichnis SYS?

MFG
Bitte warten ..
Mitglied: gamefreaktegel
26.02.2006 um 10:46 Uhr
Hallo Leute,

also es gibt in der Registry Einträge die "verbotene" Ordner enthalten... ihr alle könnt z.B. nicht den Ordner "com1" erstellen, weil dieser für den Seriellen Anschluss reserviert ist.

Man müsste mal die Registry durchstöbern ob man im selben Bereich wie com1 auch was mit sys findet...
Bitte warten ..
Mitglied: mk
26.02.2006 um 12:06 Uhr
Zum vorletzten Kommentar: Standard C-Include-Files in ../include/sys

Zum letzten: Wie sind die "verbotenen Ordner"-Einträge zu finden?
Bitte warten ..
Mitglied: Minicat
11.03.2006 um 14:18 Uhr
Hallo,

seit ihr inzwischen weiter gekommen? Ich habe hier nämlich das gleiche Problem.
Erstmal:
WinXP Home
AVG Anti-Virus
MS Anti-Spyware (Beta)
Verzeichnisse S, SY und SYS können nicht angelegt werden.

Zweite Festplatte: Win2000 Prof.
Wenn ich unter 2000 ein Verzeichnis S anlege geht es. Auch auf der XP-Partition. Wenn ich jetzt XP boote ist das Verzeichnis weg. Unsichtbar aber noch irgendwie vorhanden.

Nun habe ich ein Verzeichnis im Papierkorb liegen, darin ein Unterverzeichnis mit dem Namen S und WindowsXP kann den Papierkorb nicht leeren. Fehlermeldung: Das Verzeichnis XXX ist ist leer (beim LÖSCHEN!)

Boote ich XP im abgesicherten Modus klappt alles einwandfrei. Aufgefallen ist es, als ich eine CD installieren wollte und das nicht ging, weil die Software immer beim Versuch ein Verzeichnis mit Namen S anzulegen ausgestiegen ist.

Übrigens:
Wenn ich ein neues Verzeichnis anlege und versuch den Namen in COM1 oder LPT1 zu ändern, dann wird das einfach nicht gemacht. Weiter geschieht nichts. Bei S, SY und SYS kommt ein Fehlermeldungsrequester. Das Problem scheint etwas komplizierter zu sein. Und die Registry nach S, SY oder SYS zu durchsuchen dürfte wohl sinnlos sein.

Also falls jemanden noch was dazu einfällt, wäre für jeden Tip dankbar.
Bitte warten ..
Mitglied: 16568
11.03.2006 um 14:39 Uhr
Hm, ich würde mir jetzt mal einen Rootkit-Scanner zulegen.

Das hört sich jetzt nämlich stark danach an...


Lonesome Walker
Bitte warten ..
Mitglied: Minicat
11.03.2006 um 14:47 Uhr
Rootkit, da sträuben sich meine Nackenhaare wenn ich nur dran denke. Aber ist vielleicht wirklich mal an der Zeit, sich das anzusehen.

Obwohl ich was anderes im Verdacht habe. Vor kurzem hat sich so ein Clone vom SpySheriff hier breitgemacht. Ich habe den zwar wieder von der Platte geputzt, aber wer weis, was der noch an Hinterlassenschaften im System hat. Ich würde am liebsten neu installieren, aber leider heißt das 100% Neuinstallation, da ich so eine elendige OEM habe, die nur Install mit Format C: kennt. Also ist das die allerlette Alternative.

Na gut, mal einen Rootkit-Scanner suchen gehen...
Bitte warten ..
Mitglied: Minicat
11.03.2006 um 16:46 Uhr
Ja, genau den habe ich auch gefunden. Scannt noch (2te Platte). Aber C: ist fertig. Alle möglichen Verzeichnisse von Cygwin, GCC etc. sind "Hidden from Windows.API" weil der Name s oder sys ist. Viel Interessanter sind aber zwei Einträge in der Registry:
HKLM\System\ControlSet001\Services\sysybus.32 11-3-2206 Hiddem from Windows.API
HKLM\System\ControlSet004\Services\sysybus.32 11-3-2206 hiddem from Windows.API
und
c:\WINDOWS\system32\drivers\sysbus32.sys 7-3-2006 Hidden from Windows.API

Wenn das ganze durch ist werde ich mal sehen, was für Korrekturmöglichkeiten das Programm anbietet, aber ich denke, der Urheber ist identifiziert.
Bitte warten ..
Mitglied: Minicat
11.03.2006 um 17:18 Uhr
SO, das Problem ist definitiv geklärt.

Es ist ein Rootkit das dazu dient alle Verzeichnisse und Programme mit dem Namen S, SY und SYS zu verstecken.

Bei F-Secure gibt es eine kostenlose Beta-Version von Blacklight. Dieses Tool findet das Rootkit und bietet einen Rename an. Ich habe es gemacht und siehe da, alle Verzeichnisse und Files sind wieder da, man kann wieder Verzeichnisse und Files mit dem Namen S, SY, SYS anlegen, bearbeiten oder löschen!

Danke auch an Lonesome Walker, dein Tip mit dem Rootkit hat den Durchbruch gebracht!
Bitte warten ..
Mitglied: buga
15.04.2006 um 15:53 Uhr
Hallo Leute, vielen Dank für eure Ausführungen, ihr habt mir sehr geholfen.

Ich hatte exakt dasselbe Problem. Bin bei der Installation von RubyOnRails drauf gestossen. Im Ruby-Verzeichnisbaum gibts einen Ordner namens sys, and dem der Installer aus mir unerfindlichen Gründen scheiterte. Dachte zunächst, es sei ein Problem von Ruby, habe aber auf den Ruby-Seiten keinerlei Hinweis gefunden. Bis ich feststellte, dass ich auch manuell keinen sys-Ordner anlegen kann...(auf den Netzlaufwerken gings, aber nicht auf den lokalen Platten).

Als nächstes hatte ich XP-SP2 im Verdacht - aber auch da war nichts zu finden.

Erst nach etlichen Stunden Sucherei bin ich auf diesen Artikel gestoßen. Nachdem ich nun wieder mal kräftig Zeit verbraten habe, ist das Problem glücklicherweise gelöst.

Nochmals danke, ihr habt mich vor dem Wahnsinn bewahrt.

Grüße,
buga
Bitte warten ..
Mitglied: Biber
15.04.2006 um 20:17 Uhr
Eine Bitte noch, mk,

bitte sende eine kurze PN an Atti58 als zuständigen mit der Bitte, diesen Beitrag in "Viren & Trojaner" zu verschieben.

Ein paar Sterne gebe ich diesem Thread mit auf die Reise.

Gruß
Biber
Bitte warten ..
Mitglied: mk
15.04.2006 um 20:52 Uhr
Genial! Vielen Dank für die Lösung des Problems. Letzte Frage(n): Was passiert nach dem Rename durch Blacklight? Sollte die umbenannte Datei gelöscht werden?

Gruß mk
Bitte warten ..
Ähnliche Inhalte
Batch & Shell

Powershell Kopiere Dateien in s Archiv Verzeichnis

gelöst Frage von pixel0815Batch & Shell6 Kommentare

Mooin zusammen, irgendwie sollte dieses Skript alle Dateien von der Source die innerhalb 24h erstellt worden sind auf den ...

SAN, NAS, DAS

Synology DS1815+ Raid Sys

Frage von creationSAN, NAS, DAS1 Kommentar

Hallo zusammen, ich habe eine Frage zum Aufbau des Raid-Systems zweier NAS Systeme. In dem System gibt es 1 ...

Debian

Find: sys kernel debug Permission denied

Frage von vikozoDebian

guten Tag ich habe unter Proxmox ein LXC Container erstellt Linux prox1 4.4.15-1-pve (gcc version 4.9.2 (Debian 4.9.2-10) wenn ...

RedHat, CentOS, Fedora

Oracle Linux 7.1 sys-unconfig funktioniert nicht

Frage von RoxyyoRedHat, CentOS, Fedora

Hallo zusammen, ich habe eine Oracle Linux 7.1 VM mit dem Kernel 3.8.13. Ich würde diese VM gerne als ...

Neue Wissensbeiträge
Erkennung und -Abwehr

Trend Micro Worry Free Business Security 10.0 - erneutes Patch (1494) erschienen!

Tipp von VGem-e vor 2 StundenErkennung und -Abwehr

Moin, unter ist ein neuer Patch verfügbar, der offenbar auch Windows 10.1809 unterstützt. Tja, wie letztes Mal auch, erst ...

Humor (lol)
Administrator.de Perlen
Tipp von DerWindowsFreak2 vor 4 TagenHumor (lol)6 Kommentare

Hallo, Heute beim stöbern auf dieser Seite bin auf folgenden Thread aus dem Jahre 2006 gestossen: Was meint ihr? ...

Erkennung und -Abwehr
OpenSSH-Backdoor Malware erkennen
Tipp von Frank vor 5 TagenErkennung und -Abwehr

Sicherheitsforscher von Eset haben 21 Malware-Familien untersucht. Die Malware soll Hintertüren via OpenSSH bereitstellen, so dass Angreifer Fernzugriff auf ...

iOS
WatchChat für Whatsapp
Tipp von Criemo vor 9 TageniOS5 Kommentare

Ziemlich coole App für WhatsApp User in Verbindung mit der Apple Watch. Gibts für iOS sowohl als auch für ...

Heiß diskutierte Inhalte
Samba
Windows 10 Client in Samba-Domäne hinzufügen scheitert
Frage von diwaffmSamba32 Kommentare

Hi Leute, ich habe einen Samba Server in der Version 4.9.3 auf einer OpenSuse Maschine laufen. Damit sind momentan ...

Windows Systemdateien
Verknüpfungen nach Pfadwechsel
Frage von Hendrik2586Windows Systemdateien17 Kommentare

Guten Morgen meine lieben Kollegen und Kolleginnen, ich hab da mal eine Frage die Ihr sicher schon kennt. Es ...

Netzwerkmanagement
Sehr langsame Netzverbindung in einem bestimmten Subnet
gelöst Frage von gabeBUNetzwerkmanagement16 Kommentare

Hallo Zusammen Ich habe das folgende Problem: Unser Netzwerk, dass aus verschiedenen Subnetzwerken aufgebaut ist, ist nicht in jedem ...

Exchange Server
Exchange Server 2016 - Autodiscover mehrere Domänen
gelöst Frage von K-ist-KExchange Server15 Kommentare

Hallo, folgende Dinge sind wichtig notwendig, damit Autodiscover funktioniert: - Namensauflösung (zB autodiscover.google.at) - gültiges Zertifikat - .XML Datei ...