Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Zabbix-Server läuft nicht

Mitglied: honeybee

honeybee (Level 2) - Jetzt verbinden

02.09.2016, aktualisiert 11:21 Uhr, 4260 Aufrufe, 8 Kommentare

Hallo,

im Zabbix-Dashboard kam diese Meldung:

Zabbix server is not running: the information displayed may not be current.

und

Zabbix server is running = No 172.x.x.x:10051


Auf dem Server sieht es aber so aus:

01.
root@xxx:~# service zabbix-server start
02.
Starting Zabbix server daemon: zabbix_server
03.
/usr/local/sbin/zabbix_server already running.

So sieht es in der zabbix.conf.php aus:

01.
<?php
02.
// Zabbix GUI configuration file.
03.
global $DB;
04.

05.
$DB['TYPE']     = 'MYSQL';
06.
$DB['SERVER']   = 'localhost';
07.
$DB['PORT']     = '0';
08.
$DB['DATABASE'] = 'zabbix';
09.
$DB['USER']     = 'root';
10.
$DB['PASSWORD'] = 'xxx';
11.

12.
// Schema name. Used for IBM DB2 and PostgreSQL.
13.
$DB['SCHEMA'] = '';
14.

15.
$ZBX_SERVER      = '172.x.x.x';
16.
$ZBX_SERVER_PORT = '10051';
17.
$ZBX_SERVER_NAME = '';
18.

19.
$IMAGE_FORMAT_DEFAULT = IMAGE_FORMAT_PNG;
20.
?>

Habe Ubuntu 14.04.5 und die Zabbix-Version 3.0.4.
Wie bringe ich den Server "richtig" zum Laufen?
Mitglied: certifiedit.net
02.09.2016 um 11:23 Uhr
Hallo,

nachdem nur DU von deinem Netz mehr weisst: In dem DU schaust, wo er nicht richtig konfiguriert ist. Die DB Connection wird es allerdings vmtl nicht sein.

Alternativ darfst du gerne auf mich zu kommen und ich schau mir das am lebenden/bzw derzeit toten? Objekt direkt an.

Viele Grüße,

Christian
Bitte warten ..
Mitglied: KMUlife
02.09.2016 um 11:32 Uhr
Hey honeybee

Ansonsten zufrieden mit zabbix?

Allenfalls wird das ganze auch durch eine Portblockade nicht durchgereicht.
Greifst du von einem entfernten System auf den Zabbixserver zu (Dashboard)?
Oder direkt vom Z-Server?

Zabbix server is not running: the information displayed may not be current. --> Hats dir mal Daten angezeigt oder noch nie?

Grüsse
KMUlife
Bitte warten ..
Mitglied: honeybee
02.09.2016, aktualisiert um 11:38 Uhr
Ansonsten zufrieden mit zabbix?

Ja. Bin von Version 2.4.8 auf Version 3.0.4 gewechselt. Habe noch die Backups.

Allenfalls wird das ganze auch durch eine Portblockade nicht durchgereicht.
Greifst du von einem entfernten System auf den Zabbixserver zu (Dashboard)?
Oder direkt vom Z-Server?

Von einem entfernten System aus. Die Pings funktionieren und der Port ist geöffnet (mit Telnet geprüft).

Hats dir mal Daten angezeigt oder noch nie?

Es fehlen nähere Details zum Fehler. Deshalb bin ich ziemlich ratlos, wo der Fehler ist.

edit: Der Zabbix selbst ist "noch bedienbar", d. h. ich kann Hosts hinzufügen etc., aber der Dienst läuft anscheinend trotzdem nicht... obwohl er laut Server gestartet ist...
Bitte warten ..
Mitglied: cuilster
02.09.2016 um 11:45 Uhr
Hi.

Ich hatte vor kurzen ein ähnliches Problem. Nach dem Upgrade hatte sich der Pfad für das PID File geändert. Der Server lief, aber unter nem anderen Prozess als in dem server.conf angegebenen Pfad zum PID file. Es gab dann zwei PID Files und das Dashboard sagte "server not running" obwohl er lief.

gruß c
Bitte warten ..
Mitglied: honeybee
02.09.2016 um 11:49 Uhr
Ich hatte vor kurzen ein ähnliches Problem. Nach dem Upgrade hatte sich der Pfad für das PID File geändert. Der Server lief, aber unter nem anderen Prozess als in dem server.conf angegebenen Pfad zum PID file. Es gab dann zwei PID Files und das Dashboard sagte "server not running" obwohl er lief.

Danke für den Hinweis. Kannst du mir sagen, wie und wo ich das prüfen kann? Bin leider kein Linux-Profi...
Bitte warten ..
Mitglied: cuilster
02.09.2016 um 12:12 Uhr


in der server.conf ist der pfad zum PID file hintelegt.

also
01.
nano /etc/zabbix/zabbix_server.conf
da steht dann sowas wie
01.
PidFile=/var/run/zabbix/zabbix_server.pid
dann guckst du da rein
01.
nano /var/run/zabbix/zabbix_server.pid
Da steht dann die Prozess_ID
mit
01.
ps aux | grep zabbix
kannst du alle Prozesse anzeigen lassen welche "zabbix" enthalten...

ich steh grad en bissel auf dem schlauch was die lösung anbetrifft... kann sein das dass grad vollkommen in die falsche richtung geht
guck ma bitte ins server log

/var/log/zabbix/zabbix_server

oder entnimm den pfad aus der server.conf...
Bitte warten ..
Mitglied: cuilster
LÖSUNG 02.09.2016 um 12:36 Uhr
...kann natürlich auch an deinem SELinux liegen... falls das die gleiche Büchse betrifft...

ansonsten hier:
https://www.zabbix.com/forum/showthread.php?t=32326&page=4

Grüße
Bitte warten ..
Mitglied: honeybee
05.09.2016 um 13:37 Uhr
Bin zu CentOS umgestiegen. Dort hat es geklappt. Ist wohl ein Ubuntu-Problem.
Bitte warten ..
Ähnliche Inhalte
Windows Server
Ps1 Script lauft nicht
gelöst Frage von 131455Windows Server8 Kommentare

Hallo, führe ich Zeilen wie würde die eben als Aufgabenplanung gerne hinterlegen. Gruss Rainer

Monitoring

Zabbix: Festplattenbelegung überwachen

gelöst Frage von honeybeeMonitoring10 Kommentare

Hallo, ich möchte mit Zabbix die Speicherbelegung aller Festplattenvolumes überwachen. Leider werden keine Daten gesammelt. Habe ich in den ...

Monitoring

Zabbix - Cisco Switch monitoren

Frage von malawiMonitoring4 Kommentare

Hallo, ich habe einen Zabbix-Server mit dem ich nun einen Cisco 2960-X IOS-Switch monitoren möchte. Der Cisco-Switch ist aktuell ...

Monitoring

Zabbix und Dell Openmanage

Frage von meister00Monitoring8 Kommentare

hallo, wir haben einen zabbix 2.4 server und ich suche ein template für dell openmanage. hätte bitte jemand einen ...

Neue Wissensbeiträge
Microsoft Office

Supportlebenszyklus für Office 2010 verlängert

Information von Dani vor 14 StundenMicrosoft Office4 Kommentare

Moin, Like most Microsoft products, Microsoft Office 2010 has a support lifecycle during which we provide new features, software ...

Windows Server

Active Directory ESE Version Store Changes in Server 2019

Information von Dani vor 1 TagWindows Server

Moin, Last month at Microsoft Ignite, many exciting new features rolling out in Server 2019 were talked about. But ...

Exchange Server

Microsoft Extending End of Support for Exchange Server 2010

Information von Dani vor 1 TagExchange Server3 Kommentare

Moin, After investigating and analyzing the deployment state of an extensive number of Exchange customers we have decided to ...

Schulung & Training

Humble Book Bundle: Network and Security Certification 2.0

Tipp von NetzwerkDude vor 1 TagSchulung & Training

Abend, bei HumbleBundle gibts mal wider ein schönes Paket e-books: sind verschiedene Zertifizierungen wie MCSA, CCNA, CompTIA etc., für ...

Heiß diskutierte Inhalte
Notebook & Zubehör
Hardwareberatung: Business Notebook
gelöst Frage von waellerNotebook & Zubehör41 Kommentare

Hallo zusammen, da wir bislang nur MacBooks im Einsatz haben - nun aber auf Windows umsteigen werden - bräuchte ...

Drucker und Scanner
Suche Laserdrucker (Duplex) mit 3 Papierfächern der NICHT ständig Papier frisst
Frage von mabiesDrucker und Scanner18 Kommentare

Hallo, bislang versuchen wir es immer wieder mit Lexmark T650N. Habe da jetzt grad wieder einen sehr guten, wenig ...

Netzwerke
Seltsame Verbindungsprobleme nach Netzwerk-Switch-Tausch
Frage von MondragorNetzwerke16 Kommentare

Hallo an alle. Ich habe gestern in der Firma das NEtzwerkswitch gegen ein moderneres, leistungsstärkeres getauscht. Das alte war ...

Windows Server
Datenträger-Umbau Windows 2012 R2
Frage von petereWindows Server14 Kommentare

Hallo, ich habe auf einem Windows 2012 R2 auf Datenträger 0 diese Volumes: 0 = Startpartition 1 = EFI-Systempartition ...