WSUS - seit 07.04.2021 kein Sync mehr

Mitglied: jsysde

jsysde (Level 3) - Jetzt verbinden

08.04.2021 um 11:09 Uhr, 1852 Aufrufe, 20 Kommentare, 3 Danke

Moin zusammen,

ich sehe auf mehreren WSUS-Servern seit gestern Abend (07.04.2021, ~21.00h) Sync-Errors. Auch befreundete Admins aus anderen Unternehmen haben das gleiche Problem.
Könnt ihr bitte mal auf eure WSUS-Kisten schauen, wie das bei euch ausschaut?

Witzigerweise funktioniert der Sync auf einem (nicht mehr aktiven) WSUS-Server. Da wurde im Februar die autom. Synchronisation deaktiviert, ein jetzt angetriggerter, manueller Sync läuft aktuell noch.

Danke.

Cheers,
jsysde
Mitglied: Tommy70
08.04.2021 um 11:13 Uhr
Hallo,

kann ich bestätigen. Letzte erfolgreiche Synchronisierung am 07.04.2021 um 1 Uhr.
Danach sind alle fehlerhaft.

Tom
Bitte warten ..
Mitglied: jsysde
08.04.2021 um 11:46 Uhr
Servus.

Danke fürs schauen - beruhigt mich einerseits, andererseits wirft es (einmal mehr) ein paar Fragen auf, die ich eigentlich gar nicht stellen will...

Cheers,
jsysde
Bitte warten ..
Mitglied: psannz
08.04.2021, aktualisiert um 12:32 Uhr
Sers,

bei mir gab es heute morgen um 6:11 Uhr einen erfolgreichen Sync mit ein paar Updates. WSUS ist ein 2012R2.
Manueller Sync um 12:20 war ebenfalls erfolgreich mit +1 Update.

Grüße,
Philip
Bitte warten ..
Mitglied: n4426
08.04.2021 um 12:40 Uhr
Hallo jsysde,

bei mir ist der letze Sync 8.4.2021 um 5:25 Uhr erfolgreich.

Grüße,
n4426
Bitte warten ..
Mitglied: em-pie
08.04.2021, aktualisiert um 12:42 Uhr
Moin,

kann ich nicht bestätigen.
Da heute der 08.04.2021 ist und bei uns immer des Abends die Updates synchronisiert werden: letzter Sync am 07.04.21 ~20:30 verlief problemfrei.

Im Eventlog steht auch kein Fehler...

Edit: WSUS läuft auf einem Server 2016 - Patchstand Anfang 03/2021

Gruß
em-pie
Bitte warten ..
Mitglied: tomolpi
08.04.2021, aktualisiert um 12:42 Uhr
Zitat von @psannz:

Sers,
Tach zusammen,
bei mir gab es heute morgen um 6:11 Uhr einen erfolgreichen Sync mit ein paar Updates. WSUS ist ein 2012R2.
Manueller Sync um 12:20 war ebenfalls erfolgreich mit +1 Update.
meiner hat sich heute Nacht, 2:15 Uhr erfolgreich synchronisiert. Fehlgeschlagen ist es laut Log aber am 06.04. und am 07.04.
Grüße,
Philip
Grüße
tomolpi
Bitte warten ..
Mitglied: yumper
08.04.2021, aktualisiert um 13:05 Uhr
Hallo

mein 2019 WSUS synchronisiert jeden Tag um 21:14 fehlerlos. Kommen auch jedes mal mindestens Defender Updates. Etwas komisch - Seit der Sommerzeit wird 1 Stunde später synchronisiert.

So long

Yumper
Bitte warten ..
Mitglied: Ex0r2k16
08.04.2021 um 14:06 Uhr
Nöp, alles gut. Gerade eben Win2012R2
Bitte warten ..
Mitglied: departure69
08.04.2021 um 14:15 Uhr
Letzter erfolgreicher Synch. am 07.04.2021, 19.45 Uhr, seither nur noch Fehler:

susunbenannt - Klicke auf das Bild, um es zu vergrößern

Viele Grüße

von

departure69


P.S.: Danke für den Hinweis, ich hätte es selber vorerst nicht bemerkt.
Bitte warten ..
Mitglied: Delta9
08.04.2021 um 15:05 Uhr
Mal bei Günni geklaut:

"Bei mir liegt (lag) es an „Visual Studio 2017“ und „Visual Studio 2019“. Sobald ich die beiden Produkte deaktiviere geht der Sync wieder."

https://www.borncity.com/blog/2021/04/08/wsus-hat-kein-sync-mehr-7-4-202 ...
Bitte warten ..
Mitglied: jsysde
08.04.2021, aktualisiert um 15:52 Uhr
Servus.

Zitat von @Delta9:
"Bei mir liegt (lag) es an „Visual Studio 2017“ und „Visual Studio 2019“.
Hier ebenfalls - beide Produkte rausgenommen, Sync läuft wieder erfolgreich. *thumbs up*

Cheers,
jsysde

EDITH:
Habe erst 2017 wieder rein => Fehler
2017 raus, dafür 2019 rein => Fehler
Liegt also wohl an der Kombi aus beiden.
Bitte warten ..
Mitglied: Tommy70
08.04.2021 um 15:56 Uhr
Zitat von @Delta9:

Mal bei Günni geklaut:

"Bei mir liegt (lag) es an „Visual Studio 2017“ und „Visual Studio 2019“. Sobald ich die beiden Produkte deaktiviere geht der Sync wieder."


Bei mir hat es ebenfalls wieder funktioniert nachdem ich Visual Studio 2019 in den Produkten deaktiviert habe.

Tom
Bitte warten ..
Mitglied: departure69
08.04.2021 um 15:59 Uhr
VS raus - geht wieder.
Bitte warten ..
Mitglied: MysticFoxDE
08.04.2021, aktualisiert um 20:55 Uhr
Moin jsysde,

Zitat von @Delta9:
"Bei mir liegt (lag) es an „Visual Studio 2017“ und „Visual Studio 2019“.
Hier ebenfalls - beide Produkte rausgenommen, Sync läuft wieder erfolgreich. *thumbs up*

Cheers,
jsysde

EDITH:
Habe erst 2017 wieder rein => Fehler
2017 raus, dafür 2019 rein => Fehler
Liegt also wohl an der Kombi aus beiden.

das Problem kenne ich.
Was hast du für eine FW/UTM davor geschaltet?
Schaut dir mal die IPS/WEB-Proxy Logs nach der IP des WSUS und Blocks durch.
(Bitte prüfen ob der Datenverkehr des WSUS auch geloggt wird.)
Diese funken den Downloads des WSUS und auch dessen Synchronisierung gerne mal dazwischen.
Meistens justieren die FW/UTM Hersteller, paar Tage nachdem ein solches Problem auftritt,
die Signaturen nach und dann geht's wieder von alleine.

Manchmal hilft in solchen Fällen auch eine WSUS Bereinigung.

An einer zu trägen Datenbank kann der Sync auch zerbrechen.
Für diesen Fall hilft das folgende.
https://administrator.de/content/detail.php?id=554097
Das optimieren der Indexe hilft aber auch bei vielen anderen WSUS Problemchen. 😀
Dank diesem Zauber sind bei unseren Kunden sämtlich Downloadkategorien, inklusive Treiber 🤪 angehack und die WSUSe schnurren dennoch wie ein Kätzchen. (Die WSUS DB kann dann aber gut und gerne 20 GB und mehr erreichen.)

Grüsse aus BaWü
Alex
Bitte warten ..
Mitglied: jsysde
08.04.2021 um 21:06 Uhr
N'Abend.

Zitat von @MysticFoxDE:
[...]Was hast du für eine FW/UTM davor geschaltet?[...]
Unterschiedlichste. Sophos UTM, FritzBox, Cisco ASA, Unifi - soll ich jetzt alle Möglichkeiten aufzählen? ;-) face-wink
Deine Idee in alle Ehren, aber die Firewall ist hier nicht das Problem sondern leider einmal mehr MS - das Entfernen von VS2017/2019 hat bei allen KollegInnen, mit denen ich darüber gesprochen habe, das Problem behoben. Sobald eines der beiden Produkte wieder reingenommen wird, tritt der Fehler wieder auf - zumindest meinem analytisch denkenden Teil des Hirns genügt das als Beleg dafür, wo hier der Schuldige zu suchen ist.

Ich behalte das Thema natürlich weiter im Auge und lasse mich mal überraschen, ob und wann sich MS dazu äußert. Und wie deren Problemlösung und/oder Workaround dann ausschaut. Und natürlich lasse ich mich eines besseren belehren, wenn es dann doch auf ein IPS-Szenario hinausläuft. ;-) face-wink

Cheers,
jsysde
Bitte warten ..
Mitglied: MysticFoxDE
09.04.2021 um 06:48 Uhr
Moin jsysde,

an den FW's & Co scheint das Problem dieses Mal wirklich nicht zu hängen.
Habe gestern auf anhieb einen WSUS bei einem Kunden gefunden, der dasselbe Problem aufweist.

Bei diesem Server schlägt auch seit neustem die Serverbereinigung bei dem folgenden Schritt fehl.


🤔

Gruss Alex
Bitte warten ..
Mitglied: Ex0r2k16
09.04.2021 um 08:40 Uhr
Update: Irrtum. Doch kaputt. Thx 4 Info.
Bitte warten ..
Mitglied: jsysde
09.04.2021 um 11:03 Uhr
Servus.

Augenscheinlich ist das Problem behoben - VS2017/2019 wieder reingenommen, Sync ist erfolgreich durchgelaufen.
Danke für's Mitlesen.

Cheers,
jsysde
Bitte warten ..
Mitglied: Looser27
09.04.2021 um 13:53 Uhr
Hab gerade mal geschaut....unser WSUS hat ohne Fehler synchronisiert; das letzte Mal heute morgen um 10:00 Uhr.

Gruß

Looser
Bitte warten ..
Mitglied: kgborn
10.04.2021, aktualisiert um 23:37 Uhr
Kleiner Nachtrag - ich habe es bei mir im Blog im weiter oben verlinkten Blog-Beitrag nachgetragen. Das Produktteam hat inzwischen bestätigt, dass es ein Problem mit Visual Studio gab und das Ganze gefixt. Daher synchronisiert der WSUS inzwischen wieder. Schönes WE.
Bitte warten ..
Heiß diskutierte Inhalte
Datenschutz
Regierung testet Einsatz von Microsoft Azure-Cloud für die Bundescloud
VisuciusVor 1 TagInformationDatenschutz34 Kommentare

LÄUFT! Deutschland will Microsoft für die Bundescloud testen Ich hätts ja beinahe unter dem Topic "Humor" veröffentlicht. Aber der 1. April ist ja durch ...

Festplatten, SSD, Raid
Festplatte aus defekten Notebook ausgebaut - wird nicht erkannt - Wie gelange ich an meine Daten?
1nCoreVor 1 TagFrageFestplatten, SSD, Raid14 Kommentare

Hallo liebe Community, nach 7 Jahren hat mein XMG Notebook seinen Geist aufgegeben In dem Notebook waren zwei Festplatten verbaut (eine für System und ...

Erkennung und -Abwehr
Wie geschickt sich Malware verstecken kann - Ein Beispiel aus der Praxis eines Security Experts
colinardoVor 15 StundenTippErkennung und -Abwehr3 Kommentare

Servus Kollegen und Mitstreiter, da ja in letzter Zeit die Exchange-Lücken die Admin-Landschaft ziemlich aufgewirbelt haben und dabei auch immer mal wieder "sogenannte" Admins ...

Internet
Woher holt sich Android die Kontaktdaten von unbekannten Rufnummern?
gelöst anteNopeVor 1 TagFrageInternet8 Kommentare

Hallo zusammen, seit einiger Zeit merke ich, dass mir mein Android Gerät Namen und Informationen zu mir unbekannten Teilnehmern präsentiert. Soll heißen eine nicht ...

Windows Netzwerk
MS Lizenzierung - externe Scandienstleistung
monstermaniaVor 1 TagFrageWindows Netzwerk9 Kommentare

Hallo Allerseits, ich habe da mal eine Frage an die MS Lizenzspeziallisten. Eine externe Firma soll Scandienstleistungen für uns erledigen. Dazu ist angedacht, dass ...

Exchange Server
Exchange Update CU19 auf CU20 Fehler - Eine weitere Version dieses Produkts ist bereits installiert
gelöst StefanKittelVor 1 TagFrageExchange Server6 Kommentare

Hallo, ich habe hier einen Exchange 2016 mit CU19 (15.1.2176.2). Darauf wollte ich nun CU20 installiert. Download Es erscheint Eine weitere Version dieses Produkts ...

Exchange Server
April 2021 Microsoft Exchange Server Security Updates
FrankVor 1 TagInformationExchange Server2 Kommentare

Microsoft has released security updates for vulnerabilities found in: Exchange Server 2013 Exchange Server 2016 Exchange Server 2019 These updates are available for the ...

Windows 10
Windows 10 Updates im Abgesicherten Modus nicht möglich!
gelöst Yuuto.LucasVor 22 StundenFrageWindows 1016 Kommentare

Hallo, ich habe aktuell ein Problem bei einem Kunden Rechner. Bei diesem gibt es Probleme mit dem Soundkarten Treiber hdaudio.inf wegen dem der PC ...