Excel Wert aus Spalte angeben, wenn in anderer Spalte ein Wert steht

net-zwerk
Goto Top
Moin!

Ich hab da mal wieder ein kleines Excel Problem.

Ich habe eine Tabelle mit Toner Namen in der ersten Spalte. In den folgenden Spalten stehen die EK Preise für verschiedene Projektkunden. Nun hat aber nicht jeder Projektkunde alle Toner.

Wir möchten nun Tabellenblätter zu der Exceltabelle hinzufügen, wo wir für die einzelnen Kunden die VK Preise der Toner berechnen. Aber nur für die Toner, die der Kunde auch im Projekt hat.

Ich suche also eine Formel, die zum Beispiel so aussieht:

Schaue in Spalte B nach einem Wert der größer ist als 0, gebe mit den Wert aus, der auf der selben Zeile in Spalte A steht. Solange Du keinen Wert in Spalte B findest, gehe wieder eine Zeile weiter nach unten...

Habe ich das so halbwegs gut erklärt, was ich möchte?

Danke!

Content-Key: 1525535464

Url: https://administrator.de/contentid/1525535464

Ausgedruckt am: 22.05.2022 um 03:05 Uhr

Mitglied: erikro
erikro 18.11.2021 um 15:55:32 Uhr
Goto Top
Moin,

Pivot-Table würde ich mal sagen.

hth

Erik
Mitglied: NordicMike
NordicMike 18.11.2021 um 17:06:43 Uhr
Goto Top
=WENN(B1>0;“dann“;“sonst“)
Mitglied: em-pie
em-pie 18.11.2021 aktualisiert um 19:52:21 Uhr
Goto Top
Moin,
Zitat von @NordicMike:

=WENN(B1>0;“dann“;“sonst“)

Also ich würde ja mit dem SVERWEIS arbeiten:

Stammdaten mit den EK-Preisen:
stamm

Sheet Kunde A
kundea

Sheet Kunde B
kundeb

Edit: der Aufschlag in den Screens ist kein Aufschlag, hier fehlt ein + EK-Preis, ändert am SVERWEIS aber nichts :-) face-smile
Mitglied: Net-ZwerK
Net-ZwerK 19.11.2021 aktualisiert um 11:57:37 Uhr
Goto Top
Moin

So ganz ist es da auch nicht. In Deinem Beispiel muss man ja den Toner bei den Kunden eintragen und er sucht sich dann den entsprechenden Preis. Bei uns geht es um folgendes:

vergleich

Wir haben eine Übersicht über alle Toner in der ersten Spalte. In den folgenden Spalten die EK Preise der Kunden als Vergleich, wo der Toner am günstigsten ist. In den nächsten Tabellenblättern wollen wir dann pro Kunde eine Liste mit den Toner machen, wo es auch Preise zu gibt, damit wir dort eine VK Berechnung machen können:

kunde a

kunde b

kunde c

Es soll aber so sein, wenn wir auf dem ersten Blatt bei einem Kunden einen neuen Toner einpflegen, soll dort, wo wir den Preis eintragen, dieser Toner mit Preis gleich bei dem Kunden erscheinen zur weiteren VK Berechnung.

Veränderungen sollen im Endeffekt nur auf dem ersten Tabellenblatt erfolgen, wo die komplette Tonerliste vorliegt und alle Kundeneinkaufpreis eingetragen werden.

Oder denke ich zu kompliziert?
Mitglied: em-pie
em-pie 19.11.2021 um 12:03:04 Uhr
Goto Top
OK.

dann benötigt ihr eine Matrix-Formel - soweit ich mich entsinnen kann.
An der Stelle bin ich aber, so muss ich zugeben, raus...
Mitglied: erikro
erikro 19.11.2021 um 12:21:10 Uhr
Goto Top
Moin,

ich sag's gerne noch einmal: Pivot-Table oder besser noch PowerPivot. Oder gleich das Datenbankproblem mit einer Datenbank lösen.

Liebe Grüße

Erik
Mitglied: NordicMike
NordicMike 19.11.2021 um 13:50:20 Uhr
Goto Top
Oder gleich das Datenbankproblem mit einer Datenbank lösen.
Ich wollte es schon vorschlagen. Excel ist eine Tabelle und die Sache wird unbequem kompliziert und fehleranfällig.

Installier dir ein CMS, z.B. Joomla (3.x) mit Fabrik, dann kann man das schön web basiert abbilden und alles bequem durchrechnen lassen und anklicken.