Pjordorf-avatar
Pjordorf 1 hour ago
5 comments
Comment in: In virtualBox hyper V mit Windows installieren
Hallo,

Zitat von @StevenB98:
Hallo Leute. Ich habe einen Windowsserver in Virtualbox mit Hyper V installiert. Nun versuche ich eine VM mit Windows auf diesen Server zu installieren, kriege aber immer einen Error. Wie kriege ich eine VM drauf installiert?
https://de.wikipedia.org/wiki/Hypervisor#Klassifizierung
Du willst ein Hypervisor Typ I in einer VM auf ein Hypervisor vom Typ II laufen lassen? Nested VM ist dein Ziel, ob es allerdings auf deiner HW funktioniert ist auch sehr fraglich.
Hyper-V = Typ I
VirtualBox = Typ II

"Set-VMProcessor -ExposeVirtualizationExtensions $true" hab ich schon probiert, funktioniert nicht.
Virtualbox kann damit nichts anfangen.

Gruß,
Peter
IT-Spezi-avatar
IT-Spezi 1 hour ago
5 comments
Comment in: In virtualBox hyper V mit Windows installieren
Moin,

"Set-VMProcessor -ExposeVirtualizationExtensions $true" hab ich schon probiert, funktioniert nicht.
Das ist ein Befehl für ein Hyper-V Host, den Du ausführst, wenn die VM heruntergefahren ist und das System für eine nested Virtualization vorbereitet wird. Das kann nicht für ein Virtualbox Host funktionieren!
Der richtige Befehl wäre wohl eher
VBoxManage modifyvm --name <name> --nested-hw-virt
siehe:
https://docs.oracle.com/en/virtualization/virtualbox/6.0/user/vboxmanage ...

Jetzt habe ich schon lange mit VirtualBox nicht mehr herumgespielt, aber ich glaube nicht, dass das mitlerweile funktionieren kann.

Die Idee auf einem VirtualBox Host parallel Hyper-V zu aktivieren, ...?!?
Hyper-V ist ein Typ 1 Hypervisor.
VirtualBox ist ein Typ 2 Hypervisor.

Eine reine Hyper-V-Virtualisierungs-Babuschka kann u.U. bei VDI sinnvoll sein.

Hier über VirtualBox mit einem DC (!) kann ich mir aktuell keine sinnvolle Anwendung vorstellen. Ich hoffe auch, es handelt sich hier um eine reine Test-Spielerei und nicht um ein Produktivsystem ...

Gruß

its
Spirit-of-Eli-avatar
Spirit-of-Eli 3 hours ago
5 comments
Comment in: In virtualBox hyper V mit Windows installieren
Moin,

ich kann mir nicht vorstellen das es so überhaupt funktioniert.
Installier HyperV auf dem Host. Darin wird VBox auch laufen.

Wobei sich die Frage natürlich immer noch stellt was der Kram soll. Sinn macht es nicht.

Gruß
Spirit
StevenB98-avatar
StevenB98 3 hours ago
5 comments
Comment in: In virtualBox hyper V mit Windows installieren
Ja, habe ich.
1
tech-flare-avatar
tech-flare 3 hours ago
5 comments
Comment in: In virtualBox hyper V mit Windows installieren
Hast du Nested Virtualisierung in der Virtualbox aktiviert? Ich weiß nicht, ob es da die funktioniert gibt, aber mit Proxmox oder VMware funktioniert das

Gruß
StevenB98-avatar
StevenB98 4 hours ago
Question5 comments
In virtualBox hyper V mit Windows installieren
Hallo Leute. Ich habe einen Windowsserver in Virtualbox mit Hyper V installiert. Nun versuche ich eine VM mit Windows auf diesen Server zu installieren, kriege aber immer einen Error. Wie kriege ich eine VM drauf installiert?


"Set-VMProcessor -ExposeVirtualizationExtensions $true" hab ich schon probiert, funktioniert nicht.
1
janafels-avatar
janafels 11 hours ago
janafels has registered
Focus: Windows desktop - User group: Administrator.
hubert22-avatar
hubert22 1 day ago
hubert22 has registered
Focus: Networks - User group: Designer.
Roudn15-avatar
Roudn15 2 days ago
8 comments
Comment in: RAID-Tools for administration
Yes, there are software tools available to help manage RAID arrays. Depending on the type of RAID controller you have, you may be able to use the manufacturer's proprietary software to manage the array. If not, then you can use open source tools such as mdadm to manage Linux-based RAID arrays. You can also use software RAID management tools such as MegaRAID Storage Manager, areca CLI, and Adaptec Storage Manager, which are available for various platforms.
TracyMullins-avatar
TracyMullins 3 days ago
TracyMullins has registered
Focus: Development - User group: Administrator.
clkdiv-avatar
clkdiv 3 days ago
8 comments
Comment in: RAID-Tools for administration
Ok, thanks a lot. I have external hard drives for backup, so there was no risk trying to swap the disks one by one. If it fails, I could do it at once.

However thanks you very much for all your help!
maretz-avatar
maretz 3 days ago
8 comments
Comment in: RAID-Tools for administration
Quote from @NoAiming:

Hey clkdiv,

I assume, that as soon as I change the last disk to 8TB, the raid capacity will change to 15-16 TB, am I right?

As Pjordorf suggested, the faster and maybe easier way is a full rebuilt with a backup - if you have a backup target which is big enougth. But I would not necessarily say that your way is not possible. I remember that a former colleque of mine did this procedure with a Synology NAS. All the HDDs in it were 2 TB of size and we changed the HDDs over a few days one by one to bigger ones. The Synology NAS was then able to increase the size of the volume once the last rebuild was done. But we had to do that manually - that is not an automatism.
Maybe, just mabye, your controller is also able to do that.
Kind Regards

Even that i would NEVER do without an actual backup - so the backup need to be done anyway. And than i would also go for full re-install. Also have in mind: EVERY change of the disk will cause a full re-build, so quite a lot of waiting time...
NoAiming-avatar
NoAiming 3 days ago
8 comments
Comment in: RAID-Tools for administration
Hey clkdiv,

I assume, that as soon as I change the last disk to 8TB, the raid capacity will change to 15-16 TB, am I right?

As Pjordorf suggested, the faster and maybe easier way is a full rebuilt with a backup - if you have a backup target which is big enougth. But I would not necessarily say that your way is not possible. I remember that a former colleque of mine did this procedure with a Synology NAS. All the HDDs in it were 2 TB of size and we changed the HDDs over a few days one by one to bigger ones. The Synology NAS was then able to increase the size of the volume once the last rebuild was done. But we had to do that manually - that is not an automatism.
Maybe, just mabye, your controller is also able to do that.
Kind Regards
Pjordorf-avatar
Pjordorf 4 days ago
8 comments
Comment in: RAID-Tools for administration
Hello,

Quote from @clkdiv:
Now the 4x3 TB disks are quite old, and I am planning to change them to maybe 4 x 8TB, one by one. I assume, that as soon as I change the last disk to 8TB, the raid capacity will change to 15-16 TB, am I right?
No, wrong. The Capacity will stay as it is. You need to Manually adjust the Size. (Data will be lost). Best do a complete Backup, swap all Drives, build new RAID and restore your Data. Not necessary to run 4 Rebuilds.

Gruß,
Peter
clkdiv-avatar
clkdiv 4 days ago
8 comments
Comment in: RAID-Tools for administration
Hello and thanks for your answers. I tried with RST, but only was able to see the configuration, not any progress or so.

However, the RAID really turned itself back into "Normal" state, after days working with the computer, all in all I think it took maybe 20 hours to rebuild. I couldn't imagine it is so slow. However it is good to know the system really works.

Now the 4x3 TB disks are quite old, and I am planning to change them to maybe 4 x 8TB, one by one. I assume, that as soon as I change the last disk to 8TB, the raid capacity will change to 15-16 TB, am I right?

Thanks again. Martin
NoAiming-avatar
NoAiming 4 days ago
8 comments
Comment in: RAID-Tools for administration
Hello clkdiv,

i am not sure if you can manage your RAID-Controller with it, but try out the drivers for "Intel Rapid Storage Technology" - a short google search shows me several screenshots where you can at least view the status while running windows.
And furthermore, yes, your rebuild can take up to several hours or even a day - depending on the performance of your RAID-Controller.
Kind Regards,
maretz-avatar
maretz 4 days ago
8 comments
Comment in: RAID-Tools for administration
"very long time" is quite relative. It can mean it take 2 seconds (for a CPU this is a very long time i.e.) - or 200 Years... If you see it from another perspective - 200 Years is also quite short in meaning of the time the universe exist...

But of course it can take several hours or even days until the rebuild of a raid with 6 TB is completed...
clkdiv-avatar
clkdiv 4 days ago
Question8 commentsSolved
RAID-Tools for administration
Hello nice people!

I have a hardware RAID 0+1 made from four disks ob 3TB each.

Now one drive was temporarily disconnected, now online again. In the BIOS the RAID array status is "Rebuild". But this seems to take very long. Is there any software out there to manage RAIDs? I can't find anything at all.

The attached image shows the RAID before one disk was disconnected, now the status is yellow and shows "Rebuild".

Thank you very much!
img_3409
jordanmark9524-avatar
jordanmark9524 8 days ago
jordanmark9524 has registered
Focus: Security - User group: Sales.
eliana-avatar
eliana 8 days ago
eliana has registered
Focus: Development - User group: Developer.
RoryMoran-avatar
RoryMoran 11 days ago
RoryMoran has registered
Focus: Linux/Unix server - User group: Administrator.
hereisme-avatar
hereisme 14 days ago
hereisme has registered
Focus: Networks - User group: Administrator.
Frank-avatar
Frank 15 days ago
Tutorial
Install Monitoring Uptime Kuma
I have been looking for a simple monitoring program for our website for some time. Thanks to the help of our users I found in a post the monitoring software Uptime Kuma.

Uptime Kuma is a web server that uses different types of monitors ( HTTP(s), TCP ports, keywords, ping, DNS, push, etc.) to store and check the status of the hardware or software being monitored and, if necessary, alert you via notifications of various types (Telegram, Discord, Signal, Slack, Pushover, Email (SMTP), etc.). The software is easy to use and can additionally create its own status overviews. You can install it via Docker or directly. Here are my instructions for the installation without Docker.


back-to-topRequirements


  • Ubuntu Linux 22.04.1 LTS on a machine or VM that is always running (you want continuous monitoring).
  • The installation should be run as a standalone user and not as root user. In my example it is always the user 'frank'.
  • node, npm, nvm, pm2
  • git

back-to-topInstallation: Version Manager (nvm), Node (node) and Node Package Manager (npm)


If you already have Node and npm installed on your system, you can skip this step.

Node and npm should be installed with a version manager (nvm). This way you can keep an overview of the many versions. See also: https://github.com/nvm-sh/nvm


The terminal must be restarted for the environment variables to work. After that the command "nvm" should be available. Short check:


Now we install the current version of Node:


After the automatic download and install we check it with:


Now all requirements are met (nvm, npm and node).

back-to-topInstallation: Uptime Kuma


Details, source code and configuration can be found at: https://github.com/louislam/uptime-kuma

Now we check again for the current npm version and install the latest version if necessary:


Then we load the source code from Git and start the installation:


When the message "Done" appears, it still takes a few minutes until the input appears again. Do not abort before!

The "Uptime Kuma" server is ready to start. You can start it directly with the following command:


back-to-topInstallation: Process Manager (pm2)


I personally find it better if the server runs and is managed in the background. For this we install a process manager (pm2):


Now we start the "Uptime Kuma" server using pm2:

The default settings for this are: "localhost" and port "3001":


You can of course customize the port and the host:

After the start it should now look like this:

b9bec4e125e4ebcf59d1d363845528a0

The installation is finished. You can reach the Uptime Kuma Admin web page at:


With the process manager pm2 you can control the server:


back-to-topStart automatically at boot time


To make Uptime Kuma start automatically on the next reboot, enter the following command:


Now a generated command appears. Now paste this command completely into the shell via Copy&Paste and execute it:


This will start the server at the next reboot.

Tip: To get rid of the autostart of the server enter the following:


back-to-topUbuntu Firewall (ufw)


If the Ubuntu firewall is active, you have to release port 3001:


back-to-topCall GUI



At the first start the GUI asks for the language and creates a new user:

699563d5baa6d87477392b7a90763be5

After that you start in the Dashboard. Here you can create a new monitor:

239ae2fed2cbc035638ad7930b96a32c

66a2e5ed63b5a3bf5ebf791f184e8f43

c434462e158926058f62039ed1c30f89

That's it face-smile

Feedback, questions and additions are welcome. If you like the tutorial, I am happy about every Like (click on the heart).

Greeting
Frank
DanaFox-avatar
DanaFox 15 days ago
DanaFox has registered
Focus: Linux/Unix in general - User group: Marketing.
Peterheid-avatar
Peterheid 16 days ago
Peterheid has registered
Focus: Windows in general - User group: End-user.
Reubenaryiku004-avatar
Reubenaryiku004 16 days ago
Reubenaryiku004 has registered
Focus: Server in general - User group: End-user.
jonasschmitz403-avatar
jonasschmitz403 16 days ago
jonasschmitz403 has registered
Focus: Internet in general - User group: Editor.
tosunkaya-avatar
tosunkaya 16 days ago
tosunkaya has registered
Focus: Security - User group: Developer.
wurstel-avatar
wurstel 17 days ago
3 comments
Comment in: Regex help required (include with exclude criteria)
You're welcome.
Schinken77-avatar
Schinken77 17 days ago
3 comments
Comment in: Regex help required (include with exclude criteria)
This works as expected, thank you so much!
Schinken77-avatar
Schinken77 17 days ago
Question3 commentsSolved
Regex help required (include with exclude criteria)
Hi all,

We are trying to create an expression that matches, if the sequence is containing the string "test123".
However it should not match, if the sequence also contains the string "nowEXCLUDE".

Example sequences:
1. "abc def ghi jkl mno" --> should not match
2. "abc def ghi test123 jkl mno" --> should match
3. "abc def ghi test123 jkl nowEXCLUDE mno" --> should not match
4. "abc def ghi jkl nowEXCLUDE mno" --> should not match*

We are using the library CATLRegExp and tried a lot on https://regex101.com/ but are not successful.

Any help is greatly appreciated. Thank you.
TradeLabelSoftware-avatar
TradeLabelSoftware 18 days ago
TradeLabelSoftware has registered
Focus: Other systems - User group: Marketing.
BarcodeMaker-avatar
BarcodeMaker 18 days ago
BarcodeMaker has registered
Focus: Other systems - User group: Marketing.
margaritajin-avatar
margaritajin 23 days ago
margaritajin has registered
Focus: Development - User group: Developer.
watson11-avatar
watson11 23 days ago
watson11 has registered
Focus: Server virtualization - User group: Consultant.
MT-Sig-avatar
MT-Sig 23 days ago
MT-Sig has registered
Focus: Networks - User group: Researcher.
Roudn15-avatar
Roudn15 23 days ago
Roudn15 has registered
Focus: Quality management - User group: Editor.
R0Wi93-avatar
R0Wi93 23 days ago
R0Wi93 has registered
Focus: Development - User group: Developer.
aqui-avatar
aqui 25 days ago
Tutorial
Cisco router with zone based firewall and port forwarding

This tutorial is a short extension to the more comprehensive local Cisco Tutorial.
Due to several requests regarding port forwarding and operation with a DMZ segment it quickly shows a more detailed configuration of the modern, onboard Zone Based Firewall (ZFW) in IOS and IOS-XE.


back-to-topBasic configuration


cisco-zfw-dmz

The basic configuration is kept intentionally simple, so that it can be used for more sophisticated ZFW setups as a blueprint.
The example shows a webserver in the DMZ zone which is accessible via port forwarding from the Internet. (HTTP with port translation)
Example zone rules are as follows and must be set to individual requirements:
  • LAN -> Internet: All allowed with extended protocol inspection
  • LAN -> DMZ: Only HTTP and HTTPS traffic allowed, no Ping
  • DMZ -> Internet: Only HTTP, HTTPS, DNS, NTP and ICMP (Ping etc.) traffic allowed
  • Internet -> DMZ: Only HTTP and HTTPS traffic allowed


back-to-topZFW firewall setup


Relevant content related maps and profiles as well as zone pairings use the same color to show their relationship.

service timestamps debug datetime localtime
service timestamps log datetime localtime show-timezone year
!
hostname cisco
!
aaa new-model
!
clock timezone CET 1 0
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.10
ip dhcp excluded-address 192.168.1.250 192.168.1.254
ip dhcp excluded-address 10.1.2.1 10.1.2.10
ip dhcp excluded-address 10.1.2.50 10.1.2.254
!
ip dhcp pool LAN
network 192.168.228.0 255.255.255.0
default-router 192.168.1.1
domain-name cisco.home.arpa
dns-server 192.168.1.1
!
ip dhcp pool DMZ
network 10.1.2.0 255.255.255.192
default-router 10.1.2.1
domain-name cisco.home.arpa
dns-server 10.1.2.1
!
ip dhcp pool Server
host 10.1.2.55 255.255.255.0
-> Optional: Server gets static IP via Mac address reservation.
client-identifier 0102.42ba.67fb.4a
!
!
ip domain lookup source-interface GigabitEthernet4
ip domain name cisco.home.arpa
ip host server.cisco.home.arpa 10.1.2.55
!
lldp run
no cdp run
!
!
class-map type inspect match-any
ALLOW_IN
match access-group name
ALLOWv4
match access-group name
ALLOWv6

class-map type inspect match-any ROUTER
match protocol tcp
match protocol udp
match protocol icmp

class-map type inspect match-any
PORTFW
match access-group name
PORTFW_ACL

class-map type inspect match-any LAN
match protocol dns
match protocol http
match protocol https
match protocol pop3s
match protocol pop3
match protocol imaps
match protocol imap3
match protocol imap
match protocol smtp
match protocol sip
match protocol sip-tls
match protocol rtsp
match protocol ssh
match protocol ntp
match protocol tcp
match protocol udp
match protocol icmp

class-map type inspect match-any DMZ
match protocol dns
match protocol http
match protocol https
match protocol ntp
match protocol icmp

class-map type inspect match-any
LAN_DMZ
match protocol http
match protocol https

(class-map type inspect match-any DHCPv4
-> Optional: only if WAN port in DHCPv4 client mode!
match access-group name DHCPv4)
!
!
policy-map type inspect LANtoInternet
description Traffic LAN to Internet
class type inspect LAN
inspect
class class-default
drop

policy-map type inspect
LANtoDMZ
description Traffic LAN to DMZ
class type inspect
LAN_DMZ
inspect
class class-default
drop

policy-map type inspect DMZtoInternet
description Traffic DMZ to Internet
class type inspect DMZ
inspect
class class-default
drop

policy-map type inspect
InternetToDMZ
description Traffic Internet to DMZ
class type inspect
PORTFW
inspect
class class-default
drop

policy-map type inspect RouterToInternet
description Router a. DHCPv4 traffic to Internet
(class type inspect DHCPv4
-> Optional: only if WAN port in DHCPv4 client mode!
pass)
class type inspect ROUTER
inspect
class class-default
drop

policy-map type inspect
InternetToRouter
description Permitted traffic Internet to router
class type inspect
ALLOW_IN
pass
class class-default
drop
!
zone security Internet
zone security LAN
zone security DMZ
!
zone-pair security LanToInternet source LAN destination Internet
description Traffic LAN to Internet
service-policy type inspect LANtoInternet

zone-pair security
LanToDMZ source LAN destination DMZ
description Traffic LAN to DMZ
service-policy type inspect
LANtoDMZ

zone-pair security
InternetToRouter source Internet destination self
description Traffic Internet to Router
service-policy type inspect
InternetToRouter

zone-pair security RouterToInternet source self destination Internet
description Traffic Router to Internet
service-policy type inspect RouterToInternet

zone-pair security DMZtoInternet source DMZ destination Internet
description Traffic DMZ to Internet
service-policy type inspect DMZtoInternet

zone-pair security
InternetToDMZ source Internet destination DMZ
description Traffic Internet to DMZ
service-policy type inspect InternetToDMZ
!
!
!
interface Vlan1
description Local LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
zone-member security Local
!
interface Vlan10
description DMZ
ip address 10.1.2.1 255.255.255.0
ip nat inside
zone-member security DMZ
!
interface GigabitEthernet4
description Internet Port
ip address dhcp
ip nat outside
zone-member security Internet
!
ip dns server
ip nat inside source static tcp 10.1.2.55 80 interface GigabitEthernet4 58080
-> Port forwarding and translation
ip nat inside source static tcp 10.1.2.55 443 interface GigabitEthernet4 443
-> Static NAT
ip nat inside source route-map NONAT interface GigabitEthernet4 overload
!
!
ip access-list extended
ALLOWv4
remark Allowed to WAN ip address (VPN)
(permit udp any eq bootps any eq bootpc)
-> Optional: only if WAN port in DHCPv4 client mode!
permit udp any any eq 1701
permit udp any any eq isakmp
permit udp any any eq non500-isakmp
permit esp any any
!
ipv6 access-list
ALLOWv6
remark Allowed v6 to Firewall
permit udp any eq 547 any eq 546
!
(ip access-list extended DHCPv4
-> Optional: only if WAN port in DHCPv4 client mode!
remark Pass DHCPv4 WAN traffic
permit udp any eq bootpc any eq bootps)

ip access-list extended NAT
remark Allowed IPs for NAT
permit ip 192.168.228.0 0.0.0.127 any
permit ip 10.1.2.0 0.0.0.127 any

ip access-list extended
PORTFW_ACL
remark Pass portforwarded traffic
permit tcp any host 10.1.2.55 eq 80
permit tcp any host 10.1.2.55 eq 443
!
route-map NONAT permit 10
match ip address NAT
!
ntp source GigabitEthernet4
ntp server de.pool.ntp.org
!
end


back-to-topLinks with further information


Cisco ZFW design guide:
https://www.cisco.com/c/en/us/support/docs/security/ios-firewall/98628-z ...

ZFW firewall secured VPNs with Mikrotik and AVM FritzBox:
https://administrator.de/en/cisco-ipsec-vpn-with-mikrotik-or-fritzbox-21 ...

Cisco configuration tutorial:
https://administrator.de/tutorial/cisco-880-890-und-isr-router-konfigura ...
HannahSofia45-avatar
HannahSofia45 26 days ago
HannahSofia45 has registered
Focus: Development Databases - User group: End-user.
liam584-avatar
liam584 26 days ago
liam584 has registered
Focus: Development AI - User group: Developer.
baccalaureate-avatar
baccalaureate 28 days ago
baccalaureate has registered
Focus: Networks - User group: Consultant.
3dwolf-avatar
3dwolf 30 days ago
3dwolf has registered
Focus: Windows server - User group: Administrator.