Probleme bei Installation von Win XP auf HP Workstation Elitebook 8570w

vafk18
Goto Top
Guten Tag,

aus kompatibilitätsgründen installiere ich auf einem HP Workstation Elitebook 8570w ein Windows XP.

Nachdem der erste Teil der Installation erledigt ist und die grafische Oberfläche des Windows XP erscheinen soll, bleibt der Bildschirm für einige Minute dunkel und bringt anschließend ein BSOD. Ich habe die Festplatte schon von AHCI auf IDE umgestellt und verschiedene Images ohne und mit AHCI-Treibern verwendet. Ohne Erfolg. Ich vermute, daß die Ursache vom Video kommt.

Kennt jemand ein Image, das Windows XP auch auf neueren Rechnern funktioniert? Bzw. welche BIOS-Einstellung ich vornehmen sollte, damit ich zumindest das Setup abschließen und dann die richtigen Treiber einbinden kann.

Content-Key: 3164468078

Url: https://administrator.de/contentid/3164468078

Ausgedruckt am: 19.08.2022 um 05:08 Uhr

Mitglied: Vision2015
Vision2015 24.06.2022 um 10:48:08 Uhr
Goto Top
moin...

das ist teilweise nicht mehr möglich auf neueren geräten.

Frank
Mitglied: radiogugu
radiogugu 24.06.2022 um 10:49:11 Uhr
Goto Top
Hi.

Bescheidene Frage:

Wäre eine VM an der Stelle nicht einfacher oder gibt es irgendwelche Hardware an dem Laptop, die das Betriebssystem nativ braucht?

Gruß
Marc
Mitglied: Lochkartenstanzer
Lösung Lochkartenstanzer 24.06.2022 um 11:03:07 Uhr
Goto Top
Moin,

Beim BSOD steht üblicherweise auch ein Fehlercode. der wäre hilfreich beim Tippgeben.


Ansonsten so d neuere PCs ungeeignet für XP.

lks
Mitglied: vafk18
vafk18 24.06.2022 um 11:13:10 Uhr
Goto Top
@alle

VM geht nicht, wegen der speziellen USB-Treiber (der Rechner ist zur Justage von alten Geräten bestimmt).

Liegt das Problem am Prozessortyp und/oder Chipset (wg. Grafik)?

Ich habe derzeit noch einen IMB T61, auf dem WinXP läuft, wollte aber sicherheitshalber auf ein neueres Notebook umsteigen, falls der Rechner ausfällt.

Den Fehlercode des BSOD kann ich nicht mehr nachvollziehen, da ich die Festplatte wieder gelöscht habe. Aber ich denke, wenn es pauschal auf den neueren Chipsätzen nicht läuft, ich mir die Wiederholung der Installation sparen kann.

Falls nichts hilft, werde ich mir noch einen weiteren T61 für die Reserve besorgen und tausche dann die Festplatte aus.

Erstmal danke!
Mitglied: itisnapanto
itisnapanto 24.06.2022 um 11:29:52 Uhr
Goto Top
Zitat von @vafk18:

@alle

VM geht nicht, wegen der speziellen USB-Treiber (der Rechner ist zur Justage von alten Geräten bestimmt).

Liegt das Problem am Prozessortyp und/oder Chipset (wg. Grafik)?

Ich habe derzeit noch einen IMB T61, auf dem WinXP läuft, wollte aber sicherheitshalber auf ein neueres Notebook umsteigen, falls der Rechner ausfällt.

Den Fehlercode des BSOD kann ich nicht mehr nachvollziehen, da ich die Festplatte wieder gelöscht habe. Aber ich denke, wenn es pauschal auf den neueren Chipsätzen nicht läuft, ich mir die Wiederholung der Installation sparen kann.

Falls nichts hilft, werde ich mir noch einen weiteren T61 für die Reserve besorgen und tausche dann die Festplatte aus.

Erstmal danke!

Das geht in der Tat teilweise nicht. Ich hab für unsere Techniker extra noch ein paar alte Thinkpads am Lager. Stichwort Seriellport. Das schöne ist , die bekommt man gut und gerne für nen Zwanni.

Gruss
Mitglied: Mystery-at-min
Mystery-at-min 24.06.2022 um 11:46:27 Uhr
Goto Top
Simpler Autovergleich: Kannst du Räder einer E Klasse von 1960 auf einen aktuellen bauen?

Nein.

BIOS/UEFI, Chipsatz, gänzlich andere Umgebungsvariablen von Multicore bis hin zu RAM und Wifi Standards dürften das zu einem Ding der unmöglichkeit machen. Heisst, kauf dir ein Notebook gebraucht, welches 15 Jahre im Schrank (mindestens) lag, starte damit nochmals
Mitglied: unbelanglos
Lösung unbelanglos 24.06.2022 um 12:08:06 Uhr
Goto Top
Welche Graka ist drin?
AHCI ist obligatorisch und ggf, wenn die Grafik-Theorie stimmt, dann könnte das integrieren eines anderen Treibers in das XP Image was bringen.

Anonsten XP halt ;)
Server 2003 geht nicht?
Mitglied: Lochkartenstanzer
Lochkartenstanzer 24.06.2022 aktualisiert um 12:30:01 Uhr
Goto Top
Zitat von @Mystery-at-min:

Simpler Autovergleich: Kannst du Räder einer E Klasse von 1960 auf einen aktuellen bauen?

Nein.


Das geht schon. Man muß nur etwas tricksen, genauso wie man XP mit Tricksen auf einen aktuellen Rechner bekommen würde. Da braucht man aber viel Erfahrung und sehr viel handwerkliches Geschick dafür.

lks

PS: Ob das dann allerdings der TÜV abnehmen würde steht auf einem ganz anderen Blatt
Mitglied: Mystery-at-min
Mystery-at-min 24.06.2022 aktualisiert um 13:38:30 Uhr
Goto Top
Ich lass hier mal die technischen Details eines Reifens eines W120 (zwar nicht "E-Klasse" Betitelt, aber de facto der Ahne) klingen: Bridgestone BT <S20 W 120/70 R17 58W>

Ich glaube da braucht man schon ein wenig mehr als nur etwas tricksen. die E klasse ist seither aber auch um > 1/2 schwerer geworden und leistungsfähiger. Es wäre wohl einfacher einen W120 auf aktuelle Reifen zu stellen (aber wer würde das machen, bitte).

Aber ich gehe davon aus, dass die Aussage auf deiner Erfahrung fußt, dass es geht, du darfst es gerne in der Konstellation unter Beweis bringen face-wink Ob das noch betriebswirtschaftlich sinnvoll ist (selbst der "Beweis", ehrenthalber) ist aber etwas anderes.

Zur Sache, man prüfe solche Angebote: https://www.ebay.de/itm/165540128599?hash=item268af5e757:g:SHUAAOSwPd1ir ...
Mitglied: Lochkartenstanzer
Lochkartenstanzer 24.06.2022 um 16:14:41 Uhr
Goto Top
Zitat von @Mystery-at-min:

Ich lass hier mal die technischen Details eines Reifens eines W120 (zwar nicht "E-Klasse" Betitelt, aber de facto der Ahne) klingen: Bridgestone BT <S20 W 120/70 R17 58W>

Ich glaube da braucht man schon ein wenig mehr als nur etwas tricksen. die E klasse ist seither aber auch um > 1/2 schwerer geworden und leistungsfähiger. Es wäre wohl einfacher einen W120 auf aktuelle Reifen zu stellen (aber wer würde das machen, bitte).


Heute ist Freitag, die Ironietags sind unsichtbar. face-smile

Was ich mit diesem "Autovergleich" andeuten wollte: Man kann, mit viel Bastelarbeit die alten Reifen an das neue Auto "dranbasteln", auch wenn der TÜV das vermutlich nicht abnehmen sollte. Gernauso kann man ein XP "zurechtbiegen", indem man die registry hackt und Treiber patcht, was aber im Endeffekt selten zu einem stabilen Betrieb führt.

Man will es also nicht wirklich tun. face-smile

lks
Mitglied: Mystery-at-min
Mystery-at-min 24.06.2022 um 16:25:54 Uhr
Goto Top
Ich hab die durchaus gesehen, aber nein, ich denke weder der Autovergleich noch der WinXP auf das Notebook kann man tun. Also in dem Sinne, dass da IRGENDWAS sinnvolles bei heraus kommt. die Reifen dürften ad hoc die Grätsche machen, spätestens bei der ersten Kurve, das WinXP macht es schon davor. (s.o).
Mitglied: ultiman
ultiman 24.06.2022 um 17:02:16 Uhr
Goto Top
Moin,
ich kann am Sonntag mal nach einen Image schauen, lang ist es her face-smile
Mitglied: vafk18
vafk18 25.06.2022 um 00:51:52 Uhr
Goto Top
Ich schaue, ob ich noch meine alte Original WinXP CD finde und dann boote ich das Setup von dieser. Vielleicht sind die im Netz "zurechtgebogenen" Images nicht das wahre. Zumindest hatte ich es nicht gesehen, daß sich WinXP bereits vor dem Hochladen der grafischen Oberfläche des Setup aufgehängt hätte und wenn, dann hat die Einstellung des AHCI/IDE das Problem beseitigt. Momentan habe es so gelöst, daß in dem neuen Notebook 2x Windows 7 und 1x Windows 10 läuft, weil jede Justagesoftware so ihre eigenen Einstellungen benötigt und daher 3 unterschiedliche OS notwendig sind.
Mitglied: anteNope
anteNope 25.06.2022 aktualisiert um 07:15:18 Uhr
Goto Top
Zitat von @vafk18:
Ich schaue, ob ich noch meine alte Original WinXP CD finde und dann boote ich das Setup von dieser. Vielleicht sind die im Netz "zurechtgebogenen" Images nicht das wahre. Zumindest hatte ich es nicht gesehen, daß sich WinXP bereits vor dem Hochladen der grafischen Oberfläche des Setup aufgehängt hätte und wenn, dann hat die Einstellung des AHCI/IDE das Problem beseitigt. Momentan habe es so gelöst, daß in dem neuen Notebook 2x Windows 7 und 1x Windows 10 läuft, weil jede Justagesoftware so ihre eigenen Einstellungen benötigt und daher *3 unterschiedliche OS* notwendig sind.

Moin,
oha, das klingt in der Tat recht abenteuerlich. Es wurde zwar erwähnt, aber ich würde dir auch zu einer Virtualisierung der Systeme raten.

VM geht nicht, wegen der speziellen USB-Treiber (der Rechner ist zur Justage von alten Geräten bestimmt).
Hast du schon mal VirtualBox ausprobiert? Hier kann man USB-Geräte usw. an die VM durchreichen. Wäre zumindest mal einen Versuch wert.
Mitglied: vafk18
vafk18 25.06.2022 um 10:40:38 Uhr
Goto Top
@anteNope

Die USB-Treiber, teilweise aus Anfang 2000er Jahre, sind nicht unter VM lauffähig. Was haben wir schon alles ausprobiert. Leider...

Es ist auch lizensierte Software dabei, die auf die Seriennummer der CPU gebunden ist und das gibt immer Probleme. Außerdem muß das ganze Stabil laufen, denn ansonsten führt ein Aussetzer z.B. beim Firmwareupgrade zu einem Programmabsturz und dann ist das zu justierende Gerät zerstört.
Mitglied: anteNope
anteNope 25.06.2022 um 10:57:00 Uhr
Goto Top
Zitat von @vafk18:
Die USB-Treiber, teilweise aus Anfang 2000er Jahre, sind nicht unter VM lauffähig. Was haben wir schon alles ausprobiert. Leider...

Es ist auch lizensierte Software dabei, die auf die Seriennummer der CPU gebunden ist und das gibt immer Probleme. Außerdem muß das ganze Stabil laufen, denn ansonsten führt ein Aussetzer z.B. beim Firmwareupgrade zu einem Programmabsturz und dann ist das zu justierende Gerät zerstört.

Ohje ...

Das mit der Grafik könnte hinkommen. Wenn ich das richtig sehe, hat das Elitebook 8570w eine hybride Grafiklösung. Daran könnte es scheitern, weil ich meine die Sachen kamen erst mit Windows 7 in Mode. Eventuell mal im Bios die Grafik auf die Quadro oder die IGP festdübeln und gucken was passiert.
Mitglied: vafk18
vafk18 25.06.2022 um 11:14:52 Uhr
Goto Top
@anteNope
Ich habe das Bios durchsuch und keine Möglichkeit der Einstellung der GraKa gefunden face-sad
Mitglied: unbelanglos
Lösung unbelanglos 25.06.2022 um 12:25:57 Uhr
Goto Top
Hast du dem XP Boot Medium Mal aktuelle Treiber integriert?
Mitglied: vafk18
vafk18 25.06.2022 um 13:42:22 Uhr
Goto Top
"Aktuelle" ist gut face-smile

Ich habe XP noch nie auf den Elitebooks installiert, nur 7, 8 und 10. Und ich finde bei HP auch keine mehr. Vielleicht sind sie auf dem FTP-Server, da muß ich noch recherchieren. Irgendwelche Treiber aus dem Netz will ich nicht riskieren.
Zudem habe ich noch nie (wie lange ist es bei WinXP her?) GraKa-Treiber bei der Installation einbinden müssen; selten AHCI oder Raid. Ich erinnere mich, daß es ein Tool gab (nLite ???), mit dem ein Custom-Iso machen konnte.
Mitglied: unbelanglos
unbelanglos 25.06.2022 um 17:12:21 Uhr
Goto Top
Also...

USB, AHCI, und Grafikkartentreiber sind mit nLite in 5 Minuten in der ISO...
Mitglied: Lochkartenstanzer
Lochkartenstanzer 25.06.2022 um 17:13:54 Uhr
Goto Top
Zitat von @unbelanglos:

Also...

USB, AHCI, und Grafikkartentreiber sind mit nLite in 5 Minuten in der ISO...

Sofern es die Treiber für XP überhaupt gibt. face-smile

lks
Mitglied: unbelanglos
unbelanglos 25.06.2022 aktualisiert um 17:21:58 Uhr
Goto Top
Ja, gibt es. Ein paar Jahre alt aber vorhanden.

Ich persönlich hätte mir die 25 Minuten Aufwand angetan und hier nicht tagelang geschrieben.
Mitglied: vafk18
vafk18 25.06.2022 um 19:32:42 Uhr
Goto Top
@unbelanglos

Die Sache dauert keine 25 Minuten, sondern wesentlich mehr. Denn:

1) HP listet auf der Webseite für das EliteBook 8470p lediglich die Windows 10-Treiber. Nicht einmal mehr für 8.1.
2) Dann gibt es unzählige Treiber, die laufen können aber nicht müssen.
3) Also muß man zuerst die technischen Daten finden, wo dann hoffentlich alle Chipsätze zu finden sind.
usw. usw. Also etwas mehr Aufwand, als gemeint. Und wenn die großen Firmen XP und andere OS nicht mehr unterstützen, dann hat es einen guten Grund. Bedeutet aber nicht, daß ein x-beliebiger Admin sein Wissen von vor 20 Jahren sofort parat hat... Ich jedenfalls nicht.

Aber es geht auch anders. Ich habe im Netz ein ISO gefunden, daß die entsprechenden Treiber versprochen hatte und diese am Ende tatsächlich funktionierten. Zumindest soweit, bis ich versuchte, nach der Installation mit dem alten Partition Magic 8.0 die weiteren Partitionen für Windows 7 und Windows 10 anzulegen. Ich weiß nicht, welcher Teufel mich geritten hat aber glaubte, daß PM noch aus den Zeiten des XP stammte. Schnell installiert meldete das Problem einen Fehler auf der SDD und dummerweise OK zur Behebung bestätigt resultierte die SSD in einem schönen Gadget, daß nun mein bisher eigesetztes MiniPartition Wizard zum Start verhindert.
Erst mit AOMEI Partition Assistant 8.9 habe ich es geschafft, die SSD neu zu partitionieren und zu formatieren.

Im WinXP habe ich zwischenzeitlich auf driverscollection.com die Netzwerk- und Graka-Treiber gefunden und diese funktioneren.

So jetzt will ich Euch auch den Namen des ISOs aufschreiben, in der Hoffnung, daß es jemandem nutzt:

Windows XP PROFESSIONAL SP3 Jan 2015 + SATA Drivers [TechTools.net].iso

Folgende Treiber werden beim ersten Schritt benötigt (nach Drücken von F6):

WinVBlock
FiraDisk
und beim 8470p der ICH7M-Treiber

Diese sind im ISO enthalten und schaffen es, das XP auf einem neueren Notebook zu installieren. Derweil werde ich als zweites zwei Windows 7 und ein Windows 10 installieren.
Mitglied: unbelanglos
unbelanglos 25.06.2022 um 21:02:02 Uhr
Goto Top
Ja, sorry. Ich ging von mir aus.
Ich hatte mir wohl ein paar fertige Treiber zum slipstreamen gesucht... Generische Treiber.
Es gibt Foren die sich jahrelang mit nichts anderem beschäftigt hatten.
Mitglied: vafk18
vafk18 25.06.2022 um 21:44:37 Uhr
Goto Top
@unbelanglos
Kein Problem & ich habs geschafft! Sogar alle Treiber unter System/Hardware/Gerätemanager installiert, so daß es kein gelbes Fragezeichen gibt. Wie lange war das her? Man soll wirklich nie die Treiber inkl. der alten .net-löschen...