jaja99
Goto Top

VLAN Setup Fehler

Hi,

zuerst die gute Nachricht. Habe meinen Hex nun replaced mit dem Hap ax2.
Habe auch geschafft das Wlan intern als auch auf dem cAp ax zu konfigurieren.
Nun habe ich noch ein Problem, das ich keine Verbindung zu den Rechnern im Netzwerk 10.0.0.1/24 hin bekomme. Bin jetzt echt betriebsblind.
alle anderen Verbindungen zwischen den Vlans funktionieren wie gewünscht.

Bin ziemlich sicher das es nicht an der Firewall liegt. Lasse sie deshalb erst mal außen vor.
Hoffe ich finde hier jemanden Netten, der mir hilft und sieht wo ich den Murks gemacht habe.
Danke im voraus !
# 2024-05-19 21:10:47 by RouterOS 7.14.3
# software id = 9L1W-G84H

/interface bridge
add ingress-filtering=no name=bridge1 vlan-filtering=yes
						
/interface ethernet
set [ find default-name=ether1 ] name=e1-to-modem
set [ find default-name=ether4 ] name=e4-to-cap
set [ find default-name=ether5 ] name=e5-to-switch

/interface vlan
add interface=bridge1 name=vlan1 vlan-id=1
add interface=bridge1 name=vlan10 vlan-id=10
add interface=bridge1 name=vlan20 vlan-id=20
add interface=bridge1 name=vlan100 vlan-id=100
add interface=bridge1 name=vlan111 vlan-id=111

/interface pppoe-client
add add-default-route=yes disabled=no interface=e1-to-modem name=pppoe-out1 \
    password=wqeqwerqr use-peer-dns=yes user=639850656452@34324234234
			   
/interface list
add name=LAN
add name=WAN

/ip pool
add name=dhcp_pool-GUEST ranges=192.168.10.10-192.168.10.254
add name=dhcp_pool-IoT ranges=192.168.20.10-192.168.20.254
add name=dhcp_pool-Privat ranges=192.168.100.10-192.168.100.254
add name=dhcp_pool-SIP ranges=192.168.111.10-192.168.111.254
add name=dhcp_pool-MGMT ranges=10.0.0.60-10.0.0.254

/ip dhcp-server
add address-pool=dhcp_pool-GUEST interface=vlan10 lease-time=1d name=dhcp-guest
add address-pool=dhcp_pool-IoT interface=vlan20 lease-time=1d name=dhcp-IoT
add address-pool=dhcp_pool-MGMT interface=vlan1 lease-time=1d name=dhcp-mgmt
add address-pool=dhcp_pool-Privat interface=vlan100 lease-time=1d name=dhcp-private
add address-pool=dhcp_pool-SIP interface=vlan111 lease-time=1d name=dhcp-sip

			 
/interface bridge port
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=no interface=ether2
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=no interface=ether3 pvid=100
add bridge=bridge1 ingress-filtering=no interface=e4-to-cap
add bridge=bridge1 ingress-filtering=no interface=e5-to-switch
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=no interface=wifi1-5g pvid=100
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=no interface=wifi2-2g pvid=100
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=no interface=wifi3-guest-2g pvid=10
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=no interface=wifi4-IoT pvid=20
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=no interface=wifi5-guest-5g pvid=10

/ip neighbor discovery-settings
set discover-interface-list=LAN

/interface bridge vlan
add bridge=bridge1 tagged=bridge1,e4-to-cap,e5-to-switch vlan-ids=1
add bridge=bridge1 tagged=bridge1,e4-to-cap,e5-to-switch vlan-ids=10
add bridge=bridge1 tagged=bridge1,e4-to-cap,e5-to-switch vlan-ids=100
add bridge=bridge1 tagged=bridge1,e4-to-cap,e5-to-switch vlan-ids=20
add bridge=bridge1 tagged=bridge1,e4-to-cap,e5-to-switch vlan-ids=111

/interface list member
add interface=pppoe-out1 list=WAN
add interface=e1-to-modem list=WAN
add interface=bridge1 list=LAN
add interface=vlan1 list=LAN
add interface=vlan10 list=LAN
add interface=vlan20 list=LAN
add interface=vlan100 list=LAN


/ip address
add address=10.0.0.1/24 interface=bridge1 network=10.0.0.0																			 
add address=192.168.10.1/24 interface=vlan10 network=192.168.10.0
add address=192.168.100.1/24 interface=vlan100 network=192.168.100.0																			
add address=192.168.20.1/24 interface=vlan20 network=192.168.20.0
add address=192.168.111.1/24 interface=vlan111 network=192.168.111.0
add address=10.0.0.1/24 interface=vlan1 network=10.0.0.0

	
/ip dhcp-server network
add address=10.0.0.0/24 dns-server=10.0.0.133,1.1.1.1 gateway=10.0.0.1 netmask=24
add address=192.168.10.0/24 gateway=192.168.10.1
add address=192.168.20.0/24 gateway=192.168.20.1
add address=192.168.100.0/24 gateway=192.168.100.1
add address=192.168.111.0/24 gateway=192.168.111.1

/ip dns
set servers=10.0.0.133,1.1.1.1

/ip firewall address-list
add address=10.0.0.0/24 list=VLAN1
add address=192.168.10.0/24 list=VLAN10
add address=192.168.20.0/24 list=VLAN20
add address=192.168.100.0/24 list=VLAN100
add address=192.168.111.0/24 list=VLAN111

Content-Key: 81257837427

Url: https://administrator.de/contentid/81257837427

Printed on: June 12, 2024 at 17:06 o'clock

Member: hempel
hempel May 19, 2024 updated at 20:43:47 (UTC)
Goto Top
Nun habe ich noch ein Problem, das ich keine Verbindung zu den Rechnern im Netzwerk 10.0.0.1/24 hin bekomme. Bin jetzt echt betriebsblind.
Kaffeepause ... Das sagt hier ja eigentlich schon alles ....
/ip address
add address=10.0.0.1/24 interface=bridge1 network=10.0.0.0
add address=10.0.0.1/24 interface=vlan1 network=10.0.0.0
Doppelten IPs und Subnetze nee nee nee, das gibt Abzüg.
Erste Zeile wech und ab geht's .
Member: jaja99
jaja99 May 19, 2024 at 20:43:51 (UTC)
Goto Top
dachte ich mir ...
aber wie bringe ich dieses Netz an die bridge und an vlan1 ?
Member: hempel
Solution hempel May 19, 2024 updated at 20:47:46 (UTC)
Goto Top
Zitat von @jaja99:

dachte ich mir ...
aber wie bringe ich dieses Netz an die bridge und an vlan1 ?
Ist es doch schon mit der zweiten Zeile, vlan1 ist auf der Bridge schon getaggt also alles tutti. Erste Zeile löschen fertig.
Und alles was an den Ports untagged ins VLAN1 soll mit der PVID 1 ins VLAN1 schicken fertig.
Member: jaja99
jaja99 May 19, 2024 updated at 20:49:21 (UTC)
Goto Top
danke ... sags doch betriebsblind ...
die ersten Rechner pingen ... jetzt mal debuggen.
Member: aqui
aqui May 20, 2024 updated at 09:21:32 (UTC)
Goto Top
aber wie bringe ich dieses Netz an die bridge und an vlan1 ?
Du solltest nächstes Mal die Brille aufsetzen beim Lesen des Tutorials! 🙄
Dort steht ganz groß in dicken roten Lettern das es bei einem VLAN Setup KEINE IP Adressierung auf dem Bridge Interface selber gibt!!
Mikrotik VLAN Konfiguration ab RouterOS Version 6.41
Lesen und verstehen und vor allem die Brille nicht vergessen!! 🧐
Member: hempel
hempel May 20, 2024 updated at 10:16:38 (UTC)
Goto Top
Ich glaube so langsam sind es zu viele Brillen 🤪

1000003512
Member: jaja99
jaja99 May 20, 2024 at 14:59:33 (UTC)
Goto Top
ich weis ... aber jedes mal komme ich irgendwie auf das UI beim Quick setup und dann zerschieße ich das ding ...
Aber jetzt läuft alles
... mit einer DHCP Warnung ... dafür mache ich aber ein extra Fred auf um Ordnung zu halten ... ;)