Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Exchange 2007 unwiederbringlich defekt. Was ist mit den Postfächern?

Mitglied: schloli

schloli (Level 1) - Jetzt verbinden

07.02.2010 um 11:41 Uhr, 6348 Aufrufe, 5 Kommentare

Wir haben folgendes Problem. Ein Admin hat ein Backup eines Exchange 2007 Server zurück gespielt u. jetzt geht granix mehr...

Wir haben nun die Odner in Deutsch u. Englisch auf der Systemplatte liegen. Also:

Dokumente und Einstellungen
Documents and Settings

Programme
Program Files

Programme (x86)
Program Files (x86)

Nun startet der Exchange natürlich nicht mehr, weil der die Pfade nicht mehr findet.

Es herrscht dort ein Mixed Betrieb. D.h. wir haben noch einen funktionierenden Exchange 2003 der auf dem AD mitläuft. Nun ist mein Problem, das der Exchange 2007 natürlich viele Mailboxen beherbergt hat u. diese jetzt verloren sind.
Im AD ist ja hinterlegt, wo die Mailboxen gespeichert sind (auf dem defekten Ex2007).

Meine Idee war jetzt, den Server mit ADSEdit aus dem AD zu werfen u. den Ex2007 neu aufzusetzen und ihn gleich zunennen. Zumal ich auf dem Connector Ex03-Ex07 noch knapp 1000 Mails habe.

Meint ihr, das würde gehen?
Was wird aus den Postfächern? Wie geh ich da am besten vor?

Gebt mir bitte noch Tipps!

Vielen Dank

Gruß Timo
Mitglied: GuentherH
07.02.2010 um 12:30 Uhr
Hallo.

Meine Idee war jetzt, den Server mit ADSEdit aus dem AD zu werfen

Auf keinen Fall. Dafür gibt es ein Disasterrecovery.

Lies dir das hier einmal genau durch, wenn du damit nicht klar kommst, dann hole dir professionelle Hilfe - http://technet.microsoft.com/en-us/library/aa998848(EXCHG.80).aspx

LG Günther
Bitte warten ..
Mitglied: Edi.Pfisterer
07.02.2010 um 17:21 Uhr
Hallo!
gebe GüntherH vollinhaltlich recht, habe aber noch ein paar zusätzliche Hilfestellungen für Dich....

links:
Serverausfall
Serverübersiedeln - Das gilt so ähnlich auch für Dein Problem

die gute Nachricht zu Beginn:
Du hast kein wirklich grosses Problem

kurze Beschreibung der Lösung:
edb und stm sichern
Falls Du dein Betriebssystem auch gleich neu installierst, MUSS der Server danach natürlich den selben Namen haben, die selben Servicepacks installiert haben, etc....
anschliessend exchange "neu installieren" mit Setup /m:recovery
(Du kannst natürlich auch das aktuelle OS drauf lassen und nur setup /m:recovery durchführen
Nach erfolgreicher Installation solltest Dein System wieder gleich aussehen wie zuvor!!!
Alle relevanten Konfigurationen sind im AD gespeichert - inkl. Einstellungen bzgl. IMF usw.

einzig verbliebendes Problem: die Postfächer sind alle leer. Nun kommt Deine Sicherung der edb und stm ins Spiel:

Postfächer offline stellen
edb und stm aus der Sicherung wiederherstellen und die bei der Installation angelegten überschreiben
Postfächer Online stellen
Fertig. Der Kollege soll Dir ein paar Biere zahlen!

No big deal...

Plane das ganze halt wirklich detailliert - im Netz gibt es jede Menge Beschreibungen und Anleitungen - ich finde nur grad keine (vielleicht könntest Du uns ja hier eine schreiben, falls du Erfolg hast? Das heisst, Du könntest den Vorgang gleich mit Scrrenshots dokumentieren...)
Wichtig ist, dass du das System beim Desasterrecovery auf den selben Stand bringen kannst, den Du vor deinem Missgeschick hattest...


Ich habe oben beschriebene Aktion 8auf einem 2003er System) bereits mehrfach ohne auftretende Probleme durchgeführt. Deine Chancen stehen also ausgezeichnet!

Falls Dir das ganze doch zu steil ist:
Ein Consultant am Morgen vertreibt Kummer und Sorgen

Nett wäre, wenn Du uns wissen lässt, ob Du Erfolg hattest...
Bitte warten ..
Mitglied: schloli
07.02.2010 um 20:35 Uhr
Vielen Dank für den ausführlichen Post!

Ich habe leider "recht" voreilig genau das gemacht was du gesagt hast. Ich hatte leider keine stm u. edb. Nur ohne den TAG /m:recovery

Ist das jetzt elementar wichtig? Weil sonst müsste ich es ja "nochmal" machen. (Wäre nicht schlimm)

Gruß Timo
Bitte warten ..
Mitglied: GuentherH
07.02.2010 um 20:56 Uhr
Hallo.

Du schreibst am Sonntag um 11:41 eine Post, und wartest dann nicht einmal ein 3/4 Stunde ab, bis du Antwort bekommst, die dir viel Arbeit erspart hätte.

Ich hatte leider keine stm u. edb.

Das heißt es gibt keine Sicherung des Exchange Servers?
Was ist das dann für ein Backup, das einer der Admins zurückgespielt hat?

Ist das jetzt elementar wichtig?

Ich kann es dir bei Exchange 2007 nicht sagen, weil ich es noch nie gemacht habe. Ich habe mir schon lange unüberlegte "Schnellschüsse" abgewöhnt, zumal es fasst kein Problem gibt, das nicht in irgendeiner Form im Web beschreiben wird.
Bei Exchange 2003 war eine deratige Aktion, wie du sie durchgeführt hast mit sehr viel Aufwand verbunden, weil der neue Server eine neue SID hat, und man bei jedem User über ADSIEdit die Exchange Attribute entfernt bzw. geändert werden mussten.

Weil sonst müsste ich es ja "nochmal" machen. (Wäre nicht schlimm)

Dazu ist es jetzt zu spät. Da noch dazu ein Exchange 2003 auch noch läuft, würde ich dir doch raten professionelle Hilfe in Anspruch zu nehmen, bevor die gesamte Exchange Organisation den Bach runtergeht.

Wünsch dir viel Glück

LG Günther
Bitte warten ..
Mitglied: Edi.Pfisterer
08.02.2010 um 10:55 Uhr
Hallo!
gebe GüntherH erneut vollinhaltlich recht!!!

möglcherweise ist es eine Frage der Jahresringe, aber übereilte Handlungen sind in keinem mir bekannten Fall von Vorteil!!!!
Ohne eine vernünftige und grundlegende Analyse des vorhandenen Problems wird eine Lösung selten möglich sein...
Und: hätte man das Problem bereits zuvor Analysiert, dann hätte man es überhaupt nie bekommen!!!

Was Dein Backup betrifft:
Das ist KEIN backup, wenn nichtmal die beiden datenbanken gesichert werden. Für so eine Sicherung hat man - meinen bescheidenen Fremdsprachenkenntnissen zufolge - im niederbayrischen Raum einen Fachausdruck: DRECK DRECKERTER

ich korrigiere mich nun also:
die schlechte Nachricht zu Beginn:
Du hast ein wirklich grosses Problem

abgesehen davon, dass Dein Deutsch wirklich nicht das beste ist:

Ich habe leider "recht" voreilig genau das gemacht was du gesagt hast. Ich hatte leider keine stm u. edb. Nur ohne den TAG /m:recovery
Ist das jetzt elementar wichtig? Weil sonst müsste ich es ja "nochmal" machen. (Wäre nicht schlimm)

ich glaube zu erkennen, dass Du einfach exchange neu installierst hast und Dich nun fragst, ob es wirklich auf die paar Buchstaben /m:recovery ankommt...

Nun, öffne einfach mal Dein Exchange-Verwaltung und schau dich mal ein bisschen um...
Obwohl ich die von Dir beschriebene Vorgangsweise noch nie probiert habe (weil ich ja versuche, vorhandene Probleme zu lösen und mir nicht im selben Moment neue und schwerwiegendere einzuhandeln) kann ich mir vorstellen, du findest wenig Bekanntes.
Die Mailboxen sind alle leer (eh klar, hast du ja nicht gesichert), der SMTP-connector ist verschwunden etc etc etc.
(so würde ich es zumindest erwarten, werde mich aber hüten, das auszuprobieren....

Ich denke, durch die von dir übereilig (ich muss es nochmal sagen) vorgenommene Aktion glaubt Dein AD nun, es gibt 3 Exchange-Server, wobei sich 2 auf der selben Hardware befinden sollten... Hm.. wenn ich ein AD wäre, würde ich mich jetzt auch nicht mehr auskennen....

Wenn du das ganze jetzt "nochmal" machst, dann kann es natürlich sein, dass das AD glaubt, du hast 3, wovon 2 nun zumindest wieder funktionieren...
es kann aber auch sein, dass alles anders ist....

Langer Rede, kurzer Sinn:
(das hilft dir nicht weiter, aber es wird sich wieder jemand finden, der sich Dein Problem einhandelt und das hier liest

RUHE BEWAHREN, LESEN, LESEN, NOCHMAL LESEN, PLANEN, HANDELN
Zusatz:
WENN DIR DIE GEDULD FEHLT (oder Du noch nie verstanden hast, WARUM dein Exchange eigentlich funktioniert, so lange er funktionierte) , HOL DIR PROFESSIONELLE HILFE!!!

sorry, aber Du wirst jetzt wohl niemanden mehr finden (hoffentlich täusche ich mich), der Dir in der jetzigen Situation weiterhelfen wird können, da es wohl weltweit nur wenige geben dürfte, die die selben 2 Fehler gemacht hat, die ihr gemacht habt...

trotzdem: alles Gute!!!
Bitte warten ..
Ähnliche Inhalte
Festplatten, SSD, Raid

Kompletten Festplatteninhalt final-unwiederbringlich löschen

gelöst Frage von donnyS73lbFestplatten, SSD, Raid17 Kommentare

Hallo zusammen, eine Frage: Wenn ich eine Festplatte mit sensiblen Daten so löschen will, dass nichts wiederhergestellt werden kann, ...

Outlook & Mail

Outlook 2007 - .NK2-Datei defekt

gelöst Frage von will02Outlook & Mail3 Kommentare

Hallo Zusammen, ich habe Grundkenntnisse von unserer IT-Infrastruktur bin aber leider kein Informatiker und könnte deshalb etwas Support von ...

Exchange Server

Exchange 2007 Postfach deaktiviert und anschließend verschwunden

gelöst Frage von BlackVictoryExchange Server2 Kommentare

Hallo Zusammen. Folgende Gegebenheiten: Exchange 2007 Server 2003 3 Speichergruppen Ein Postfach eines Benutzers hat unerkläörlicherweiße 34 GB. Die ...

Exchange Server

Exchange Server 2007 - Postfach mit neuem Benutzer verknüpfen

gelöst Frage von chb1982Exchange Server2 Kommentare

Hallo zusammen, ich habe hier ein Setup aus einem SBS-Server 2008 und einem Windows Server 2012R2 Der SBS und ...

Neue Wissensbeiträge
Windows 7
Win7 Update scheitert KB4512506
Information von infowars vor 4 StundenWindows 7

Falls jemand auch das Problem hat mit dem: Monatliches Sicherheitsqualitätsrollup für Windows 7 für x64-basierte-Systeme (KB4512506) Das scheint mit ...

Humor (lol)
Wenn hacken nach hinten los geht
Information von em-pie vor 1 TagHumor (lol)4 Kommentare

Moin, weil heute Freitag ist, nachfolgender kurzer Artikel zum schmunzeln:) l+f: NULL ist ein notorischer Falschparker

Windows Update
Windows: August 2019 Patchday-Probleme
Information von kgborn vor 1 TagWindows Update2 Kommentare

Ich kippe mal einige kurze Informationen hier rein - vielleicht hilft es Betroffenen. Die August 2019-Updates für Windows haben ...

Sicherheits-Tools
Kaspersky "Sicherheitslösung"
Information von Looser27 vor 2 TagenSicherheits-Tools1 Kommentar

Wieso überrascht mich das nicht wirklich? Kaspersky gefährdet Privatsphäre

Heiß diskutierte Inhalte
SAN, NAS, DAS
Leiser stromsparender Debian EXT4 NAS-Heimserver: ECC-RAM wie betreiben?
Frage von Laser12SAN, NAS, DAS25 Kommentare

Moin, aktuell stelle ich einen Rechner zusammen, den mein Computerhändler bauen wird. Nach Jahrzehnten mit Desktops und zwei Notebooks ...

LAN, WAN, Wireless
VPN Tunnel zu PiVPN steht, aber kein Internet
gelöst Frage von KabuntelLAN, WAN, Wireless18 Kommentare

Hallo Community, habe heute PiVPN auf meinem Raspberry Pi 3b+ installiert, mit dem How To vom Kuketz-Blog Ich kann ...

Netzwerkgrundlagen
Proxmox auf dedicated Root Server mit nur einer IP nutzen
gelöst Frage von ndreier933Netzwerkgrundlagen12 Kommentare

Hallo Community, ich bin neu hier im Forum und weiß nicht ob ich das Thema richtg zugeordnet habe?Zusätzlich habe ...

Router & Routing
PfSense routing OpenVPn und IPSec
Frage von TheOnlyOneRouter & Routing11 Kommentare

Hallo zusammen, ich habe 3 Standorte die per VPN miteinander verbunden sind. (siehe Bild) Nun stehe ich vor der ...