Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst 3ware 9650SE, SuperMicro Board, Kernelmodul erkenn Controller nicht

Mitglied: AxelErnst

AxelErnst (Level 1) - Jetzt verbinden

13.03.2007, aktualisiert 14.03.2007, 9002 Aufrufe, 1 Kommentar

3w-9xxx liefert nach laden des modules keine Ergebnisse, es kein controller vorhanden

Hallo,

ich quäle mich, einen 3ware 9650SE mit dem 3w-9xxx modul anzusteuern. Der Controller ist im Supermicro-Board PDSME+ installiert, das Raid vorbereitet, laut Biosstartmeldung wird das Bios des Controllers erfolgreich registriert. Ich habe mehrere Distries und das von 3ware gelieferte module probiert. Nach modprobe 3w-9xxx wird zwar das modul geladen, aber das war's. Es gibt außer der erfolgreichen Lademeldung keine weitere Aktivität, folglich ist der Controller oder seine Platte (Raid1-verbund) nicht ansprechbar.

Hat dies schan einmal jemand erlebt? Nach den gängigen Methoden und Anleitungen sollte doch das Laden des Modules reichen? Gibt es wie bei (USB) Modulen Parameter, die man mit übergeben kann?

Einzig auffällig fand ich lspci, das den Controller nennt, allerdings als unknown device 1004 klassifiziert.

Habe die letzten zwei Tage mit dem Thema zugebracht und bin nach etlichen Suchorgien für jeden Denkanstoß dankbar.

Axel.
Mitglied: AxelErnst
14.03.2007 um 09:20 Uhr
Hallo Mitleser,

das Problem konnte gelöst werden. Das Problem besteht darin, dass 3ware zwar SuSE 10.1 als supportet einstuft, was aber nicht -wovon ich ausging- automaitsch für 10.2 gilt. Alle in den Kerneln < 2.6.19 enthaltenen 3w-9xxx Module unterstützen die 9xxx er Serien der Controller. Mit Ausnahme des hier verwendeten 9650SE. Per Zufall stieß ich auf der Herstellerseite auf diese Information. dort gibt es für den in SuSE 10.2 verwendeten 2.6.18 Kernel ein passendes Modul. Allerdings funktioniert die simple Installationsanleitung nicht wirklich. Diese besagt, kopiere auf Diskette und lade beim Installationsvorgang. Das klappt leider nicht, da das Setup keine vfat/fat Treiber lädt. Auch das Formatieren der Diskette mit ext2 bringt keinen Erfolg. Ich habe dies dann wie folgt gelöst:

- Treiber auf Diskette mit ext2-Format
- Installationsprogramm bis zum ersten Dialog laufen lassen.
- Auf eine freie Konsole wechseln.
- fd0 einhängen, mittels insmod direkt den Treiber laden
- Installation forstsetzen.
- Der nach Installation folgende Reboot scheitert natürlich wegen des nicht enthaltenen Moduls.
- Aktuelle Knoppix booten (kommt mit 2.6.19 ! kann also direkt den Controller ansprechen)
- Partitionen mounten.
- chroot in den eigentlichen / Mountpoint
- Modul von Diskette in den Kernelpfad kopieren, dabei das Default-Modul überschreiben.
- Dann unbedingt mkinitrd laufen lassen, denn sonst kann das System nie starten. Die Parameter für das bootimage sind bereits durch Yast korrekt eingestellt.
- Neustart.

Läuft.

Ich habe dies hier so ausführlich erläutert, damit es auch anderen hilt. Ich hoffe der Artikel ist jetzt nicht zu lang.

Gruß Axel.

P.S. Der Hersteller hatte sich binnen 8 Stunden gemeldet, allerdings nur eine telefonische Hilfe in England in Aussicht gestellt. Insofern zumindest ein + für die grundsätzliche Bereitschaft für den Support.
Bitte warten ..
Ähnliche Inhalte
CPU, RAM, Mainboards

BIOS UPDATE für ein Supermicro X8DT3-F Server Board

gelöst Frage von ThomasKernCPU, RAM, Mainboards2 Kommentare

Hallo zusammen, evtl. kann mir jemand kurzfristig weiterhelfen. Ich habe ein kleines Problem mit einem Supermicro X8DT3-F Server Board. ...

Server-Hardware

Supermicro Netzteil prüfen

gelöst Frage von hermesServer-Hardware3 Kommentare

Hallo Admins, vielleicht kann mir ja einer von Euch helfen, bei Google habe ich jedenfalls nicht das gewünschte gefunden. ...

LAN, WAN, Wireless

Supermicro bootet nicht

gelöst Frage von FalcoKLAN, WAN, Wireless13 Kommentare

Moin Leute ich soll hier in der Firma nen Mini-ITX Ultra Tiny mit Win2012 füttern. Bei uns passiert das ...

Server-Hardware

Supermicro Server, Frontpanel defekt

gelöst Frage von LordGurkeServer-Hardware3 Kommentare

Hallo zusammen, Kennt jemand einen Trick, wie man bei Supermicro-Gehäusen, dieses Frontpanel mal in die Finger bekommt? Hintergrund: Heute ...

Neue Wissensbeiträge
iOS
IOS hat nen Cursor !!!
Tipp von Criemo vor 6 StundeniOS

Nette Funktion im iOS. iPhone-Mauszeiger aktivieren „Nichts ist nerviger, als bei einem Tippfehler zu versuchen, den iOS-Cursor an die ...

Off Topic
Avengers 4: Endgame - Erster Trailer
Information von Frank vor 2 TagenOff Topic1 Kommentar

Ich weiß es ist Off Topic, aber ich freue mich auf diesen Film und vielleicht geht es anderen hier ...

Webbrowser
Microsoft bestätigt Edge mit Chromium-Kern
Information von Frank vor 2 TagenWebbrowser5 Kommentare

Microsoft hat nun in seinem Blog bestätigt, dass die nächste Edge Version kein EdgeHTML mehr für die Darstellung benutzen ...

Sicherheit

MikroTik: Sicherheitslücke wird ausgenutzt obwohl ein Update seit langem verfügbar ist

Information von sabines vor 2 TagenSicherheit

Obwohl ein Update, dass die nun massenhaft ausgenutzte Lücke schließt, seit langem (März 2018) verfügbar ist, wird es offensichtlich ...

Heiß diskutierte Inhalte
Exchange Server
Exchange Server 2010: Keine Eingehenden E-MAils
Frage von gabeBUExchange Server15 Kommentare

Hallo Zusammen Ich habe das kurzen auf dem Exchange 2010 Server das Problem, dass ich keine externen E-Mails mehr ...

Rechtliche Fragen
Systemhaus auf Abwegen
Frage von rocco61Rechtliche Fragen13 Kommentare

Hallo zusammen, bin derzeit ratlos bei dem folgenden Scenario: In einen Seniorenheim wurde beschlossen, die IT an eine andere ...

Router & Routing
MikroTik - Routing, Bridging, Switching
gelöst Frage von Alex29Router & Routing9 Kommentare

Hallo in die Runde, als Hobby-Admin würde ich bitte mal wieder Eure Hilfe benötigen. Seit der Umstellung auf RouterOS ...

Outlook & Mail
Kalendersync mit Android und Outlook
Frage von Stefan007Outlook & Mail8 Kommentare

Hi Leute, kennt jemand eine Möglichkeit um Termine zwischen installiertem Outlook auf dem PC und dem Kalender auf einem ...