WIN10 Admin und Powershell Variable

Mitglied: Molly11

Molly11 (Level 1) - Jetzt verbinden

24.11.2020, aktualisiert 01.12.2020, 337 Aufrufe

Hallo zusammen,

wahrscheinlich werden manche die Hände über dem Kopf zusammenschlagen, aber ich komme echt nicht weiter.
Und ich denke, das es ein Rechteproblem auf dem neu aufgesetzten WIN10 Pro Rechner ist.

Historie:
Notebook von WIN7 Home auf WIN10 Home aktualisiert und dann Lizenz für WIN10 Pro erstanden. Aktualisierung auf WIN 10 Pro durchgeführt.

Jetzt habe ich ein PowerShell Programm geschrieben, was eine Abfrage zur Backupspeicherung erstellt und dann einen Automatischen Task erstellt.
Führe ich das Programm im Useraccount als Admin in der ISE aus, wird alles erstellt. (Task und Subscript) Wird auch ausgeführt, nur der Kopiervorgang geht ohne Kopie der Datei aus.
Frage ich in der Kommandozeile dann get-item $PFADVARIABLE ab, bekomme ich die Werte angezeigt.

Und jetzt der Hammer.
Melde ich mich mit dem Adminaccount am Rechner an, und führe die ISE als Administrator aus ( zur Sicherheit) läuft auch alles wie geplant. Erstellen des Task, Script neu erstellen. Nur die Kopie funktioniert wieder nicht.
Bei Abfrage der $PFADVARIABLE bekomme ich die Meldung das diese NULL sind. Also nicht vorhanden, obwohl abgefragt und auch vom Programm verstanden.
Also für mich verständlich, das nicht kopiert wird, da kein Pfad.

Führe ich die ISE im ADmin Account normal aus ( Ohne als Administrator ausführen) wird das Subscript erstellt, jedoch kein Task. Und die PFADVARIABLE sind auch wieder gegeben.
Taskerstellung wird abgebrochen mit Register-ScheduledTask : Zugriff verweigert
In C:\PS\BackupQuery.ps1:99 Zeichen:6

Register-ScheduledTask $SName -InputObject $D


Obwohl ich im Adminaccount hänge. Als Principal setze ich "NT-AUTORITÄT\SYSTEM" ein um anmeldungsfrei den Taskscript laufen zu lassen.

Und nach rund 2 Wochen testen mit verschiedenen Accounts, Principals und Variablen bin ich immer noch nicht weiter.

Meine Bitte, wo muß ich schauen ( WIN10 oder PS) um die Rechte zur Variablensetzung und Taskerstellung möglich zu machen.
Vielleicht habe ich mich auch total verrannt. :-/ face-confused

Gruß
M


Update:
Also das Problem mit dem beschreiben der Ordner und den Variablen ist soweit erstmal gelöst.
https://answers.microsoft.com/en-us/windows/forum/windows_vista-security ...
Die Rechte auf den Taskordner waren überhaupt nicht für den Admin gegeben.

Es wird jetzt ein Task erstellt, ein Subscript erstellt und auch durch den TaskScheduler ausgelöst / ausgeführt.

Nur wird keine Kopie aus der angegebenen Datei in den angegebenen Ordner erstellt. :-( face-sad

Lasse ich aber das Subscript zur Kopie in der Powershell ISE ( Admin oder nicht ) laufen, wird eine Kopie im gewünschten Ordner erstellt.

Ist vielleicht jemanden dieses Phänomen bekannt?
Heiß diskutierte Inhalte
Off Topic
HomeOffice Pflicht - Büroaustattung vom Arbeitgeber?
h45okeg493sVor 1 TagFrageOff Topic35 Kommentare

Hallo zusammen, aufgrund der HomeOffice Situation wollte ich mal rumfragen, muss der Arbeitgeber neben der Hardware wie Notebook, etc. auch Büroausstattung wie Bürostühle zur ...

Server-Hardware
Gebrauchte Server von eBay-Kleinanzeigen
dh2411Vor 1 TagFrageServer-Hardware15 Kommentare

Hallo zusammen, neulich war ich auf eBay-Kleinanzeigen unterwegs und dort wurden mir einige Server vorgeschlagen. Ich habe dort auch meinen aktuellen Home-Server recht günstig ...

Backup
Backupmöglichkeit Teamviewer
gelöst greenhorn1Vor 1 TagFrageBackup16 Kommentare

Hallo, ich habe bei meiner Teamviewer Lizenz die Möglichkeit ein Backup des PC´s durchzuführen. Leider funktioniert das nicht! Nach Rückfrage an Teamviewer erhielt ich ...

Firewall
Sonicwall: Angreifer sind über eine SMA 100 ins eigene Netzwerk eingedrungen
Looser27Vor 1 TagInformationFirewall3 Kommentare

Bei SonicWal sind nach eigenen Angaben wohl Angreifer mit Hilfe von Zero-Day-Attacken ins eigene Netzwerk eingedrungen. Nach ersten Analysen handelt es sich dabei um ...

Webentwicklung
Webseite LAMP auf USB-Stick mit Minimalsystem?
mirmichVor 1 TagFrageWebentwicklung11 Kommentare

Hallo, eine Webseite soll "archiviert" aber lokal lauffähig bleiben. Die "neue Webseite" läuft auf einer aktuellen PHP Version - die "alte Webseite" auf einer ...

Grafikkarten & Monitore
Zweiter Bildschirm geht sporadisch immer aus?!
GeronimooVor 1 TagFrageGrafikkarten & Monitore8 Kommentare

Moin zusammen, ich habe ein Problem mit meinem 2. Monitor und zwar geht dieser sporadisch immer für 1-2 Sekunden aus oder flackert ein bisschen ...

Switche und Hubs
Kurioses Problem IP Adresse ändern am Cisco SG350 10p
gelöst Xaero1982Vor 21 StundenFrageSwitche und Hubs16 Kommentare

Moin Zusammen, ich habe hier einen neuen Cisco SG350 10p. Wie schon so oft wollte ich ihm eine neue IP geben, also gehe ich ...

TK-Netze & Geräte
Panasonic NS700 - Endgeräte klingeln nicht, bzw. Gespräche kommen nicht an
gelöst jensgebkenVor 20 StundenFrageTK-Netze & Geräte24 Kommentare

Hallo Gemeinschaft, nun habe ich mir für meine gebrauchte Anlage doch noch eine gebrauchte BRI gekauft - Installation klappte soweit auch - raustelefonieren kann ...