Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Buffalo Linkstation LS-WXL (2x 1TB) RAID 0 wiederherstellen

Mitglied: Woodstok79

Woodstok79 (Level 1) - Jetzt verbinden

15.12.2015, aktualisiert 04:54 Uhr, 5702 Aufrufe, 9 Kommentare

Hallo Forum,

ich verzweifle beim Versuch meine Daten von der Buffalo Linkstation LS-WXL mit 2x 1TB im RAID 0 Verbund wiederherzustellen. Vorab: mir war klar, dass RAID 0 nicht die beste Wahl ist, ich hatte leider nur zu dem Zeitpukt schon > 1TB Daten auf dem NAS angesammelt. Habe daher Backups von ca. 95% der Daten - mir geht es nun darum die letzten 5% zurück zu bekommen.

Laut Aussage vom Buffalo Support ist ein Festplattencontroller defekt (Fehler E07) - mit dem Hinweis, dass das Gehäuse defekt ist und die Festplatten noch benutzbar sind. Die defekte LS-WXL springt nach mehrmaligem Ein-und Ausschalten wieder an. Die rote LED am Gehäuse blinkt 1x lang, 4x kurz - ich nehme an, das verweist auf einen Fehler E14, denn die Buffalo Software gibt folgendes an:
Fehler:
E14:RAID-Array 1 kann nicht eingehängt werden. (2015/49/14 21:49:59)
E16:Laufwerk 2 wurde nicht gefunden. (2015/50/14 21:50:32)
--> wenn ich die Aussage vom Support richtig deute, ist der Controller des Laufwerks 2 defekt - der Controller sitzt im Gehäuse, richtig?

Mein Lösungsweg war:
Ich bin davon ausgegangen, dass ich "nur" ein neues Gehäuse brauche, Festplatten einbaue und die Daten wieder da sind. Nun habe ich hier ein brandneues Leergehäuse LS441e - die Anleitung besagt aber, dass die Festplatten die eingebaut werden, neu partitioniert werden. Wenn ich die LS441e ohne Platten ins Netz hänge, kann ich Sie überhaupt nicht erreichen. Ich habe derzeit noch eine Anfrage an Buffalo USA laufen - die haben jedoch zunächst auf das Manual verwiesen.

Vielleicht hat jemand von Euch eine passgenaue Lösung parat:
a. gibt es eine Möglichkeit die LS441e mit beiden 1TB Festplatte zu starten, ohne neu zu partitionieren und wieder auf meine Daten zuzugreifen?
b. könnte ich den Inhalt beider Laufwerke auf ein drittes kopieren und dann die Daten wieder herstellen? Z.B. über eine SATA - USB Schnittstelle? Habe hier schon was in den Foren dazu gelesen... Kann man z.B. die Inhalte von den Festplatten 1 und 2 kopieren und danach beide zusammenfügen? - der RAID Verbund müsste doch auf der Festplatte 1 sein...

An Hardware habe ich derzeit:
- Laptop
- LS-WXL (mit offenbar defektem Festplattencontroller für Laufwerk 2)
- Festplatte 1 (1TB) - mit meinen Daten (in Verbund RAID 0 mit Festplatte 2)
- Festplatte 2 (1TB) - mit meinen Daten (in Verbund RAID 0 mit Festplatte 1)
- LS441e
- Festplatte 3 (2TB) - neu

und ... meine Antworten werden zeitverzögert kommen - ich wohne in den USA.

Vielen Dank, dass Du bis hierhin gelesen hast. ;)
Gruß
Björn
Mitglied: Arch-Stanton
15.12.2015 um 08:48 Uhr
Einfach mal einsehen, daß die Daten weg sind. Lehrgeld bezahlt und nie wieder mit Raid 0 herum experimentieren.

Gruß, Arch Stanton
Bitte warten ..
Mitglied: runasservice
15.12.2015, aktualisiert um 09:51 Uhr
Hallo,

Zitat von Woodstok79:
Laut Aussage vom Buffalo Support ist ein Festplattencontroller defekt (Fehler E07) - mit dem Hinweis, dass das Gehäuse defekt ist und die Festplatten noch benutzbar sind. Die defekte LS-WXL springt nach mehrmaligem Ein-und Ausschalten wieder an.

Wenn nur der "Controller" defekt sein soll, dann würde ich den Kontroller tauschen, sollte ja nicht das Problem sein:


6b3f10e98ba4660385bf0de8937d3f04 - Klicke auf das Bild, um es zu vergrößern


Ich würde aber gleich das ganze "Mainboard" tauschen:

f557c449c72673a911e6a8894e57efb7 - Klicke auf das Bild, um es zu vergrößern

Lass Dir (einfach) die Teile vom Buffalo Support schicken.

Mit freundlichen Grüßen Andreas
Bitte warten ..
Mitglied: ypstech
15.12.2015 um 09:52 Uhr
Hallo Woodstock

M.E. besteht wenig Hoffnung... Die Frage-die aber nur Buffalo beantworten kann- ist: sind die Metadaten zur RAID- Geometrie auf den Festplatten oder (vereinfacht gesagt) im RAID- Controller hinterlegt?
So wie Du das schilderst scheinen sie nicht auf den Platten hinterlegt zu sein, da hast Du keine Chance!
Interessant wäre auch zu wissen was fürn Dateisystem verwendet wird und obs ein Hardware oder Fakeraid ist. Bei nem ext- Dateisystem mit mdraid bestände vielleicht die Möglichkeit das System mit nem Linux auszulesen, das sollte dann aber jemand machen der RICHTIG Ahnung hat!
Bitte warten ..
Mitglied: runasservice
15.12.2015, aktualisiert um 11:25 Uhr
Zitat von ypstech:

M.E. besteht wenig Hoffnung... Die Frage-die aber nur Buffalo beantworten kann- ist: sind die Metadaten zur RAID- Geometrie auf den Festplatten oder (vereinfacht gesagt) im RAID- Controller hinterlegt?
So wie Du das schilderst scheinen sie nicht auf den Platten hinterlegt zu sein, da hast Du keine Chance!

Die komplette Konfiguration ist auf den Festplatten hinterlegt. Du kannst also ganz leicht die Festplatten von einer defekten Buffalo Linkstation LS-WXL in eine neue Linkstation LS-WXL einbauen, einschalten und fertig.

Man kann sich die Mühe machen und die Elektronik tauschen oder einfach ein neues Leergehäuse (LS-WXL) kaufen, gerade nochmal getestet (hier mit Raid 1 ).

Problem beim TO ist, das er versucht seine Festplatten aus einer Buffalo Linkstation LS-WXL ohne Umwege in eine Buffalo Linkstation LS441e einzubauen, das wird meiner Meinung nach nicht funktionieren.

Also erstmal die Festplatten wieder in eine (neue) Linkstation LS-WXL einbauen, Backup anlegen und dann die Festplatten in eine Buffalo Linkstation LS441e einbauen. Die LS441e wird dann die Festplatten neu einrichten, Backup einspielen, fertig.....


Mit freundlichen Grüßen Andreas
Bitte warten ..
Mitglied: ypstech
15.12.2015 um 11:50 Uhr
na wenns auf den Platten hinterlegt ist sollte es gehen. Die Möglichkeit das RAID (vom älteren NAS) ins neue zu importieren gibts wohl leider nicht? Ist ja eigentlich der selbe Hersteller und das OS dürfte auch ähnlich sein...
Es gibt für solche Fälle auch Software (RIAD Reconstructor" o. ä. , kostet aber was und sollte auch nur von Fachleuten benutzt werden
Bitte warten ..
Mitglied: runasservice
15.12.2015 um 12:23 Uhr
Zitat von ypstech:

Es gibt für solche Fälle auch Software (RIAD Reconstructor" o. ä. , kostet aber was und sollte auch nur von Fachleuten benutzt werden

Die Buffalo Linkstation LS-WXL ist aus der Plastik-Klasse. Brauchbare Ersatzteile kosten wenig Geld. Du bekommts eine gebrauchte LS-WXL ab 20,- €. Ich würde deshalb keinen Aufriss machen.

MfG Andreas
Bitte warten ..
Mitglied: Woodstok79
15.12.2015, aktualisiert um 12:37 Uhr
Hallo zusammen,

WOW!
Danke für Eure produktiven und schnellen Antworten. Ich denke ich werde folgendes machen:
1. ein zweites, neues NAS mit 2x 2TB (und RAID 1@Arch Stanton) aufsetzen und die 95% wiederbeleben, um handlungsfähig zu sein. Denn laut Andreas kann ich mit der LS441 eh nix wiederherstellen. Somit habe ich ewig Zeit, die 5% wieder zu holen.
2. den Buffalo Support nach einem neuen Controller fragen. Wenn das nicht geht,
3. bei Ebay ein LS-WXL Leergehäuse ersteigern - hierzu noch eine Frage - muss das die gleiche Bauform sein? LS-WX2.0TL/R1 EU - oder kann ich ein Gehäuse aus den USA verwenden? Sprich: Wie Baugleich müssen die Controller sein?

Die Festplatten direkt auslesen oder zu rekonstruieren erscheint mir als letzte Möglichkeit. Da müsste ich mir viel Wissen aneigenen außerdem habe ich mit der o.A. Lösung einen großen Vorteil: Zeit. ;)

Wie sicher ist es denn, dass der Controller defekt ist und nicht die Platte selbst? Mache ich etwas kaputt, wenn ich die Platten mal tausche und die LS-WXL wieder hochfahre, um den Controller als Fehlerquelle eindeutig zu identifizieren?

Viele Grüße
Björn
Bitte warten ..
Mitglied: runasservice
15.12.2015, aktualisiert um 13:39 Uhr
Zitat von Woodstok79:

Wie sicher ist es denn, dass der Controller defekt ist und nicht die Platte selbst? Mache ich etwas kaputt, wenn ich die Platten mal tausche und die LS-WXL wieder hochfahre, um den Controller als Fehlerquelle eindeutig zu identifizieren?

Die Fehler E07,E14, E16 sprechen schon für ein Fehler im Kontroller/Mainboard. Du hast aber recht, die Platten können auch einen Totalschaden haben. Du kannst auch einfach mal eine neue Festplatte einbauen um das zu testen.

Ich bin jetzt davon ausgegangen, das Du das soweit mit dem Service abgesprochen hast und dein Festplatten in Ordnung sind

Also, Platten ausbauen und an einen PC anschliesen. Jetzt kannst Du die Platten prüfen. Buffalo nutzt die Software MDADM für das Raid. Entweder der kostenpflichtige UFS-Explorer oder eine Linux Live-CD benutzen.

Am einfachsten sollte es für dich mit UFS-Explorer sein, hier die passende Anleitung:

http://www.ufsexplorer.com/inf_linkstation.php


Mit freundlichen Grüßen Andreas
Bitte warten ..
Mitglied: Woodstok79
15.12.2015, aktualisiert um 13:41 Uhr
Hallo Andreas,

Vielen Dank für Deine informative Antwort und die Bestätigung, dass die Fehler für den Controller sprechen. Der Buffalo Service weiß ja auch nur, dass die Fehler E07, E14 und E16 aufgetreten sind. Ob zusätzlich die Festplatte einen Schaden hat kann wohl niemand anhand der Fehler sagen - ohne Controller keine Diagnose. Leider bin ich Hardware technisch eingeschränkt, denn ich habe nur einen Laptop und kann die Platte nicht an einen PC anschließen. Eine SATA - USB Schnittstelle + UFS Explorer oder über Linux ist derzeit zu kostspielig und zu zeitaufwendig.

Aber, gehen wir mal davon aus, dass die Platten in Ordnung sind. Somit werde ich zunächst Deinen Rat befolgen, keinen Aufriss machen und (a) einen neuen Controller besorgen (Anfrage läuft bei Buffalo) oder alternativ (b) ein gebrauchtes Leergehäuse ersteigern.
Sollte das nicht funktionieren, muss ich mich tiefer in diese Challenge einarbeiten. Ich halte Euch auf jeden Fall auf dem Laufenden. (Kann allerdings ein paar Wochen dauern, bis ich ein Leergehäuse aus Deutschland mitbringe) - aber ich hab ja Zeit...

DANKE! DANKE! DANKE! You made my day!

Beste Grüße
Björn
Bitte warten ..
Ähnliche Inhalte
Netzwerkprotokolle
NAS-Server LS-WXL und Windows 10
Frage von klansoftNetzwerkprotokolle9 Kommentare

Ein freundliches Hallo in die Runde! Ich schlage mich gerade mit einem Problem im Bereich NAS-Server in Verbindung mit ...

Festplatten, SSD, Raid

Buffalo LinkStation LS220 6 TB (2x 3 TB) Sind 6 TB nutzbar?

Frage von 133808Festplatten, SSD, Raid9 Kommentare

Liebe Community, ich benötige ein NAS mit 6 TB Festplatte. In diesem Model (siehe Screen), sind 2 x 3 ...

SAN, NAS, DAS

Buffalo ls-qvl startet nicht mehr

gelöst Frage von Rocco72SAN, NAS, DAS7 Kommentare

Hallo Community, ich habe schon das Forum durchsucht, aber nicht brauchbares gefunden also werde ich hier meine Frage nochmal ...

SAN, NAS, DAS

Buffalo LinkStation 220D wird nicht erkannt

gelöst Frage von 21243SAN, NAS, DAS6 Kommentare

Moin, moin. Eine neue LS 220D wurde ausgepackt und mit einer fabrikneuen WD 1TB HDD bestückt. Dann wurde die ...

Neue Wissensbeiträge
Sicherheits-Tools

TrendMicro Worry-Free Business Security 10.0 SP1 - Jetzt in Deutsch verfügbar! (Windows 10 1903 Support)

Tipp von TrinXx vor 1 TagSicherheits-Tools1 Kommentar

Moin! Nach wochenlangem Warten wird Trend Micro das SP1 für WFBS 10 voraussichtlich am 26.08.19 veröffentlichen. Ich habe das ...

Hyper-V
Setup VM W2016 startet nicht in Hyper-V 2016
Erfahrungsbericht von keine-ahnung vor 2 TagenHyper-V4 Kommentare

Moin, sitze gerade über meinem neuen Server und versuche, die VM auf den Host zu prügeln. Jetzt wollte ich ...

Server-Hardware

HPE Proliant ML350P Gen8 Probleme mit Zugriff auf Raid-Volumes

Erfahrungsbericht von goscho vor 2 TagenServer-Hardware1 Kommentar

Hallo Leute, das Problemgerät: HPE ML350P G8 Windows Server 2012R2 HyperV-Host 8 x 300 GB 10K SAS HDD (1 ...

Humor (lol)

"Linux und 5 Gründe Warum man kein Windows verwenden sollte sondern Ubuntu Linux"

Information von Snowbird vor 4 TagenHumor (lol)9 Kommentare

Gerade gefunden. Ja, ist etwas älter, aber irgendwie lustig?

Heiß diskutierte Inhalte
Backup
Veeam Backup Endpoint Free sichert nicht alle Dateien in AppData
gelöst Frage von speedy26gonzalesBackup12 Kommentare

Hallo, ich sollte ein paar Dateien in C:\Users\xyc\AppData\Local\Microsoft\Outlook wieder herstellen. Auf dem Benutzerkonto ist in Outlook ein IMAP Konto ...

Server
Ein Server ins Haus stellen. Was brauche ich dafür?
Frage von JoschiTomServer10 Kommentare

Hallo Community, ich spiele mit dem Gedanken eine Server mir zu holen. Was brauche ich dafür? Und wie sind ...

Windows 10
Windows 10 Backup auf Netzwerk Storage
Frage von Futschel2608Windows 1010 Kommentare

Hallo geehrte Mitstreiter Innen, Wir wollen in unserer Windows 10 Domäne den Einzelnen Usern ermöglichen ihre Desktop PC's zusichern. ...

Batch & Shell
Mittels SED Text ersetzen in Anführungszeichen
gelöst Frage von nekronBatch & Shell9 Kommentare

Moin … bin nicht wirklich der SED/regex Mensch, vielleicht kann mir jemand auf die Schnelle Helfen :) ich habe ...