Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Captive Portal - Verbindung unterbrochen, keine Anmeldung möglich

Mitglied: micson

micson (Level 1) - Jetzt verbinden

04.01.2014, aktualisiert 13:56 Uhr, 6293 Aufrufe, 6 Kommentare, 1 Danke

Hallo,

habe für unsere Gäste WLAN bereitgestellt und dies mit pfSense und dem Captive Portal realisiert.
Siehe Beitrag: https://www.administrator.de/link/netzwerkkonfiguration-und-firewall-reg ...

Leider beklagten Gäste Verbindungsabbrüche (Nach ca. 30-45min war keine Verbindung mehr möglich.) und eine neuerliche Anmeldung über das Captive Portal war nicht möglich.
Ich habe nun nochmals mittels Laptop die Funktion überprüft. Die Anmeldung über das Portal verlief problemlos und die Verbindung war gut. Ich habe anschließend den Empfang in mehreren Räumen überprüft.
Plötzlich hatte ich das selbe Problem. Beim Auftruf einer Internet-Seite wird das Captive Portal eingezeigt, nach erneuter Eingabe von Zimmernummer und Passwort (durch pfSense User Manager) ist jedoch kein Login möglich. Auch ein Trennen und erneutes Verbinden der WLAN-Verbindung am Laptop bringt keine Lösung.

Ursprünglich erfolgte die Einrichtung mit pfSense 2.0.3 und ich habe vor ca. 3 Wochen eine Umstellung auf die Version 2.1 gemacht. Ob es bereits bei der vorigen Version Schwierigkeiten gab, kein ich leider nicht genau sagen, da nicht immer Rückmeldungen von den Gästen erfolgt sind.
Es wurde für jedes der 6 Zimmer eine Zimmernummer mit zugehörigem Passwort im User Manager angelegt und der Gruppe "Guests" zugewiesen. In den Captive Portal-Einstellungen wurde folgende Auswahl getroffen:

e9f9ee587cca4b02d26698f9a1c9b5aa - Klicke auf das Bild, um es zu vergrößern

Idle Timeout: 120min
Begrenzung der Bandbreite
Weiterleitung auf unsere Webseite


Wo könnte ich die Ursache finden? Ich bedanke mich für Eure Ratschläge!

Gruß
micson


User Manager - Privileges

ec5153310cad8e9e6396cea65dda9f92 - Klicke auf das Bild, um es zu vergrößern
Mitglied: aqui
04.01.2014 um 12:41 Uhr
Du solltest zuallererst mal den Grund der Verbindungsabbrüche klären ! Kann das z.B. an zu schlechter HF Abdeckung der APs liegen ?
Möglich ist auch das du im CP Setup aus Versehen nach 30 oder 45 Minuten einen Zwangsabbruch oder Zwangslogout gesetzt hast.
Normalerweise wenn du ohne Zeitlimit arbeitest darf es keine Abbrüche geben.
Zudem solltest du im Setup die Option "Allow only User/Groups with CP priviliges" anhaken.
Ein Testsetup mit 2.1 rennt hier mit einer embedded miniPCI als Bridge in ein CP Segment mit Cisco WAP 321 fehlerfrei und ohne Abbrüche nach dem Login.
Allerdings hier mit Einmalpasswörtern und nicht mit statischen User/Password.
Letzteres ist aus Sicherheitsgründen nicht zu empfehlen. denn die Zugangsdaten werden meist getauscht und sind nach wenigen Tagen kompromittiert. Weisst du aber sicher selber. Sinnvoller ist ein kleiner Webserver der die Voucher bequem per SMS sendet oder als WebGUI
https://www.administrator.de/contentid/193763
Kläre also erstmal die technischen Gründe des Verbindungsabbruchs das wäre der erste Schritt !!
Bitte warten ..
Mitglied: micson
04.01.2014 um 13:14 Uhr
Hallo aqui,

Verbindungsschwierigkeiten kann ich im Moment aussschließen.

Zudem solltest du im Setup die Option "Allow only User/Groups with CP priviliges" anhaken.

Setze ich den Haken und versuche mich über das Portal anzumelden, erscheint die Fehlermeldung "invalid credentials specified". Ich habe den Haken wider entfernt und die Netzwerkverbindung am Laptop getrennt und anschließend wieder hinzugefügt. Nun ist die Anmeldung am Portal wieder möglich. Im Moment tippe ich auf den User Manager. Dort sind aber alle 6 Zimmer der Gruppe "guests" hinzugefügt. Die "System Privileges" sind alle ausgewählt.
Bitte warten ..
Mitglied: aqui
04.01.2014 um 13:18 Uhr
Das riecht dann aber nach einem Konfig Fehler im lokalen User Manager !! Wenn du das anhakst kann dioch niemals "invalid credentials specified" kommen. Das würde ja bedeuten das du diesen Usern keine Captive Portal Priliges im User Manager zugewiesen hast.
Vermutlich ist hier also ein Konfig Fehler.
Bitte warten ..
Mitglied: micson
04.01.2014 um 14:00 Uhr
Ich glaube, hiermit ist das Problem gelöst.
Ich habe bei der Benutzergruppe "Guests" folgende Privilegien hinzugefügt:

User - Services - Captive portal login (siehe Anfangspost)

Ich werde es die nächste Zeit beobachten und gebe eine kurze Rückmeldung, ob dies die einzige Ursache war.

Vielen Dank inzwischen!
Bitte warten ..
Mitglied: aqui
04.01.2014 um 15:09 Uhr
Das fixt es mit Sicherheit !
Wie gesagt...du solltest besser Abstand von statischen User/Pass Kombinationen nehmen und mit Vouchern arbeiten. Das ist erheblich sicherer und verhindert generell solche Setup Fehler. Deine Entscheidung....
Bitte warten ..
Mitglied: micson
21.01.2014 um 19:40 Uhr
Hallo,

das Problem war damit leider nicht gelöst. Aber ich habe jetzt eine heiße Spur. Ich habe nämlich zusätzlich zu den AP's einen Repeater in Verwendung (http://www.avm.de/de/Service/Service-Portale/Service-Portal/index.php?p ...). Und jedes Mal, wenn die Anmeldung über das Captive Portal in Reichweite des Repeaters erfolgte, der Sendebereich aber dann verlassen wurde, ging die Verbindung verloren und keine weitere Anmeldung war möglich. Stecke ich den Repeater aus und verwende nur die AP's tritt dieses Problem nicht auf. Nach drei Versuchen immer das selbe Ergebnis.
Deshalb hatte ich im VLAN-Netz "Privat" nie Verbindungsprobleme, da der Repeater nur das Gastnetz verstärkt.

Unterstützt der Universal Repeater Mode diese Funktion nicht?
Bitte warten ..
Ähnliche Inhalte
Netzwerke

PfSense - Captiv Portal in einer Wohngruppe zur Nutzungsbegrenzung

Frage von AranoNetzwerke4 Kommentare

Moin moin. Wir möchten gerne in unseren Wohngruppen Internet zu Verfügung stellen bzw. es ausbauen. Derzeit wird das nur ...

Netzwerke

Weiterleitung nach Anmeldung im Captive Portal

gelöst Frage von MLangHSENetzwerke1 Kommentar

Hallo, ich habe eine Frage bzgl. des Tutorials zum Theme Captive Portal wie hier beschrieben: Es geht darum ob ...

Router & Routing

PfSense - VPN-Verbindung über Captive Portal?

Frage von micsonRouter & Routing8 Kommentare

Hallo, seit mehreren Jahren biete ich unseren Gästen erfolgreich einen WLAN-Zugriff über das Captive Portal von pfSense an. Jetzt ...

LAN, WAN, Wireless

Pfsense - Captive Portal in verbindung mit Squid(Guard)

gelöst Frage von sleeplessnightLAN, WAN, Wireless2 Kommentare

Hey ihr, Ich erkläre einmal, wie das bei mir aufgebaut ist: 1) CP sitzt im VLAN. 2) FW Rule, ...

Neue Wissensbeiträge
Python

Sie meinen es ja nur gut - Microsoft hilft python-Entwicklern auf unnachahmliche Weise

Information von DerWoWusste vor 1 TagPython2 Kommentare

Stellt Euch vor, Ihr nutzt python unter Windows 10 und skriptet damit regelmäßig Dinge. Nach dem Update auf Windows ...

Sicherheits-Tools

TrendMicro Worry-Free Business Security 10.0 SP1 steht in Englisch bereit mit Unterstützung für Windows 10 1903 (May Update)

Information von VGem-e vor 1 TagSicherheits-Tools1 Kommentar

Moin Kollegen, Dann kommt wohl demnächst auch die deutschsprachige/europäische Version zur Auslieferung. Gruß VGem-e

Batch & Shell
PowerShell Konferenz - Videos online
Information von NetzwerkDude vor 1 TagBatch & Shell

Abend, die Tage werden Videos der Talks von der diesjährigen EU Powershell Konferenz hochgeladen, sind einige Interessante dabei: MFG ...

Windows Update

Windows 10 1903 Updates über Wsus erst nach Auswahl weiterer Produktkategorie

Information von Spirit-of-Eli vor 3 TagenWindows Update6 Kommentare

Moin, den Tipp habe ich hier noch nicht gesehen. Er adressiert all diejenigen, die Windows 10 1903 über einen ...

Heiß diskutierte Inhalte
Erkennung und -Abwehr
Unerklärlicher Gestank im EDV-Raum - "neues" Gebäude und keine offenkundige Ursache feststellbar!
Frage von VGem-eErkennung und -Abwehr29 Kommentare

Moin Kollegen, ich habe seit heute Morgen das Problem, dass in unserem EDV-Raum ein total unerklärbarer Gestank herrscht! Ich ...

Verschlüsselung & Zertifikate
Bitlocker oder Veracrypt unter Win10? Was ist hinsichtlich Performance, Sicherheit, Backup und Kompatibilität besser?
Frage von PluwimVerschlüsselung & Zertifikate23 Kommentare

Guten Morgen, bei mir wird demnächst eine neue Platte fällig, weil ich mein Win7-System auf Win10 umstellen will. D.h. ...

LAN, WAN, Wireless
Warum ist die Datenübertragung per WLAN zu bestimmten Servern sehr langsam?
Frage von PluwimLAN, WAN, Wireless18 Kommentare

Hallo Netzwerker, beim Einrichten des Notebooks für einen Bekannten fiel mir auf, dass Downloads per WLAN teilweise extrem lahm ...

Router & Routing
Microsoft Server: Kopierlast auf bestimmte NIC legen für Backup
gelöst Frage von LollipopRouter & Routing15 Kommentare

Guten Tag Mit zwei Servern machen wir eine einfache Datenspiegelung als Teil unseres Backup-Systems. Dazu wünsche ich mir einen ...