Drucker verschwunden im Terminalserver-Modus

Mitglied: 9603

9603

13.02.2005, aktualisiert 15.02.2005, 11345 Aufrufe, 7 Kommentare

auf dem TS 2003 sind mit einem mal alle netzwerkdrucker verschwunden und das startmenü ist auf das minimum abgemagert.

bis dato war das startmenü in üblicher weise aufgebaut, wie man es so kennt.
jetzt ist es auf ein minimum reduziert (abmelden-suche-programme).
die standarddrucker sind ebenfalls verschwunden (waren als netzwerkdrucker allen benutzern zur verfügung gestellt)

ich hab bereits versucht, die drucker lokal neu zu installieren, aber kein erfolg.
die terminal-benutzer haben weiter das eingeschränkte menü und es sind keine drucker zu finden.
gehe ich über suchen-gesamtes verzeichnis durchsuchen dann sind die drucker aufgelistet und ich kann sie auch aufrufen und verbinden. das gilt dann aber nur für die jeweilige session. beim nächsten anmelden sind die drucker wieder alle weg. an den rechten der benutzer kann es somit also nicht liegen.

das kuriose: selbst wenn sich der admin über terminal einwählt bekommt er nur noch das reduzierte menü und ebenfalls keine drucker mehr in sicht.

ich fürchte, dass es was mit den profilen zu tun und dort dauerhaft die druckereinträge futsch sind.

wer kann abhilfe schaffen?

thx 4 help
Mitglied: fritzo
13.02.2005 um 19:43 Uhr
Hi,

das Problem sind wahrscheinlich nicht die Drucker, sondern eine Policy, die auf dem TS zieht. Habt Ihr evtl. jüngst eine Client-Policy aktiviert und diese zieht runter bis auf die OU, in der sich der TS befindet? Oder hat jemand an der lokalen Policy des TS herumgespielt?

Versuch am besten, auf der (dedizierten) OU für den Terminalserver die Policy-Vererbung zu deaktivieren und schreib für die TS eine eigene Policy. Diese weist Du den Usern, aber nicht den Admins zu.

Grüße,
fritzo
Bitte warten ..
Mitglied: 9603
9603 (Level 1)
13.02.2005 um 22:23 Uhr
thx 4 help.

denke auch, dass da sowas in der art passiert ist bzw jemand das getan hat.
kannst du mir nen tip geben, wie ich das rausfinden kann bzw wo ich das dann rückgängig mache?
hab imho keinen plan, wo ich danach suchen soll....

die ts-user haben eine eigene ou mit zugehöriger sicherheitsrichtline. da hab ich reingeschaut und nix gefunden. auch ausprobiert, alles auf "nicht konfiguriert" zu setzen. ohne erfolg. an dieser richtlinie scheint es also tatsächlich nicht zu liegen.

die admins liegen unter dem ordner der standardmässig angelegten users nicht in dieser ou.
Bitte warten ..
Mitglied: fritzo
14.02.2005 um 02:55 Uhr
Hi,

dann ist es wahrscheinlich eine Policy, die oberhalb gesetzt ist und jetzt zieht - evtl. wird sie sogar mit "force" bis nach unten durchgejagt. Versuch mal diese zu finden.

Deaktiviere nach Möglichkeit die Vererbung und bau Dir für die TS eigene GPOs sonst ziehst Du auf dem TS alle Policies für Clients und das ist nicht immer so wirklich witzig (cogito ergo sum).

Wenn Du sehen willst, welche Policies gezogen werden, kannst Du das zB mit "gpresult" in der Dosbox. Ansonsten wie gesagt- schau mal in der lokalen Sicherheitsrichtlinie auf dem Server selbst.

Die Policies findest Du, wenn Du die MMC Active Directory Benutzer und Computer (dsa.msc) öffnest, auf einer der OUs (auch auf der obersten) die Eigenschaften aufrufst und dann den Karteireiter "Gruppenrichtlinien" rechts anklickst. Bevor Du hier etwas änderst, frag aber besser jemand, der sich damit gut auskennt, weil Du sonst einiges damit zerschießen kannst.

Grüße,
fritzo
Bitte warten ..
Mitglied: nmp
14.02.2005 um 07:45 Uhr
Hallo,

wir haben bei uns im Betrieb auch einen Terminal Server. Hatte auch schon das Problem mit den Druckern, dies konnte ich dann durch neustarten folgenden Dienstes beheben:

Druckerwarteschlange

Leider denke ich das wird dir nicht viel Helfen da ja dein Startmenü reduziert ist.


mfg NMP
Bitte warten ..
Mitglied: 9603
9603 (Level 1)
14.02.2005 um 14:15 Uhr
Deaktiviere nach Möglichkeit die
Vererbung und bau Dir für die TS eigene
GPOs sonst ziehst Du auf dem TS alle Policies
für Clients und das ist nicht immer so
wirklich witzig (cogito ergo sum).

hab ich getan, ohne erfolg !!!

Wenn Du sehen willst, welche Policies
gezogen werden, kannst Du das zB mit
"gpresult" in der Dosbox.

ich hab auf dem TS keine möglichkeit mehr eine dos-box aufzumachen, da ausführen net mehr da und taskmanager deaktiviert. weiter möglichkeit zum öfnen einer dos-box kenne ich nicht.

Ansonsten wie gesagt- schau mal in der
lokalen Sicherheitsrichtlinie auf dem Server
selbst.

auf eine lokale policy auf dem ts kann ich nicht zugreifen bzw. es gibt ja dort gar keine, weil in der domäne verankert und die wird vom domänencontroller verwaltet.

Die Policies findest Du, wenn Du die MMC
Active Directory Benutzer und Computer
(dsa.msc) öffnest, auf einer der OUs
(auch auf der obersten) die Eigenschaften
aufrufst und dann den Karteireiter
"Gruppenrichtlinien" rechts
anklickst.

ich hab alles durchgemacht (alle ou´s und die domäne selbst) und so ziemlich alles auf die standardwerte zurückgesetzt. keine auswirkungen auf den TS. und am TS darf ich nüschd mehr machen. es kann nur ne lokale geschichte auf dem TS selber sein, aber ich weis nicht, wo ich da suchen sollte, da er ja lediglich die standardverwaltung drauf hat.

ich verzweifel jetzt bald...heul ;-) face-wink)
Bitte warten ..
Mitglied: fritzo
14.02.2005 um 21:07 Uhr
Hi,

letztes Mittel wäre, die Sicherheitseinstellungen zurückzusetzen. Versuch, an eine dosbox ranzukommen und gib dort folgendes ein:

secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose

Es wäre gut, wenn ihr ein funktionierendes Backup des Servers hättet.

Grüße,
fritzo
Bitte warten ..
Mitglied: 9603
9603 (Level 1)
15.02.2005 um 11:13 Uhr
ich habs rausgefunden woran es lag: es lag an registrywerten, die falsch gesetzt waren.

auf dieser seite bin ich fündig geworden: http://support.microsoft.com/default.aspx?scid=kb;DE;829380
da steht zwar nur was über die version von xp home ist aber analog übertragbar auf die server-registry.

nachdem ichs mit dem current user erfolgreich ausprobiert hatte, musste ich es nur noch unter HK_LocalMachine analog übertragen und da war es wieder mein startmenü.
Bitte warten ..
Heiß diskutierte Inhalte
Windows 7
Windows 7 fast alle Programme melden zeitweise "keine Rückmeldung"
GerdlangVor 1 TagFrageWindows 732 Kommentare

Im Oktober 2020 wurde mein Rechner von einem Virus befallen. Habe ihn dann zur Softwarereparatur in eine renomierte IT-Werkstatt gegeben. Danach war alles OK. ...

Windows Server
Server fährt um 22:04 einfach runter
achim22Vor 1 TagFrageWindows Server17 Kommentare

Hi, ich habe seit drei Tagen das Problem das sich das Blech einfach runter fährt, ohne jeglichen Grund. Dachte erst es liegt an den ...

Off Topic
Probearbeit als Systemadministrator
xsheynVor 1 TagAllgemeinOff Topic10 Kommentare

Hallo zusammen, aktuell suche ich eine neue Stelle und wurde nun für 2 Tage zum Probearbeiten eingeladen. Die Stelle wäre als IT-Systemadministrator im Service ...

Notebook & Zubehör
Notebook zurücksetzen "ohne" Passwort abfrage
gelöst ZeppelinVor 1 TagFrageNotebook & Zubehör11 Kommentare

Hallo zusammen, ich habe ein Lenovo ThinkPad und möchte dieses so einrichten, dass es nicht möglich ist dieses ohne weiteres Zurückzusetzten. Ich habe hierzu ...

Windows 10
Microsoft verkündet das Support-Ende für Windows 10 Home und Pro
IT-SpeziVor 1 TagInformationWindows 1011 Kommentare

Moin, laut der offiziellen Microsoft-Webseite ist im Jahr 2025 Schluss mit dem Support für Windows 10 Home und Windows 10 Pro. Am 14. Oktober ...

Netzwerkgrundlagen
Firewall-Frage in Verbindung mit FritzBox-VPN
SarekHLVor 17 StundenFrageNetzwerkgrundlagen32 Kommentare

Hallo zusammen, ich habe folgenden Aufbau (bisher ohne die im Bild schon eingezeichnete Firewall): Ziel ist es, über das VPN kommende Anfragen nur zur ...

Microsoft
Richtiges Patch Management?
leon123Vor 1 TagFrageMicrosoft7 Kommentare

Hallo zusammen, wie macht ihr das mit dem Patch Management? Benutzt ihr spezielle Tools von Drittherstellern (ich habe mir Atera angesehen) oder lässt ihr ...

Installation
Firmennetzwerk Release
gelöst LeohansyVor 1 TagAllgemeinInstallation5 Kommentare

Hallo In einem Firmennetzwerk ist Anwender Software installiert , die mehrere Arbeitsplätze und Abteilungen nutzen. Ist die Software dann auf einem Server installiert ? ...