Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Git installiert, aber wie erstes Repository mit ZendStudio hochspielen ?

Mitglied: TorstenE

TorstenE (Level 1) - Jetzt verbinden

19.10.2013 um 12:00 Uhr, 1971 Aufrufe, 11 Kommentare

Ich habe auf einem Ubuntu Server git installiert und ein "leeres" Repository erstellt.

[code]
cd /repos
mkdir test.git
cd test.git
git --bare init
exit
[/code]

Dateien etc gibt es ja noch nicht, die liegen auf meinem Windows Rechner mit Zend Studio.

Wenn ich jetzt über ZendStudio praktisch mein "Projekt" pushen will, erhalte ich folgende Fehlermeldung
"ssh://user@host/repos/test.git fatal: /repos/test.git does not appear to be a git repository"

Vermutlich muß ich noch irgend etwas auf dem Ubuntu Server einstellen, aber was ?
Die Angaben zu "master" und "origin" sind ja auch irgendwie noch nicht definiert


Torsten.E





Mitglied: certifiedit.net
19.10.2013, aktualisiert um 12:08 Uhr
Moin Torsten,

bei Fragen zu Ubuntu ist das Wiki von Ubuntu immer sehr aufschlussreich.

http://wiki.ubuntuusers.de/Git

In der Regel findet man dort auch nur Trivia, die einem später in die Hände spielen.

Viele Grüße,
Christian
certified IT

PS: Als Ergänzung dazu: http://scie.nti.st/2007/11/14/hosting-git-repositories-the-easy-and-sec ...
Bitte warten ..
Mitglied: TorstenE
19.10.2013 um 12:30 Uhr
Danke Christian, aber soweit bin ich mit den Infos bisher ebenfalls gekommen.

Ich verstehe es im Augenblick so, dass das "leere" Repository von ZendStudio nicht richtig erkannt wird
Bitte warten ..
Mitglied: certifiedit.net
19.10.2013 um 12:55 Uhr
Zitat von TorstenE:
Danke Christian, aber soweit bin ich mit den Infos bisher ebenfalls gekommen.

Ich verstehe es im Augenblick so, dass das "leere" Repository von ZendStudio nicht richtig erkannt wird

Dann leg doch einfach mal testweise eine einfache Datei ins Repos.
Bitte warten ..
Mitglied: 16568
19.10.2013, aktualisiert um 13:56 Uhr
Mittlerweile gibts ja so einen tollen Kurs: KLICK

Da lernt man dann auch, wie man seine Daten mit GIT versioniert...


Lonesome Walker
Bitte warten ..
Mitglied: TorstenE
19.10.2013 um 14:04 Uhr
Ich hab mal auf einer Linux Maschine manuell ein Repository eingerichtet, eine Datei hinzugefügt und dann in das "leere" Repository gespielt.
Das hat geklappt.
Danach mit ZendStudio das Repository eigelesen hat ebenfalls geklappt
Datei geändert in ZendStudio und ins Repository zurückgespielt - klappt ebenfalls

So wie es ausschaut kann man also mit ZendStudio NICHT in ein leeres Repository hochladen sondern muß praktisch erst eins mit master erstellen und dann in ZendStudio importieren
Bitte warten ..
Mitglied: certifiedit.net
19.10.2013, aktualisiert um 14:08 Uhr
Hallo Torsten,

das wird es wohl sein. Ohne Master weiss das ZS eben nicht, wohin mit dem guten Stück SW.

Bitte noch als gelöst markieren.
Bitte warten ..
Mitglied: nxclass
19.10.2013 um 22:12 Uhr
... ich dachte der vorteil von Git ist es dass man lokal sein Repo. halten und darin entwickeln kann.

Soll heisen, du clonest dir das Repo. vom Server auf deinen Rechner und arbeitest direkt darin.
Bitte warten ..
Mitglied: TorstenE
23.10.2013 um 16:22 Uhr
Also ich hab das jetzt zig mal versucht. Ich bin vermutlich zu blöd dazu.
Repo auf dem Server. Dann mit ZS geclont. Datei geändert und versucht wieder zurück zu pushen, geht einfach nicht.

Kann jemand mein Repo testen, Daten gibts per PM

TorstenE
Bitte warten ..
Mitglied: nxclass
24.10.2013, aktualisiert um 10:49 Uhr
Dann mit ZS geclont
... evtl. versucht Du es als erstes auf der Kommandozeile, da siehst Du dann auch Fehlermeldungen.
Tools wie gitg oder gitk sind auch hilfreich.

Btw. ich kenne viele die sich mit ZS ihr Repository zerschossen haben, also am Ende arbeitest Du irgendwann eh auf der Shell.
Bitte warten ..
Mitglied: 16568
24.10.2013 um 11:31 Uhr
Zitat von nxclass:
... evtl. versucht Du es als erstes auf der Kommandozeile, da siehst Du dann auch Fehlermeldungen.

Würde er den Kurs besuchen, den ich oben verlinkt habe, würde er schon wissen, was los is

Btw. ich kenne viele die sich mit ZS ihr Repository zerschossen haben, also am Ende arbeitest Du irgendwann eh auf der Shell.

Naja... ich bin ja schon ein eingefleischter Fan der Bash, aber wenn man ZS verwendet, die haben da auch Ihre eigenen Sachen: KLICK.


Lonesome Walker
Bitte warten ..
Mitglied: TorstenE
25.10.2013 um 13:29 Uhr
Problem gelöst.
Gestern kam die Beta Version von ZendStudio 10.5 (zuvor 10.0).
Installiert und die ganze GIT Geschichte funktioniert.

Trotzdem danke für die vielen Tips die haben mich auch so weiter gebracht.

Torsten
Bitte warten ..
Ähnliche Inhalte
Windows 10
Windows 10 state repository service
Erfahrungsbericht von BosnigelWindows 10

Servus! Mir ist heute folgendes aufgefallen: Habe heute einen Rechner mit Windows 10 installiert. Clean Install Version 1709 ISO ...

Windows Tools

WSUS Update-Repository Verzeichnis Lesefehler

gelöst Frage von Injoy111Windows Tools1 Kommentar

Ich habe wie ich hoffe nur eine kleines Problem. Auf meinem SBS2011 ist das WSUS installiert und funktioniert auch. ...

Outlook & Mail

Outlook Contact Repository für alle Benutzer

Frage von fireskyerOutlook & Mail3 Kommentare

Exchange: 2010 Outlook: 2010 Hallo miteinander Wir würden gerne für eine Abteilung einen Kontaktordner anlegen, der alle Kontakte von ...

Backup

VEEAM Direct SAN Access auf Repository?

Frage von Leo-leBackup1 Kommentar

Hallo zusammen, was genau muss konfiguriert werden, wenn ich auch auf ein Repository ( Windows Server 2016 per FC ...

Neue Wissensbeiträge
Humor (lol)
Administrator.de Perlen
Tipp von DerWindowsFreak2 vor 1 TagHumor (lol)3 Kommentare

Hallo, Heute beim stöbern auf dieser Seite bin auf folgenden Thread aus dem Jahre 2006 gestossen: Was meint ihr? ...

Erkennung und -Abwehr
OpenSSH-Backdoor Malware erkennen
Tipp von Frank vor 2 TagenErkennung und -Abwehr

Sicherheitsforscher von Eset haben 21 Malware-Familien untersucht. Die Malware soll Hintertüren via OpenSSH bereitstellen, so dass Angreifer Fernzugriff auf ...

iOS
WatchChat für Whatsapp
Tipp von Criemo vor 5 TageniOS5 Kommentare

Ziemlich coole App für WhatsApp User in Verbindung mit der Apple Watch. Gibts für iOS sowohl als auch für ...

iOS
IOS hat nen Cursor!
Tipp von Criemo vor 6 TageniOS5 Kommentare

Nette Funktion im iOS. iPhone-Mauszeiger aktivieren „Nichts ist nerviger, als bei einem Tippfehler zu versuchen, den iOS-Cursor an die ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
SSD zeigt falsche Werte
Frage von karl2014Festplatten, SSD, Raid25 Kommentare

Ich habe ein Problem mit der SSD in meinem Laptop mit Windows 10. Es ist eine 1Tb Platte die ...

Grafikkarten & Monitore
PCIe 1.0 Grafikkarte für 3840x2160
Frage von Windows10GegnerGrafikkarten & Monitore24 Kommentare

Hallo, mein Vater hat einen neuen Monitor gekauft, welcher eine native Auflösung von 3840*2160 hat. Diese muss jetzt auch ...

Windows 10
Windows Enterprise 1809 Eval nicht bootbar
Frage von Sunny89Windows 1022 Kommentare

Hallo zusammen, bevor ich mich jetzt noch stundenlang rumärger wollte ich euch fragen, ob Ihr die gleichen Probleme habt ...

Ubuntu
Installation freerdp 2.0.0-rc4
Frage von kristovUbuntu20 Kommentare

Hallo, möchte freerdp 2.0.0-rc4 auf linux mint 18.3 installieren, habe aber keine Ahnung, wie das funktioniert. freerdp 1.1 ist ...