tob-yxcmin64
Goto Top

Konfiguration für Cisco Router A und B mit OSPF und HSRP

Für das angefügte Bild benötige ich Hilfe zur Konfiguration der 2 Router A und B.
Hierzu wurde in der Vergangenheit schon mal eine Anfrage gestellt. Allerdings war die Aufgabenstellung mißverständlich dargestellt, so daß ich hier das Original zur Aufgabe einstellen möchte.

Meine Konfiguration hierzu würde lauten:
Router A
interface ethernet 0
description Lokales LAN Router A
ip address 20.1.1.1 255.255.255.255

interface ethernet zu Switch Port 1
10.30.1.2 255.255.0.0

router ospf 10
network 10.30.0.0 0.0.255.255

Router B
interface ethernet 0
description Lokales LAN Router A
ip address 20.2.2.2 255.255.255.255

interface ethernet zu Switch Port 2
10.30.1.3 255.255.0.0

router ospf 10
network 10.30.0.0 0.0.255.255

HSRP Konfiguration
Router A
ip address 10.50.5.1 255.255.255.0
standby 1 ip 10.50.5.254
standby 1 priority 110
standby 1 preempt

Router B
ip address 10.50.5.2
standby 1 ip 10.50.5.254
standby 1 priority 90
konfig_ra-rbbild

Content-Key: 6365035447

Url: https://administrator.de/contentid/6365035447

Printed on: June 20, 2024 at 23:06 o'clock

Member: aqui
Solution aqui May 27, 2024, updated at May 28, 2024 at 08:29:52 (UTC)
Goto Top
Auch keinen Gruß...
Du bist zu spät, denn Hausaufgabentag im Forum ist bekanntlich immer nur der Freitag! 🐟 🧐
Aber wir sind ja nicht so und haben immer ein ❤️ für Lernende... 😊

Dein Setup hat leider mehrere grobe Fehler und sieht ein bisschen so aus wie das Auto deines Accountbildes. face-wink
Zudem kommt erschwerend dazu das die Aufgabe 9 selber oberflächlich und dilettantisch gestellt wurde. face-sad
Leider alles Punkte die unklar sind und die Aufgabe zu einem Ratespiel machen. Aber...sortieren wir mal die Fakten:
  • Grundsätzlich redet die Aufgabe NICHT von OSPF und HSRP?!
  • OSPF erfordert immer eine Area was in der Business Systemintegration zum Grundwissen gehören sollte!
  • Die /32 Hostadressen an den Routern sind sehr wahrscheinlich Lookback Adressen. Diese sind als Router ID für eine saubere OSPF Konfig in der Regel zwingend erforderlich weil man die Router ID niemals an Link abhängige physische Interfaces bindet! Loopbacks werden immer als Hostadressen angegeben. Folglich ist also anzunehmen das damit die Loopback Adressen gemeint sind. (Geraten)
  • Eth2 - Eth1 ist vermutlich ein Koppelnetz als übliches Failover (Geraten). Hier fehlen auch die Adressangaben für die Router die ebenfals geraten wurden. face-sad
  • HSRP ist eine Funktion zur Gateway Redundanz für Endgeräte. Es macht also nur Sinn in einem Client Netzwerk was vermutlich (geraten) das Netzwerk am Switch darstellen soll und weniger der Punkt zu Punkt Failover Link zw. den Routern. Sinnvollerweise richtet man also hier im Switchnetz die HSRP Funktion ein für Clients um die Router A und B redundant erreichen zu können. Auch hier fehlen leider wieder die Adressen für die Router die auch wieder geraten wurden. face-sad
  • Es ist kein HSRP Primary Router definiert. (Geraten hier Router A, höhere Prio mit Default 100) Zudem wurde auch Preempting angenommen, das Rückschalten auf den Primary im Falle eines Failover Events.
  • Sinnvoll ist die HSRP Verbindung immer mit einem Passwort zu sichern um zu verhindern das Unbefugte im Netz den Primary Router per HSRP kapern! (Security).
  • Gleiches gilt unbedingt auch für OSPF und ist unten einmal für den Failover Link als optionales Beispiel in Klammern mit einem statischen Passwort dargestellt.

Setzt man das alles voraus, sähe eine Konfiguration beider Router plus Switch dann so aus:

back-to-topRouter A

hostname Router_A
!
clock timezone CET 1 0
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
interface Loopback0
 description Router ID OSPF
 ip address 20.1.1.1 255.255.255.255
!
interface Ethernet 0
description Lokales Switch LAN (R-A)
ip address 10.30.1.253 255.255.0.0
standby 1 ip 10.30.1.254
standby 1 preempt
standby 1 authentication md5 key-string Geheim123
!
interface Ethernet 2
description Koppelnetz Router B
ip address 10.50.5.1 255.255.255.0
(ip ospf authentication-key 123Geheim)
!
router ospf 1
 log-adjacency-changes
 auto-cost reference-bandwidth 10000
 passive-interface default
 no passive-interface Ethernet 0
 no passive-interface Ethernet 2
 network 0.0.0.0 255.255.255.255 area 0 
! 

back-to-topRouter B

hostname Router_B
!
clock timezone CET 1 0
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
interface Loopback0
 description Router ID OSPF
 ip address 20.2.2.2 255.255.255.255
!
interface Ethernet 0
description Lokales Switch LAN (R-B)
ip address 10.30.1.252 255.255.0.0
standby 1 ip 10.30.1.254
standby 1 priority 50
standby 1 preempt
standby 1 authentication md5 key-string Geheim123
!
interface Ethernet 1
description Koppelnetz Router A
ip address 10.50.5.2 255.255.255.0
(ip ospf authentication-key 123Geheim)
!
router ospf 1
 log-adjacency-changes
 auto-cost reference-bandwidth 10000
 passive-interface default
 no passive-interface Ethernet 0
 no passive-interface Ethernet 1
 network 0.0.0.0 255.255.255.255 area 0
! 

back-to-topSwitch

hostname Switch
!
clock timezone CET 1 0
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
interface Ethernet 1
 description Port Router A
 switchport access vlan 1
!
interface Ethernet 2
 description Port Router B
 switchport access vlan 1
!
interface Vlan1
 description Lokales LAN
 ip address 10.30.1.1 255.255.0.0
!
(ip route 0.0.0.0 0.0.0.0 10.30.1.254)
! 

Sollte der Switch auch ein Layer 3 fähiger Switch sein und auch am OSPF Routing partizipieren, dann entfällt die o.a. statische Default Route und wird durch ein OSPF Setup ersetzt.
router ospf 1
 log-adjacency-changes
 auto-cost reference-bandwidth 10000
 network 0.0.0.0 255.255.255.255 area 0 
Alle geratenen IP Adressen sind Folge der zu oberflächlich gestellten Aufgabe 9. face-sad
Member: aqui
aqui May 29, 2024 at 07:11:01 (UTC)
Goto Top
Wenn es das denn nun war und du eine 2 für die Lösung bekommen hast, bitte nicht vergessen deinen Thread hier dann auch als erledigt zu schliessen!!
How can I mark a post as solved?