Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst MS Outlook 2003 und Authentifizierung vor dem Senden zu Postfix

Mitglied: priez

priez (Level 1) - Jetzt verbinden

16.04.2008, aktualisiert 10.05.2008, 6906 Aufrufe, 2 Kommentare

MS Outlook 2003 sendet ein XXXX als ersten SMTP Befehl bei der Verbindung. Danach ein HELO und dann überspringt es einfach das AUTH.

Hi,

Outlook 2003 zu postfix 2.3.8. Client hinter einem 0815 Router. Postfix ist konfiguriert und erwartet ein AUTH vor dem Senden. Da das aber nicht kommt bekommt der Client einen "RELAY ACCESS denied" Fehler.

Mal die verkürzte Form des SMTP Verkehrs in eigenen Worten:
1. Outlook sendet ein XXXX <ClientPCName>
2. Postfix gibt ein 502 Befehl unbekannt.
3. Outlook sendet ein HELO <ClientPCName>
4. Postfix gibt ein 250 OK.
5. Outlook sendet ein MAIL FROM: <email>


ABER anstatt dem 5. Schritt sollte ein AUTH angefordert werden. Im Outlook ist "Postausgangsserver erfordert Authentifizierung" aktiviert mit korrekten Logindaten etc. Mich wundert, das nur ein HELO kommt und kein EHLO.

Ich schätze das Problem ist nur auf Client zu lösen, aber mich würde eine Lösung am Postfix eher reizen, da ich >1000 Emailclients im Einsatz habe und nicht allen hinterherpatchen kann falls was nicht funktioniert.

Weitere Infos:
- Postfix-config ist erprobt und funktioniert mit allen gängigen Clients normal.
- mit einer anderen Outlook2k3 Installation (anderer PC) und gleichen Logindaten funktioniert es.
- mit Thunderbird auf dem Problemclient und gleichen Daten geht es. Aber es MUSS ja outlook2k3 sein.
- Habe noch mit einer älteren Postfix Version und dem Client getestet. Es ist das gleiche Problem.
- Nach 4 Stunden alles mögliche Lesen frage ich jetzt einfach mal.


Ich habe schon alles serverseitige ausprobiert und suche hier direkt nach einer Serverlösung.
ODER
Nach einer einfachen Möglichkeit Outlook 2003 beizubringen sich mit EHLO zu melden, damit er die Servereinstellungen kennt. HAbe selbst gesucht und nichts in den Einstellungen gefunden.


Danke schon einmal für evtl. Antworten.

René
Mitglied: priez
10.05.2008 um 21:42 Uhr
hi,

das Problem war eine Filterung irgendeiner FW zwischen Client und postfix. Habe einfach postfix auch an 587 horchen lassen und den client umgestellt. Das hat die FW dann nicht umgeschrieben.

mfg

René
Bitte warten ..
Mitglied: priez
10.02.2009 um 22:15 Uhr
Hi,

noch eine Anmerkung. Das XXXX <Client-PC-Name> war durch die Firewall forciert. Die hat aus dem "EHLO" einfach "XXXX" gemacht.

Warum das passiert ist mir und dem Kunden unklar. Also sollte jemand ein ähnliches Problem haben hilft ein hochsetzen des debug levels im Postfix (setzt nebenbei soft_bounce aktiv in der main.cf) So geht keine Email verloren.

Mit hohen Debuglevel seht ihr die gesamte Session im Log. Vorsicht. Nicht bei mehr als 2000 Anfragen pro Minute einfach so den debug erhöhen..., sonst könnte Euer System etwas lahm werden. Das Debug am besten direkt am Tel einschalten, den Kunden zur Aktion auffordern und wieder den Debuglevel zurücksetzen.

mfg

René
Bitte warten ..
Ähnliche Inhalte
Windows Server

MS-SQL Server lokale Authentifizierung - Logging

gelöst Frage von ThomasAndersonWindows Server5 Kommentare

Hallo Zusammen, wo im MS-SQL Server kann denn nachvollzogen werden, wann sich welcher lokaler User am System authentifiziert hat? ...

Exchange Server

Außendienstdrucker smtp Authentifizierung an MS TMG

gelöst Frage von DocMacExchange Server8 Kommentare

Guten Morgen zusammen, Ich habe Heute morgen eine Anfrage erhalten, ob es möglich wäre, dass die stationären Multi-Funktionsdrucker unserer ...

Exchange Server

Authentifizierung per Outlook Anywhere

Frage von Leo-leExchange Server4 Kommentare

Hallo Forum, wir haben folgendes Problem mit Outlook 2013 u Exchange 2010 Nach dem monatlichen Passwortwechsel verlangt Outlook übers ...

LAN, WAN, Wireless

802.1x Authentifizierung HP Switch und MS NPS

gelöst Frage von NoobOneLAN, WAN, Wireless7 Kommentare

Hallo Zusammen, ich würde gerne bzw. bin dabei in unserem Netzwerk die Authentifizierung an den LAN-Ports einzuführen. Der Switch ...

Neue Wissensbeiträge
Datenschutz

SiSyPHuS Win10: Analyse der Telemetriekomponenten in Windows 10

Tipp von freesolo vor 3 TagenDatenschutz1 Kommentar

Alle die sich detailliert für die Datensammlung interessieren die unter Windows 10 stattfindet, sollten sich folgende Analyse des BSI ...

Sicherheit
Adminrechte dank Intel-Grafikkarte
Information von DerWoWusste vor 3 TagenSicherheit2 Kommentare

ist das Advisory, welches beschreibt, welche Intel HD Graphics Modelle Sicherheitslücken haben, mit denen sich schwache Nutzer zu Admins ...

Internet

EU Urheberrechtsreform: Eingriff in die Internetkultur

Information von Frank vor 3 TagenInternet1 Kommentar

Liebe Besucherin, lieber Besucher, warum erscheint das obere Banner in allen Beiträgen? Aus Protest gegen Teile der geplanten EU-Urheberrechtsreform ...

Windows Server
Windows Backup - FilterManager Event 3
Tipp von NixVerstehen vor 4 TagenWindows Server

Hallo zusammen, ich bin kein gelernter ITler und auch beruflich nicht in dem Feld tätig. Wir setzen in unserem ...

Heiß diskutierte Inhalte
Hyper-V
Hyper-V Manager startet, jedoch keine VM
Frage von NaleorHyper-V14 Kommentare

Hallo zusammen, auf meinem Windows 10 (Build 1703) Notebook von der Arbeit scheint Hyper-V plötzliche nicht mehr zu funktionieren. ...

Windows Server
Sonntagsfrage: Welchen Sinn seht Ihr noch im Server 2019 Essentials
Frage von ashnodWindows Server13 Kommentare

Guten Morgen, ich habe gestern den Windows Server 2019 Essentials als Trial in einer VM installiert um mir das ...

DNS
50 EUR für Telekom-, Unitymedia- und Vodafone-Kunden
Frage von Zorro1199DNS13 Kommentare

Hallo zusammen, wie evaluieren gerade das korrekte Einhalten von DNS-TTLs durch verschiedene Provider. Aktuell suchen wir noch Kunden der ...

Windows Server
Windows 2012 R2 - Skript um Druckerkonfiguration auszulesen und zu setzen
gelöst Frage von Der-PhilWindows Server11 Kommentare

Hallo! Kennt ihr eine Möglichkeit, per Skript die Konfiguration eines Druckers auszulesen und auf einen anderen anzuwenden? Hintergrund: Ich ...